08:01:25 <licanwei> #startmeeting watcher
08:01:26 <openstack> Meeting started Wed Apr 24 08:01:25 2019 UTC and is due to finish in 60 minutes.  The chair is licanwei. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:29 <openstack> The meeting name has been set to 'watcher'
08:02:20 <licanwei> thank you Corne for the agenda
08:02:36 <Dantalion> no problem
08:02:39 <licanwei> Agenda for today: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#04.2F24.2F2019
08:03:32 <licanwei> #link https://review.opendev.org/#/c/653344/ Formalize DataSourceBase interface  needs review
08:04:51 <Dantalion> All feedback on the interface is appreciated
08:06:20 <licanwei> Dantalion: you do a very good job :)
08:06:51 <licanwei> I'll review this spec again
08:07:38 <licanwei> #link https://review.opendev.org/#/c/653931/ Add a force field to audit needs review
08:09:08 <licanwei> this spec proposes to add a force option when creating audit
08:09:25 <Dantalion> I'll try and review this spec today
08:09:47 <licanwei> Dantalion: thanks!
08:10:24 <chenke> help
08:11:35 <licanwei> #action Dantalion review  https://review.opendev.org/#/c/653931/
08:12:04 <chenke> Hi Dantalion, i am busy with an urgent project recently, i will understand your commit as soon as possible.
08:12:22 <licanwei> #action licanwei chenke review  https://review.opendev.org/#/c/653344/
08:13:55 <licanwei> https://review.opendev.org/#/c/645294/ Allow for global datasource preference from config needs review
08:15:43 <Dantalion> This implements the recently approved spec
08:16:09 <licanwei> Dantalion: LGTM!
08:16:30 <licanwei> final review
08:17:05 <licanwei> https://review.opendev.org/#/c/653977/ Resolve problems with audit scope and add tests needs review
08:17:40 <licanwei> #action licanwei reveiw https://review.opendev.org/#/c/653977/
08:19:26 <chenke> very nice commits
08:19:51 <licanwei> https://review.opendev.org/#/c/654800/ Drop use of git.openstack.org needs review
08:20:24 <chenke> i I think your coding ability is very strong.
08:20:40 <licanwei> #action licanwei reveiw https://review.opendev.org/#/c/654800/
08:21:04 <licanwei> https://review.opendev.org/#/c/653913/ separate launching audit scheduler needs review
08:21:58 <Dantalion> I have seen issues with scheduling on devstack this patch seems to have solved it thanks
08:22:32 <licanwei> Dantalion: yes
08:23:08 <licanwei> https://review.opendev.org/#/c/651746/ Make the same method be self-explanatory in different strategies needs review
08:23:42 <licanwei> #action licanwei reveiw https://review.opendev.org/#/c/651746/
08:24:19 <licanwei> Dantalion: I agree to add a base method
08:24:33 <Dantalion> licanwei: Might need to re-execute those commands, you have a typo in review / reveiw
08:24:55 <licanwei> #action licanwei review https://review.opendev.org/#/c/651746/
08:25:24 <Dantalion> Yes, with add_migration as base method this patch would look good to me
08:25:52 <chenke> ok, i will put the method as base method
08:26:23 <chenke> https://review.opendev.org/#/c/654800/5/doc/source/contributor/testing.rst    this patch look good to me
08:26:33 <licanwei> #action chenke add a new patch for https://review.opendev.org/#/c/651746/
08:27:36 <licanwei> #topic discussions
08:28:24 <licanwei> Approved file based metric spec needs to be implemented [https://review.opendev.org/#/c/643312/]
08:29:34 <Dantalion> I am unsure if sumitjami intents to implement his spec, I propose I try to contact him and ask. If he is not going to we can look at who can do it.
08:30:35 <chenke> How are you going to contact him?
08:30:37 <licanwei> Dantalion: OK, thanks you
08:31:10 <Dantalion> chenke: opendev users have an email address that is public
08:31:20 <Dantalion> sjamgade@suse.com
08:31:24 <chenke> haha
08:31:45 <sum12> hello, sorry for being late
08:32:07 <Dantalion> hello welcome
08:32:22 <licanwei> sum12:  hi
08:32:28 <chenke> welcome
08:33:42 <licanwei> sum12: Could you continue to implement your spec file based metric
08:34:01 <licanwei> ?
08:34:34 <sum12> yes I am working on it, but was distracted preparing for workshop at the summit.
08:34:38 <chenke> Dantalion: I think you are friends with sumitjami. I forgot the email.
08:35:07 <sum12> will try to get initial review before going to summit
08:35:25 <sum12> licanwei: i hope that is fine :-)
08:35:47 <licanwei> sum12: That's OK ,thank you!
08:35:52 <Dantalion> chenke: I have never met sumitjami in person
08:36:25 <Dantalion> sum12: thank you :)
08:36:54 <licanwei> about URL migration to opendev.org
08:37:30 <licanwei> Dantalion: What do you want to discuss?
08:37:47 <sum12> Dantalion: if you are going to be at the summit, we can meet (i am sumitjami) (too many nicks !)
08:38:20 <Dantalion> Are the 3 currently open patches enough to complete the migration to opendev?
08:38:41 <Dantalion> sum12: I won't be there unfortunately but josecastroleon will be
08:39:14 <licanwei> Dantalion: I don't sure
08:40:00 <chenke> i will check it
08:41:00 <licanwei> Dantalion: I don't think it's a problem~
08:41:45 <Dantalion> licanwei: the redirects will stay for long time so no problem indeed
08:41:49 <Dantalion> chenke: thank you
08:41:51 <licanwei> topic: Watcher blueprints need cleaning https://blueprints.launchpad.net/watcher
08:42:36 <Dantalion> I think we should clean up the blueprints to better reflect what currently is implemented and what is being worked on
08:42:52 <licanwei> Dantalion: There are many unimplemented specs
08:44:19 <licanwei> We are no more people to do these
08:45:14 <Dantalion> Agreed we can not implement all unimplemented specs
08:45:36 <chenke> the spec `Add Show Datamodel API` and  `Add resource_name in action input parameter` i will implement it before this release.
08:46:02 <Dantalion> But some status of blueprints is incorrect and train series is missing as option for example
08:46:24 <licanwei> Dantalion: I will check these bp when I have time
08:46:49 <Dantalion> Okaj, thank you
08:49:41 <licanwei> we can discuss which need to do and invalid unused
08:50:09 <Dantalion> Yes, could be topic for other meeting
08:51:56 <licanwei> any questions?
08:52:37 <chenke> I have no other thoughts for the time being.
08:52:46 <Dantalion> I have no more questions
08:53:44 <licanwei> OK, I'll end the meeting
08:53:53 <licanwei> Thank you all :)
08:54:04 <Dantalion> Yes, thanks everyone :)
08:54:09 <licanwei> see you next meeting time:)
08:54:20 <chenke> thanks everyone
08:54:34 <licanwei> #endmeeting