12:00:12 <dviroel> #startmeeting watcher
12:00:12 <opendevmeet> Meeting started Thu Nov 28 12:00:12 2024 UTC and is due to finish in 60 minutes.  The chair is dviroel. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:13 <opendevmeet> The meeting name has been set to 'watcher'
12:00:25 <dviroel> hello everyone o/
12:00:35 <amoralej> o/
12:00:36 <dviroel> who is around today?
12:00:36 <marios> hello \o
12:00:44 <jgilaber_> o/
12:00:58 <kopecmartin> \o
12:01:15 <dviroel> alright, let's start with today's meeting agenda
12:01:23 <dviroel> #link https://etherpad.opendev.org/p/openstack-watcher-irc-meeting (Meeting agenda)
12:01:47 <dviroel> feel free to add your own topics to the agenda
12:02:08 <sean-k-mooney> o/
12:02:10 <dviroel> also, there is a topic at the end, to place your changes that requires attention from reviewers
12:02:45 <dviroel> note that watcher meetings don't have a fixed chair, but a list of volunteers
12:03:17 <dviroel> i just added a meting chair list at the top
12:03:30 <dviroel> to help us to control who would be the next one
12:03:40 <sean-k-mooney> speaking of
12:04:05 <sean-k-mooney> given many? all? of the attendiess will be travelign next week for internal reasons
12:04:19 <sean-k-mooney> shoudl we cancel the meeting next week or proceed
12:04:55 <marios> good point sean-k-mooney we discussed briefly with rlandy yesterday (and i added teh first item on agenda behalf of rlandy (who is out today) and she'll be afk during the meeting next week and won't be able to chair
12:04:57 <sean-k-mooney> we shoudl send a mail to the list if we are canceling
12:05:30 <amoralej> +1 to cancel it
12:05:31 <sean-k-mooney> i would propsoe we cancel unless there is a pressing topic
12:05:33 <dviroel> yeah, i think that we all have a conflict at this time next week
12:05:53 <jgilaber_> +1 to cancel it as well
12:06:12 <sean-k-mooney> ack, then lets record that and we can notify the list after the meeting
12:06:17 <dviroel> ok,  unless someone has a topic that we can't postpone, we can cancel it
12:06:26 <marios> sounds good
12:06:53 <marios> action item for someone to notify the list?
12:06:56 <dviroel> #agreed cancel next watcher community meeting (dec 5th)
12:07:21 <dviroel> yes, I can send the notification email
12:07:25 <marios> cool thank you dviroel
12:08:04 <dviroel> #action dviroel to notify that next week meeting is cancelled
12:08:21 <dviroel> and speaking of chair list
12:08:32 <dviroel> a patch was proposed to update meeting's info
12:08:43 <marios> oh yeah forgot about that :)
12:08:44 <dviroel> #link https://review.opendev.org/c/opendev/irc-meetings/+/935806 (Update Watcher team meeting information)
12:09:00 <dviroel> and it was merged a few minutes ago
12:09:04 <dviroel> thanks marios
12:09:09 <marios> cool thanks dviroel
12:09:40 <dviroel> alright, next topic
12:09:41 <sean-k-mooney> oh excelent that mean we can grab an ical for this slot once the page is rendered
12:10:00 <dviroel> #topic Update on prometheus datasource
12:10:25 <dviroel> #link https://review.opendev.org/c/openstack/watcher/+/934423 (WIP Add prometheus data source for watcher decision engine)
12:10:28 <marios> o/ hello I added this one just to provide some update on progress and see if there are any concerns or comments (here or after if someone reads logs )
12:10:56 <marios> so one main item this week is that we have made the fqdn label, expected on prometheus metrics, to be configurable
12:11:16 <marios> in other words we stil expect A label on metrics that will identify the exporter (and we default to expecting it to be 'fqdn')
12:11:30 <marios> but that can be overridden by the wathcer prometheus_client config
12:11:59 <marios> thanks for all the reviews this week, i think we are making decent progress. i would like to get this merged by the end of the year
12:12:15 <marios> and then iterate. in this first version we are only wiring up host cpu and memory usage queries
12:12:34 <marios> are there any comments, questions or concerns
12:12:49 <sean-k-mooney> more a comment then a concern
12:13:21 <sean-k-mooney> i think we will be at a point where it could merge before the end of the year. im unsure if we will have the tempest job to test it ready at that point
12:13:54 <sean-k-mooney> so as we get closer we shoudl discuss if that hsould be a requrirement or are we happy with the unit testing to allow merging
12:14:05 <sean-k-mooney> we dont have to decided that now
12:14:21 <marios> right, i wanted to mention the work being done byu rlandy in parrallel there https://review.opendev.org/c/openstack/watcher/+/935371 . so at the moment we aren't ready for it yet (i mean the data source still needs a few more iterations for the things identified thus far/docs etc)
12:14:25 <sean-k-mooney> we can evaluate that on the review
12:14:50 <marios> yeah so i agree with you, like we'll have to call that at some point, maybe it won't be ready in time so ... we can consider merging the data source first.
12:15:02 <marios> i mean, it is kind of chicken/egg situation sean-k-mooney
12:15:15 <sean-k-mooney> yep it is
12:15:19 <marios> like the job would need my patch to merge first so the data source could be tested (as is presently expressed with depends-on)
12:15:22 <marios> right
12:15:49 <dviroel> yeah, it still can be tested with depends-on
12:16:16 <sean-k-mooney> so i think this will naturally resolve itslef as we make progress in paralle on both
12:16:27 <sean-k-mooney> but that was the only concern with the timeline
12:16:43 <marios> i hope in 2 weeks time (our next meeting) that part should be clearer and we can revisit
12:16:52 <sean-k-mooney> i thnk we are still on track to complete this feture this cycle and likely can compelte the inial work before the end of the year as you hopped
12:16:54 <marios> see how far along both of those efforts are i mean
12:17:03 <sean-k-mooney> +1
12:17:25 <dviroel> +1
12:17:56 <dviroel> alright, that's a topic for next meeting then (in 2 weeks)
12:18:07 <marios> ack
12:18:29 <dviroel> anything else that we want to cover about this topic?
12:18:59 <dviroel> ok, next
12:19:09 <dviroel> #topic watcher launchpad teams
12:19:19 <dviroel> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/QLHS64DL7QJR725CEKGAVKCOEKXBE36Z/#KASNW2E2NWSOQRF3M2UUD6H3YXTGLDGF
12:19:47 <sean-k-mooney> this should hopefully be relitivly short. the openstack-admins team now has ownership fo the watcher-driver team
12:20:15 <sean-k-mooney> i have an AR form the PTG to update the memberhisp and a proposal on how to create the new teams linked above
12:20:27 <sean-k-mooney> the summary is i would like to have 3 teams
12:20:42 <sean-k-mooney> watcher driver for blupint approval and launchpad managment.
12:20:56 <sean-k-mooney> watcher-bugs an open team for bug triage
12:21:19 <sean-k-mooney> and watcher-coresec for secuity bugs and VMT process
12:21:59 <sean-k-mooney> there has been no objections on the mailing list so before i ask the openstack-admins to make those changes are thre any concerns
12:22:04 <marios> thanks for the update and summary sean-k-mooney and for leading that effort
12:22:53 <marios> so to be clear, openstack-admins has ownership. will that be extended to include you so you can do these other things now?
12:22:53 <dviroel> looks good to me, thanks for this proposal sean-k-mooney and for leading it
12:22:55 <amoralej> that looks good to me
12:23:31 <marios> or sean-k-mooney you will submit the proposal to the openstack-admins and they will then create the teams?
12:23:32 <sean-k-mooney> marios: i will ask openstack-admins to add me as an admin of watcher-drivers and add watcher-drivers as admins of the two new teams
12:23:45 <marios> ack
12:23:50 <sean-k-mooney> all teams will be owned by openstack-admins and i will not be part of that group
12:24:17 <sean-k-mooney> dan as secuirty leason will be the inial member of the coresec group
12:25:10 <sean-k-mooney> ack then can we consider this formally AGREED?
12:25:21 <dviroel> great, I don't see any objetions on this proposal
12:25:40 <sean-k-mooney> i can take the action to reach out after the meeting
12:25:51 <dviroel> #agreed on new launchpad teams proposed by sean-k-mooney
12:26:39 <dviroel> #action sean-k-mooney to reach out openstack-admins after this meeting to create the teams
12:27:18 <dviroel> ty sean-k-mooney - next topic, also yours
12:27:24 <dviroel> #topic gerrit group changes
12:27:50 <dviroel> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/LT6TCS2BZJMWFEJAXHWV5SHZ6LPIHN7P/
12:28:17 <sean-k-mooney> ok so this should also be relitivly quick. as deciribed in the mailing list post there are a numer of changes to the gerrit teams that i have proposed
12:28:30 <sean-k-mooney> again there has been no objection to this at the ptg or on the mailing list
12:28:54 <sean-k-mooney> the tl;dr is i would be added to each of the watcher teams in several cpasities
12:29:24 <sean-k-mooney> first i would be added to allow adding/removing members over time starting with adding the gobal stable maint team to the release groups
12:30:01 <sean-k-mooney> the proposal also incldues adding tempest core to the tempest plugin  and some other changes to simplfy the group srtucture
12:30:21 <sean-k-mooney> impornatly at this time the proposal does not remove anyone form any gerrit group
12:30:56 <sean-k-mooney> before moving forwad with this i would like to ask are there any concerns with the proposal detialed in teh link above
12:31:19 <amoralej> no objections or concerns from my side
12:31:33 <marios> i think this is a good start sean-k-mooney ... we have to start somwhere. even with this, we'll still have challenges merging things for a while until we get more active cores
12:32:11 <dviroel> no objections from my side, seems the right approach to start getting this project more active
12:32:26 <marios> but our current patch rate is not massive so... as i said its a good start and it'll allow us to start merging things (e.g. if you get core and we have one or two others like Dan who can help us merge things initially)
12:32:42 <sean-k-mooney> marios: ack, it is my hope that over the course of the cycle that can be adressed but i agree
12:32:58 <jgilaber_> +1 from me
12:33:06 <marios> i think early in the new year we will need to revisit and assuming folks are reviewing regularly and contributing we can consider expanding
12:33:15 <dviroel> +1
12:34:05 <sean-k-mooney> shall we take an action to review the group memberhsip again around milestone  3
12:34:22 <sean-k-mooney> based on partipation at that point
12:35:15 <dviroel> +1, make sense
12:35:22 <marios> yeah sounds good
12:36:00 <marios> me trying to find the dates do you have a link handy sean-k-mooney (looking at https://releases.openstack.org/ )
12:36:02 <sean-k-mooney> ack then if there is no objection lets recored the agreement and action itme for me to follow up with the gerrit admins to effect the group changes
12:36:15 <sean-k-mooney> milestone 3 is feb 27th
12:36:26 <marios> thanks
12:36:29 <sean-k-mooney> https://releases.openstack.org/epoxy/schedule.html
12:36:37 <dviroel> ok, no ojections wrt to this proposal too
12:36:56 <sean-k-mooney> #link https://releases.openstack.org/epoxy/schedule.html#epoxy-3-milestone
12:37:06 <dviroel> #agreed on sean-k-mooney proposal for watcher's gerrit groups change
12:37:40 <dviroel> #action sean-k-mooney to follow up with the gerrit admins to effect the group changes
12:39:09 <dviroel> alright, anything else for this topic?
12:40:01 <sean-k-mooney> not from me
12:40:10 <dviroel> ok, I also don't see any specific review request in next topic
12:40:23 <sean-k-mooney> i can make a general one
12:40:31 <dviroel> marios already commented about his change for the new prometheus datasource
12:40:43 <sean-k-mooney> my first priority is to complete merging the ci fix serises i have up
12:40:47 <marios> yeah i didn't want to repeat that in the reviews section dviroel thanks :)
12:40:54 <sean-k-mooney> there are 3 patches left
12:41:07 <marios> so speaking of ci patches i wanted to ask at the end but maybe it applies here sean-k-mooney
12:41:29 <marios> is this one known/expected given in-flight fixes https://zuul.opendev.org/t/openstack/build/b42aec775d2141a1b677ff05931b3255 ?
12:41:41 <marios> watcher.tests.api.v1.test_audits.TestPost.test_create_continuous_audit_with_wrong_interval
12:41:51 <marios> testtools.matchers._impl.MismatchError: 'Exactly 5 or 6 columns has to be specified for iterator expression.' not in '{"faultcode": "Server", "faultstring": "Exactly 5, 6 or 7 columns has to be specified for iterator expression.", "debuginfo": null}'
12:42:48 <marios> it isn't something i touch in my code (at least not directly/knowingly) so i am not sure where it comes from ... and locally tox-py39 passes. if it is not something immediatly nkown lets move on sean-k-mooney sorry didn't mean to hijack
12:43:03 <sean-k-mooney> hum
12:43:20 <sean-k-mooney> i hav not seen that either but we shoudl look into that
12:43:40 <marios> ok fine apologies for the detour please carry on with your 3 patches left for ci
12:43:45 <sean-k-mooney> it could be an exiting test instablity of an sideefect fo your change thanks for highlighting it
12:43:57 <sean-k-mooney> ack
12:44:14 <sean-k-mooney> so the first patch (ill get the links later) add pre-commit to ci
12:44:28 <sean-k-mooney> the second patch fixes the eventlet incompatablity wiht py312
12:44:49 <sean-k-mooney> and the final patch move the testing runtimes to ubuntu noble
12:45:12 <sean-k-mooney> i am hopeing to land those 3 changes in the next week or so
12:45:33 <sean-k-mooney> that shoudl bring watcher up to date with the python version we are intended to test this cycle
12:45:46 <sean-k-mooney> #link https://review.opendev.org/c/openstack/watcher/+/934394
12:45:53 <dviroel> right, and there is a relation chain between those
12:45:54 <sean-k-mooney> #link https://review.opendev.org/c/openstack/watcher/+/933890/11
12:46:02 <sean-k-mooney> #link https://review.opendev.org/c/openstack/watcher/+/932963/15
12:46:07 <sean-k-mooney> yep
12:46:09 <marios> thanks for working on those sean-k-mooney
12:46:36 <sean-k-mooney> so i just wanted to note they are avaible for reivew and thank those that already have
12:47:32 <sean-k-mooney> if those are still open with no negitive feedback next week i will approve them
12:47:34 <dviroel> great, sean-k-mooney thanks for highlight these changes, they are really important
12:47:44 <dviroel> +1
12:48:04 <sean-k-mooney> for now ill leave them for chenker to review if they have time
12:48:21 <sean-k-mooney> marios: oh
12:48:26 <sean-k-mooney> https://zuul.opendev.org/t/openstack/build/a87e35c92f5a44c691d9daf3b7849c07
12:48:29 <marios> thanks for your review time in advance chenker o/ :)
12:48:44 <sean-k-mooney> so chenker did approve the first one this morning and i hit the same ci issue you found
12:48:58 <marios> cool so "wasn't me"
12:49:04 <marios> thanks for the link sean-k-mooney
12:49:07 <sean-k-mooney> so that looks like an actul breakage perhaps due to a new release of a dep
12:49:20 <amoralej> likely
12:49:24 <marios> yeah so it hit tox-py39/312 and also tox-cover
12:49:33 <marios> and local tox -e py312 py39 is green
12:49:51 <sean-k-mooney> ok we likely will need to have a sperate patch to fix that first before the rest can proceed
12:50:04 <sean-k-mooney> i think we can dicuss this outside fo the meeting however
12:50:08 <amoralej> oh, something added "or 7" :)
12:50:12 <marios> right
12:50:19 <sean-k-mooney> do we have anything else for today?
12:50:25 <marios> just mismatch on faultstring
12:50:31 <dviroel> sean-k-mooney: i don't think so
12:51:06 <dviroel> we can just wrap up for today
12:52:02 <dviroel> someone want to add something or any other announcement? otherwise we can close the meeting
12:52:38 <amoralej> volunteer for chairing next meeting?
12:53:05 <marios> so in theory it can be rlandy since we skipped next week's one... but they aren't here to confirm ;)
12:53:19 <marios> i mean rlandy had previously volunteered to take next week's one
12:53:37 <dviroel> right, we can check with rlandy afterwards, otherwise i can chair again if needed, i will be around
12:53:47 <marios> and yeah i was going to say the same i can do it too
12:53:55 <amoralej> ack
12:53:58 <marios> so between us we should have at least 1 chair :)
12:54:51 <sean-k-mooney> ok lets close out the meeting then o/
12:55:33 <dviroel> ack, i will let marious as backup of rlandy then ;)
12:55:42 <dviroel> let's wrap up
12:55:43 <marios> ack sounds good
12:55:46 <dviroel> thank you all for participating
12:55:58 <dviroel> #endmeeting