12:00:01 <marios> #startmeeting watcher
12:00:01 <opendevmeet> Meeting started Thu Dec 12 12:00:01 2024 UTC and is due to finish in 60 minutes.  The chair is marios. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:01 <opendevmeet> The meeting name has been set to 'watcher'
12:00:11 <marios> hello all o/ who is around today
12:00:16 <amoralej> o/
12:00:16 <dviroel> o/
12:00:20 <jgilaber> o/
12:01:08 <chandankumar> o/
12:01:14 <marios> #link https://etherpad.opendev.org/p/openstack-watcher-irc-meeting meeting agenda
12:01:39 <marios> ok lets get going on the agenda items we will take them in order given
12:01:49 <marios> #topic     ( rlandy) Open reviews (not expected to be merged before year end):
12:01:57 <marios> #link     https://review.opendev.org/q/project:openstack/watcher+status:open+-is:wip
12:02:05 <rlandy> thanks @marios
12:02:07 <marios> lets add dashboard there too
12:02:17 <rlandy> listed the reviews there that would need W+
12:02:18 <marios> #link https://review.opendev.org/q/project:openstack/watcher-dashboard+status:open+-is:wip
12:02:44 <marios> ok lets take them one at a time, give folks chance for any concerns or comments or status
12:02:57 <marios> #link https://review.opendev.org/c/openstack/watcher/+/934423 Add prometheus data source for watcher decision engine
12:03:12 <marios> thanks for reviews on this one i think it is close now.
12:03:20 <marios> thanks amoralej and sean for the latest round of reviews
12:03:46 <marios> my plan is to add in the client auth options and try to get it into mergeable state by the end of th eyear
12:03:51 <marios> (i.e. next week ;))
12:04:03 <marios> then the followup patch will deal with vm level metrics
12:04:11 <amoralej> you mean auth or better https handling ?
12:04:18 <marios> i mean both
12:04:30 <amoralej> i thought we wouldn't need auth
12:04:33 <marios> basicaaly add the client opts for basic_auth user/pass if user wants, or client cert/ca
12:04:39 <marios> from our side its just adding the client opts
12:04:52 <marios> the "heavy lifting " is done on the observabilityclient
12:04:59 <amoralej> does observabilityclient support auth ?
12:05:02 <marios> so agree with the notion of trying to establish the interface
12:05:07 <marios> it has basic_auth
12:05:12 <marios> you can set the user/pass on the session
12:05:15 <marios> if you pass it through
12:05:16 <amoralej> good
12:05:21 <amoralej> yeah, then, let's expose it
12:05:28 <marios> so it should be cheap to add the client opts on our side anyway
12:05:28 <amoralej> but in follow up :)
12:05:32 <marios> and establish our interface
12:05:45 <marios> ok lets discuss this bit on the review then, personally i think one more iteration for th eclient opts is OK
12:06:12 <amoralej> ok
12:06:26 <marios> thanks amoralej for diving in there and as discussed earlier in this channel helping to test this it is very useful and helpful feedback
12:06:52 <marios> thanks to others that have had a look already and please keep reviews coming thank you
12:06:57 <marios> anything else before we move on from this one
12:07:41 <marios> #link https://review.opendev.org/c/openstack/watcher/+/935371 Add Tempest test for Prometheus integration
12:07:50 <rlandy> thanks for all the reviews
12:07:59 <rlandy> only W needed here
12:08:14 <marios> nice one rlandy++
12:08:22 <rlandy> working on scenarios in follow up patch
12:08:40 <rlandy> but hitting the stated bug - so will report on that in next meeting
12:09:03 <marios> so this patch is setting up sg-core to expose ceilometer metrics exported as prometheus metrics
12:09:20 <marios> i mean 935371  (adding some general info for anyone following along in the meeting logs)
12:09:42 <marios> but currently it is actually not using any of the prometheus metrics right?
12:09:47 <marios> so that is coming in the followup patch
12:09:55 <rlandy> correct
12:09:59 <marios> lets link it here?
12:10:20 <rlandy> https://review.opendev.org/c/openstack/watcher/+/937497
12:10:43 <marios> #link https://review.opendev.org/c/openstack/watcher/+/937497 WIP: Run scenario tests with prometheus
12:11:05 <marios> anything further on this topic rlandy or anyone?
12:11:06 <rlandy> you will notice they all fail on  https://bugs.launchpad.net/watcher-tempest-plugin/+bug/2090853
12:11:21 <rlandy> so we have no option but to get the prometheus metrics in :)
12:11:26 <rlandy> that's all
12:12:13 <marios> #info known bug on watcher-tempest-plugin affecting https://bugs.launchpad.net/watcher-tempest-plugin/+bug/2090853
12:12:28 <marios> thanks for the info rlandy
12:12:37 <marios> anything else here before we move to the next
12:13:02 <marios> #link https://review.opendev.org/c/openstack/watcher/+/933909 Update python versions, drop py3.8
12:13:33 <marios> looks like martin is not here right now?
12:13:54 <marios> anyone else can talk about this one? i think as written, we just need a workflow .
12:14:06 <marios> our only current active core has already added +2 (Sean)
12:14:18 <rlandy> marios: note these were just added to the list to notify people that we are waiting on W ... idk if there is a need to address any one in particular
12:14:28 <rlandy> martin is out until monday
12:14:45 <marios> so right now it would mean harrassing dsmith or slaweq as the other two cores.
12:14:55 <marios> probably we should add them to the review, doing that now in fact with a note
12:16:14 <marios> Dan, Slaweq can you please check this and merge if you agree. Right now we only have Sean as active core so until we get some more please help us merge some of the things. Sorry for unsolicited pings and thanks in advance ;)
12:16:19 <marios> i added this note ^
12:16:23 <marios> anything further on this topic?
12:16:41 <marios> i think if there is no push back until the new year we can ask sean to merge like this
12:16:48 <marios> that is another solution until we build our core team
12:16:58 <rlandy> +1
12:17:13 <rlandy> ie: ok to wait
12:17:39 <marios> yes
12:17:43 <marios> ok, moving on ...
12:17:52 <marios> #link https://review.opendev.org/c/openstack/watcher/+/934583 Remove default override for config options policy_file
12:18:08 <marios> i think similar story here right
12:18:27 <marios> this one belongs to gmann
12:19:03 <marios> so sean has voted and we'll need to harrass Dan/Chenker/Slaweq for now, and in the new year we can ask sean to merge with one +2 if needed until we build core team out
12:19:42 <marios> i won't copy/paste my review request note on this review (or others) yet for example i think some folks will indeed be out until the new year
12:19:52 <marios> anything else on this one before we move on?
12:20:16 <marios> #link https://review.opendev.org/c/openstack/watcher/+/932264 tox: Drop envdir
12:20:33 <marios> same story here ...
12:20:47 <marios> ah in fact, here sean can merge it
12:20:56 <marios> dsmith added his +2
12:21:08 <marios> adding note for sean
12:21:45 <marios> anything else here?
12:22:05 <marios> #link https://review.opendev.org/c/openstack/watcher/+/934996 Unblock the CI gate
12:22:53 <marios> so per seans comment here we need to wait for https://review.opendev.org/c/openstack/project-config/+/936754
12:23:08 <marios> but then we should workflow -1 /934996 or add depends-on
12:24:27 <marios> moving on ...
12:24:37 <marios> next topic
12:24:45 <marios> #topic     (amoralej) For watcher-dashboard the more meaningful reviews are:
12:24:58 <marios> amoralej: i will list them here but feel free to start giving any context you wanted to
12:25:08 <marios> #link https://review.opendev.org/c/openstack/watcher-dashboard/+/932693
12:25:14 <marios> #link https://review.opendev.org/c/openstack/watcher-dashboard/+/888912
12:25:19 <marios> #link https://review.opendev.org/c/openstack/watcher-dashboard/+/933910
12:25:26 <marios> #link https://review.opendev.org/c/openstack/watcher-dashboard/+/935043
12:25:35 <marios> #link https://review.opendev.org/c/openstack/watcher-dashboard/+/934781
12:25:37 <amoralej> we don't need to go one by one, i just wanted to focus what are the more relevant reviews in watcher-dashboards
12:25:44 <marios> #link https://review.opendev.org/c/openstack/watcher-dashboard/+/932890
12:25:56 <marios> ack anything we need to call out?
12:26:01 <amoralej> it's mostly some sanity fixes
12:26:23 <amoralej> and bug fixing
12:26:57 <amoralej> just, asking for review and we can discuss there or here if you have doubts
12:27:31 <marios> thanks amoralej any comments before we move on
12:27:36 <marios> (anyone)
12:28:13 <amoralej> I was wondering if we should backport those fixes in watcher-dashboard to supported releases
12:28:41 <amoralej> I'm not sure if it's worthy, tbh
12:29:07 <marios> so, it might be more work than worth it, but i am also not sure yet
12:29:25 <marios> the project has been mostly dormant in the last couple years so ... might be easy/cheap to backport
12:29:30 <marios> but does anyone care?
12:29:48 <rlandy> it seems there is enough work to get them into the current release
12:29:54 <amoralej> I expect backports should be easy to do, but yes, that's my question
12:30:01 <amoralej> if anyone is interested
12:30:15 <amoralej> and it's mostly work to get ci running, etc...
12:30:21 <amoralej> in case it's not, i didn't check
12:30:37 <marios> yes this is another good point rlandy ; can we revisit this in the new year amoralej sounds like a good agenda item once these things actually start mergein on master
12:30:39 <amoralej> we can focus in master so far
12:30:53 <rlandy> +1
12:31:30 <marios> k moving on ..
12:31:37 <dviroel> +1 on revisit this, once we have more reviewers too
12:31:54 <dviroel> reviewers that have power to merge them :)
12:32:04 <marios> yes
12:32:07 <amoralej> +1
12:32:28 <marios> #topic     https://review.opendev.org/q/project:openstack/watcher-specs+status:open+-is:wip
12:32:37 <marios> #link https://review.opendev.org/c/openstack/watcher-specs/+/752508 Fix hacking min version to 3.0.1
12:33:17 <marios> i *think* takashi had a series of patches for this no?
12:33:19 <marios> checking
12:33:35 <marios> ah this is watcher-specs though maybe he missed that one
12:34:13 <marios> k cant quickly find anyway
12:34:23 <marios> any discussion on this one?
12:35:04 <marios> moving on momentarily ..
12:35:32 <marios> #topic     https://review.opendev.org/q/project:openstack/watcher-tempest-plugin+status:open+-is:wip
12:35:37 <marios> #link https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/936837 Update documentation and add a job to publish it
12:35:48 <marios> #link https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/934009 Drop translation sections
12:35:56 <marios> any dicussion here ?
12:36:49 <marios> moving on in a moment...
12:37:35 <marios> #topic (doug) Meetings on Dec 26th and Jan 2nd. Should we cancel these due to holidays?
12:37:55 <marios> thanks for adding this one i was going to propose the same
12:38:00 <dviroel> yep, due to holidays and low audience, is anyone against to cancel both?
12:38:01 <marios> looks like there is agreement on the etherpad
12:38:35 <jgilaber> +1 to cancel, there's likely very few people around on those dates
12:39:17 <marios> #info watcher weekly irc meeting cancelled Thursday 26 December 2024 and Thursday 02 January 2025 due to engineering holiday outages
12:39:36 <marios> anything else before we move on ?
12:39:54 <dviroel> we need someone to send that in the ML
12:40:01 <marios> yes good call dviroel
12:40:05 <marios> any volunteer
12:40:20 <dviroel> i can
12:40:48 <marios> #action dviroel will mail openstack-discuss about cancelled irc meetings 26Dec & 02Jan
12:40:51 <marios> thank you
12:41:32 <marios> #topic     (doug) Nova spec merged: scheduler hints info available in server details
12:41:38 <marios> #link https://review.opendev.org/c/openstack/nova-specs/+/936140 Add spec for show scheduler hints in server details
12:41:49 <dviroel> yeap, just want to bring this topic, since is important from watcher's point of view
12:42:27 <marios> nice job getting that merged dviroel
12:42:28 <dviroel> this spec is now merged in nova-spec, and one of the main use cases is to allow services, like watcher to retrieve additional placement constraints of running instances
12:42:30 <amoralej> nice
12:42:39 <amoralej> dviroel++
12:42:52 <dviroel> for watcher,  this could reflect on more constraints to be evaluated by Strategies, when selecting a destination host for instance migrations
12:43:15 <dviroel> I am expecting to propose the nova changes and get them merged in this release too
12:43:42 <dviroel> and after that, watcher and strategies will also need to be modified to properly account these new constraints...
12:43:58 <dviroel> but probably work for another release
12:44:55 <dviroel> any questions on that $topic?
12:45:05 <marios> thanks for the extra context dviroel
12:45:08 <amoralej> you think some initial improvements in the strategy to align with nova scheduler, other that the related with the scheduler-hints, is doable in this release?
12:45:09 <dviroel> :)
12:46:06 <dviroel> amoralej: maybe, it is also possible to include other constraints like server_groups for instance...
12:46:18 <dviroel> that are already available in nova's api
12:46:18 <amoralej> exactly, that was my point
12:46:50 <amoralej> given that we already have part of it, i was thinking if we may start implementing that part which does not require the new feature
12:47:01 <amoralej> even if it's not perfect, it may be better that what we have
12:47:22 <amoralej> said so, i have no idea about how complex it is
12:48:00 <dviroel> right, I think that is something that I can bring to the following meetings...
12:48:14 <amoralej> sounds good to me
12:48:30 <marios> anything further from anyone for right now on this before we move on
12:49:29 <marios> #topic next meeting chair
12:49:47 <marios> so rlandy is in the list but i don't know if they will be up for it... we can revisit between now and then
12:49:52 <amoralej> I may not be available at meeting time next week
12:50:04 <marios> but i think rlandy said they can do it so leaving as is for now
12:50:05 <rlandy> I can do it next week
12:50:20 <marios> #info rlandy to chair irc meeting 19th December 2024
12:50:29 <marios> next one after that is (checks calendar)
12:50:38 <marios> 09th Jan
12:50:56 <marios> volunteer to chair 09 Jan irc meeting please?
12:51:17 <amoralej> i can take it
12:51:18 <marios> if you aren't up for next week i can take it rlandy we talk before then obv
12:51:26 <marios> thank you amoralej
12:51:41 <marios> #info amoralej to chair irc meeting 09 Jan 2025
12:51:51 <dviroel> thanks amoralej
12:52:10 <marios> that is the end of topics
12:52:17 <marios> #topic open discussion
12:52:30 <marios> anything anyone would like to bring up here before we close out today?
12:53:57 <marios> ok then thanks all for participating o/
12:53:59 <marios> #endmeeting