12:00:00 <marios> #startmeeting watcher
12:00:00 <opendevmeet> Meeting started Thu Jan 23 12:00:00 2025 UTC and is due to finish in 60 minutes.  The chair is marios. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:00 <opendevmeet> The meeting name has been set to 'watcher'
12:00:22 <marios> hello folks, lets do a roll call for a minute and we'll get going.
12:00:25 <marios> who is around today?
12:00:33 <amoralej> o/
12:00:35 <rlandy> o/
12:00:37 <jgilaber> o/
12:00:53 <marios> #link https://etherpad.opendev.org/p/openstack-watcher-irc-meeting weekly agenda topics
12:01:28 <marios> we'll take those in order as usual please add any topics you want to present ^^
12:01:35 <chandankumar> o/
12:01:43 <dviroel> o/
12:02:11 <marios> ok lets get going
12:02:23 <marios> #topic     sean: Reset the DPL model for Watcher project: https://review.opendev.org/c/openstack/governance/+/939488
12:02:34 <marios> sean-k-mooney: o/ around ^
12:03:23 <marios> looks like sean-k-mooney is not currently available or momentarily afk... either way does anyone have any updates or comments on that ^
12:03:33 <marios> I believe we discussed it last week too... checking the review for any latest
12:03:50 <marios> so, still needs votes from the other folks
12:04:04 <rlandy> maybe Martin still needs to -1 it
12:04:22 <rlandy> or whoever we replace Martin with?
12:04:23 <marios> #info needs votes from all existing DPL members https://review.opendev.org/c/openstack/governance/+/939488
12:04:35 <marios> right in fact that info is wrong
12:04:40 <marios> Martin doesn't need to -1 it
12:04:47 <marios> the opposite
12:04:52 <marios> since he won't be working there any more
12:04:53 <rlandy> ok - I'll ping Martin and ask to take a look
12:05:00 <rlandy> just for this case
12:05:15 <marios> i mean, he should +1 it if anything, like he wants to reset his involvement
12:05:32 <rlandy> but not the whole model
12:06:09 <rlandy> " Watcher team either needs to opt-in the DPL
12:06:09 <rlandy> model for the next cycle or have the PTL in coming election." per the description on the change
12:06:14 <marios> so we need Martin and Dan to have a look. if they don't comment i think we can take that as they don't/can't be involved moving forward right?
12:06:57 <rlandy> ok - I'll take the action item to ping them and ask them to take a look
12:07:08 <marios> did we say chandankumar was interested in going into tact-sig? that would leave us with someone for tact-security then if Dan is not going to continue
12:07:29 <dviroel> we need to reach gmann on how to proceed, since watcher plans to continue with DPL but we also need to replace at least one liaison
12:07:30 <rlandy> ^^ dansmith when you are in? can you comment?
12:07:33 <chandankumar> yes, I was about to say that, you can add me at the place of martin
12:07:36 <marios> #action rlandy will reach out to Dan and Martin about https://review.opendev.org/c/openstack/governance/+/939488
12:07:40 <marios> thank you rlandy
12:08:29 <marios> so should/will one of us update that patch or should be ping Ghanshyam about it
12:08:47 <marios> to add Chandan and whoever else might take on the tact-sig does anyone know the proper etiquete?
12:09:37 <marios> tbd i guess we can revisit this next week
12:09:44 <marios> any further comments on this one?
12:10:49 <marios> k moving to the next topic ...
12:11:00 <marios> #topic     (rlandy): watcher-tempest-plugin review ready for core votes:
12:11:21 <marios> #link     https://review.opendev.org/q/project:openstack/watcher-tempest-plugin
12:11:45 <marios> is that the right link rlandy ^
12:11:55 <marios> (i got it from the etherpad)
12:12:50 <marios> this one ? https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/939517
12:12:55 <chandankumar> i think https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/938136/
12:13:12 <rlandy> correct
12:13:16 <marios> right, both of those then? one is rebased on the other right?
12:13:16 <chandankumar> marios: you have already added the other one
12:13:21 <chandankumar> yes
12:13:22 <dviroel> all open: https://review.opendev.org/q/project:openstack/watcher-tempest-plugin+status:+open
12:13:41 <chandankumar> Tested here: https://review.opendev.org/c/openstack/watcher/+/939702?usp=search
12:13:42 <marios> #link https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/939517
12:13:48 <marios> #link https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/938136/
12:14:27 <marios> #link https://review.opendev.org/c/openstack/watcher/+/939702?usp=search Tested here
12:14:56 <marios> sean-k-mooney: please check when you next have reviews time ^^^ thank you
12:15:01 <amoralej> https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/939517 needs rebase i think
12:15:37 <marios> ack thanks amoralej  ... chandankumar can you check ^ and then sean-k-mooney can vote
12:16:13 <chandankumar> amoralej: marios sure, let me rebase it
12:16:26 <marios> thanks
12:16:34 <marios> anything further on this topic ?
12:16:42 <opendevreview> chandan kumar proposed openstack/watcher-tempest-plugin master: Run make_host/instance statistics function for gnocchi datasource  https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/939517
12:17:55 <marios> moving on ...
12:17:59 <marios> #topic     marios: watcher decision engine prometheus datasource https://review.opendev.org/c/openstack/watcher/+/934423
12:18:24 <marios> so i think we can merge this? sean-k-mooney as previously discussed
12:18:32 <marios> the last update was ~2 weeks ago (tomorrow)
12:18:43 <marios> there are no further requests or comments and -1
12:19:16 <opendevreview> chandan kumar proposed openstack/watcher-tempest-plugin master: Run make_host/instance statistics function for gnocchi datasource  https://review.opendev.org/c/openstack/watcher-tempest-plugin/+/939517
12:19:32 <marios> so sean-k-mooney please have a look and merge https://review.opendev.org/c/openstack/watcher/+/934423 when you next have time for reviews o/ thanks
12:19:54 <dviroel> +1 to merge it
12:20:02 <marios> thank you dviroel
12:20:06 <marios> and all reviewers
12:20:23 <sean-k-mooney> yep i will do that today
12:20:29 <marios> thank you sean-k-mooney
12:20:49 <sean-k-mooney> and sorry i was not around before but i am now
12:20:49 <marios> #info merging prometheus datasource https://review.opendev.org/c/openstack/watcher/+/934423
12:20:55 <marios> np sean-k-mooney
12:21:03 <marios> anything else before we move to the next topic?
12:21:43 <sean-k-mooney> nope
12:21:50 <marios> ;)
12:22:00 <marios> moving on
12:22:06 <marios> #topic    (marios): bug triage summary
12:22:19 <marios> so i think rlandy you added a related item on the agenda
12:22:43 <marios> we had another bug triage call/irc meeting combination this week
12:22:45 <marios> fetching logs
12:23:03 <marios> #info weekly bug triage meeting minutes     Minutes: https://meetings.opendev.org/meetings/watcher_bug_triage_21_january_2025/2025/watcher_bug_triage_21_january_2025.2025-01-21-12.00.html
12:23:18 <opendevreview> Alfredo Moralejo proposed openstack/watcher master: Add support for instance metrics to prometheus datasource  https://review.opendev.org/c/openstack/watcher/+/938893
12:23:24 <marios> we got through a few this week, we did them newest first this time around
12:23:38 <marios> anything anyone wants to add or hilight?
12:24:28 <marios> per rlandy item on the agenda, we said we would have one more call/irc combination next week at the same time (tuesday 1200 utc)
12:24:38 <rlandy> just if anyone else wants to run the call?
12:24:40 <marios> we need someone to chair so we can give rlandy a well deserved rest
12:24:47 <marios> thank you rlandy
12:24:49 <rlandy> otherwise I can do it
12:25:02 <marios> do you *want* to do it? :D
12:25:03 <rlandy> it will be the last focused bug call
12:25:16 <rlandy> I'm fine with it either way
12:25:16 <marios> i mean, if you want/don't mind then we can cancel the call for volunteers... ;)
12:25:24 <rlandy> I'll do it
12:25:29 <marios> \o/
12:25:32 <marios> thank you rlandy
12:25:58 <dviroel> rlandy++
12:25:58 <marios> #info rlandy will chair bug triage call tue 28 1200 UTC
12:26:27 <marios> rlandy: bug czar
12:26:43 <marios> k any other comments or concerns before we move on
12:27:27 <dviroel> only rlandy can talk on gmeet, write on lauchnpad and on irc at the same time
12:27:40 <marios> yes :)
12:27:44 <rlandy> lol - not that hard
12:28:10 <marios> moving to the next topic
12:28:16 <marios> #topic     (marios): chair for irc meeting feb 06
12:28:26 <marios> we have a chair for next week thank you dviroel o/
12:28:31 <dviroel> :)
12:28:38 <marios> can we have a volunteer for the next one on feb 06?
12:28:58 <rlandy> I'll do it
12:29:02 <marios> i.e. this meeting in 2 weeks
12:29:18 <marios> ok thank you again rlandy :)
12:29:48 <marios> #info rlandy will chair irc meeting feb 06 1200 UTC
12:30:15 <marios> ok moving on then...
12:30:21 <marios> i don't see any other topics so...
12:30:26 <marios> #topic open floor
12:30:32 <marios> anything else someone wants to bring up?
12:30:39 <marios> anything from the mailing list we can hilight?
12:30:44 <rlandy> marios: do we need to return to the governance discussion if sean-k-mooney is with us now?
12:30:53 <marios> sure
12:31:28 <amoralej> i just sent a new ps on https://review.opendev.org/c/openstack/watcher/+/938893/ with doc fix
12:31:34 <amoralej> please reset your vots
12:31:42 <marios> thanks for updating amoralej looking now
12:31:48 <sean-k-mooney> the DPL topic
12:32:12 <sean-k-mooney> we can if ye want. at the end
12:32:28 <marios> we are there :)
12:33:16 <marios> sean-k-mooney: ^
12:33:19 <sean-k-mooney> so we have 2 related topics actully. on the dpl topic, we coudl revert to the PTL model but i think we would need to propose nomination this week if we wanted to do that
12:33:39 <sean-k-mooney> otherwise we can continue with the dpl process for one more cycle to see if that works for us
12:33:50 <marios> i think we only one we don't have is replacement for dan tact-security
12:34:16 <marios> ah.. onboarding too
12:34:20 <marios> ke chen
12:34:27 <sean-k-mooney> so onboarding is not actully required
12:34:32 <marios> ok
12:34:58 <sean-k-mooney> if needed i cna do the tact-security role but ill reach out to dan and see if they are willing to continue in that role later today
12:35:21 <sean-k-mooney> marios: are you ok to contiue to be the infra liasion
12:35:29 <marios> #info please revisit https://review.opendev.org/c/openstack/watcher/+/938893 (and parent patch merging today)
12:35:32 <marios> sean-k-mooney: yes
12:35:49 <sean-k-mooney> so the 3 required roels are infra, security and release
12:35:49 <marios> and chandankumar also wanted to join sean-k-mooney
12:36:01 <sean-k-mooney> ack
12:36:24 <sean-k-mooney> lets check with gman what the process is and if we shoudl propsoe a new revision to the patch after we check with dan
12:36:31 <marios> sean-k-mooney: so rlandy already has an action item to reach out to dan and martin can you please coordinate with rlandy ?
12:36:37 <rlandy> do we need martin to vote or can chandankumar just replace?
12:36:49 <rlandy> no problem to reach out to martin if that is the way to go
12:36:58 <sean-k-mooney> so i think if we follow the process stictly
12:37:04 <rlandy> sean-k-mooney, you can coordinate with dan
12:37:10 <rlandy> I'll reach out to martin
12:37:14 <sean-k-mooney> if we dont all vote -1 in time then the patch is merged and we revert to ptl model
12:37:23 <sean-k-mooney> then we can submit a new patch to go back to dpl
12:37:29 <marios> well i mean, if its like that we already have a couple -1s on it
12:37:50 <marios> so as you said (and we mentioned earlier in this meeting) we also need to ask Ghanshyam if we can update the patch or post new one
12:38:12 <sean-k-mooney> and if they are ok to contues as release liason
12:38:19 <marios> right
12:38:32 <sean-k-mooney> lets follow up with peopel asyc of the meetign and try and resolve this by the end of the week
12:38:35 <marios> do you want to do that and rlandy will reach out to dan and martin as previously agreed here?
12:38:50 <marios> that being reach out to ghanshyam
12:39:08 <sean-k-mooney> i can reach out to dan and gmann
12:39:15 <marios> ok thank you sean-k-mooney
12:39:32 <marios> #action sean-k-mooney to reach out Dan and Ghanshyam re https://review.opendev.org/c/openstack/governance/+/939488
12:39:32 <dviroel> what about chenke?
12:39:38 <marios> right dviroel
12:39:53 <sean-k-mooney> i can email them too i guess and see if they resopond
12:40:04 <marios> great thanks sean-k-mooney
12:40:22 <sean-k-mooney> the ohter option is we coudl have a ptl election  + still have addtional liaons
12:40:26 <marios> #action sean-k-mooney to reach out to chenker re https://review.opendev.org/c/openstack/governance/+/939488
12:40:35 <sean-k-mooney> so that always our backup plan if this does not pan out
12:41:02 <marios> any other topic for open floor?
12:41:06 <dviroel> ok so we first need to check with them if they plan to continue, and after that decide who is going to take the empty chairs :)
12:41:20 <marios> right dviroel
12:41:22 <sean-k-mooney> yep
12:41:28 <sean-k-mooney> so related topic.
12:41:32 <marios> but i think as we discussed here we should be covered on the 'who will take them'
12:41:42 <marios> so mostly it is a sanity check that indeed they won't be around/interested
12:41:48 <marios> (unless they might be i don't know)
12:41:49 <marios> ;)
12:42:17 <sean-k-mooney> i didnt get to send this yet but im currently working on an email regarding expandign the watcher core teams
12:43:03 <sean-k-mooney> i am going to try and send that today and ill reach out to peopel before i do to confirm if they are ok with being nominated
12:43:26 <marios> great thanks sean-k-mooney
12:43:27 <sean-k-mooney> for now i am not going to propose removign anyoen form the core groups with the excption fo martin
12:43:54 <dviroel> ++
12:43:59 <marios> we have discussed this in a couple of the recent irc meetings too... this being expanding our core group especially since reviews are starting to back up
12:44:08 <sean-k-mooney> since martin will nolonger be aroudn ill remove them form the watcher tempest plugin core group but if they return we can alwasy readd them
12:44:11 <marios> as just one example my prometheus datasource has been sitting for 2 weeks
12:44:20 <marios> because we will merge it with one core +2
12:45:03 <sean-k-mooney> yep so im going to be conservite in my proposal and we can revisit this topic again after/at the ptg
12:45:18 <sean-k-mooney> but my propsal is to email the list
12:45:26 <sean-k-mooney> and reivew next week
12:45:40 <marios> sounds good
12:45:42 <sean-k-mooney> if there are no objections after the next meetign ill apply the chagnes in gerrit
12:46:05 <dviroel> lgtm
12:46:21 <sean-k-mooney> that was all i had on that topic.
12:46:28 <marios> any further comments or concers on this one?
12:47:04 <marios> #info sean-k-mooney will propose expanding the core groups with post to openstack-discuss
12:47:28 <marios> any other topics for today?
12:49:14 <marios> thanks all for your participation o/
12:49:17 <marios> #endmeeting