12:00:06 <rlandy> #startmeeting watcher IRC meeting April 17
12:00:06 <opendevmeet> Meeting started Thu Apr 17 12:00:06 2025 UTC and is due to finish in 60 minutes.  The chair is rlandy. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:06 <opendevmeet> The meeting name has been set to 'watcher_irc_meeting_april_17'
12:00:18 <rlandy> hello all - who's around?
12:00:27 <dviroel> hi o/
12:00:43 <chandankumar> o/
12:01:44 <marios> o/
12:03:04 <dviroel> yeah quiet week, due to the holidays..
12:03:30 <rlandy> #link https://etherpad.opendev.org/p/openstack-watcher-irc-meeting#L104
12:03:37 <rlandy> today's topics ^^
12:04:11 <rlandy> and yeah - I expect light attendance as there are holidays in many countries today
12:04:21 <rlandy> let's start ...
12:04:45 <rlandy> #topic (rlandy) Any comments/concerns/unaddressed issues from the PTG?
12:04:59 <rlandy> looks like this is related to dviroel topic:
12:05:11 <rlandy> Flamingo PTG summary: https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/JJGOTIERMNE2ABAWTE7KP2I7HT7PDNQZ/
12:05:20 <rlandy> so dviroel do you want to take this?
12:05:56 <dviroel> right, I wrote this PTG summary, which also includes our cross-project discussions,  with telemetry, horizon and nova teams
12:06:46 <dviroel> so please take a look, see if I didn't miss anything important from PTG
12:06:54 <rlandy> thank you for writing out the summary
12:07:06 <dviroel> there is also some action item that are already assigned to people
12:07:21 <dviroel> while others have no assignees
12:07:49 <rlandy> dviroel: is there any action item that needs an assignee now?
12:08:06 <rlandy> ie: that cannot wait to see if that item will in fact be taken on?
12:08:30 <dviroel> I don't think so
12:08:50 <dviroel> we were missing some contributors to help on the eventlet removal
12:09:15 <dviroel> but chandankumar and I already volunteer
12:10:10 <dviroel> but still, if someone wants  to join us in any of the related topics, you are welcome :)
12:11:15 <rlandy> thank you dviroel  - anything more on the PTG topic?
12:11:46 <dviroel> not on my side
12:12:39 <rlandy> ok - let's move on then ...
12:12:48 <rlandy> #topic: (rlandy) Any release activities we need to take care of?
12:13:18 <rlandy> sean-k-mooney: ^^ is there anything that we need to take care of at the moment wrt releases?
12:16:19 <rlandy> anyone else on the DPL know of any activities there?
12:16:29 <rlandy> if not, I can ask off line ...
12:17:01 <chandankumar> I also need to find out do we need to cut a new release of watcher-tempest-plugin
12:17:52 <rlandy> #action chandankumar  to find out do we need to cut a new release of watcher-tempest-plugin
12:19:12 <rlandy> #action rlandy to follow up with release liaison
12:19:25 <sean-k-mooney> rlandy: sorry was distacted
12:19:32 <rlandy> just in time :)
12:19:35 <sean-k-mooney> am bobcat is about to go end of life
12:19:45 <sean-k-mooney> so we need to review stable patches
12:19:50 <sean-k-mooney> and prepare the final release
12:20:04 <sean-k-mooney> im currently doing that for nova but plan to look at watcher later today
12:20:12 <sean-k-mooney> we have about a week to do that
12:20:30 <sean-k-mooney> so ill try to see if we can do a bobcat release next wednesday
12:20:39 <sean-k-mooney> and likely release for the other stable branches too
12:20:42 <rlandy> ok - so could you show me/joan how to do that so there are more people who can help
12:20:45 <chandankumar> sean-k-mooney, Do we also need a new tag for 2025.1 release?
12:20:57 <sean-k-mooney> no thats already done
12:21:00 <chandankumar> for watcher-tempest-plugin
12:21:23 <sean-k-mooney> that was goign to be done with the rest of the tempest ones
12:21:29 <sean-k-mooney> but i cna double check with the release team
12:21:37 <chandankumar> sean-k-mooney, thank you !
12:21:47 <chandankumar> I will check the latest tempest tag
12:22:14 <sean-k-mooney> https://review.opendev.org/c/openstack/releases/+/944697
12:22:24 <sean-k-mooney> so we did that already
12:22:40 <sean-k-mooney> its 3.4.0
12:22:47 <chandankumar> ah yes, great
12:23:20 <sean-k-mooney> im goign to start working on the doc for when we need to do these things next week too
12:23:30 <sean-k-mooney> so that we have a common souce to refence as needed
12:26:16 <rlandy> thank you sean-k-mooney
12:26:45 <rlandy> anything else for releases?
12:26:53 <sean-k-mooney> nope
12:27:23 <rlandy> ok - great ... moving on
12:27:31 <rlandy> #topic (dviroel) Specs open for review
12:27:43 <rlandy> #link https://review.opendev.org/c/openstack/watcher-specs/+/943873 (disable cold/live migration for host maintenance strategy)
12:27:52 <rlandy> #link https://review.opendev.org/c/openstack/watcher-specs/+/947282 (Adds spec for extend compute model attributes)
12:27:58 <rlandy> dviroel: ^^ pls go ahead
12:28:00 <dviroel> right, we have 2 specs open for review
12:28:17 <dviroel> we discussed about them in the PTG
12:28:43 <dviroel> the first one is from jneo8 - and we already have some discussions going on
12:29:07 <dviroel> the second one I recently sent for review
12:29:30 <dviroel> it is about extending the compute model in watcher
12:29:59 <dviroel> to include new attributes/capabilites related to host/instances
12:30:34 <dviroel> that will help us to build better strategies and solutions
12:31:44 <sean-k-mooney> the two are releated
12:31:56 <sean-k-mooney> but we dont neesisally need to make one depend on the other
12:32:34 <sean-k-mooney> because of the outcome of the nova sesssion
12:32:34 <dviroel> right, the first one could benefit from second one
12:32:50 <sean-k-mooney> ya the first could also use instance metadta to express policy
12:32:57 <sean-k-mooney> which could benift form the second
12:33:11 <sean-k-mooney> but we can consier that as a future incremental imporvement
12:33:23 <sean-k-mooney> i will call that out in my spec review when i get to it
12:33:42 <dviroel> ++
12:35:51 <dviroel> that's it, more a request for reviews at this moment :)
12:36:10 <rlandy> dviroel do you have a timeframe by when reviews should be done?
12:37:47 <dviroel> we didn't define a deadline for specs
12:38:14 <dviroel> but usually before milestone-2
12:38:31 <rlandy> right - so whatever date that is
12:39:12 <dviroel> #link https://releases.openstack.org/flamingo/schedule.html (Flamingo Schedule)
12:39:49 <rlandy> Jun 30 - Jul 04
12:40:03 <rlandy> Flamingo-2 milestone
12:41:10 <rlandy> ok - thank you dviroel
12:41:14 <rlandy> let's move on ...
12:41:32 <rlandy> #topic bug triage ...
12:41:36 <rlandy> Plan was to hold two bug triage meetings per month - last week canceled due to PTG
12:41:44 <rlandy> added links to the bug lists:
12:41:53 <rlandy> #link https://bugs.launchpad.net/watcher
12:42:03 <rlandy> #link https://bugs.launchpad.net/watcher-dashboard
12:42:12 <rlandy> #link https://bugs.launchpad.net/watcher-tempest-plugin
12:42:35 <rlandy> I didn't add any particular bug for today due to decision to have a dedicated bug meeting
12:42:54 <rlandy> buy if anyone else wants to raise a bug for discussion, please do
12:43:08 <chandankumar> I have added this https://bugs.launchpad.net/watcher-tempest-plugin/+bug/2107531 bug
12:43:41 <chandankumar> If anything more missing from tempest tests conventions side in watcher-tempest-plugin, Please do add.
12:44:00 <rlandy> let's triage that bug ...
12:44:04 <rlandy> importance?
12:44:26 <rlandy> moved from new to triaged
12:44:34 <chandankumar> I would add it to wishlist. as it is not blocking anything
12:45:00 <dviroel> ack, it is a good to have
12:45:07 <chandankumar> Added the proper labels
12:45:12 <rlandy> done - please ping david about that next week after holidays
12:45:22 <chandankumar> rlandy, sure!
12:45:35 <rlandy> thank you chandankumar
12:45:43 <rlandy> anyone else?
12:46:28 <chandankumar> nothing from my side
12:46:34 <rlandy> k - let's move to open topics
12:46:40 <rlandy> # topic - open
12:46:50 <rlandy> anything else to discuss?
12:48:44 <dviroel> i think that we had lot of discussions last week :)
12:48:50 <rlandy> sure ...
12:49:09 <rlandy> dviroel,  thank you for volunteering to chair the next meeting
12:49:23 <rlandy> we can close out then ...
12:49:26 <rlandy> thank you all
12:49:32 <dviroel> ty rlandy o/
12:49:47 <rlandy> #endmeeting