#edge-computing-group: Weekly Edge Computing Group Call

Meeting started by csatari at 14:02:51 UTC (full logs).

Meeting summary

  1. Roll Call (csatari, 14:03:02)
    1. Eric Sarault eric.sarault@kontron.com (esarault_, 14:03:40)

  2. Action items (csatari, 14:04:02)
  3. Alternating meeting slots (csatari, 14:04:38)
    1. Mark Beierl mark.beierl@dell.com (mbeierl, 14:04:56)
    2. APAC slot is: every first Thursday of the month at 0700 UTC (csatari, 14:05:14)
    3. First APAC slot is Thursday, 5th of July (csatari, 14:05:22)

  4. Use Case sub-group (csatari, 14:05:48)
    1. The template was updated. (csatari, 14:06:15)
    2. https://etherpad.openstack.org/p/feedback_on_template (csatari, 14:06:25)
    3. Anyone is fee to add use cases following the template to here: https://wiki.openstack.org/wiki/Edge_Computing_Group/Use_Cases (csatari, 14:08:03)
    4. We should have a status field for the use cases what indicated if ti is under disucssion or verified. (csatari, 14:09:14)
    5. https://gerrit.opnfv.org/gerrit/#/c/58959/ (mbeierl, 14:10:06)
    6. OPNFV Edge team also started to write use cases: https://gerrit.opnfv.org/gerrit/#/c/58959/ (csatari, 14:10:15)
    7. Expectation is to finalize the use cases by end of july (csatari, 14:11:06)
    8. Please add your comments to https://etherpad.openstack.org/p/feedback_on_template (csatari, 14:11:27)

  5. Dublin PTG follow-up discussion (csatari, 14:11:55)
    1. Regular review meeting: Every Thursday 16-17h CET (csatari, 14:12:09)
    2. Starting from this week. (csatari, 14:12:32)

  6. Glance (csatari, 14:14:13)
    1. ACTION: Gerg0 to initiate a mail discussion about the pros and cons of the Glance architecture options (csatari, 14:14:46)

  7. Keystone (csatari, 14:14:59)
    1. https://etherpad.openstack.org/p/ECG_Keystone_Testing (csatari, 14:15:51)
    2. OPNFV Edge Meeting tomorow from 1300 UTC: https://zoom.us/j/5014627785 (csatari, 14:17:28)
    3. ACTION: Gerg0 to send the OPNFV Edge meeting details to the edge couputing maiing list (csatari, 14:18:49)
    4. There is an onging disucssion about the behaviour of K2K federation when there is a network connectivity issue between the Keystones (csatari, 14:21:31)
    5. No network issues inside the edge cloud instance, but the edge cloud instance is isolated from the rest of the edge cloud infrastructure (csatari, 14:22:22)
    6. In this case a manually added SAML info can be provided to Keystone (csatari, 14:23:28)
    7. There is also support for application credentials which also provides a solution for the problem. (csatari, 14:24:55)
    8. Basic diagram describing federated authentication workflows: https://bit.ly/2yJ0eGp (csatari, 14:26:31)
    9. Even more details: https://bit.ly/2HmXySC (csatari, 14:28:57)
    10. Users are replicated to the edge cloud instance using the shadow users (csatari, 14:32:48)
    11. To replicate the projects there is a feature called federated autoprovisioning. (csatari, 14:33:27)
    12. https://docs.openstack.org/keystone/queens/user/application_credentials.html (csatari, 14:33:49)
    13. https://docs.openstack.org/keystone/latest/advanced-topics/federation/federated_identity.html#auto-provisioning (csatari, 14:33:58)
    14. StartlingX does not use K2K federation at the moment. It uses https://wiki.openstack.org/wiki/Keystone_edge_architectures#Keystone_API_Synchronization_.26_Fernet_Key_Synchronization (csatari, 14:36:27)

  8. AoB (csatari, 14:39:33)
    1. N/A (csatari, 14:39:50)


Meeting ended at 14:40:09 UTC (full logs).

Action items

  1. Gerg0 to initiate a mail discussion about the pros and cons of the Glance architecture options
  2. Gerg0 to send the OPNFV Edge meeting details to the edge couputing maiing list


People present (lines said)

  1. csatari (37)
  2. ildikov (3)
  3. openstack (3)
  4. rcherrueau (3)
  5. mbeierl (2)
  6. esarault_ (1)


Generated by MeetBot 0.1.4.