13:04:06 <csatari> #startmeeting weekly_edge_computing_group_call
13:04:07 <openstack> Meeting started Thu Aug  9 13:04:06 2018 UTC and is due to finish in 60 minutes.  The chair is csatari. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:10 <openstack> The meeting name has been set to 'weekly_edge_computing_group_call'
13:04:19 <csatari> #topic Roll call
13:04:28 <csatari> #info Gergely Csatari
13:07:20 <csatari> #topic Links
13:07:33 <csatari> #link https://etherpad.openstack.org/p/YVR-edge-keystone-brainstorming
13:07:43 <csatari> #link https://wiki.openstack.org/wiki/Edge_Computing_Group#Keystone
13:09:54 <csatari> #topic Usage of Keystone federation on the field
13:10:17 <csatari> #info StarlingX does not use Keystone federation at the moment.
13:10:50 <csatari> #info Loss of connectivity between the client and the IdP can result in problems in case of Keystone federation.
13:13:16 <csatari> #info StarlingX uses synchronisation of data. Now it moves towards a database synchronisation approach. Database synchronisation is half done.
13:15:17 <csatari> #info The db replicaiton is done via an agent which is able to do schema transformation in case of diferent versions.
13:20:25 <bogdando> o/
13:20:36 <csatari> #info The problem with API synchronisatio: 1) there is a table with revocation events which is populated by different actions, like password change 2) User ID-s and project ID-s are not synchronised (this is needed to enable the usage of Fernet keys generated remotely).
13:20:58 <bogdando> for the DB replication topics, just wanted to point out some questions http://lists.openstack.org/pipermail/edge-computing/2018-August/000385.html
13:21:12 <csatari> #info There is an activity to implement Galera spanning over multiple locations.
13:21:21 <bogdando> I wish to know more of that agent which is able to do schema transformation in case of different versions, as well
13:21:55 <csatari> bogdando: You can ask about it now and in the next 39 minutes here: https://zoom.us/j/671236148
13:23:37 <csatari> #info Galera is able to synch ~16 db-s.
13:31:42 <csatari> #action csatari To do some analyzis on the listed concerns for the alternatives.
13:32:34 <csatari> #info Mapping rules for Keystone federation can be static.
13:36:59 <csatari> #info Singned SAML-s can be user only once and only for a specific SP.
13:37:24 <csatari> Unscoped token can be reused, but can expire.
13:37:34 <csatari> #info Unscoped token can be reused, but can expire.
13:44:15 <csatari> #action Greg to get the StarlingX database replication design document to the Edge Computing Group wiki
13:46:49 <csatari> #action csatari Update the wiki to have the two DB synch alternatives represented.
13:47:52 <mbeierl> I thought this meeting was 1 hour later - is this the review of Dublin Edge Notes, or is this another meeting that I missed?
13:47:55 <csatari> #topic Federation testing
13:52:35 <csatari> mbeierl:  This is the Keystone meeting.
13:52:47 <mbeierl> csatari: ok, thanks
13:52:55 <csatari> The review of Dublin notes starts in 8 mins.
13:56:38 <csatari> #topic Closing
13:57:28 <csatari> #info More meetings to come week after next week.
13:57:39 <csatari> #info We will have a session in the PTG about Keystone.
13:58:06 <csatari> #info We will use the same timeslot.
13:58:18 <csatari> #info Thursday 15h-16h CET.
13:59:28 <csatari> #endmeeting