19:00:03 <amitgandhinz> #startmeeting Weekly Poppy Meeting
19:00:04 <openstack> Meeting started Thu Oct  9 19:00:03 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:08 <openstack> The meeting name has been set to 'weekly_poppy_meeting'
19:00:19 <amitgandhinz> #topic RollCall
19:00:23 <amitgandhinz> o/
19:00:25 <obulpathi> o/
19:01:07 <tonytan4ever> Hello
19:01:10 <tonytan4ever> 0/
19:01:34 <obulpathi> malini is in meeting, will join us shortly
19:01:44 <amitgandhinz> ok
19:02:04 <amitgandhinz> anyone from fastly, maxcdn, akamai, edgecast, or hybernia?
19:03:14 <obulpathi> looks like no one here
19:03:18 <amitgandhinz> =/
19:03:32 <megan_w_> we need to send out agendas on tuesdays again i think
19:03:42 <amitgandhinz> possibly
19:03:45 <megan_w_> make sure they know we need them here
19:03:46 <amitgandhinz> and hi megan_w_!
19:03:48 <megan_w_> hi!
19:04:07 <obulpathi> hi megan_w_!
19:04:25 <amitgandhinz> #topic Review Last Weeks Items
19:04:30 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-10-02-19.00.html
19:04:44 <amitgandhinz> so only one action item from last
19:04:46 <amitgandhinz> week
19:04:54 <amitgandhinz> megan_w_ to get a MaxCDN point of contact for tonytan4ever
19:05:02 <amitgandhinz> any update on that megan_w_?
19:05:20 <megan_w_> amitgandhinz: meeting scheduled for next week
19:05:28 <amitgandhinz> awesome
19:05:29 <megan_w_> that's what i was pinging about in the other channel
19:05:42 <amitgandhinz> hehe i know, but i like everyone to hear it =P
19:05:49 <tonytan4ever> Great.
19:05:51 <obulpathi> :)
19:05:53 <amitgandhinz> it gets officially documented this way =P
19:06:11 <amitgandhinz> ok
19:06:18 <amitgandhinz> #topic Blueprint Updates
19:06:27 <amitgandhinz> #link https://blueprints.launchpad.net/poppy
19:06:38 <amitgandhinz> obulpathi: list services
19:06:43 <obulpathi> needs review
19:06:53 <amitgandhinz> ok
19:07:03 <amitgandhinz> miqui: add-docstrings update?
19:07:08 <amitgandhinz> miqui: you around?
19:08:32 <obulpathi> looks like miqui is not active on irc
19:08:58 <obulpathi> should we just leave this task as it is
19:09:00 <amitgandhinz> ok lets carry on
19:09:12 <amitgandhinz> delete-service tonytan4ever
19:09:23 <tonytan4ever> It's under review.
19:09:45 <tonytan4ever> So I think it's fair to change its status to Needs Review.
19:09:46 <amitgandhinz> dns-driver - amitgandhinz - havent started it yet
19:09:53 <amitgandhinz> tonytan4ever: just updated it =P
19:09:58 <tonytan4ever> Cool.
19:10:24 <amitgandhinz> gate-cassandra hasnt been worked on yet
19:10:44 <amitgandhinz> rm-mockdb - i had a patch out there but abandoned it due to gerrit issues
19:10:57 <amitgandhinz> i will resubmit it, but it wont be mergable until we get cassandra at the gate
19:11:35 <obulpathi> oh, so its blocking the mockdb-rm
19:11:48 <obulpathi> rm-mockdb, rather
19:11:58 <amitgandhinz> yeh because removing mockdb requires replacing it with another db
19:12:04 <amitgandhinz> we only have cassandra to replace it with
19:12:10 <amitgandhinz> but that will fail all tests at the gate
19:12:20 <amitgandhinz> so either we introduce sqla or put cassandra in
19:12:34 <amitgandhinz> ok anything else started
19:12:40 <amitgandhinz> patch?
19:12:41 <obulpathi> I started the patch-service
19:12:59 <obulpathi> can you please assign it to me and change status to started?
19:13:05 <amitgandhinz> done
19:13:11 <obulpathi> cool ... thanks :)
19:13:12 <amitgandhinz> purge?
19:13:21 <tonytan4ever> I started it.
19:13:39 <amitgandhinz> assigned
19:13:59 <tonytan4ever> Sure, and I already have a partial PR for that.
19:14:08 <amitgandhinz> cool
19:14:15 <amitgandhinz> also the py34 is now merged =)
19:14:26 <obulpathi> yay!
19:14:41 <obulpathi> so we will have py33 and py34?
19:14:58 <amitgandhinz> for now yes
19:15:03 <obulpathi> ok .. cool
19:15:13 <amitgandhinz> i will get rid of oy33 and py26 once its officially denounced
19:15:19 <obulpathi> cool
19:15:31 <amitgandhinz> ok anymore bp updates?
19:15:58 <obulpathi> nothing else from me
19:16:08 <tonytan4ever> I am good.
19:16:14 <amitgandhinz> #topic Make X-Project-ID Header mandatory
19:16:35 <amitgandhinz> #link agenda here: https://wiki.openstack.org/wiki/Meetings/Poppy
19:16:48 <amitgandhinz> so this first item came from malini who is not here
19:17:01 <amitgandhinz> but basically, we require to always have an x-project-id in the header
19:17:12 <amitgandhinz> so it should be mandatory
19:17:19 <amitgandhinz> is there a reason why it shouldnt be required?
19:17:52 <obulpathi> I think its partially for to do with having project_id in url for some of our tests
19:17:56 <tonytan4ever> What is the expected behavior if this header is not present ?
19:18:14 <tonytan4ever> 400 bad request ?
19:18:16 <amitgandhinz> so if the id is in the url, there is already a pecan hook to take it and put it in the header
19:18:21 <obulpathi> right now our code check to see if its in url and then looks for in it headers
19:18:26 <obulpathi> yes,
19:18:46 <obulpathi> but its not mandatory to have it in headers ... thats what she is driving us to adopt I think
19:18:55 <amitgandhinz> the only reason we support it in the url is due to Rackspace's implementation of keystone
19:19:07 <amitgandhinz> as of keystone v3, it doesnt have to be in the header
19:19:38 <obulpathi> ok .. so we just need to make sure we have the the project id header in all our tests
19:19:44 <amitgandhinz> yeh
19:19:47 <tonytan4ever> OK, I believe the pecan hook check X-Project-ID first, if it is not present it will look into url.
19:19:55 <amitgandhinz> and i think with repose a filter can be used to add it to the header
19:20:15 <obulpathi> oh ok .. cool
19:20:42 <amitgandhinz> i think when working on zaqar we also made it mandatory in there
19:21:04 <amitgandhinz> ok do we all agree to make it mandatory?
19:21:09 <obulpathi> yep
19:21:15 <tonytan4ever> #agreed.
19:21:17 <amitgandhinz> #agreed make x-project-id header mandatory
19:21:30 <amitgandhinz> tonytan4ever: you just agreed to a .
19:21:36 <amitgandhinz> =P
19:21:45 <amitgandhinz> ok moving on
19:21:45 <tonytan4ever> #agreed make x-project-id header mandatory
19:22:13 <amitgandhinz> #topic handling of next/prev links in list results
19:22:29 <amitgandhinz> so two options here, one is to return an empty list []
19:22:53 <amitgandhinz> or two, return the marker for the last item/current url in the links
19:23:14 <amitgandhinz> i think zaqar uses option 2, but they have a constant stream of messages
19:23:19 <amitgandhinz> what does nova do here?
19:23:33 <obulpathi> I contacted the DRG, but have not got any response from them yet
19:24:28 <obulpathi> it not apparent from documentation, will look into the code and figure out how they do it
19:24:39 <obulpathi> and get the format finalized
19:25:23 <obulpathi> #action obulpathi to finalize on the format of the next_url for listing services
19:25:40 <obulpathi> also for information,
19:25:50 <obulpathi> nova does listing differently
19:25:54 <amitgandhinz> yeh
19:25:58 <obulpathi> its splits out only metadata first
19:26:01 <amitgandhinz> im looking at heat and nova and they are all different
19:26:07 <amitgandhinz> im not even seeing the marker semantics
19:26:13 <obulpathi> like [server1, link , status]
19:26:33 <amitgandhinz> so im currently leaning towards option 1
19:26:35 <obulpathi> and then client needs to go and fetch the service for more details on server1
19:27:05 <obulpathi> nyw .... option 1 is the current implementaiton
19:27:13 <obulpathi> s/nyw/btw ...
19:27:19 <malini> o/
19:27:26 <obulpathi> hello malini :)
19:27:31 <amitgandhinz> hi malini
19:27:37 <amitgandhinz> do you support option 1?
19:27:40 <tonytan4ever> ok.
19:27:53 <malini> amitgandhinz: no
19:28:05 <amitgandhinz> why not?
19:28:29 <tonytan4ever> I think we should support option 1 for now, just for the sake of simplicity.
19:28:40 <malini> with the empty list, we make it harder for clients
19:29:08 <obulpathi> actually option 2, it even more easy
19:29:31 <obulpathi> the edge case of next_url when there are no more items to fetch will go away
19:29:43 <malini> now we just need to find a client developer to support me :-P
19:29:50 <tonytan4ever> OK, you mean it will be implemented easy
19:30:03 <obulpathi> tonytan4ever: yes
19:30:34 <tonytan4ever> but I would think that's confusing for client though, when you the 'next' is really the current one.
19:30:56 <obulpathi> there won't be any peek ahead into the database to check to see if there are any more items
19:31:10 <malini> tht is a philosophical question - what is next when there is no next?
19:31:21 <amitgandhinz> so when there are no services, what is the marker value?
19:31:28 <amitgandhinz> ie there is no current marker?
19:31:31 <obulpathi> none
19:31:38 <amitgandhinz> none or "none" lol
19:31:48 <malini> as in '?marker='  ??
19:32:08 <obulpathi> yes
19:32:21 <malini> tht doesnt look good either
19:32:23 <amitgandhinz> how do i know im on the last page?
19:32:33 <amitgandhinz> ie how does a client know when to stop asking for next
19:32:44 <malini> when services is []
19:33:13 <obulpathi> yes
19:33:17 <amitgandhinz> and when services is [] then ?marker=_
19:33:42 <amitgandhinz> or ?marker=last_item
19:33:49 <obulpathi> in case 1: the next_url filed is absent
19:34:13 <malini> I like the ?marker=last_item
19:34:28 <malini> but what happens when the DB has no services to return
19:34:38 <amitgandhinz> then there is no marker
19:34:56 <tonytan4ever> So even if the last page of service is less than the number of limit,  you are still not in the last page ?
19:34:57 <malini> i.e do not return marker param in the url ?
19:35:16 <malini> tht was for amitgandhinz
19:35:27 <amitgandhinz> malini: correct
19:35:28 <tonytan4ever> You always have to get to an empty services [] to get to last page ?
19:35:48 <amitgandhinz> if no services, marker is not returned.
19:36:03 <amitgandhinz> if less than a page of items, marker is the last item
19:36:14 <malini> I like that
19:36:14 <amitgandhinz> if more than a page of items, marker is the last item on the page
19:36:23 <obulpathi> amitgandhinz: yes
19:36:30 <amitgandhinz> if on last page, marker is last item on that page
19:36:42 <amitgandhinz> client calls that link until they get serivces = []
19:36:49 <amitgandhinz> during which marker is still that last itme
19:37:03 <amitgandhinz> ok, i like that
19:37:10 <obulpathi> thats is almost how it works now
19:37:13 <amitgandhinz> i want feedback from devs though (eg the DRG)
19:37:20 <malini> amitgandhinz: +1
19:37:21 <amitgandhinz> then move forward
19:37:31 <amitgandhinz> ok lets revisit this topic in the channel
19:37:32 <obulpathi> +1
19:37:36 <tonytan4ever> +1
19:37:42 <obulpathi> I already contacted them, waiting for their reply
19:37:54 <amitgandhinz> #topic Openstack Summit Paris Agenda
19:37:59 <amitgandhinz> w000000000000t!!!!
19:38:04 <amitgandhinz> they want us
19:38:07 <amitgandhinz> they love us
19:38:08 <malini> WOOOOOOOTTTT!!!
19:38:12 <obulpathi> WOOOOOOOOOOTTT!!!!!!!!!!
19:38:25 <malini> tht is awesome <:o)
19:38:29 <amitgandhinz> so......I will be presenting at the design summit track
19:38:31 <obulpathi> malini: I my woot have more oo than yours :)
19:38:38 <amitgandhinz> #link http://kilodesignsummit.sched.org
19:38:39 <tonytan4ever> I actually like to hear 'they need us'.
19:38:41 <malini> but I have a party cap
19:38:50 <amitgandhinz> it will be one of the "Other project" sessions
19:38:56 <obulpathi> aaah
19:39:16 <malini> amitgandhinz: you should pack some poppy for the summit ;)
19:39:30 <amitgandhinz> the design summit differs from the main conference in that these are geared more towards design
19:39:50 <obulpathi> yes, it is more sort of like an unconference
19:39:55 <obulpathi> jsut discuss your ideas
19:40:06 <malini> it'll be really cool if we can get the CDN folks there..I mean the real ones :)
19:40:11 <amitgandhinz> yeh
19:40:21 <amitgandhinz> so my plan is the following (open to ideas)
19:40:22 <amitgandhinz> ...
19:40:34 <amitgandhinz> do a 10 minute overview of the Poppy project
19:40:47 <amitgandhinz> talk about the challenges
19:40:51 <amitgandhinz> talk about what we have done so far
19:40:59 <amitgandhinz> talk about vendor involvement
19:41:14 <amitgandhinz> hopefully have some of the vendors interacting with Poppy present
19:41:28 <amitgandhinz> ugh we lost megan_w
19:41:40 <obulpathi> oops
19:41:44 <malini> challenges —> we should also look at why similar efforts have failed in the past
19:41:53 <amitgandhinz> #action megan_w to gauge vendor participation in Paris
19:42:00 <amitgandhinz> malini: yes!
19:42:13 <amitgandhinz> and then i want to spend some time discussing what is next for Poppy
19:42:30 <amitgandhinz> ie what does the Kilo release look like
19:42:40 <obulpathi> +1
19:42:41 <amitgandhinz> what will we be focused on (or should be focusing on)
19:42:47 <amitgandhinz> what challenges are next for us
19:43:03 <amitgandhinz> both from an architecture perspective, and a feature perspective
19:43:24 <amitgandhinz> the session will be 45 minutes long
19:43:31 <tonytan4ever> SGTM.
19:43:38 <obulpathi> +1
19:43:40 <amitgandhinz> any other ideas people have?
19:43:47 <obulpathi> looks like a solid plan
19:43:47 <malini> we also need to gauge if/how we should go the incubation route
19:44:04 <obulpathi> +1
19:44:04 <malini> maybe its too early, but we need to get a feel
19:44:10 <amitgandhinz> yeh
19:44:21 <amitgandhinz> try to see what the interest is for this type of project in openstack
19:44:36 <amitgandhinz> #idea try to see what the interest is for this type of project in openstack
19:44:45 <amitgandhinz> #idea challenges —> we should also look at why similar efforts have failed in the past
19:44:55 <amitgandhinz> #idea talk about the challenges
19:45:02 <amitgandhinz> #idea talk about what we have done so far
19:45:02 <malini> With the openstack tent discussions going on, there might be room ..sorry tent for us
19:45:08 <amitgandhinz> #idea talk about vendor involvement
19:45:19 <amitgandhinz> #idea do a 10 minute overview of the Poppy project
19:45:33 <amitgandhinz> #idea what does the Kilo release look like
19:46:09 <amitgandhinz> i also need/want to directly invite certain members to the session
19:46:27 <amitgandhinz> community members who can have a direct impact on what this team is doing
19:46:31 <obulpathi> will it be a good point to discuss any integration with other openstack-projects?
19:46:39 <amitgandhinz> i plan to invite designate to it
19:46:48 <obulpathi> +1
19:46:57 <tonytan4ever> good idea.
19:46:59 <amitgandhinz> potentially zaqar if we go down a message route
19:47:18 <obulpathi> yep
19:48:56 <amitgandhinz> ok any other ideas?
19:48:56 <obulpathi> so any other ideas?
19:49:01 <amitgandhinz> jnx!
19:49:04 <obulpathi> hhahha
19:49:24 <malini> none from me
19:49:39 <obulpathi> also, it would be a good idea to attend designate and other interesting projects
19:49:43 <amitgandhinz> ok, so we can discuss the session more in the channel
19:49:48 <amitgandhinz> obulpathi: +1
19:49:56 <tonytan4ever> Aside from the challenges, you also want to talk about prospects ?
19:49:59 <obulpathi> and tell them what we are doing
19:50:06 <malini> tonytan4ever: good point :)
19:50:15 <tonytan4ever> To attract more interest to us.
19:50:39 <amitgandhinz> prospects = future features?
19:50:58 <tonytan4ever> OK, they can be mixed up.
19:51:18 <malini> 'prospects' should be a justification of why we should exist
19:51:34 <malini> as in how poppy can benefit openstack
19:51:45 <amitgandhinz> #idea how poppy can benefit openstack
19:52:00 <obulpathi> and idea can change your life!
19:52:07 <obulpathi> s/and/an
19:52:26 <malini> sounds like we are in cellphone business :D
19:52:30 <amitgandhinz> ok so i will start a first draft of the prezi and we can work on it together
19:52:32 <obulpathi> hahhaha ...
19:52:45 <amitgandhinz> 7 min left
19:52:49 <malini> amitgandhinz: +1
19:52:51 <amitgandhinz> #topic open discussion
19:53:02 <obulpathi> #topic Global limit for paging
19:53:17 <obulpathi> how about having a global limit for paging
19:53:31 <obulpathi> tonytan4ever: do you want to discuss your idea?
19:53:33 <amitgandhinz> is that like the default?
19:53:51 <tonytan4ever> I am all for a global limit number
19:54:02 <amitgandhinz> can ya'll define global limit?
19:54:08 <obulpathi> can you please tell us what the global limit is
19:54:17 <obulpathi> tonytan4ever: ^
19:54:18 <amitgandhinz> obulpathi: stop reading my mind!
19:54:36 <tonytan4ever> It is kind like a default, but that global default should be a configurable value.
19:54:41 <obulpathi> amitgandhinz: sorry ..I read it little bit off this time
19:54:48 <obulpathi> next time I will get it right :D
19:55:08 <tonytan4ever> So any entity that needs pagination will use this default value as limit.
19:55:33 <amitgandhinz> so that should be defined in the conf file (and the api should define a default if its missing from the conf)
19:56:05 <tonytan4ever> That is good to me.
19:56:09 <obulpathi> tony is worried that we will have too many limit options in config file
19:56:10 <amitgandhinz> ok cool
19:56:23 <amitgandhinz> we just need one for services and one for flavors right?
19:56:27 <obulpathi> and he is saying that we should have a default limit for all paging stuff
19:56:28 <amitgandhinz> any more limits?
19:57:08 <malini> in case we end up needing separate limit for certain fields, we can always add them
19:57:10 <obulpathi> tonytan4ever: thats what I understood. please correct me if this is not what you have in mind
19:57:49 <tonytan4ever> We should avoid too many paging-limit config values in our conf file/option.
19:58:03 <malini> tonytan4ever: +1
19:58:19 <amitgandhinz> agreed, but i dont think 2-5 limits is a lot?
19:58:27 <amitgandhinz> if its more than that then i agree we need a global limit
19:58:34 <obulpathi> yeah, if we have too many then we can add
19:58:37 <amitgandhinz> yeh
19:58:43 <amitgandhinz> ok 1 minute remaining
19:58:59 <malini> amitgandhinz: is that NO global limits for now?
19:59:30 <amitgandhinz> correct
19:59:35 <tonytan4ever> Also having a limit on each entity make our applicaiton's conf file depend on business logic
19:59:40 <amitgandhinz> ok times up
19:59:44 <amitgandhinz> continue in the channel plz
19:59:49 <malini> bye
19:59:50 <amitgandhinz> #endmeeting