21:01:40 <obulpathi> #startmeeting Weekly Poppy Meeting
21:01:41 <tonytan4ever> o/
21:01:41 <openstack> Meeting started Thu Nov  6 21:01:40 2014 UTC and is due to finish in 60 minutes.  The chair is obulpathi. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:44 <openstack> The meeting name has been set to 'weekly_poppy_meeting'
21:01:54 <obulpathi> #topic RollCall
21:02:01 <malini> o/
21:02:06 <megan_w_> o/
21:02:06 <obulpathi> o/
21:02:07 <catherin_> o/
21:02:27 <obulpathi> anyone from fastly, maxcdn, akamai, edgecast, or hybernia?
21:02:32 * ametts forgot the time changed with daylight savings, and just happened to still have this window open after checking in an hour ago.
21:02:49 <malini> *wish they wud stop meddling with the clocks*
21:02:57 <catherin_> +1
21:02:59 <miqui> +1
21:03:12 <malini> we never argue in this meeting :D
21:03:13 <obulpathi> hhaha
21:03:15 <obulpathi> hi miqui
21:03:17 <miqui> hahahaha
21:03:24 <miqui> hi obulpathi
21:03:44 <obulpathi> I think most of us are here
21:03:48 <obulpathi> lets get started
21:03:50 <obulpathi> #topic Review Last Weeks Items
21:03:59 <obulpathi> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-10-23-19.00.html
21:04:19 <malini> woot woot..no action items :)
21:04:25 <obulpathi> :)
21:04:28 <malini> tht looks weird
21:04:49 <obulpathi> btw malini: the link sates to 10-23
21:04:54 <obulpathi> is ther ea latest one?
21:05:05 <malini> hmmm..probably not
21:05:14 <obulpathi> I checked on http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/
21:05:21 <obulpathi> ok lets carry on
21:05:29 <obulpathi> no review items :)
21:05:41 <obulpathi> moving on
21:05:41 <malini> #link http://eavesdrop.openstack.org/meetings/weekly_poppy_meeting/2014/weekly_poppy_meeting.2014-10-30-18.59.html
21:05:59 <malini> we do have some stuff from last week
21:06:08 <obulpathi> thanks malini :)
21:06:33 <obulpathi> #topic megan_w_ to start investigation SNI and Keyless SSL
21:06:43 <malini> FYI..https://wiki.openstack.org/wiki/Meetings/Poppy gets updated after eac meeting with logs/minutes
21:06:47 <obulpathi> any updates on this megan_w_?
21:06:54 <megan_w_> no, unfortunatley not
21:07:01 <megan_w_> i know that akmaia doens't support it
21:07:11 <megan_w_> SNI is not supported by all broswers, so adoption is still a little low
21:07:34 <miqui> what is SNI?
21:07:40 <megan_w_> investigation is ongoing
21:07:48 <megan_w_> ssl on a shared ip
21:08:00 <obulpathi> good work megan_w_
21:08:00 <miqui> k thanks megan_w_
21:08:03 <obulpathi> since we want to aim for the common features supported by all CDNs and browsers
21:08:31 <obulpathi> so can I keep it in action  items?
21:08:40 <obulpathi> the ongoing investigation?
21:09:26 <obulpathi> #action megan_w_ to continue investigation on SNI and Keyless SSL
21:09:28 <megan_w_> yep
21:09:34 <obulpathi> cool thanks :)
21:09:51 <obulpathi> btw .. this is the syntax for action items right?
21:09:57 <obulpathi> malini: ^
21:10:09 <malini> yes
21:10:42 <obulpathi> cool .. moving on
21:11:03 <obulpathi> next is blueprints
21:11:03 <obulpathi> #topic Blueprint Updates
21:11:12 <obulpathi> #link https://blueprints.launchpad.net/poppy
21:11:34 <miqui> my update
21:11:35 <obulpathi> #topic cloud-dns-driver
21:11:52 <obulpathi> miqui: can we go through them in order
21:11:58 <miqui> sure...sorry
21:12:01 <obulpathi> unless you want to go first
21:12:04 <obulpathi> no thats fine :)
21:12:06 <obulpathi> ok ..
21:12:10 <obulpathi> back to DNS driver
21:12:10 <miqui> no thats fine..
21:12:15 <miqui> lets follow protocoll...
21:12:34 <obulpathi> so, I tested the limitations for DNS driver
21:12:44 <obulpathi> we can create 500 domains + subdomains in total
21:12:50 <obulpathi> each one is its own zone
21:13:00 <obulpathi> and for each subdomain we can create 500 records
21:13:20 <malini> is this for Rackspace DNS driver?
21:13:26 <obulpathi> because of a bug in my code, I though we could create more records, but 500 seems to be the limit
21:13:28 <obulpathi> sorry
21:13:34 <obulpathi> yes this is for Rackspace DNS
21:13:48 <obulpathi> and I finished the default DNS interface as well
21:13:55 <obulpathi> and incorporated it into poppy
21:14:07 <obulpathi> now working on integrating the Rackspace DNS driver
21:14:26 <obulpathi> so lets keep the status of the bp same
21:14:37 <obulpathi> #topic caching-rules
21:14:57 <obulpathi> I have had time to work on this, as I am working on both patch and DNS driver
21:15:05 <obulpathi> once patch goes through, I will take this up
21:15:22 <malini> do you want to unassign urself till then obulpathi?
21:15:36 <obulpathi> sure, that would be agood idea
21:15:38 <obulpathi> let me do it
21:16:05 <obulpathi> ok done
21:16:20 <obulpathi> #topic add-docstrings
21:16:31 <obulpathi> miqui: stage is yours :)
21:16:50 <miqui> submitted 2nd update of the patch....
21:16:57 <miqui> would be great if it gets merged.. so
21:17:06 <obulpathi> cool ...
21:17:10 <miqui> that the docstrings start showing..
21:17:22 <miqui> i should be done with a 3rd update this weekend..
21:17:22 <malini> another +1 & I will merge it
21:17:29 <obulpathi> awesome .. good job miqui
21:17:33 <malini> #link https://review.openstack.org/#/c/131035/
21:17:38 <miqui> thanks malini
21:17:43 <obulpathi> malini: sure will review it
21:17:54 <malini> yw miqui :)
21:17:59 <miqui> so basically my thoughts are this bp is kinda like first pass
21:18:08 <obulpathi> also, from on we should start adding the docstrings for the new code
21:18:15 <malini> obulpathi: +1
21:18:17 <miqui> since the code will continue to change at least folks that add new code
21:18:25 <miqui> can then add the docsstrings accordingly..
21:18:27 <malini> tht should be one of our review criteria
21:18:37 <miqui> malini: +1
21:18:37 <obulpathi> good point malini
21:19:01 <tonytan4ever> So we need to A) raise the limit B) get multiple account ?
21:19:03 <tonytan4ever> because 500 is too low of a limit for us
21:19:07 <tonytan4ever> I think even for early access 500 is too few.
21:19:07 <malini> We need our review guidelines posted somewhere
21:19:11 <obulpathi> #agreed we should add docstrings to our code and docstrings should be part of review criteria from now on
21:19:20 <miqui> malini:  +1
21:19:40 <obulpathi> malini: can I assign this guidelines action?
21:19:51 <malini> obulpathi: sure
21:19:54 <miqui> once am done with the 3rd and final pass at this then i'll move on to another bp
21:20:04 <malini> miqui: tht will be awesome
21:20:29 <obulpathi> #action malini to take care of posting review guidelines
21:20:33 <obulpathi> thanks miqui
21:20:38 <miqui> sure...np
21:20:46 <obulpathi> #action purge-content
21:20:55 <tonytan4ever> This one is under review.
21:21:04 <obulpathi> https://review.openstack.org/#/c/129674/
21:21:10 <obulpathi> #link https://review.openstack.org/#/c/129674/
21:21:51 <malini> will review that
21:21:56 <obulpathi> cool .. lets get this reviewed and get it ready for merging by the time amit is back
21:22:21 <obulpathi> #action dns-driver
21:22:25 <obulpathi> this is me
21:22:44 <obulpathi> so this part is pretty much done
21:22:57 <obulpathi> will submit this along with the cloud-dns-driver
21:23:03 <obulpathi> so this can be marked as good progress
21:23:36 <obulpathi> #action patch-service
21:23:50 <malini> #info: Refer to the bps in ur patch commit messages
21:24:04 <obulpathi> #link https://review.openstack.org/#/c/128682/
21:24:10 <obulpathi> oh ok thanks, malini
21:24:18 <obulpathi> #link https://blueprints.launchpad.net/poppy/+spec/patch-service
21:24:26 <obulpathi> this is currently under review
21:24:38 <obulpathi> malini uncovered bugs in this
21:24:45 <obulpathi> so currently working to fix them
21:24:54 <malini> thanks obulpathi!
21:24:57 <obulpathi> will get them fixed in a day or two
21:25:09 <obulpathi> thanks :)
21:25:12 <malini> I will have the api tests also all done by then
21:25:28 <obulpathi> #action set-restrictions
21:25:37 <obulpathi> #link https://blueprints.launchpad.net/poppy/+spec/set-restrictions
21:25:53 <tonytan4ever> This one is under review too.
21:25:54 <obulpathi> #link https://review.openstack.org/#/c/131252/
21:26:00 <obulpathi> cool tony
21:26:16 <obulpathi> so lets get this one reviewed and get it ready to merge by the time amit is back
21:26:37 <obulpathi> #action akamai-driver
21:26:45 <obulpathi> #link https://blueprints.launchpad.net/poppy/+spec/akamai-driver
21:26:56 <obulpathi> tonytan4ever, updates on this
21:27:00 <tonytan4ever> This one is in good progress, as I just checked in a patch set.
21:27:16 <obulpathi> #link https://review.openstack.org/#/c/133103/
21:27:56 <obulpathi> everyone please take a look into this patch and give your early feedback
21:28:05 <obulpathi> good job tonytan4ever :)
21:28:27 <obulpathi> #action home-doc
21:28:36 <obulpathi> miqui, updates on this?
21:28:43 <tonytan4ever> There are a few items to be worked out, both from our side and akamai side, but I am reasonably confident I can make it work in a few days.
21:28:49 <obulpathi> also I am marking the akamai driver as good progress
21:29:02 <obulpathi> cool .. awesome :)
21:29:19 <miqui> obulpathi: no updates, but will start that early next week
21:29:32 <obulpathi> cool ...
21:29:48 <miqui> you can mark add-docstrings good progress..
21:29:57 <miqui> will be done soon..
21:30:01 <obulpathi> once you go through next patch set for docstrings, lets make high priority
21:30:05 <obulpathi> sure sur :)
21:30:32 <obulpathi> sure sir :)
21:30:43 <obulpathi> hi miqui, it seems that I can not change it
21:30:50 <obulpathi> can you please log into launcgpad and change it
21:30:59 <miqui> k, no worries.. k will do that niow..
21:31:10 <obulpathi> I don't have permissions it seems
21:31:16 <malini> i updated it
21:31:26 <obulpathi> also tonytan4ever, can you please update the status of hte akamai-driver
21:31:28 <miqui> done..
21:31:41 <obulpathi> malini: status of the akamai-driver to good-progress
21:31:48 <obulpathi> thanks malini :)
21:32:20 <malini> I might be making this up - but if u refer to the bp in the commit message, the status will get updated
21:32:32 <obulpathi> so anybody else started with new bluprints
21:32:43 <obulpathi> malini, interesting, will check it
21:32:45 <malini> #link https://wiki.openstack.org/wiki/Gerrit_Workflow#Committing_Changes
21:33:07 <malini> for the open patches, update your commit message if you happen to submit another patchset
21:33:19 <obulpathi> cool
21:33:55 <obulpathi> #info blueprint status can be updated using commit message https://wiki.openstack.org/wiki/Gerrit_Workflow#Committing_Changes
21:34:06 <obulpathi> thanks for the info malini :)
21:34:18 <obulpathi> ok, so no new blueprints?
21:34:25 <obulpathi> we have our hands full anyways
21:34:32 <obulpathi> so lets move on to bugs
21:34:56 <obulpathi> #topic Bugs Update
21:35:03 <obulpathi> #link https://bugs.launchpad.net/poppy
21:35:39 <obulpathi> ok, so any bugs squashed?
21:35:58 <obulpathi> yep, so an important ifo
21:36:04 <malini> no :(
21:36:10 <obulpathi> its ok :)
21:36:17 <malini> they breed!
21:36:21 <obulpathi> hahaha
21:36:30 <miqui> haha
21:36:41 <obulpathi> malini: do you want to talk about the API tests being broken?
21:36:58 <malini> hmmm..yes..not broken really
21:37:25 <obulpathi> ok
21:37:27 <malini> But anyways, most of the API tests depend on the service being configured at the provider
21:37:35 <malini> eg. fastly/ Akamai etc.
21:38:06 <malini> This can cause flaky tests if the provider throws errors at the worst..AT the best case, we still have SLOW tests
21:38:18 <malini> we need some way around this
21:38:44 <malini> probably create a mock provider..something tht can mimic provider responses
21:38:52 <malini> I will add a bp for this
21:38:57 <obulpathi> cool
21:39:07 <malini> If anybody has ideas on this, plz ping me
21:39:09 <tonytan4ever> I thought we already have a mock provider
21:39:31 <tonytan4ever> Yes we do.
21:39:39 <malini> hmmm…is it updated?
21:40:17 <malini> tht is not good enough (atleast what we currently have there)
21:40:49 <malini> lets take this to #openstack-poppy
21:40:58 <obulpathi> ok
21:40:58 <malini> I dont want to hijack the meeting
21:41:00 <tonytan4ever> Depends on what you mean by updated. It has some basic functionality as other providers, but it seems like not covering all the test cases you want.
21:41:11 <obulpathi> lets break this out in to #openstack-poppy
21:41:14 <tonytan4ever> ok
21:41:28 <obulpathi> another thing is that
21:41:32 <malini> tonytan4ever: it returns some hardcoded responses, but not necessarily relates to the requests
21:41:45 <malini> anyways topic for #openstack-poppy
21:42:11 <obulpathi> we also need to make sure that we run api tests for all our code changes
21:42:15 <obulpathi> and then only merge them
21:42:25 <obulpathi> we had 2 bugs that sneaked into our code
21:42:29 <malini> obulpathi: +1
21:42:37 <malini> will add tht to review guidelines
21:42:45 <obulpathi> https://bugs.launchpad.net/poppy/+bug/1389766
21:42:46 <uvirtbot> Launchpad bug 1389766 in poppy "API tests for flavors are failing" [Undecided,New]
21:42:56 <obulpathi> https://bugs.launchpad.net/poppy/+bug/1389790
21:42:57 <uvirtbot> Launchpad bug 1389790 in poppy "API tests failing for create service" [Undecided,New]
21:43:00 <obulpathi> cool
21:43:02 <obulpathi> thanks malini
21:43:19 <obulpathi> #action malini to update guidelines regarding running api tests
21:43:49 <obulpathi> https://review.openstack.org/#/c/132889/
21:44:22 <obulpathi> please take a look and lets get this patch ready
21:44:24 <malini> Reviews plz..another +1 & this can be merged
21:44:41 <obulpathi> this patch addresses api tests for lfavors
21:45:01 <obulpathi> ok
21:45:03 <obulpathi> moving on
21:45:10 <obulpathi> any other updates on bugs?
21:45:35 <malini> not from me
21:45:38 <obulpathi> ok cool
21:45:41 <obulpathi> #topic New Items
21:45:44 <obulpathi> so new items
21:46:16 <obulpathi> so anybody heard from amit about poppy talk at paris?
21:46:26 <miqui> not me..
21:46:35 <miqui> was wondering how it went...
21:46:44 <obulpathi> me too
21:46:53 <tonytan4ever> me three.
21:47:06 <obulpathi> probably, we can keep this for amit
21:47:13 <malini> +1
21:47:14 <obulpathi> to update us next week, when he is back
21:47:16 <miqui> yeah...
21:47:30 <obulpathi> so, any new items?
21:47:36 <malini> none from me
21:47:51 <obulpathi> cool, lets move on
21:47:53 <obulpathi> #topic Open Discussion
21:48:09 <miqui> i saw a patch about this: http://www.fig.sh/
21:48:21 <miqui> this seems cool....
21:48:27 <miqui> am starting to use docker more and more...
21:48:28 <malini> yes!! amit is in the docker wagon ;)
21:48:35 <obulpathi> #topic running poppy using fig
21:48:39 <miqui> am pushing the wagon...
21:48:45 <malini> tht is great miqui !
21:48:54 <obulpathi> miqui, fig is super cool
21:49:22 <miqui> oh yes...awesome reading next couple of days...
21:49:27 <obulpathi> and amit is already running poppy, cassandra, and repose using fig
21:49:34 <miqui> nice...
21:49:51 <obulpathi> yep, its really interesting tool
21:50:00 <obulpathi> kudos to amit for bringing it in :)
21:50:48 <obulpathi> any other discussions?
21:50:49 <malini> gtg now folks..ttyl in #openstack-poppy
21:50:56 <obulpathi> ttl malini :)
21:50:58 <obulpathi> thanks and tc
21:51:02 <miqui> ttl folks...
21:51:06 <miqui> tc
21:51:09 <obulpathi> ok
21:51:20 <tonytan4ever> see ya
21:51:21 <obulpathi> good progress people :)
21:51:27 <obulpathi> see you all next week
21:51:33 <obulpathi> same time, same channel
21:51:37 <obulpathi> #endmeeting