17:08:42 <johnthetubaguy> #startmeeting XenAPI
17:08:43 <openstack> Meeting started Wed Jan 30 17:08:42 2013 UTC. The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:08:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:08:46 <openstack> The meeting name has been set to 'xenapi'
17:09:06 <johnthetubaguy> so did people like the format last week? please +1 or -1
17:09:50 <ameade_> the meeting format?
17:09:55 <johnthetubaguy> by which I mean should we use the formal agenda, or just raise questions at the start?
17:10:04 <johnthetubaguy> yes, sorry I meant meeting format
17:10:20 <ameade_> +1
17:10:23 <ameade_> for formal agenda
17:11:13 <matelakat> +1
17:11:42 <johnthetubaguy> OK, well didn't get any email about adding things to the agenda
17:11:48 <johnthetubaguy> please to add to the wiki page
17:11:55 <johnthetubaguy> #link http://wiki.openstack.org/Meetings/XenAPI
17:12:03 <johnthetubaguy> for future meetings :-)
17:12:11 <johnthetubaguy> I will try email the request next time
17:12:14 <johnthetubaguy> Ok...
17:12:25 <johnthetubaguy> #topic Actions from last meeting
17:12:43 <johnthetubaguy> the only action was for me
17:12:58 <johnthetubaguy> I looked into the python situation in Dom0
17:13:01 <matelakat> The swift client, right?
17:13:03 <johnthetubaguy> just to report back...
17:13:17 <johnthetubaguy> installing EPEL breaks yum a little bit
17:13:27 <johnthetubaguy> but installing python 2.6 from EPEL is fine
17:13:35 <johnthetubaguy> they are independent issues really
17:13:52 <johnthetubaguy> speaking to some XenServer/XCP folks that is as expected
17:14:00 <johnthetubaguy> I got a clean install of the swift client
17:14:09 <ameade_> I think your notes on it are good
17:14:24 <johnthetubaguy> thanks, I should add that link...
17:14:49 <johnthetubaguy> #link http://wiki.openstack.org/XenServer/PostInstall
17:14:54 <johnthetubaguy> its documented above
17:14:57 <johnthetubaguy> cool
17:15:06 <johnthetubaguy> questions?
17:15:14 <rainya> more a comment
17:15:18 <johnthetubaguy> sure
17:15:33 <rainya> we haven't had a chance to try it out in our enviornments, but DO plan to pursue that path longer-term
17:15:48 <johnthetubaguy> cool, sounds good
17:15:58 <rainya> it seems like the right way to go about doing it, but we've got to see how it works at scale, etc, etc :)
17:16:04 <johnthetubaguy> drop me a line if you have issues
17:16:07 <johnthetubaguy> totally
17:16:13 <matelakat> john, did you tried to use the swift client, or just did the installation?
17:16:39 <johnthetubaguy> matelakat: it seemed to work, but I honestly didn't try it out too much
17:16:42 <rainya> i also want to ping our xenserver guy (who is out right now) to see what (if any) concerns he has for our environment
17:16:57 <johnthetubaguy> cool
17:17:07 <rainya> more to follow! that's all for now from us
17:17:14 <matelakat> johnthetubaguy: ok
17:17:16 <johnthetubaguy> #topic blueprints
17:17:21 <ameade_> johnthetubaguy: thanks for your help so far
17:17:33 <johnthetubaguy> not got anything myself, anyone got anything they want to raise
17:17:46 <matelakat> I have a sort of draft stuff.
17:17:55 <johnthetubaguy> I was planning on having another XenAPI session at the summit, or at least submitting one
17:18:08 <johnthetubaguy> so at some point we can thinking about Havana stuff
17:18:15 <matelakat> but that's more about a review, not really the blueprint itself.
17:18:23 <johnthetubaguy> anything people have hanging for Grizzly?
17:18:33 <johnthetubaguy> matelakat: OK feel free to post a link
17:18:37 <matelakat> #link https://blueprints.launchpad.net/cinder/+spec/xenapinfs-glance-integration
17:19:04 <matelakat> this is the bp, and the change is: #link https://review.openstack.org/20790
17:19:38 <johnthetubaguy> awesome, this is the integration between XenAPI, Cinder and the NFS SR
17:19:41 <johnthetubaguy> cool stuff
17:19:46 <johnthetubaguy> OK anything else?
17:19:56 <matelakat> So if you guys have any comments on that, comment on that.
17:20:17 <matelakat> no
17:20:24 <johnthetubaguy> #topic docs
17:20:42 <johnthetubaguy> lots have lovely features have dropped, are we all OK getting some docs in?
17:21:30 <johnthetubaguy> there is a nice getting started guide #link http://wiki.openstack.org/Documentation/HowTo
17:21:39 <johnthetubaguy> and the reviewers have always been very kind to me!
17:22:35 <johnthetubaguy> ... silence ... we probably need someone to take this on
17:22:52 <johnthetubaguy> #action advertise to get more help for XenAPI docs
17:22:59 <johnthetubaguy> #topic QA
17:23:10 <johnthetubaguy> Any pressing bugs, or reviews, or issues this week?
17:23:30 <matelakat> I am looking at the devstack readme at the moment, and try to add some comments to it, to make it easier to get started with devstac/XS
17:23:39 <johnthetubaguy> sounds good
17:24:42 <johnthetubaguy> #topic AOB
17:24:50 <johnthetubaguy> #topic Open Discussion
17:25:03 <johnthetubaguy> OK so any other questions from people?
17:25:56 <johnthetubaguy> I assume people are OK with this time next week
17:26:13 <johnthetubaguy> feel free to edit the wiki to add any topics you have #link http://wiki.openstack.org/Meetings/XenAPI
17:27:34 <johnthetubaguy> Ok, so there are some things we have
17:27:44 <johnthetubaguy> XenAPI lib into Oslo
17:27:52 <johnthetubaguy> to share between nova and cinder
17:27:57 <johnthetubaguy> what do people think?
17:29:13 <johnthetubaguy> ??
17:29:22 <matelakat> So the lib, that would be pulled up, is a sort of xenapi interface, right?
17:29:23 <johnthetubaguy> I am +1 for the idea
17:29:31 <matelakat> At the moment looking at the cinder stuff.
17:29:40 <matelakat> Let's look at the code, give me a sec..
17:29:49 <johnthetubaguy> yes, a layer on top of the very low level XenAPI python driver
17:30:05 <johnthetubaguy> to share code between Cinder and Nova talking to XenAPI
17:30:11 <matelakat> #link ttps://github.com/openstack/cinder/blob/master/cinder/volume/drivers/xenapi/lib.py
17:30:16 <matelakat> #link https://github.com/openstack/cinder/blob/master/cinder/volume/drivers/xenapi/lib.py
17:30:34 <matelakat> This is the candidate - at least from my side.
17:30:43 <matelakat> But I wouldn't pull up the whole to oslo.
17:30:52 <johnthetubaguy> At the same time, we were thinking about tidying up the exception handling
17:31:43 <johnthetubaguy> XenAPI exceptions tend to pop out, and calling code needs to translate the codes, where as that should probably be part of that shared code, so calling code doesn't need to keep catching exceptions
17:31:50 <johnthetubaguy> should be easier to test that way
17:32:18 <johnthetubaguy> So, we should probably raise this at the summit so it gets more attention
17:32:35 <johnthetubaguy> And/or just submit things to Oslo for review
17:32:53 <johnthetubaguy> OK, any more comments or questions?
17:33:07 <johnthetubaguy> or random XenServer questions?
17:33:09 <matelakat> How could we pull things up to oslo, I mean what is the procedure?
17:33:41 <johnthetubaguy> #link http://wiki.openstack.org/Oslo
17:34:49 <johnthetubaguy> OK, so I think we are done for this week
17:34:51 <johnthetubaguy> thanks all
17:34:57 <matelakat> thanks, bye
17:35:03 <johnthetubaguy> same time next week
17:35:21 <johnthetubaguy> #endmeeting