17:03:21 <johnthetubaguy> #startmeeting XenAPI
17:03:22 <openstack> Meeting started Wed Feb 27 17:03:21 2013 UTC. The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:25 <openstack> The meeting name has been set to 'xenapi'
17:03:34 <johnthetubaguy> #topic blueprints
17:03:38 <johnthetubaguy> Hi all
17:03:48 <johnthetubaguy> lets go through the usual agenda, usual wiki page
17:04:17 <johnthetubaguy> no one has added any pressing issues, anything major from anyone before we start?
17:04:59 <johnthetubaguy> OK, sounds like it could be a quick one then...
17:05:33 <johnthetubaguy> so any blueprints to discuss
17:05:46 <matelakat> not from my side.
17:05:47 <johnthetubaguy> maybe this is a good point to bring up the etherpad for the summit session
17:05:56 <matelakat> Yes, that sounds good.
17:06:05 <johnthetubaguy> #link https://etherpad.openstack.org/HavanaXenAPIRoadmap
17:06:10 <johnthetubaguy> ideas welcome on there
17:06:47 <matelakat> I will put the postponed blueprint there
17:06:56 <johnthetubaguy> GPU?
17:07:26 <matelakat> #link https://blueprints.launchpad.net/nova/+spec/xenapi-volume-drivers
17:07:35 <johnthetubaguy> oh right
17:07:38 <matelakat> But GPU seems to be another good candidate
17:07:39 <johnthetubaguy> yes
17:07:47 <matelakat> I will add GPU as well.
17:07:50 <johnthetubaguy> depends if anyone has the time to do it really
17:07:53 <johnthetubaguy> cool
17:08:19 <matelakat> Added those two things.
17:08:20 <johnthetubaguy> thanks for those
17:08:52 <johnthetubaguy> cool, just added image portability
17:09:02 <johnthetubaguy> always comes up, but we are getting closer I think
17:09:09 <matelakat> Yes, that was my action from last meeting.
17:09:17 <matelakat> So its 1:1 :-)
17:09:47 <matelakat> Oh, I might missunderstood image portability
17:09:54 <matelakat> What does it mean exactly?
17:10:07 <johnthetubaguy> images across many hypervisors and many openstack clouds
17:10:15 <johnthetubaguy> cloud-init etc
17:10:33 <johnthetubaguy> getting tools install and agent installed using cloudinit, maybe
17:10:38 <johnthetubaguy> that kind of thing
17:10:56 <matelakat> So it is about the guest -level code.
17:11:03 <matelakat> Not related to image formats at all.
17:11:09 <johnthetubaguy> maybe both
17:11:15 <matelakat> Let's separate them.
17:11:20 <johnthetubaguy> in the full picture sense
17:11:21 <matelakat> I will make the correction.
17:11:32 <johnthetubaguy> well, we need the whole picture really
17:11:40 <johnthetubaguy> its a bit more complicated than just those two
17:11:42 <johnthetubaguy> separately
17:12:06 <johnthetubaguy> can't think why though now… hmm...
17:12:21 <johnthetubaguy> #topic Docs
17:12:29 <matelakat> So basically, let's just start with the goal: images across many hypervisors and many openstack clouds
17:12:38 <johnthetubaguy> matelakat: sure
17:12:56 <johnthetubaguy> matelakat: how are the docs coming along?
17:13:22 <matelakat> I haven't touched any docs this week.
17:13:55 <matelakat> I was busy this week making a local gitmirror.
17:14:01 <johnthetubaguy> Ok, you got a timeframe for that?
17:14:12 <matelakat> For the docs you mean?
17:14:21 <johnthetubaguy> yes
17:14:39 <matelakat> Not yet.
17:14:47 <johnthetubaguy> it looks like I can maybe help along the CentOS install of OpenStack on XenAPI docs
17:14:58 <johnthetubaguy> probably next week before I start of that one though
17:15:28 <matelakat> How much time do we have for the docs?
17:15:31 <johnthetubaguy> #action johnthetubaguy to look at CentOS install docs
17:15:34 <matelakat> Approximately?
17:15:57 <johnthetubaguy> matelakat: good question, not sure
17:16:30 <johnthetubaguy> sooner for the translaters benifit I think
17:16:45 <johnthetubaguy> OK, any more docs things
17:16:47 <johnthetubaguy> ?
17:17:13 <johnthetubaguy> ask anne gentle for a date
17:17:20 <matelakat> okay
17:17:39 <johnthetubaguy> #QA and Bugs
17:17:49 <johnthetubaguy> #topic QA and Bugs
17:18:10 <johnthetubaguy> any updates on this?
17:18:35 <johnthetubaguy> #action johnthetubaguy needs to ask Rackspace QA about external facing tests
17:18:40 <matelakat> not really from my side.
17:18:50 <matelakat> Anyone else with some interesting bugs?
17:19:10 <johnthetubaguy> do you have time to re-test all the big features post nova-conductor?
17:19:27 <johnthetubaguy> like live-migration with block migration
17:19:38 <johnthetubaguy> I know armando found some gremlins there
17:20:04 <matelakat> live migration tests are failing at the moment, since 22
17:20:17 <matelakat> I meant live block migration.
17:21:16 <johnthetubaguy> is there a bug on LP for that?
17:21:22 <johnthetubaguy> was armando covering that one?
17:21:35 <johnthetubaguy> I will have coffee with him tomorrow, I will check
17:21:54 <matelakat> I did not have the time to look at that.
17:22:07 <johnthetubaguy> #action johnthetubaguy needs to check with armandomi to see about live-migration with block
17:22:13 <johnthetubaguy> OK
17:23:01 * johnthetubaguy feeling silly that mate is sat opposite him and no one else wants to talk to me
17:23:17 <johnthetubaguy> ok, so I think that is all for QA
17:23:28 <matelakat> sure.
17:23:31 <johnthetubaguy> #topic Open Discussion
17:23:47 <matelakat> Let's dig out armando's bugreport.
17:24:44 <johnthetubaguy> OK, if you can find it, make sure its tagged
17:25:09 <johnthetubaguy> that would be awesome
17:25:24 <johnthetubaguy> anything else from people?
17:25:30 <matelakat> #link https://bugs.launchpad.net/nova/+bug/1118491
17:25:33 <uvirtbot> Launchpad bug 1118491 in nova "check_can_live_migrate_source does not return data (xenapi)" [High,Fix released]
17:25:38 <johnthetubaguy> ah, yes
17:25:38 <matelakat> But that's fixed.
17:25:51 <matelakat> So I guess we have another issue.
17:25:52 <johnthetubaguy> bit its still now working I take it?
17:26:02 <matelakat> What time do you see armando tomorrow?
17:26:16 <johnthetubaguy> not sure yet, we didn't decide
17:26:31 <johnthetubaguy> depends when I get a bookcase delivered
17:26:33 <matelakat> Okay, I will look at the logs, and drop a mail / file a bug.
17:26:40 <johnthetubaguy> cool, thanks
17:26:47 <johnthetubaguy> bug sounds good
17:26:53 <matelakat> question
17:26:57 <johnthetubaguy> fire away
17:27:27 <matelakat> just a sec, searching for the link....
17:27:32 <johnthetubaguy> ok
17:28:16 <matelakat> #link https://bugs.launchpad.net/cinder/+bug/1131291
17:28:17 <uvirtbot> Launchpad bug 1131291 in cinder "XenAPINFS: Volume always uploaded as vhd/ovf" [Undecided,Fix committed]
17:28:32 <matelakat> Do I need to do anything to get it included in G?
17:29:14 <johnthetubaguy> where did you push it, trunk?
17:29:19 <matelakat> y
17:29:31 <johnthetubaguy> I think there will be an rc cadidate tag at some point
17:29:50 <johnthetubaguy> not read through the email lists today, but some time after the rc1 branches are made
17:30:03 <matelakat> I see the Milestone filled in for nova bugs, but not for this cinder one
17:30:04 <johnthetubaguy> but always fix in trunk first, then backport if required
17:30:42 <johnthetubaguy> I would ping jgriffith to see what he has to say
17:30:52 <johnthetubaguy> any more questions?
17:31:06 <matelakat> I will contact with jgriffith.
17:31:15 <johnthetubaguy> #endmeeting