15:00:07 <johnthetubaguy> #startmeeting XenAPI
15:00:08 <openstack> Meeting started Wed May 15 15:00:07 2013 UTC.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <openstack> The meeting name has been set to 'xenapi'
15:00:20 <johnthetubaguy> hi, who is around for the meeting today?
15:00:22 <BobBall> you were watching the clock, weren't you john :D
15:00:29 <johnthetubaguy> :-D
15:00:44 <matelakat> hi
15:00:47 <johnthetubaguy> any more topics from people, other than what is in the agenda page?
15:01:22 <BobBall> nah
15:01:23 <johnthetubaguy> OK, looks like just the three of us
15:01:24 <BobBall> not from me
15:01:30 <johnthetubaguy> lets get going
15:01:40 <BobBall> I thought we might want to talk about quantum stuff and get other people in to help with that, but we'll go through what Mate's got
15:01:46 <BobBall> at the appropriate point of the Agenda of course!
15:02:06 <johnthetubaguy> matelakat, you got anything for the agenda?
15:02:11 <johnthetubaguy> other than quantum?
15:02:25 <matelakat> I am 50% regarding to last meetings action
15:02:33 <matelakat> The bugstat page has been updated.
15:02:45 <matelakat> Quantum is up and running.
15:02:52 <matelakat> In the lab.
15:02:53 <johnthetubaguy> one sec...
15:03:03 <johnthetubaguy> #topic Actions from last meeting
15:03:19 <matelakat> Okay, so
15:03:25 <matelakat> bugstat page updated.
15:03:25 <johnthetubaguy> so bob, did you poke dan, I think I saw a promising email>?
15:03:32 <johnthetubaguy> cool
15:03:32 <BobBall> I did indeed
15:03:41 <BobBall> I'm sure if you asked him, Dan would consider himself well and truly poked
15:03:42 <johnthetubaguy> I updated the wiki
15:04:01 <johnthetubaguy> #action matelakat to document bug finder in XenAPI team wiki
15:04:05 <BobBall> The status is that the machines have been re-built and the domU image put back on one of them
15:04:16 <BobBall> we're now ready to move on to the puppet stuff
15:04:18 <matelakat> Whatever that means.
15:04:43 <johnthetubaguy> #info smokestack making progress, hosts ready, now to work on fixing up puppet scrips
15:04:50 <matelakat> I think I will try to have a chat with Dan this week, or beginning of next week.
15:05:18 <BobBall> So one change...
15:05:23 <johnthetubaguy> cool, its merge his old puppet scripts into the new upstream ones I guess, to add in XenServer support into the puppet modules
15:05:28 <BobBall> we were going to have half the machines running 6.1 and half running 5.6 FP2
15:05:45 <johnthetubaguy> OK, then flip over the others if all goes well?
15:05:48 <BobBall> however I realised that since smokestack is running the jobs on a random machine, we don't want differences between the versions meaning some tests pass and some tests fail
15:05:58 <johnthetubaguy> indeed
15:06:00 <BobBall> so we have switched all machines to 6.1 which is what we should be focusing on now
15:06:11 <johnthetubaguy> ah, gotcha
15:06:15 <johnthetubaguy> sounds good
15:06:22 <johnthetubaguy> leave the virt option open too
15:06:41 <BobBall> yes - although I haven't testing running 5.6FP2 in a VM under 6.1
15:06:46 <BobBall> that would be an interesting experiment for sure
15:06:48 <BobBall> :)
15:07:07 <johnthetubaguy> well lets run before we can walk, obviously
15:07:11 <johnthetubaguy> next topic
15:07:12 <BobBall> On to Mate's action?
15:07:20 <johnthetubaguy> which one?
15:07:24 <BobBall> I was just browsing the bug report...
15:07:35 <BobBall> saw https://bugs.launchpad.net/nova/+bug/1162973 which looked interesting - aggregate live migration not working
15:07:37 <uvirtbot`> Launchpad bug 1162973 in nova "XCP resource pool - unable to migrate instances" [Medium,Triaged]
15:07:47 <BobBall> do we have any tests for this?
15:07:48 <johnthetubaguy> ok, we have a bug section for later, but we can do that now
15:07:55 <BobBall> oh, sorry
15:07:57 <johnthetubaguy> mate added them into tempest I think
15:08:09 <BobBall> smokestack progress is also later on the agenda but we covered that(!)
15:08:17 <johnthetubaguy> ah, true
15:08:23 <matelakat> Excuse me.
15:08:33 <matelakat> Are we talking about Bob's bug, or not?
15:08:41 <johnthetubaguy> we can
15:08:57 <BobBall> Not my bug - just an interesting one :) Did you add aggregate live migrate tests to Tempest mate?
15:08:58 <johnthetubaguy> I am current re-writing the live-migrate code paths, cough
15:09:02 <matelakat> Are we at that page regarding to the agenda?
15:09:20 <johnthetubaguy> nope, I only have to delete it in a few hours
15:09:29 <matelakat> I never tested any pool config.
15:09:38 <matelakat> never tested means no jenkins jobs
15:09:43 <johnthetubaguy> sure, but your tests can test such a configuration
15:09:56 <johnthetubaguy> just I assume no one tests to pool support
15:10:00 <matelakat> I tried it once manually, but please don't consider it as a proof for anything
15:10:11 <matelakat> That was a long ago.
15:10:14 <johnthetubaguy> indeed
15:10:16 <matelakat> with J.
15:10:24 <matelakat> with fish and chips.
15:10:30 <johnthetubaguy> but tempest has tests that work, its just requires some setup
15:10:37 <matelakat> yes.
15:10:47 <matelakat> The same tests as the block migration.
15:10:49 <johnthetubaguy> I guess the other point is there are current no automated tests checking that config?
15:11:11 <BobBall> That was more my question - does the Citrix CI test this config for live migration
15:11:13 <matelakat> No automated tests with pools.
15:11:19 <BobBall> I know we test block migration outside of pools
15:11:21 <BobBall> okay
15:11:40 <matelakat> Can we move on?
15:11:46 <BobBall> sure
15:11:54 <matelakat> Where are we regarding to the agenda?
15:12:05 <BobBall> actions
15:12:08 <BobBall> but we've jumped over a bit
15:12:22 <BobBall> next is your action Mate on documenting the bug finder in the XenAPI team wiki
15:12:34 <johnthetubaguy> mate said he didn't do it
15:12:39 <johnthetubaguy> I raised a new one for next week
15:12:42 <matelakat> I will give it a low priority.
15:12:48 <johnthetubaguy> we are done here I guess
15:12:56 <johnthetubaguy> #topic blueprints
15:12:56 <matelakat> I'll be focusing on smoke.
15:13:08 <johnthetubaguy> +1 to smokestack
15:13:11 <BobBall> oh - what about your action John?
15:13:19 <matelakat> tss tss
15:13:20 <johnthetubaguy> its done
15:13:27 <BobBall> I missed that :)
15:13:28 <BobBall> okay :
15:13:30 <BobBall> :)
15:13:30 <johnthetubaguy> we did that really early on I thought
15:13:32 <matelakat> tss tss
15:13:36 <johnthetubaguy> lol
15:13:42 <johnthetubaguy> so, xenapi-server-log
15:13:47 <johnthetubaguy> a quick update
15:14:02 <johnthetubaguy> chatting with people, its a feature that is used loads
15:14:18 <johnthetubaguy> I was hoping to spend a day hacking to see how bad it would look for H
15:14:47 <johnthetubaguy> so I am probably going to take that and target for H-2 ish
15:14:51 <johnthetubaguy> but will see how it goes
15:14:59 <matelakat> Can I have a Q?
15:15:00 <johnthetubaguy> any more from blueprints?
15:15:03 <johnthetubaguy> sure
15:15:10 <matelakat> A patch is mentioned in the bp.
15:15:14 <johnthetubaguy> yup
15:15:30 <johnthetubaguy> its not considered the best way forward
15:15:31 <BobBall> that patch is in all versions of XenServer and XCP though
15:15:37 <matelakat> It doesn not mean, that you need to do anything with that patch, it is just there for documentation purposes
15:15:40 <matelakat> OK
15:15:44 <matelakat> Bob reads my mind.
15:15:45 <BobBall> I assumed Mate was meaning the xen patch?
15:15:55 <johnthetubaguy> I might use bits of that patch
15:16:00 <johnthetubaguy> it was a xenapi patch I think
15:16:17 <BobBall> https://github.com/jamesbulpin/xcp-xen-4.1.pq/blob/master/log-guest-consoles.patch ?
15:16:21 <BobBall> that's a xen patch - not xapi
15:16:28 <johnthetubaguy> oh, that one
15:16:35 <matelakat> Yes, I meant that one.
15:16:36 <johnthetubaguy> gotcha
15:16:37 <BobBall> in fact XAPI knows nothing about it at all
15:16:48 <johnthetubaguy> its not that important
15:17:06 <johnthetubaguy> just for reference
15:17:19 <johnthetubaguy> cool, any more for blueprints, any thing for docs, else straight to bugs
15:17:23 <BobBall> I've confirmed that it's in Tampa
15:17:28 <BobBall> I can confirm it's in Boston if you give me a second
15:17:47 <BobBall> yes, it's in Boston too.
15:17:51 <matelakat> Bob, can we use numbers instead of codenames?
15:17:54 <BobBall> But it is a XenServer patch to Xen - which is not upstream.
15:18:09 <BobBall> Sorry; it's in XenServer 6.0 and 6.1 (probably earlier too) - and therefore it'll be in the 1.6 XCP too
15:18:30 <matelakat> So, back to that blueprint.
15:18:33 <BobBall> but it is not present in Xen upstream, therefore a change is needed to upstream xen if you want to use this on xapi-xcp on Ubuntu or CentOS etc
15:18:35 <matelakat> It has two parts.
15:18:46 <matelakat> One is an OS, and the other is a dom0 mod.
15:18:51 <johnthetubaguy> ??
15:18:57 <matelakat> dom0 mod - logrotate, etc.
15:18:57 <johnthetubaguy> oh, maybe
15:19:11 <johnthetubaguy> and other bits I think, but yes
15:19:22 <johnthetubaguy> hoepfully will just add a script to help set that up
15:19:42 <BobBall> Could do the log rotate through a XAPI plugin triggered by domU cronjob... a little ugly, but keeps a clean separation for Dom0 changes
15:20:02 <johnthetubaguy> I guess it is a deployer choice
15:20:07 <matelakat> I would trigger it from dom0
15:20:11 <matelakat> in case domu is dead
15:20:14 <johnthetubaguy> +1 that was my plan
15:20:40 <matelakat> So dom0 is responsible for baking the rotated log tails
15:20:50 <matelakat> OS is just reading those.
15:20:55 <johnthetubaguy> +1
15:21:00 <BobBall> well I was assuming using a loopback filesystem so domu being dead would only mean consoles stopped getting logged at some point when the disk ran out of space but fair enough :)
15:21:26 <johnthetubaguy> planning to do both, using loopback inside dom0
15:21:32 <johnthetubaguy> and dom0 log rotate
15:21:39 <johnthetubaguy> will try it, and see how it goes
15:21:43 <BobBall> ok
15:21:46 <johnthetubaguy> and if the VNC terminals stay up
15:21:57 <matelakat> And what happens if disk goes full
15:22:04 <matelakat> I meant loopback goes full.
15:22:18 <johnthetubaguy> the logs stop growing for other users on that host
15:22:24 <johnthetubaguy> but it doesn't kill the host
15:22:33 <matelakat> And is the guest affected?
15:22:41 <johnthetubaguy> might do one per VM, but that is probably overjill
15:22:52 <johnthetubaguy> shouldn't be, all part of the testing
15:23:32 <matelakat> Let's move on, leave some space for J
15:23:41 <johnthetubaguy> indeed
15:23:58 <johnthetubaguy> any more blueprints, or any docs stuff?
15:24:01 <matelakat> Are we at the point, where I can share my quantum experiences?
15:24:09 <johnthetubaguy> almost
15:24:13 <BobBall> well does you want to cover the devstack bp mate?
15:24:26 <matelakat> Okay.
15:24:29 <BobBall> Any questions, or reviews that you need us to do or something?
15:24:46 <matelakat> It is showing progress, I had some really exciting feedback this week, and thanks for that again.
15:24:53 <matelakat> I think we are getting there.
15:25:11 <johnthetubaguy> #topic OpenDiscussion
15:25:17 <matelakat> As soon as the networking patch is accepted, we can kill out eth0 and the rest of the stuff.
15:25:19 <johnthetubaguy> I think we are there already, fire away
15:25:27 <matelakat> Okay. QUantum
15:25:31 <matelakat> Are you prepared?
15:25:39 <johnthetubaguy> almost
15:25:40 <BobBall> or the networking stack formally known as quantum
15:25:50 <johnthetubaguy> +!
15:25:54 <johnthetubaguy> +1
15:25:58 <matelakat> We don't know what is its name.
15:26:05 <matelakat> #link https://github.com/citrix-openstack/qa/blob/master/xenserver-quantum-devstack.sh
15:26:09 <BobBall> if I had a choice, I'd vote for Dave.
15:26:40 <matelakat> So that is a script, which will set up a devstack with quantum.
15:26:55 <johnthetubaguy> the firewall driver is a worry, but porbably correct
15:26:56 <matelakat> With using Maru's patches, and some spice on top of that.
15:27:04 <matelakat> which firewall driver?
15:27:04 <johnthetubaguy> whats the spice?
15:27:15 <BobBall> an existing devstack installation?
15:27:15 <johnthetubaguy> XEN_FIREWALL_DRIVER=nova.virt.firewall.NoopFirewallDriver
15:27:41 <matelakat> #link https://github.com/citrix-openstack/quantum/commit/b267632284ebb5f3f66137e85881d976f5d145c7
15:27:48 <matelakat> John, I linked in the "spice"
15:27:56 <matelakat> So, first things first.
15:28:23 <matelakat> Maru's DHCP patch will need to be modified slightly, and I am doing that this week.
15:28:31 <matelakat> Regarding to the firewall driver.
15:29:18 <matelakat> As quantum is implementing the security groups (or not at the moment), you need to turn off the nova one, in order to avoid conflicts.
15:29:25 <johnthetubaguy> not sure why you had to change some of that stuff, but not looked at quantum in a while
15:29:52 <johnthetubaguy> OK, you used to be able to do both I thought, never mind
15:29:58 <matelakat> So, that ugly patch.
15:30:08 <matelakat> It is about getting things working.
15:30:27 <johnthetubaguy> OK, looks like security groups needs some TLC for XCP
15:30:53 <matelakat> So, regarding to security groups.
15:30:54 <johnthetubaguy> but its a good step forward, regardless
15:31:28 <matelakat> I turned them off, because otherwise a race condition appears with the agent and the L3 plugin fighting for iptables.
15:31:53 <matelakat> And I spoke with maru.
15:31:55 <johnthetubaguy> hmm, fun
15:31:57 <johnthetubaguy> OK
15:32:50 <johnthetubaguy> any insights?
15:33:03 <matelakat> So he had a question, that we might need to think about.
15:33:17 <matelakat> Does Citrix have any intention of providing a namespace-supporting dom0 kernel for  XS/XCP?  In Folsom, no L3 filtering was being performed in dom0, so namespace support was only required in domU.  However, the security group implementation introduced in Grizzly will require that L3 filtering be performed in dom0, and the lack of namespace support will prevent a configuration that supports overlapping ips.
15:33:43 <johnthetubaguy> oh, yeah, that one
15:33:43 <matelakat> So that's something we need to do.
15:34:01 <johnthetubaguy> but you could just have a separate machine running dhcp
15:34:02 <matelakat> Honestly, I am not really keen on doing any L3 filtering on dom0
15:34:38 <BobBall> I also think it'd be hard to make that change to support namespaces
15:34:48 <johnthetubaguy> why is that?
15:35:06 <BobBall> XS 6.1 is out, 6.2 is nearly out, and my understanding is it needs a kernel change which might be tricky to convince people to take in a hotfix
15:35:44 <matelakat> I think we should need to do some more investigation, to understand the requirements.
15:35:56 <BobBall> If we can do the L3 filtering in the DomU then that would be an easier fit than changing the dom0 kernel on released versions
15:36:56 <johnthetubaguy> but we can just use a separate server right?
15:37:09 <johnthetubaguy> one dedicated for dhcp
15:37:18 <johnthetubaguy> with a kernel that supports that stuff
15:37:38 <matelakat> DHCP is working, and indeed running in DomU
15:37:51 <johnthetubaguy> I don't mean domU
15:38:05 <johnthetubaguy> I mean a separate full server, not a VM, just runing DHCP
15:38:14 <matelakat> domU - other machine, isn't it the same?
15:38:35 <matelakat> It's not dom0
15:39:17 <johnthetubaguy> not quite
15:39:24 <BobBall> so what means that Maru still thinks it needs namespaces in dom0?
15:39:36 <johnthetubaguy> well, there is no need for maru's path I thought, if you run in a separate machine
15:39:48 <johnthetubaguy> if you run dhcp on every server
15:39:53 <johnthetubaguy> something they might do this release
15:39:58 <johnthetubaguy> then you would want that on dom0
15:40:06 <johnthetubaguy> mostly because the L3 routing is going on there
15:40:27 <matelakat> I am not sure I understand you, John.
15:40:41 <johnthetubaguy> erm, could do to draw a picture
15:40:51 <matelakat> good idea.
15:40:55 <matelakat> Let's take it offline.
15:41:11 <matelakat> and carry on with the meeting.
15:41:15 <johnthetubaguy> well, basically DHCP could be run on a server not running XenServer
15:41:24 <johnthetubaguy> and just do it as with any other hypervisor
15:41:38 <johnthetubaguy> its only needed on XenServer to support single box deployments
15:41:51 <johnthetubaguy> and multi-host, which is not yet upstream
15:41:56 <johnthetubaguy> yes, lets move on
15:42:09 <johnthetubaguy> I had one item, Xen Hackathon
15:42:16 <johnthetubaguy> it was more an advert that I am going
15:42:41 <johnthetubaguy> but that was all really
15:42:50 <johnthetubaguy> anything more?
15:43:02 <BobBall> I'm afraid that the hackathon has run out of spaces...
15:43:02 <johnthetubaguy> or we can quickly touch quantum?
15:43:09 <BobBall> I was hoping to go, but won't be there
15:43:24 <johnthetubaguy> indeed, it was going to be to chat with those who were going
15:43:26 <BobBall> I'm assuming that the focus will be on Xapi in CentOS and not OpenStack?
15:43:35 <johnthetubaguy> well, it will be now
15:43:43 <johnthetubaguy> I might look at the console-log
15:43:46 <johnthetubaguy> if people are interested
15:43:55 <BobBall> that'd be great to get something up stream
15:44:09 <johnthetubaguy> oh, I wasn't thinking that side
15:44:22 <johnthetubaguy> someone is already upstreaming that patch
15:44:24 <BobBall> oh :D
15:44:29 <BobBall> good to hear!
15:44:45 <johnthetubaguy> so any more for any more?
15:45:03 <matelakat> I am done.
15:45:08 <johnthetubaguy> I will probably leave for the airport then...
15:45:14 <BobBall> I'm done too
15:45:17 <BobBall> Have a safe trip
15:45:20 <matelakat> y
15:45:20 <johnthetubaguy> thank you
15:45:23 <johnthetubaguy> see you later
15:45:24 <BobBall> Try not to drink too much guinnes
15:45:25 <BobBall> +s
15:45:26 <johnthetubaguy> #endmeeting