15:02:14 <johnthetubaguy> #startmeeting XenAPI
15:02:15 <openstack> Meeting started Wed May 22 15:02:14 2013 UTC.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:18 <BobBall> yeah! pffft! Wait your turn! :D
15:02:19 <openstack> The meeting name has been set to 'xenapi'
15:02:28 <johnthetubaguy> hello people
15:02:32 <johnthetubaguy> who is here for XenAPI?
15:02:59 <BobBall> o/~
15:03:02 <BobBall> Mate should be here too
15:03:08 <BobBall> but he's not yet
15:03:20 <BobBall> and I'm working from home - hence can't shout at him over the wall
15:03:22 <matelakat> hi
15:03:34 <johnthetubaguy> ah, hello
15:03:38 <johnthetubaguy> any more for any more?
15:03:42 <matelakat> He was shouting so loud, so I was able to hear it.
15:04:18 <BobBall> :)
15:04:20 * johnthetubaguy starts to write paper about proof of wormholes in cambridge
15:04:35 <BobBall> I've got dozens of them in my garden... don't think we need a paper...
15:04:40 <johnthetubaguy> #topic Actions from last week
15:05:00 <johnthetubaguy> matelakat did you document the bug finder?
15:06:13 <johnthetubaguy> don't think there are any other actions
15:06:53 <matelakat> I haven't documented the bugfinder.
15:06:57 <johnthetubaguy> ok
15:06:58 <BobBall> btw, while we wait for matelakat (ding) to answer...
15:06:59 <BobBall> oh
15:07:03 <BobBall> there you go, he answered :D
15:07:06 <BobBall> I'll wait my turn then
15:07:17 <johnthetubaguy> #action matelakat to document bug finder in XenAPI team wiki
15:07:23 <johnthetubaguy> ok BobBall?
15:07:46 <matelakat> Sorry guys, I am chatting with dan on smoke, which is quite important.
15:08:07 <BobBall> well it's not an action
15:08:11 <BobBall> so I can wait my turn in the agenda
15:08:22 <BobBall> shall we talk about QA then?
15:08:28 <BobBall> (was that next in line?)
15:08:36 <johnthetubaguy> we can, nothing else on the list
15:08:44 <johnthetubaguy> anyone got any blueprint updates?
15:08:51 <matelakat> no
15:09:01 <johnthetubaguy> #action Bugs and QA
15:09:12 <johnthetubaguy> so its bug day again, the bi weekly nova bug day anyways
15:09:23 <johnthetubaguy> did some triage of the xenserver bugs again
15:09:30 <BobBall> So in terms of QA, as Mate says, we're currently working with Dan to figure out what needs to change in the XenServer scripts to get smokestack working again
15:09:35 <johnthetubaguy> working on the agent setting thing
15:09:38 <johnthetubaguy> cool
15:09:44 <johnthetubaguy> quick update?
15:10:05 <BobBall> Mate could say more if you were interested, but I think the important thing is that Mate has promised not to sleep until it's back and working
15:10:22 <johnthetubaguy> #info openstack xenapi driver uses PV tools to set the host name when using the agent, but XS 6.1 seems to have pulled this feature
15:10:30 <matelakat> Updates next week.
15:10:36 <johnthetubaguy> I am interested what the plan is, and if I can help really
15:10:39 <matelakat> I just started to work on this.
15:10:46 <johnthetubaguy> OK
15:10:54 <BobBall> Minor clarficiation on that John...
15:10:55 <matelakat> I will let you know, if I need help.
15:11:07 <BobBall> XS 6.1 _with the new tools_ does not support this
15:11:15 <johnthetubaguy> #info matelakat working to get smokestack back up and running
15:11:42 <BobBall> the feature wasn't an official feature (bad excuse I know) but more importantly it didn't work in windows 2012 in some scenarios
15:11:43 <johnthetubaguy> I hurd you can't attach block volumes to a running VM if you use the old tools on XS 6.1 though
15:11:59 <BobBall> as such, it didn't make sense to port that feature over to the new-style drivers (which were a complete re-write anyway)
15:12:22 <BobBall> if we need a way to set the hostname then we should look at a PR to get it into the guest tools rather than the PV drivers
15:12:43 <johnthetubaguy> that is my plan now
15:12:53 <BobBall> that would require a reboot (which we don't in the old-way of doing it) but would be using the MS supported methods and wouldn't break in the ways that we've seen it break
15:13:17 <BobBall> I meant if we want XS to do it then the guest tools is the place it should be.  An OS solution that doesn't use the XS guest tools is of course fine too
15:13:20 <johnthetubaguy> we need reboots for other things anyway, so would be good to add that in there
15:13:38 <johnthetubaguy> cloudbase-init does set the hostname for you too
15:13:46 <johnthetubaguy> but that works regardless I think
15:13:59 <BobBall> ok
15:15:32 <johnthetubaguy> OK, so...
15:15:43 <johnthetubaguy> #topic Open Discussion
15:15:47 <johnthetubaguy> anything more to raise?
15:15:57 <BobBall> yes
15:15:59 <BobBall> damnit
15:16:04 <BobBall> I've forgotten what it was now though
15:16:10 <johnthetubaguy> oops
15:16:24 <BobBall> oh yes
15:16:42 <BobBall> I thought it'd be worthwhile having a chat with Mate about the changes he's made for the Quantum integration
15:16:52 <BobBall> Maru was surprised that a revised approach was needed
15:17:04 <matelakat> So
15:17:13 <matelakat> I think the DHCP change is not needed.
15:17:36 <matelakat> Having one agent controlling both domU and dom0 bridges does not sound good.
15:18:11 <matelakat> So I have a devstack change, that will eliminate this issue, and start two separate agents, one for domU, one for dom0
15:18:26 <matelakat> And create a "physnet" physical bridge.
15:18:27 <johnthetubaguy> ah, OK
15:18:34 <johnthetubaguy> so routing the traffic in the DomU?
15:18:39 <matelakat> So that no code change is needed.
15:18:54 <BobBall> both agents in the domu you mean?
15:18:54 <matelakat> tunnelling with vlans.
15:19:06 <matelakat> agents tun in domu, that's correct.
15:19:28 <johnthetubaguy> yup, that makes sense I think
15:19:37 <matelakat> I have a change for that.
15:19:39 <matelakat> Wait a sec.
15:19:53 <johnthetubaguy> in the general case, you probably don't want that running on a VM anyway, or at least not on a nova-compute node
15:20:22 <johnthetubaguy> it might mean what they do with mult-host support for DHCP will not work
15:20:44 <BobBall> ok
15:20:53 <BobBall> so john - which wouldn't work multi-host?
15:20:57 <BobBall> Maru's way or Mate's way?
15:21:07 <johnthetubaguy> #info while openstack network support for XenAPI L2 is going well, but L3 patch may not be needed
15:21:15 <johnthetubaguy> erm, Mate's way
15:21:25 <johnthetubaguy> but they haven't done multi-host yet
15:21:26 <BobBall> Well a revised L2 patch is needed to remove the need for the L3 patch
15:21:39 <johnthetubaguy> oh, interesting
15:21:53 <johnthetubaguy> I guess that makes sense
15:21:54 <BobBall> I think that's right matelakat ?
15:22:20 <matelakat> I think only my setup will work with multi host.
15:22:38 <johnthetubaguy> but that they implemented multi host yet?
15:22:41 <johnthetubaguy> have^
15:22:48 <matelakat> That's not right, I am sorry, I think both should work - mine works for sure.
15:23:03 <johnthetubaguy> do they have mult-host for DHCP now?
15:23:13 <matelakat> In multi-host, I meant mapping your network to physical nets.
15:23:30 <johnthetubaguy> ah, I mean running multiple DHCP
15:23:48 <johnthetubaguy> like in nova's multi-host
15:24:16 <matelakat> I think, it is really hard to discuss these things via IRC.
15:24:26 <johnthetubaguy> I have a feeling they are dropping that stuff anyways
15:24:36 <johnthetubaguy> possibly yes
15:24:45 <matelakat> I know, my wife and my mother-in law are capable of discussing colors over the phone, but I am not that clever.
15:24:54 <johnthetubaguy> lol
15:25:04 <BobBall> colours need the woman gene...
15:25:17 <BobBall> chromosone!
15:25:19 <matelakat> For me, networking needs a whiteboars.
15:25:21 <johnthetubaguy> its bluey green with a hint of three week old dry grass
15:25:31 <BobBall> It's been too long since I've been at school :D
15:25:43 * BobBall will not ask what a whiteboar is.
15:25:54 <matelakat> So, let's get back to this networking discussion.
15:26:04 <BobBall> idd
15:26:06 * johnthetubaguy thinks of some form of white pudding made from wild boar
15:26:09 <johnthetubaguy> indeed
15:26:17 <johnthetubaguy> what was the issue here?
15:26:24 <matelakat> I would like to associate proper meaning to those "multi-host", and "nova-like" words.
15:26:27 <BobBall> so - John - are you happy that Mate's approach is better than the currently proposed approach?
15:26:33 <johnthetubaguy> I think it is when you have one DHCP per host stuff is not great
15:26:37 <matelakat> Are you visiting us this week John?
15:26:58 <johnthetubaguy> no plans, but I could, tomorrow
15:27:03 <matelakat> Bob?
15:27:19 <BobBall> I'm WFM in the morning
15:27:25 <BobBall> but I'll be in in the arvo hopefully
15:27:30 <matelakat> I am sorry for all these things, but it is pointless for me to discuss networking through IRC.
15:27:30 <BobBall> having a kitchen delivered!
15:27:36 <BobBall> that's fine :)
15:27:40 <johnthetubaguy> that sounds important
15:27:48 <johnthetubaguy> OK
15:28:06 <johnthetubaguy> so maybe we are done for now, and we can answer questions people have next week
15:28:15 <matelakat> Okay, so if you pop in to the office, you can have curry as well.
15:28:28 <BobBall> I will probably be in post-curry
15:28:37 <matelakat> Let me know your decision, John.
15:28:49 <matelakat> Sync-up, and have some diagrams.
15:29:13 <johnthetubaguy> Ok, will try drop by in the afternoon, will check with sally later
15:29:23 <BobBall> I'm thinking maybe we need diagrams sketched out online
15:29:28 <johnthetubaguy> oh, curry too maybe
15:29:32 <BobBall> We need to convince others on the patch review too
15:29:45 <johnthetubaguy> we have diagrams, its just slow and hard to point
15:30:01 <BobBall> ok
15:30:04 <johnthetubaguy> we can talk about the devstack refactoring as well I guess
15:30:17 <johnthetubaguy> agree and end point for the networking config
15:30:25 <johnthetubaguy> informally at least
15:30:57 <johnthetubaguy> so we all done now?
15:31:05 <BobBall> think so
15:31:07 <matelakat> aj
15:31:09 <matelakat> stop
15:31:13 <matelakat> Question
15:31:13 <johnthetubaguy> #endmeeting