15:02:01 <johnthetubaguy> #startmeeting XenAPI
15:02:02 <openstack> Meeting started Wed Jul 10 15:02:01 2013 UTC.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:05 <openstack> The meeting name has been set to 'xenapi'
15:02:19 <johnthetubaguy> Hello, who is around for the XenAPI meeting?
15:04:45 <matel> I am here
15:05:10 <johnthetubaguy> cool, any more people around?
15:05:34 <euanh_> I'm here
15:05:39 <johnthetubaguy> cool
15:06:37 <matel> Okay, so I have a question.
15:06:52 <BobBall> sorry - I thought I was in here!
15:06:54 <matel> Does RS has pygrub installed in domU/
15:07:28 <johnthetubaguy> matel: oh, good question, don't think so, let me check
15:07:37 <johnthetubaguy> anyone got stuff to raise today?
15:07:58 <BobBall> not from me that I can think of
15:08:08 <BobBall> although my brain is in so many different places who knows if I'll remember something
15:08:46 <matel> I have another question about what images are used for testing within RS
15:09:06 <matel> And if RS support 3 part images at all
15:09:12 <johnthetubaguy> matel: just our usual image we use in production, no three part images
15:09:23 <johnthetubaguy> matel: all vhds in the usual way
15:09:46 <matel> Okay, I had a discussion around a tempest test.
15:10:13 <matel> I was using a vhd, and it behaves in a different way compared to the 3 part ones.
15:10:36 <matel> If anyone is interested: #link https://review.openstack.org/35841
15:11:01 <matel> It's not a biggie, and I am about to commit the change.
15:11:38 <johnthetubaguy> matel: what happens differently?
15:12:23 <matel> create an image from an instance
15:12:27 <matel> minDisk parameter
15:12:45 <matel> the review page contains all the info.
15:13:07 <johnthetubaguy> not sure I get it
15:13:16 <johnthetubaguy> what is minDisk trying to say?
15:13:41 <matel> I guess a minDisk in an image whould indicate the minimum required disk.
15:14:10 <johnthetubaguy> right, that makes sense
15:14:43 <johnthetubaguy> so I think our behavior makes sense, trying to understand the other case
15:14:56 <matel> Yeah, that is strange.
15:15:32 <matel> I think afazekas said that it should be the behavior as well.
15:15:49 <johnthetubaguy> hmm, odd one
15:15:57 <johnthetubaguy> any more for any more?
15:16:32 <matel> I just have a comment, that I looked to the volume related stuff today, and we would definitely need to clean up that part.
15:17:11 <johnthetubaguy> in tempest?
15:17:16 <matel> In nova
15:17:29 <johnthetubaguy> whats up with it, looking at the volume driver stuff again?
15:17:34 <matel> yes
15:17:46 <johnthetubaguy> yeah, lots of tidying required in there
15:17:55 <johnthetubaguy> whats the state of that blueprint?
15:18:15 <johnthetubaguy> do we think its more important than the other ones we have for h-3?
15:18:28 <matel> Trying to catch up what's needed, but did not do too much with it this week.
15:19:01 <BobBall> I guess the problem we have with the h-3 blueprints is that other priorities are overtaking it
15:20:01 <johnthetubaguy> sure, we just need to keep that up to date
15:20:12 <johnthetubaguy> what is so low priority about what is in those bps
15:20:29 <matel> I think we could look at the bps on Monday, and update their status, Bob, what do you think?
15:20:31 <johnthetubaguy> or should we raise new ones for the work you are doing now
15:20:49 <johnthetubaguy> just good to be clear on our plans for H
15:21:04 <BobBall> yes
15:21:08 <BobBall> we'll updapte on Monday
15:21:11 <johnthetubaguy> H-3 is going to be super full of stuff, so we might be thanked for dropping a few bits, particular if it anit making it in
15:21:12 <johnthetubaguy> cool
15:21:31 <johnthetubaguy> #action BobBall to update blueprint around Citrix efforts
15:21:43 <BobBall> much of the work we're doing isn't a BP type thing - e.g. making our integration using supported interfaces
15:21:54 <johnthetubaguy> well, that is a blueprint really, but hey
15:22:03 <BobBall> it is?
15:22:03 <BobBall> ok
15:22:06 <johnthetubaguy> or could be I guess
15:22:07 <BobBall> well we can add that for sure!
15:22:09 <BobBall> okay
15:22:33 <johnthetubaguy> just need to add the sub steps correctly, and you might want it in several bps, if it will go over several sprints
15:23:00 <johnthetubaguy> sadly there is no epic or group of blueprints, just make the end goal the last bp in the set of dependencies
15:23:12 <johnthetubaguy> matel: how to I check for pygrub again?
15:23:54 <matel> john, I don't really understand your q
15:24:09 <johnthetubaguy> well, I am on a nova-compute, checking for pygrup
15:24:32 <matel> I was looking at that bug, and discovered, that the same pygrub logic is used if you're booting a raw volume.
15:25:00 <matel> So I don't want to screw up RS functionality, so that's why I ended up asking you if you guys have pygrub in domU
15:25:34 <matel> I know that we agreed to remove that logic, and I would love to do that, although I think an extra check should not be a pain.
15:25:35 <johnthetubaguy> matel: we don't boot from a volume today
15:25:46 <johnthetubaguy> matel: it only uses that with nfs though, right?
15:25:54 <matel> john: Do you boot raw volumes?
15:26:06 <johnthetubaguy> matel, we don't boot from any volumes
15:26:15 <matel> It has noting to do with nfs
15:26:18 <johnthetubaguy> what do you mean by raw volumes?
15:26:20 <matel> sorry, I meant raw images
15:26:32 <johnthetubaguy> oh, we don't have raw images either
15:26:41 <matel> Okay, so you only have vhd.
15:26:53 <johnthetubaguy> yep, ^
15:27:04 <johnthetubaguy> all vhd, no three part
15:27:11 <johnthetubaguy> all ovf
15:27:24 <matel> tgz -ed vhd
15:27:29 <johnthetubaguy> trailling some ISO booting, but thats separate
15:27:35 <johnthetubaguy> matel: yep
15:28:40 <johnthetubaguy> when do we use pygrub with raw images then?
15:28:51 <johnthetubaguy> surely its only when there is no os_type stated?
15:29:02 <johnthetubaguy> matel ^
15:29:36 <matel> yes, I guess, I am digging the code.
15:29:59 <johnthetubaguy> there is nothing much special about raw image
15:30:13 <johnthetubaguy> we just stream into a VHD, then keep going down the same path as VHD
15:31:28 <BobBall> Am I still here?
15:31:42 <johnthetubaguy> matel: can confirm we don't have pygrub on nova-compute
15:31:47 <johnthetubaguy> BobBall: yes
15:31:54 <johnthetubaguy> any more questions?
15:32:04 <matel> Okay.
15:32:08 <BobBall> I thought so
15:32:30 <matel> #link https://github.com/openstack/nova/blob/master/nova/virt/xenapi/vm_utils.py#L1457
15:32:39 <BobBall> Sorry - a bit of a rubbish one from me today
15:32:59 <matel> You see john, raw is using the same pygrub approach.
15:33:06 <johnthetubaguy> matel: gotya
15:33:17 <johnthetubaguy> matel: but only once its not marked on the image
15:33:21 <matel> sure.
15:33:36 <johnthetubaguy> ooh, maybe not...
15:33:36 <matel> I'm gonna remove that intel.
15:33:58 <johnthetubaguy> yeah, I am +1 on that
15:34:15 <matel> Okay, let the code speak, I will add you to the reviewers.
15:34:24 <matel> I am done.
15:34:25 <johnthetubaguy> yep, sounds best
15:34:28 <johnthetubaguy> cool
15:34:33 <johnthetubaguy> any more?
15:34:48 <johnthetubaguy> just the one action for bob to update blueprint
15:34:49 <johnthetubaguy> s
15:35:30 <johnthetubaguy> I am mostly tracing down a few gremlins and race conditions we are seeing, but thats about all
15:35:36 <johnthetubaguy> #endmeeting