15:01:12 <johnthetubaguy> #startmeeting XenAPI
15:01:13 <openstack> Meeting started Wed Aug 21 15:01:12 2013 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:16 <openstack> The meeting name has been set to 'xenapi'
15:01:19 <johnthetubaguy> hi everyone
15:01:24 <johnthetubaguy> who is around for the meeting?
15:04:55 <BobBall> hmmm
15:04:56 <BobBall> weird
15:04:57 <BobBall> I am
15:05:02 <BobBall> I was expecting this to highlight
15:05:17 <BobBall> dunno why xenapi up there ^^ didn't cause me to sit up and take notice
15:05:37 <BobBall> johnthetubaguy:
15:05:49 <BobBall> Sorry for the delayed start
15:05:58 <johnthetubaguy> anyone else around
15:06:02 <matel> I am here.
15:06:04 <BobBall> matel is ;)
15:06:12 <BobBall> And we can pull euanh in if needed
15:07:09 * BobBall waits :)
15:09:04 <johnthetubaguy> cool
15:09:12 <johnthetubaguy> so people got stuff for the agenda?
15:09:27 <BobBall> Let's go through the normal agend
15:09:30 <BobBall> we have stuff to raise
15:09:38 <BobBall> but only in the right place
15:09:47 <johnthetubaguy> OK
15:09:59 <johnthetubaguy> no actions from last meeting I guess
15:10:10 <johnthetubaguy> #topic Blueprints
15:10:17 <johnthetubaguy> hows we doing on this front
15:10:22 <johnthetubaguy> its the merge freeze today
15:10:28 <johnthetubaguy> so all changes need to be up today
15:10:32 <johnthetubaguy> hows we looking?
15:11:13 <BobBall> they are all up I thin
15:11:14 <BobBall> k
15:11:17 <BobBall> we've got a couple of BPs
15:11:24 <johnthetubaguy> Ok, cool
15:11:25 <BobBall> including one late-bloomer (xenserver-core)
15:11:32 <BobBall> but all changes are up and ready for review
15:11:34 <johnthetubaguy> are they all approved now?
15:11:40 <BobBall> it's BP freeze now, right?
15:11:42 <BobBall> yes, all approved
15:11:46 <BobBall> feature freeze in a few days time
15:12:03 <johnthetubaguy> erm, code needs to be uploaded today
15:12:08 <johnthetubaguy> merged by two weeks time
15:12:11 <johnthetubaguy> or something like that
15:12:16 <BobBall> nice
15:12:23 <BobBall> are we disabling git review for new patches?
15:12:28 <BobBall> that'd be a good help to the reviewers ;)
15:12:33 <johnthetubaguy> nope, other bug patches are welcome still
15:12:40 <BobBall> but yes, code is all uploaded
15:12:52 <johnthetubaguy> we just reserve the right to −2 any new patches that are blueprints
15:13:12 <johnthetubaguy> nope, bug patches are welcome until we ship
15:13:18 <matel> I guess one can modify its patch, right?
15:13:34 <johnthetubaguy> yup
15:13:41 <johnthetubaguy> good point
15:13:56 <matel> So I think we are good on this front. Bob did a great patch bombing.
15:14:07 <johnthetubaguy> all good
15:14:36 * BobBall does the patch-bomb dance
15:15:24 <johnthetubaguy> #topic Docs
15:15:29 <johnthetubaguy> so any docs news
15:15:42 <matel> johnthetubaguy: I was emailing on xs-devel regarding to image import/export, I added you to the last email, your input is more than welcome.
15:15:46 <BobBall> yes lots of fun docs
15:16:06 <BobBall> https://blueprints.launchpad.net/openstack-manuals/+spec/redocument-xen was drafted
15:16:21 <BobBall> although a noticeable percentage of those bugs are "we should document more configurations"
15:16:39 <matel> I am looking at the docs right now, reading through the existing documentation. Spoke with anne, it seems that docs are heading towards a consolidated config manual.
15:16:40 <BobBall> so I do not consider them as important as the base docs
15:17:54 <ekarlso-> (wom 2+
15:18:47 <johnthetubaguy> OK
15:18:50 <johnthetubaguy> that seems fair
15:18:58 <johnthetubaguy> accuracy is more important I think
15:19:04 <johnthetubaguy> so remove missleading stuff first
15:19:09 <johnthetubaguy> then add missing stuff
15:19:31 <johnthetubaguy> matel: sorry, I hope to wade in on that, just not had chance
15:19:42 <johnthetubaguy> cool, whats the timeframe on the docs stuff?
15:19:49 <johnthetubaguy> patches coming soon?
15:20:05 <johnthetubaguy> feel free to ping me on IRC if I can help with "is that still true" questions
15:20:06 <matel> I am not really expecting patches this week.
15:20:17 <johnthetubaguy> no problem
15:20:26 <matel> I am reading through the docs.
15:20:28 <BobBall> Figuring out what to change this week we hope
15:20:32 <johnthetubaguy> this post freeze time is the perfect time to try and tidy up the docs
15:20:38 <BobBall> and updating the wiki pages too
15:20:52 <johnthetubaguy> do we plan to port more of the wiki pages into the docs?
15:21:05 <johnthetubaguy> obviously the devstack docs do not belong in the admin guide, but other than those
15:21:53 <BobBall> Quite possibly - there are things in the wiki that we know are missing from the admin guide
15:21:53 <annegentle> johnthetubaguy: patches are going on now to create the config guide
15:21:57 <johnthetubaguy> Of course, the big TODO on the docs is making stuff like that step by step guide using Ubuntu / Fedora packages, and making it work inside a DomU
15:22:15 <johnthetubaguy> annegentle: cool, we should take a look at those
15:22:16 <annegentle> johnthetubaguy: the Compute Admin Guide will not have much left in it
15:22:24 <annegentle> johnthetubaguy: really the install/config docs are the focus
15:22:38 <annegentle> johnthetubaguy: not much "admin" -- more how do you get Compute running with xen
15:23:00 <johnthetubaguy> annegentle: sounds good, that what I was hoping
15:23:08 <annegentle> johnthetubaguy: shaunm is Shaun McCance and is a contractor with Cisco working solely on the Install guide
15:23:14 <annegentle> johnthetubaguy: you can definitely check with him
15:23:37 <johnthetubaguy> ah, cool, do you want to introduce me to him, in case I can help with quick questions?
15:23:56 <annegentle> johnthetubaguy: yep sure, come by #openstack-doc afterward
15:24:11 <johnthetubaguy> annegentle: ah, OK, will do
15:24:28 <johnthetubaguy> so, sounds like good progress is happening there
15:24:55 <johnthetubaguy> shall we move on to bugs...?
15:25:02 <BobBall> yup
15:25:07 <BobBall> I've got a nice one
15:25:08 <BobBall> or
15:25:11 <BobBall> more importantly a nice fix
15:25:15 <johnthetubaguy> cool
15:25:22 <johnthetubaguy> #topic Bugs
15:25:25 <BobBall> I had an epiphany last night
15:25:46 <BobBall> http://paste.openstack.org/show/44771/ is all that is needed to get things working on LVM-based SRs!
15:25:55 <BobBall> Particularly with Mate's fix to allow upload/download of raw OVAs
15:26:51 <johnthetubaguy> OK, are we going to look at fixing up that safe copy?
15:26:56 <BobBall> Fixes things like https://bugs.launchpad.net/nova/+bug/1162382
15:26:57 <uvirtbot> Launchpad bug 1162382 in nova "LVM over ISCSI as default SR not working" [Low,Won't fix]
15:27:16 <BobBall> I need to really understand that issue
15:27:19 <johnthetubaguy> I think you said we don't need it, if we check for VBDs being removed from Dom0?
15:27:20 <BobBall> I haven't understood it fully yet
15:27:25 <BobBall> I think that safe copy isn't needed at all
15:27:38 <BobBall> I think it was probably added by someone looking in dom0 rather than the code
15:27:45 <johnthetubaguy> well, it was added because there were races when the copy had not completed when that code returned
15:27:48 <BobBall> the vdi.copy will block until it returns
15:27:58 <BobBall> unless you use async copy
15:28:17 <BobBall> and unless we've got parallel API calls - one to copy then the next to clone based on that copy or something - then it'll never be a problem
15:28:28 <johnthetubaguy> hmm, thats an interesting one, it may have originally being doing async when that was added, its worth a history did at some point
15:28:40 <BobBall> I look a little at the history but didn't spot that
15:28:59 <johnthetubaguy> it would be around cactus I think
15:29:28 <BobBall> Anyway - this patch is an easy one to accept because it doesn't affect the existing use cases
15:29:38 <BobBall> of ext - that behaves identically
15:29:49 <BobBall> so current users wouldn't be affected at all.  Guaranteed ;)
15:29:50 <johnthetubaguy> sort of, but we might introduce a sutible bug into the LVM support, which sounds bad
15:30:04 <johnthetubaguy> would rather we looked into the route cause myself
15:30:18 <BobBall> We're confident that there isn't one there
15:31:32 <johnthetubaguy> OK
15:31:38 <johnthetubaguy> then we should look at the VHD case
15:31:55 <johnthetubaguy> what was the parallel calls you were talking about
15:31:59 <johnthetubaguy> copy on the same VDI?
15:32:10 <matel> a sec, Bob has a guest
15:32:11 <johnthetubaguy> two copies on the same VDI, I mean?
15:32:19 <johnthetubaguy> lol, OK
15:32:45 <BobBall> Let's move on
15:32:48 <BobBall> I'l cehck the cause
15:32:58 <BobBall> gimme an action :)
15:33:02 <BobBall> to track down the original commit
15:33:26 <johnthetubaguy> #action look up why VDI.copy work around was added
15:33:36 <johnthetubaguy> oops
15:33:50 <johnthetubaguy> #action BobBall investigate VDI.copy workaround
15:33:57 <johnthetubaguy> OK
15:34:00 <johnthetubaguy> any more for bugs
15:34:30 <johnthetubaguy> just to say, once we pass feature freeze, it would be good to try and fix up some of the pending bugs we have in launchpad
15:34:46 <johnthetubaguy> I think I can get some time to do that, is anyone else likely to get some time on that?
15:34:54 <BobBall> It's planned yeah
15:35:06 <BobBall> but we'll have to see how it goes
15:35:14 <BobBall> there are other non-Havana things that we need to do for OS
15:35:23 <BobBall> such as fixing xenserver-core to work better under the havana base
15:35:48 <BobBall> so while there is a code freeze for havana there isn't necessarily a date for Citrix this time :D
15:35:55 <BobBall> And we want to do some prototyping of things
15:36:00 <BobBall> etc etc
15:36:37 <johnthetubaguy> hmm, so working on a private branch? might not be awesome if I am dropping a load of bug fixes
15:36:46 <BobBall> no
15:36:56 <BobBall> xenserver-core is not in openstack's github
15:37:07 <johnthetubaguy> oh, I see, working on xenserver-core
15:37:09 <BobBall> anything that is developed will be pushed to gerrit etc
15:37:22 <BobBall> even though it won't make H
15:37:46 <BobBall> i.e. if we do some prototype work that we might want to talk about at I summit then we can do that between now and release
15:37:49 <BobBall> in fact we have to ;)
15:38:01 <johnthetubaguy> OK, the idea of the period post feature freeze is to stabilze for the H release, so more help we can get the better, but clearly there are other priorities
15:38:29 <johnthetubaguy> I am certainly not about to do 100% on the bug fixing, doing similar prototyping here and there!
15:38:40 <johnthetubaguy> OK.. enough about bugs I guess
15:38:42 <BobBall> We will be fixing bugs
15:38:57 <johnthetubaguy> cool, thats all good
15:39:03 <BobBall> it all goes into the priority pot is all I'm saying
15:39:10 <johnthetubaguy> sure, understood
15:39:19 <BobBall> and some bugs are irrelevant :)
15:39:30 <BobBall> I'm glad to see we don't have any high bugs
15:39:34 <johnthetubaguy> if they are irrelevant, we can close them
15:39:40 <johnthetubaguy> so let me know
15:39:42 <BobBall> and the mediums could b e lows
15:39:52 <BobBall> irrelevant is also possibly low
15:40:13 <johnthetubaguy> https://wiki.openstack.org/wiki/BugTriage#Task_2:_Prioritize_confirmed_bugs_.28bug_supervisors.29
15:40:18 <BobBall> https://bugs.launchpad.net/nova/+bug/1161471 for example could be low because we don't recommend 3-part images in production ;)
15:40:20 <uvirtbot> Launchpad bug 1161471 in nova "xenapi: guest kernel not cleaned up" [Medium,Triaged]
15:40:23 <johnthetubaguy> •	Medium if the bug prevents a secondary feature from working properly
15:40:29 <johnthetubaguy> •	Low if the bug is mostly cosmetic
15:40:29 <BobBall> ah
15:40:36 <johnthetubaguy> •	Wishlist if the bug is not really a bug, but rather a welcome change in behavior
15:40:50 <johnthetubaguy> •	High if the bug prevents a key feature from working properly for some users (or with a workaround)
15:41:21 <johnthetubaguy> I might start looking at targeting some bugs for Havanna if they look bad
15:41:37 <johnthetubaguy> anyways, if people do spot issues with the bug priorites, do drop me a note
15:41:40 <BobBall> https://bugs.launchpad.net/nova/+bug/1207253 should be "low" by that
15:41:42 <uvirtbot> Launchpad bug 1207253 in nova "xenapi config settings should be in their own nova config section" [Medium,Triaged]
15:42:03 <johnthetubaguy> BobBall: you mean XenServer does not recommend three part images?
15:42:28 <johnthetubaguy> we should look at documenting what we know works well, and is tested well, and what is in an "unknown" state
15:42:36 <johnthetubaguy> we should look at pulling some of the feature people don't use
15:42:47 <johnthetubaguy> we could deprecate them in the havanna timeframe
15:42:55 <johnthetubaguy> three part images are one
15:42:56 <BobBall> indeed
15:43:01 <johnthetubaguy> pools is another
15:43:02 <BobBall> I don't want to deprecate it
15:43:05 <BobBall> either of them
15:43:10 <johnthetubaguy> whys that?
15:43:26 <BobBall> 3-part images are useful for testing and some rare use cases
15:43:41 <BobBall> pools are used by a small group of users so are a secondary feature
15:43:59 <johnthetubaguy> OK, so we need to get some effort to make those features work, and get them properly tested
15:44:10 <BobBall> yes
15:44:29 <johnthetubaguy> otherwise, they need to die, well, they might do that by themsleves, as the pool feature has shown
15:44:31 <BobBall> That's another post-freeze effort - better testing
15:44:45 <BobBall> in our internal CI and smokestack, even if we can't commit unit tests
15:44:58 <johnthetubaguy> indeed, how is the gating trunk going?
15:45:29 <BobBall> Expecting SS to be always-voting at the end of this week (possibly set up over the weekend)
15:45:30 <johnthetubaguy> its the multi-machine tests that we need to get working against trunk really soon
15:45:40 <johnthetubaguy> cool
15:45:46 <johnthetubaguy> how about running tempest tests?
15:45:47 <BobBall> -2 voting will be a few weeks after that once stability has been proven
15:46:17 <BobBall> I guess that's unlikely to make Havana unless the infra freeze is much later ;)
15:46:50 <BobBall> or if they don't have one (they aren't listed in the release schedule)
15:46:50 <johnthetubaguy> not sure there is such a thing, just they try to keep stuff stable when we hit milestones, I thought
15:46:53 <BobBall> :D
15:46:53 <BobBall> indeed
15:46:58 <johnthetubaguy> they don't release
15:47:07 <BobBall> XS is running in the RS cloud
15:47:10 <BobBall> which is fun
15:47:17 <BobBall> but hit some obvious IP issues
15:47:23 <johnthetubaguy> cool
15:47:30 <BobBall> i.e. can't install devstack domU without DHCP
15:47:47 <BobBall> but we now have an XVA/RPM combo being auto generated
15:47:55 <BobBall> so perhaps we can use that rather than the devstack install scripts
15:48:47 <johnthetubaguy> hmm, shame XS has no build in NAT
15:48:58 <johnthetubaguy> maybe ip tables rules could do that?
15:49:16 <johnthetubaguy> give it a static address, on a private network, and NAT traffic out xenbr0
15:49:28 <BobBall> it's the DHCP server that we'd need that's more fun
15:49:33 <BobBall> we have a work around but it makes things ugly
15:49:38 <johnthetubaguy> given with DHCP on RAX cloud, you would only get one per expected mac address
15:49:45 <BobBall> indeed
15:49:53 <johnthetubaguy> well you have isolated networks in the RAX cloud
15:49:56 <johnthetubaguy> just use those?
15:50:09 <matel> BobBall - I thought adding a DHCP server to a private net solved the issue.
15:50:17 <BobBall> indeed
15:50:20 <BobBall> it does
15:50:27 <BobBall> but then you have to use that server as the launchpoint
15:50:27 <johnthetubaguy> yeah, then RAX private networks will give you multi host
15:50:32 <BobBall> I haven't done any more work on it
15:50:42 <BobBall> it's a potential way forward but it's still icky :)
15:50:53 <johnthetubaguy> hmm, you want a single clean thing everytime
15:51:01 <johnthetubaguy> so you will always be launching XenServers right
15:51:05 <matel> I would prefer not to hack iptables stuff.
15:51:08 <BobBall> me too
15:51:39 <BobBall> My tentative plan is to have the XS with the IP (no DHCP server) with an XVA already built in it and ready to do the devstack thang
15:51:45 <johnthetubaguy> sure, but the rest will be waiting for us to support hypervisors in the RAX cloud, its not high priority
15:51:57 <BobBall> "support"? :) It works :D
15:52:07 <BobBall> isn't that the definition of "support"? ;)
15:52:11 <johnthetubaguy> well you only get one IP per machine
15:52:16 <johnthetubaguy> that what I mean
15:52:17 <BobBall> That's all we need
15:52:21 <johnthetubaguy> OK...
15:52:29 <johnthetubaguy> I guess I don't see your issue
15:52:35 <BobBall> gate is fully isolated - don't forget that running devstack in dom0 for libvirt works on RS cloud
15:52:46 <BobBall> The issue I have ATM is purely a setup one I think
15:52:53 <johnthetubaguy> OK
15:53:01 <BobBall> but setup for XS doesn't work in that environment
15:53:06 <matel> If devstack changes, and your XVA is out of date, you might have issues running the tests.
15:53:23 <johnthetubaguy> yeah, needs fresh devstack code on each run
15:53:38 <BobBall> Of course
15:53:47 <johnthetubaguy> but anyways, sounds like it just need some TLC, and it should be up and running
15:53:47 <BobBall> And the domU needs to get the nova etc code somehow too
15:53:51 <matel> Our internal CI is using a JEOS as a starting point.
15:53:52 <BobBall> but that's all manageable
15:53:56 <antonym> yeah, i'm hoping we can make a quick script that will work with the configdrive to auto configure the instance, then i can make an actual xenserver image
15:54:12 <antonym> would be a little quicker to stand up
15:54:27 <johnthetubaguy> antonym: yeah, that sounds good, build up from base centos 6.4?
15:54:33 <BobBall> It would save my hair from being pulled out too
15:54:41 <BobBall> Not xenserver-core - we need XS 6.2
15:54:41 <matel> Devstack install time is a round 700 secs (653)
15:54:49 <antonym> something that would run the xe pif-reconfigure on boot and use the configdrive info
15:55:03 <johnthetubaguy> ah, gotcah
15:55:16 <matel> In a virtual machine it is 900 sec
15:55:18 <antonym> our agent would probably not work so much since it relies on xenstore... which is already being used :P
15:55:24 <johnthetubaguy> I guess HVM XenServer doesn't get xenstore info, lol
15:55:35 <BobBall> antonym: Other option would be to use auto-generated answerfile
15:55:43 <johnthetubaguy> yeah, configdrive should have all the info already
15:55:44 <BobBall> even if it just uses the static IP passed into the kernel
15:55:57 <BobBall> a script can easily read that and put it as the IP for static config
15:56:01 <antonym> BobBall: yeah, if you want to run through the entire install process... i'm thinking we capture the image before firstboot
15:56:22 <johnthetubaguy> that would help when we build up pools
15:56:30 <johnthetubaguy> so they get unique uuids, etc
15:56:35 <BobBall> uh oh - going into unchartered territory there ;) Golden images in pools are a big no-no ATM
15:56:53 <antonym> ah, all the uniqueness is generated in the install?
15:56:59 <BobBall> indeed
15:57:02 <matel> I am remastering an ISO for virtual xenserver installs.
15:57:13 <antonym> gotcha... i almost have my build automated anyways, so we could just use that then
15:57:20 <BobBall> and we haven't done enough analysis to understand if we've got all the uniquness bits in one place to configure for the golden image
15:57:33 <BobBall> isolated is much easier to argue
15:57:38 <johnthetubaguy> sure
15:57:44 <johnthetubaguy> baby steps first
15:57:47 <johnthetubaguy> OK...
15:57:58 <BobBall> 60 seconds!
15:58:01 <johnthetubaguy> #topic Open Discussion
15:58:05 <johnthetubaguy> any last remarks?
15:58:25 <BobBall> Yes.  It's sunny so I'm going to have a barbeque tonight.
15:58:32 <johnthetubaguy> sounds like we are moving forward
15:58:40 <matel> give a review to our changes, if you have time.
15:58:41 <johnthetubaguy> hmm, thats a good idea, I might do that too
15:58:50 <BobBall> oh good point
15:58:55 <BobBall> johnthetubaguy! Please review the XenAPI changes!
15:58:55 <BobBall> :)
15:58:56 <matel> Oh, I inserted my message to the right point!
15:58:57 <johnthetubaguy> there on my list, fingers cross that happens today!
15:58:57 <BobBall> *grin*
15:59:10 <BobBall> And also rope someone else in so there is another core working on it :D
15:59:10 <matel> Just -1, -2 them
15:59:19 <johnthetubaguy> obviously :)
15:59:24 <johnthetubaguy> #endmeeting