15:00:32 <johnthetubaguy> #startmeeting XenAPI
15:00:33 <openstack> Meeting started Wed Jan 29 15:00:32 2014 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:39 <openstack> The meeting name has been set to 'xenapi'
15:00:42 <johnthetubaguy> who is around today?
15:00:51 <matel> matel
15:00:57 <thouveng> guillaume thouvenin
15:01:09 <BobBall> Mr Robert Ball
15:02:11 <johnthetubaguy> so..
15:02:22 <johnthetubaguy> #topic Blueprints
15:02:29 <johnthetubaguy> hows it going
15:02:39 <thouveng> nothing really new on my side.
15:02:46 <BobBall> Can the patches be opened up pls thouveng ?
15:02:48 <thouveng> I'm looking for adding test
15:03:01 <BobBall> I know they need tests, but it'd be good for them to be more visible
15:03:02 <thouveng> yes I can open them
15:03:10 <thouveng> ok sure
15:03:32 <thouveng> in the same time I'm writing a blog post
15:03:57 <thouveng> about those patches so it will be more convenient to open them
15:04:25 <BobBall> Is there any chance someone at RAX could test the pci pass through aspect johnthetubaguy?
15:04:33 <BobBall> I'm struggling from a hardware perspective
15:05:19 <johnthetubaguy> erm, not sure I can
15:05:23 <johnthetubaguy> don't have hardware for that
15:06:02 <BobBall> Drat
15:06:05 <johnthetubaguy> any more on blueprints?
15:06:14 <thouveng> nope
15:06:15 <BobBall> thouveng was saying he'd like someone else to test it too
15:07:24 <thouveng> If I open the patches maybe I will have some feedback
15:07:47 <thouveng> but right now I'm trying to see how to use mock and unit test :)
15:08:08 <johnthetubaguy> OK, we can help you if you open then
15:08:09 <thouveng> at least to test method like  attach_pci_devices
15:08:29 <thouveng> they should be open now
15:08:47 <BobBall> it's actually quite straight forward
15:08:47 <johnthetubaguy> cool
15:08:54 <johnthetubaguy> you read the mock docs?
15:09:02 <BobBall> you add a decorator @mock.patch.object(module, 'method')
15:09:13 <BobBall> and an argument to your test function
15:09:22 <thouveng> yes I read the doc but when I look the code it is not so easy
15:09:26 <BobBall> and then do argument.return_value='string'
15:10:14 <BobBall> ah
15:10:21 <BobBall> I was talking about the _get_passthrough_devices test
15:10:29 <thouveng> I will try that. I don't see clearly where to add code but I will run some tries
15:10:30 <BobBall> not attach_pci_devices (which is a little more complicated...)
15:11:14 <BobBall> I gave a hint in my latest comments on the commit
15:11:35 <BobBall> but I'm more than happy to explain more - here or email or wherever :)
15:12:02 <thouveng> Yes I see it and I'm looking how _test_spawn is working
15:12:21 <BobBall> The problem is that all of the functions are local to the spawn method
15:12:29 <BobBall> which is why there is one huge test for it
15:12:43 <BobBall> but I'm hoping it'll be an easy copy+paste jobby to get the tests going
15:12:57 <johnthetubaguy> yeah, that fella is tricky
15:12:58 <thouveng> Ok. I will ask you by email then :)
15:13:17 <matel> tricky = smells
15:13:24 <matel> Just to be corect.
15:13:28 <matel> correct
15:13:38 <BobBall> indeed.
15:13:45 <BobBall> But at least it has a test ;) that's something.
15:14:29 <johnthetubaguy> I perfer the actual unit tests more
15:14:36 <johnthetubaguy> but that spawn one can work
15:14:51 <BobBall> I didn't see actual unit tests for those functions?
15:15:03 <BobBall> I could have been being blind though...
15:16:10 <johnthetubaguy> OK,
15:16:15 <johnthetubaguy> add the little unit tests first
15:16:21 <johnthetubaguy> then worry about the spawn one later
15:16:30 <johnthetubaguy> to be honest, if it doesn't break it, thats cool by me
15:16:58 <johnthetubaguy> I had to modify that test recently, because it was incorrect, and its not a nice thing at all
15:17:01 <johnthetubaguy> anyways
15:17:12 <johnthetubaguy> anything specific to discuss here?
15:17:28 <BobBall> I think not for now
15:17:46 <matel> not related to these things.
15:17:48 <johnthetubaguy> cool
15:17:53 <johnthetubaguy> #topic QA
15:18:03 <BobBall> Does QA include talking about bugs? :)
15:18:07 <johnthetubaguy> so upstream testing…
15:18:12 <BobBall> oh yeah
15:18:16 <BobBall> matel's turn
15:18:17 <johnthetubaguy> ah, well we can do bugs first if you want?
15:18:23 <johnthetubaguy> ok, bugs second
15:18:25 <BobBall> although I've done a chunk yesterday too
15:18:47 <matel> Okay, so Bob has set up a nodepool in our CI -so that we could try out the nodepool changes.
15:18:56 <matel> Other than that, we passed full tempest.
15:19:18 <matel> The time it takes is not the best, let me dig it up for you.
15:20:10 <matel> https://github.com/citrix-openstack/xenapi-os-testing/issues/26
15:20:21 <matel> It shows, that full tempest took 5862.250s
15:20:36 <matel> We still have some error messages in the logs - which make the job fail.
15:20:47 <johnthetubaguy> ah, OK, thats good progress
15:20:51 <matel> But it's definitely a progress further.
15:20:54 <johnthetubaguy> so we have a good localrc now I guess?
15:21:04 <matel> We have a working localrc, yes.
15:21:27 <matel> We created a status page to make it easier to monitor, what needs to be done/where we are.
15:21:44 <johnthetubaguy> hang on, so it takes 97 mins right, so 1hour 37mins
15:21:46 <BobBall> And we have a nodepool running internally which creates nodes (or at least tries to create nodes!) in the rax cloud
15:21:55 <johnthetubaguy> did you do anything in parrallel?
15:22:08 <matel> #link https://wiki.openstack.org/wiki/XenServer/GateIntegration
15:22:10 <johnthetubaguy> I think gate does parallelism of 2 or 4?
15:22:14 <matel> 2
15:22:29 <matel> This run was with 2 as well
15:22:34 <BobBall> It used to be 4 but it was dropped recently because nova can't cope ;)
15:22:44 <johnthetubaguy> yeah, that sounds right
15:22:55 <johnthetubaguy> hmm, well, reducing that is a good goal
15:23:06 <BobBall> It's a secondary goal to getting it working :P
15:23:16 <matel> Bob has some pending changes, which might help.
15:23:48 <BobBall> indeed - this is on trunk
15:23:51 <BobBall> not the CTX branch
15:23:58 <BobBall> so not all of my speedups are there yet
15:24:06 <matel> So I think there are still stuff to do, but we are showing progress.
15:24:26 <matel> johnthetubaguy: could you please review https://wiki.openstack.org/wiki/XenServer/GateIntegration
15:24:47 <johnthetubaguy> #action johnthetubaguy to review https://wiki.openstack.org/wiki/XenServer/GateIntegration
15:24:50 <BobBall> So ummm
15:24:53 <BobBall> it might just have worked
15:24:53 <johnthetubaguy> I will try to do that
15:24:55 <matel> And let me know, if you guys wanted to see some other info on that page.
15:24:56 <BobBall> mate
15:25:03 <matel> yes, Bob?
15:25:13 <BobBall> ssh ubuntu@10.219.3.168
15:25:16 <BobBall> to get to our nodepool
15:25:21 <johnthetubaguy> ah, so that time was on trunk, thats good news
15:25:25 <BobBall> then nova list and we have a template that is there and running
15:25:27 <matel> BobBall - are you telling me, that we built a node?
15:25:37 <BobBall> I'm not certain
15:25:49 <BobBall> no, not a node, the image
15:25:53 <BobBall> but the image seems to work
15:25:55 <BobBall> it's in devstack
15:25:56 <BobBall> which is good
15:26:04 <matel> BobBall: take it offline
15:26:06 <BobBall> ssh root@162.242.233.166
15:26:11 <BobBall> okay
15:26:12 <BobBall> true
15:26:17 <BobBall> this is all behind our firewall :D
15:26:41 <BobBall> matel: stamp file isn't there :/
15:26:42 <matel> 162.242.233.166 - that's not
15:26:54 <BobBall> no - but you can't get in without the private key which is
15:27:03 <BobBall> but anyway
15:27:04 <matel> BobBall - use jenkins username
15:27:05 <johnthetubaguy> hehe
15:27:05 <BobBall> we'll take it offline.
15:27:32 <johnthetubaguy> anyways, sounds like there is awesome progress there
15:27:49 <matel> Yes, unfortunately, I am not working this week.
15:27:49 <johnthetubaguy> what is the plan for reporting into gerrit?
15:28:08 <matel> I guess we are aiming for full gate integration.
15:28:13 <BobBall> That's the only missing step ATM because we want full gate
15:28:19 <BobBall> this nodepool setup is for verification + testing
15:28:24 <BobBall> but a backup plan as well
15:28:35 <BobBall> if we need to report to gerrit we'll just setup something simple with pygerrit
15:28:35 <johnthetubaguy> right, but how are we reporting into review.openstack.org
15:28:43 <johnthetubaguy> I am just reading the wiki
15:29:12 <BobBall> It's not on the wiki because the wiki is aimed at the primary plan of OS zuul managing it
15:29:14 <matel> johnthetubagu: I thought it's handled by the infrastructure
15:29:37 <matel> johnthetubaguy: why do you have such a long nick? :-)
15:29:40 <johnthetubaguy> matel: it is, crossed wires, BobBall was talking about a backup plan
15:29:52 <johnthetubaguy> mate: to annoy people with RSI
15:30:03 <matel> RSI?
15:30:04 <BobBall> matel: try jo<tab> ;)
15:30:17 <johnthetubaguy> repetitive strain injury
15:30:22 <BobBall> matel: and if that doesn't work, get a proper IRC client like irssi
15:30:25 <matel> BobBall: cool, I like this tab thing.
15:30:51 <johnthetubaguy> I just found the tab thing too, nice
15:30:59 <BobBall> haha
15:30:59 <BobBall> wow
15:31:06 <matel> BobBall: teach us
15:31:07 <BobBall> you guys aren't from the IRC oldschool then
15:31:44 <matel> Okay, so after the IRC quickstart, BobBall wanted to look at the bugs.
15:32:00 <BobBall> Back in the day(tm) I even wrote an IRC client.  Because there weren't enough of those around.
15:32:19 <matel> BobBall: I am so proud of knowing you
15:32:20 <johnthetubaguy> BobBall: the bugs?
15:32:25 <BobBall> New bughttps://bugs.launchpad.net/nova/+bug/1274088
15:32:30 <BobBall> #link https://bugs.launchpad.net/nova/+bug/1274088
15:32:47 <BobBall> Interesting one because it has the same top-level fingerprint as a major gate fail
15:32:50 <BobBall> but don't get confused
15:33:04 <BobBall> the "timeout waiting for XYZ" in this case is caused by an iscsi race
15:33:18 <BobBall> Arguably in nova or in XAPI
15:33:29 <BobBall> but I've got a fix up at https://review.openstack.org/#/c/69879/ too
15:33:32 <matel> UnboundLocalError - that's a programming issue.
15:33:38 <johnthetubaguy> you are working on a fix right?
15:33:40 <BobBall> the coding is shoddy
15:33:47 <BobBall> but it's not actually an error as such
15:33:56 <BobBall> the code scans through an SR looking for a specific VDI which it assumes exists
15:34:03 <BobBall> and it doesn't, so the value is unbound
15:34:24 <BobBall> I've fixed both the shoddy coding and added a wait if the VDI isn't there quite yet
15:34:38 <BobBall> so we shouldn't get the unboundlocalerror and it should work too :)
15:34:58 <BobBall> Just waiting on the Citrix CI to confirm it's happy with the change
15:35:12 <BobBall> anyway
15:35:28 <BobBall> just wanted to highlight that it's a XenAPI specific bug which pretends to be the biggest gate blocker ATM
15:35:31 <BobBall> so don't be fooled
15:35:40 <matel> Ah, I see
15:35:44 <johnthetubaguy> very good point
15:36:04 <BobBall> That's all I wanted to say
15:36:11 <johnthetubaguy> cool, good heads up
15:36:22 <BobBall> oh - not quite
15:36:23 <johnthetubaguy> that is a bit of code that needs some… TLC
15:36:35 <johnthetubaguy> (tender loving care)
15:36:36 <BobBall> now that the gate is open again... I'd quite like some core love on my nova patches
15:36:46 <johnthetubaguy> yeah, I hear you
15:36:51 <johnthetubaguy> I would love to get those in soon too
15:37:06 <johnthetubaguy> I am just trying to write and test a new nova scheduler at the moment, so a bit distracted
15:37:07 <BobBall> https://review.openstack.org/#/c/58754/13 is the first in the series not yet merged
15:37:09 <johnthetubaguy> appologies
15:37:34 <johnthetubaguy> I will try bring that up with other RAX types, once I give it a +2
15:37:41 <matel> johnthetubaguy: BobBall's happiness is just a few clicks away.
15:37:45 <BobBall> ta
15:37:59 <BobBall> haha - I'm happy _right now_.
15:38:18 <johnthetubaguy> lol
15:38:26 <johnthetubaguy> also I could upset him...
15:38:29 <johnthetubaguy> but anyways
15:38:37 <johnthetubaguy> #topic Open Discussion
15:38:49 <johnthetubaguy> any one got anything?
15:38:55 <matel> None from me
15:39:14 <BobBall> ummm
15:39:19 <BobBall> I thought so
15:39:22 <BobBall> but I can't remember what it was
15:39:24 <BobBall> so I'll say no
15:39:34 <johnthetubaguy> OK
15:39:50 <johnthetubaguy> so meeting ending in 3….
15:39:53 <johnthetubaguy> 2….
15:39:59 <thouveng> I'm here :)
15:40:08 <thouveng> but nothing to add
15:40:12 <johnthetubaguy> 1 ...
15:40:12 <matel> hahaha
15:40:14 <johnthetubaguy> :)
15:40:19 <thouveng> I'm thinking about all your comments :)
15:40:39 <johnthetubaguy> have a good week, until next time...
15:40:43 <johnthetubaguy> #endmeeting