15:07:16 <johnthetubaguy> #startmeeting XenAPI
15:07:16 <openstack> Meeting started Wed Mar  5 15:07:16 2014 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:19 * BobBall steals the hyphon
15:07:19 <openstack> The meeting name has been set to 'xenapi'
15:07:22 <BobBall> o/
15:07:27 <BobBall> (before you ask who's here)
15:08:18 <johnthetubaguy> lol
15:08:26 <johnthetubaguy> anyways, who is here?
15:08:33 <johnthetubaguy> #topic Blueprints
15:08:40 <matel> i am listening
15:08:50 <johnthetubaguy> nothing for blueprints this week I guess?
15:09:07 <BobBall> I hope not
15:09:08 <johnthetubaguy> lets start planning for the design summit later this week
15:09:23 <BobBall> because if we have anything on BPs then they are too late :D
15:09:23 <johnthetubaguy> I delayed VIF hotpug to Juno, just hadn't been reviewed enough
15:09:39 <BobBall> Oh... I thought I saw vif hotplug go in
15:09:46 <BobBall> guess I was mistaken!
15:10:03 <johnthetubaguy> nope, that was me abandoning it, didn't get any reviews hardly, just sandy and garyk
15:10:11 <johnthetubaguy> anyways...
15:10:15 <johnthetubaguy> #topic QA
15:10:20 <johnthetubaguy> hang on
15:10:24 <johnthetubaguy> #topic CI
15:10:29 <johnthetubaguy> so, hows it going
15:10:41 <BobBall> http://ca.downloads.xensource.com/OpenStack/xenserver-ci/recent_finished.txt
15:10:46 <BobBall> http://ca.downloads.xensource.com/OpenStack/xenserver-ci/current_queue.txt
15:11:00 <BobBall> and more impressively the stats someone else made at http://www.rcbops.com/gerrit/reports/nova-cireport.html
15:11:15 <BobBall> which show that even though we were the last to the party we've got the best CI*
15:11:18 <BobBall> *subjective
15:11:53 <johnthetubaguy> hehe, sounds good
15:12:00 <BobBall> XenServer CI voted on 446 patchsets (84.15%), passing 425 (89.10%), failing 52 (10.90%) and unparsed 0 (0.00%)
15:12:07 <johnthetubaguy> its almost like the biggest production code is running XenAPI… hmm
15:12:19 <BobBall> I think that's the best overview of the CI that you can really point to
15:12:25 <johnthetubaguy> OK, thats looking really good
15:12:36 <johnthetubaguy> how are the waiting times? did we backup much?
15:12:44 <BobBall> Not backed up at all ATM
15:13:09 <BobBall> Having access to 40 nodes gives us the ability to process quite a bit more than the rush
15:13:18 <BobBall> so I don't have any concerns leading up to I-3
15:13:36 <BobBall> Not seen queue length go above 20 recently
15:15:15 <johnthetubaguy> nice
15:15:20 <johnthetubaguy> top work on this stuff
15:15:47 <johnthetubaguy> I would love to take this and start running the networking we use at rackspace, and maybe run our tests suite, add images with agents, etc, etc
15:16:19 <BobBall> We're in the process of adding tests + deploying at RAX
15:16:29 <BobBall> which will give something easy to start from with whatever setup you want
15:16:32 <johnthetubaguy> cool, sounds good
15:16:38 <BobBall> although networking will likely be very hard to change
15:16:38 <johnthetubaguy> so reducing the skip list?
15:16:46 <BobBall> Not on our radar ATM
15:17:08 <johnthetubaguy> so what do you see as the big next steps?
15:17:24 <johnthetubaguy> volume tests?
15:17:54 <BobBall> We're aiming to have it deployed in RAX by the end of the week
15:18:04 <johnthetubaguy> sweet
15:18:05 <BobBall> but after that we'll take stock and think about next steps
15:18:11 <johnthetubaguy> sounds good
15:18:16 <BobBall> full tempest does work, but race conditions make it unrealiable
15:18:26 <BobBall> at some point we'll raise bugs and hopefully track some of them down
15:18:32 <BobBall> but not sure if that'll be the priority
15:18:37 <BobBall> other drivers have extensive skip lists
15:18:41 <johnthetubaguy> right, I hear you
15:18:51 <johnthetubaguy> do we have any volume coverage right now?
15:19:03 <leifz> Thanks for all the hard work Bob!
15:19:30 <BobBall> checking
15:19:32 <matel> I am not sure right now, we can check it, but only next week.
15:19:44 <johnthetubaguy> sounds cool
15:19:44 <matel> What do you mean exactly on volume coverage?
15:20:10 <matel> johnthetubaguy: What do you mean on volume coverage?
15:20:18 <BobBall> certainly some - e.g. tempest.api.compute.v3.servers.test_attach_volume.AttachVolumeV3Test
15:20:31 <BobBall> tempest.api.compute.volumes seems to be all enabled
15:20:39 <johnthetubaguy> ah, cool
15:20:44 <matel> I guess, that's covering at least the connection part.
15:20:50 <BobBall> tempest.api.volume.admin has a bunch of tests too
15:21:45 <BobBall> https://github.com/citrix-openstack/xenapi-os-testing/blob/master/tempest_exclusion_list
15:21:49 <BobBall> that's the current exclusion list BTW
15:22:22 <johnthetubaguy> Thanks yes, I updated the wiki the other day, noticed lots of volume holes, but its not too bad
15:22:52 <johnthetubaguy> BobBall: I agree with you on not chasing that list too aggressively
15:22:57 <BobBall> The exclusion list is definitely bigger than we want it to be
15:23:02 <johnthetubaguy> agreed
15:23:29 <BobBall> My hope is that we can run a second tempest run easily (not sure how though) to run all of the excluded tests so we can have some stats on which ones are failing
15:23:55 <johnthetubaguy> ah, sounds cool
15:24:27 <johnthetubaguy> anyways, lots of good work there
15:24:34 <johnthetubaguy> massive thank you!
15:24:40 <johnthetubaguy> #topic Bugs
15:24:48 <johnthetubaguy> we were running dry on that topic
15:25:09 <johnthetubaguy> anyone got clangers we need to fix before icehouse ships?
15:25:09 <BobBall> idd
15:25:17 <johnthetubaguy> idd??
15:25:21 <BobBall> indeed
15:25:26 <johnthetubaguy> ah
15:25:37 <BobBall> I'm lazy
15:25:40 <BobBall> and down with the kids.
15:26:17 <BobBall> No clanges that I'm aware of
15:26:29 <johnthetubaguy> cool, well, its bug fixing time
15:26:48 <johnthetubaguy> and I feel much better about that, now we have CI to make sure we don't totally screw things in the process :D
15:27:07 <johnthetubaguy> #link https://bugs.launchpad.net/nova/+bugs?field.tag=xenserver
15:27:21 <leifz> johnthetubaguy: Are we creating a list of must haves or just grab one?
15:27:37 <johnthetubaguy> leifz please do look for must haves
15:27:49 <johnthetubaguy> right now, we are saying there is nothing that is super blocking
15:27:57 <johnthetubaguy> target the ones we really want for icehouse-rc1
15:28:00 <BobBall> I want to drop some of those wishlist too
15:28:14 <BobBall> Many of them aren't bugs bug feature requests (hence wishlist, I know)
15:28:25 <BobBall> but let's just be realistic and say that we're not planning on doing them any time soon
15:28:25 <johnthetubaguy> BobBall: I hear you, I think the old ones we should just kill them
15:28:32 <johnthetubaguy> BobBall agreed
15:28:56 <BobBall> Shall I just go through and close some? ;)
15:29:26 <johnthetubaguy> well, we should probably double check, some of those might be quite good introductory bugs
15:29:40 <johnthetubaguy> https://bugs.launchpad.net/nova/+bug/1024944
15:29:44 <johnthetubaguy> lets kill it
15:30:30 <BobBall> https://bugs.launchpad.net/nova/+bug/1026552 too
15:30:59 <johnthetubaguy> yeah, probably "Won't fix" for all the shared storage ones
15:31:13 <johnthetubaguy> lets not pretend
15:31:26 <johnthetubaguy> cool, any more?
15:31:39 <BobBall> certainly yes
15:31:47 <BobBall> but not to be found during this meeting :)
15:32:27 <johnthetubaguy> indeed
15:32:50 <johnthetubaguy> I just turned one away from being inprogress when it wasn't any more
15:32:54 <BobBall> Is https://bugs.launchpad.net/nova/+bug/1169769 the behaviour of other hypervisors?
15:32:57 <johnthetubaguy> anyways, please take a bug
15:33:33 <johnthetubaguy> BobBall: yeah, its a funny one, I would need to check
15:34:02 <johnthetubaguy> BobBall: if the user turns a VM off, we want to respect that, and that request fights with that intention
15:34:19 <johnthetubaguy> anyways, lets move on I think...
15:34:32 <johnthetubaguy> we can do this in openstack-nova at some other point
15:34:45 <BobBall> indeed
15:34:47 <johnthetubaguy> #topic Open Discussion
15:34:57 <johnthetubaguy> any more things people want to discuss?
15:35:31 <johnthetubaguy> just a note that this will stay in UTC, if you are dialling in from the US, its a different time next week
15:35:59 <BobBall> https://bugs.launchpad.net/nova/+bug/1215383 should be low / wishlist ?
15:36:01 <johnthetubaguy> #action please check your UTC watches next week
15:36:52 <johnthetubaguy> BobBall: hmm, not sure, its kinda buggy, so would love to kill it
15:37:15 <BobBall> I'm not aware of any bugs - other than "it doesn't work with LVM"?
15:37:51 <johnthetubaguy> BobBall: or it feels like it could be a source of bugs, I can't remember now, your work on VDI-in-use errors may remove this code from my list of dodgy code
15:37:57 <BobBall> so I'd say it's "mostly cosmetic" :)
15:38:05 <johnthetubaguy> yeah, low
15:38:33 <johnthetubaguy> cool, any more for any more?
15:38:43 <matel> no thanks.
15:38:48 <BobBall> not from me.
15:39:01 <leifz> nope
15:39:39 <johnthetubaguy> sweet
15:39:46 <johnthetubaguy> have a good week all
15:39:52 <johnthetubaguy> thanks for all the good work
15:39:57 <matel> sweet thanks.
15:40:00 <johnthetubaguy> bug fixing time, yeah!
15:40:12 * johnthetubaguy does imaginary big kick in the air
15:40:16 <johnthetubaguy> #endmeeting