15:01:47 <johnthetubaguy> #startmeeting xenapi
15:01:48 <openstack> Meeting started Wed Oct  8 15:01:47 2014 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:52 <openstack> The meeting name has been set to 'xenapi'
15:02:07 <johnthetubaguy> #topic XenServer CI
15:02:16 <matel> Hello
15:02:26 <johnthetubaguy> matel: hello, sorry distracted my IRC
15:02:31 <matel> No, that's ok.
15:02:35 <johnthetubaguy> s/my/by/
15:02:41 <johnthetubaguy> anyways, how the CI doing these days
15:02:50 <matel> GImme some secs, let me to a query.
15:02:56 <johnthetubaguy> np
15:04:08 <matel> Bob added some new query parameters to the CI scripts.
15:05:16 <matel> Failures
15:05:16 <matel> -------------------
15:05:16 <matel> 22 No tempest failures detected
15:05:16 <matel> 20 More than 10 failures
15:05:16 <matel> 13 Fewer than 2 duplicates
15:05:17 <johnthetubaguy> do we still have the swift thing?
15:05:17 <matel> 2 tempest.api.compute.admin.test_floating_ips_bulk.FloatingIPsBulkAdminTest.test_create_list_delete_floating_ips_bulk
15:05:22 <matel> 2 tempest.api.compute.admin.test_hypervisor.HypervisorAdminTest.test_get_hypervisor_show_servers
15:05:25 <matel> 2 tempest.api.compute.admin.test_hosts_negative.HostsAdminNegativeTest.test_show_host_detail_with_non_admin_user
15:05:28 <matel> 2 tempest.api.compute.admin.test_hosts_negative.HostsAdminNegativeTest.test_show_host_detail_with_nonexistent_hostname
15:05:31 <matel> 2 tempest.api.compute.admin.test_hypervisor.HypervisorAdminTest.test_search_hypervisor
15:05:33 <matel> 2 tempest.api.compute.admin.test_hosts.HostsAdminTest.test_show_host_detail
15:05:35 <matel> 2 tempest.api.compute.admin.test_hypervisor.HypervisorAdminTest.test_get_hypervisor_uptime
15:05:37 <matel> 2 tempest.api.compute.admin.test_hypervisor.HypervisorAdminTest.test_get_hypervisor_show_details
15:05:42 <matel> This is what the query tells me.
15:05:55 <matel> which testcase was the swift?
15:06:00 <johnthetubaguy> hmm, interesting
15:06:16 <johnthetubaguy> I mean the status report sent to a swift container
15:06:23 <matel> osci-view failures --recent 72
15:06:36 <matel> Ah, where is that, let me check the wiki.
15:06:50 <johnthetubaguy> oh, good point, the wiki should tell that
15:07:02 <matel> http://f0ab4dc4366795c303a0-8fd069087bab3f263c7f9ddd524fce42.r22.cf1.rackcdn.com/ci_status/results.html
15:07:12 <matel> https://wiki.openstack.org/wiki/XenServer/XenServer_CI/AdminTips
15:07:49 <matel> I thought you are referencing to a test failure related to swift.
15:07:57 <johnthetubaguy> #link http://f0ab4dc4366795c303a0-8fd069087bab3f263c7f9ddd524fce42.r22.cf1.rackcdn.com/ci_status/all_failures.txt
15:08:01 <johnthetubaguy> yeah, sorry, thats the one I mean
15:08:15 <matel> Ok, sure thing. I'm looking at that as well.
15:08:47 <matel> tempest.api.compute.servers.test_server_actions.ServerActionsTest.test_reboot_suspended_server_hard seems to be the big one
15:09:00 <matel> and tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTest
15:09:09 <matel> Do they look familiar?
15:09:31 <johnthetubaguy> kinda
15:09:36 <matel> Let's try to find a console output for tempest.api.compute.servers.test_server_actions.ServerActionsTest.test_reboot_suspended_server_hard
15:09:40 <johnthetubaguy> I mean I think they might be general gate issues
15:10:12 <matel> Would be nice to be able to get to the console logs.
15:10:29 <matel> johnthetubaguy: can you recall how to do that?
15:10:45 <johnthetubaguy> should be in the results folder somewhere
15:11:20 <johnthetubaguy> which failed test had that in, I guess is the question
15:12:04 <matel> yep
15:12:18 <matel> are you logged in, johnthetubaguy?
15:12:30 <johnthetubaguy> logged into where?
15:12:37 <johnthetubaguy> I am looking at the results in swift basically
15:12:46 <matel> logged in to osci
15:12:58 <johnthetubaguy> no, not logged into there
15:13:51 <matel> Okay, I guess that's something that would be nice, to be able to associate job ids to the individual test failures.
15:14:19 <johnthetubaguy> well, we have the tempest logs
15:14:24 <johnthetubaguy> and all the screen logs I think
15:14:43 <johnthetubaguy> should have the info we need
15:15:16 <matel> I'm looking for the console log
15:16:03 <johnthetubaguy> what you looking for from there?
15:16:09 <johnthetubaguy> the test running stuff?
15:16:20 <johnthetubaguy> tempest.txt.gz should be fine
15:16:53 <matel> yes, where I can find those names.
15:17:05 <matel> wuff, that's a huge blob
15:17:26 <johnthetubaguy> http://dd6b71949550285df7dc-dda4e480e005aaa13ec303551d2d8155.r49.cf1.rackcdn.com/72/121872/5/27088/testr_results.html.gz
15:17:32 <johnthetubaguy> that one is quite good
15:17:42 <matel> Let me look at that
15:18:05 <matel> But I think we would definitely find a way to do some triage -ing.
15:18:46 <johnthetubaguy> well we have the top fails, I guess we just need to find instances of that fail
15:19:10 <matel> Yes, but tha should be done by computers .
15:19:33 <matel> Let me add this to the wiki.
15:19:40 <johnthetubaguy> cool
15:20:09 <johnthetubaguy> yeah, the last three failures at the bottom of here would be good:
15:20:15 <johnthetubaguy> http://f0ab4dc4366795c303a0-8fd069087bab3f263c7f9ddd524fce42.r22.cf1.rackcdn.com/ci_status/all_failures.txt
15:22:06 <matel> Okay, I guess we need to find a way to do that, I see no point of doing it now manually.
15:22:44 <johnthetubaguy> sure
15:22:47 <johnthetubaguy> makes sense
15:22:50 <matel> could you create an action item for me: lookup logs related to tempest.api.compute.servers.test_server_actions.ServerActionsTest.test_reboot_suspended_server_hard and tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTest
15:23:06 <matel> you are the IRC wizard.
15:23:36 <matel> Maybe we already have this functionality, it just needs to be documented.
15:23:37 <johnthetubaguy> #action matel lookup logs related to tempest.api.compute.servers.test_server_actions.ServerActionsTest.test_reboot_suspended_server_ha
15:23:45 <johnthetubaguy> yeah
15:23:48 <johnthetubaguy> got output to swift
15:23:58 <matel> And I also need to check wether these failures could be caused by code changes on that area?
15:24:12 <johnthetubaguy> well, its quite possible its affecting the general gate too
15:24:30 <johnthetubaguy> its the last 22 failures are all the same patch, thats a good hit :)
15:24:34 <johnthetubaguy> hint^
15:24:46 <matel> aye
15:24:46 <johnthetubaguy> but yeah, we need more data
15:24:51 <johnthetubaguy> any more on the CI?
15:24:59 <matel> Will talk to Bob regarding to that.
15:25:11 <johnthetubaguy> OKay
15:25:11 <matel> Well, have you seen that project-config has been split?
15:25:17 <johnthetubaguy> #topic Open Discussion
15:25:24 <matel> It's not really relevant, anyhow.
15:25:27 <johnthetubaguy> not really got much to say
15:25:38 <johnthetubaguy> expect its summit planning time, get your ideas on the wiki page
15:25:50 <johnthetubaguy> I don't plan on having a XenAPI session though
15:25:56 <matel> I see.
15:26:32 <johnthetubaguy> it would be good to get some more refactoring work complete, now we are open for kilo
15:26:46 <matel> I won't be there, I did not contribute anything during the last period .
15:27:04 <matel> AH, Bob is here
15:27:05 <johnthetubaguy> any more for any more?
15:27:10 <johnthetubaguy> ah, lol
15:27:12 <matel> Let's ask him about the CI quickly
15:27:17 <BobBallAway> go for it
15:27:20 <johnthetubaguy> BobBallAway: any more for any more?
15:27:37 <matel> BobBallAway: is there a way to query the job ids that have a particular test failure?
15:27:40 <BobBallAway> well asking me about the CI?
15:27:41 <BobBallAway> yes
15:27:48 <BobBallAway> osci-view failures --with-fail "text"
15:27:50 <matel> teach us, please.
15:27:56 <matel> Okay, let me try that.
15:27:58 <BobBallAway> or --with-fail "" if you want to list the jobs with no failures
15:28:35 <matel> Ah, that's an empty list
15:28:42 <matel> osci-view failures --with-fail "tempest.api.compute.servers.test_server_actions.ServerActionsTest.test_reboot_suspended_server_hard"
15:29:05 <BobBallAway> I usually just use a much smaller search string
15:29:11 <matel> We want to look at the logs of the top offenders.
15:29:19 <BobBallAway> and if it's empty make sure you're also using --recent if you were for the original list you're looking at
15:29:33 <matel> osci-view failures --with-fail "test_reboot_suspended_server_hard"
15:29:49 <matel> Okay,anyhow, take it offline.
15:29:56 <BobBallAway> indeed
15:29:58 <johnthetubaguy> cools
15:30:05 <johnthetubaguy> I guess we are done for today?
15:30:15 <matel> yes, we are.
15:30:31 <johnthetubaguy> matel: BobBallAway: thanks both
15:30:34 <johnthetubaguy> #endmeeting