21:00:03 <flaper87> #startmeeting Zaqar
21:00:04 <openstack> Meeting started Mon Sep  1 21:00:03 2014 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:07 <openstack> The meeting name has been set to 'zaqar'
21:00:09 <flaper87> #topic Roll Call
21:00:15 * flaper87 o/
21:00:37 * vkmc o/
21:00:41 <flaper87> vkmc: flwang ?
21:01:42 <flaper87> kgriffs: roll call
21:01:44 <flaper87> :D
21:01:50 <kgriffs> o/
21:01:56 <flaper87> good boy
21:02:05 <flaper87> #topic Actions from last meeting
21:02:11 <flaper87> #link http://eavesdrop.openstack.org/meetings/zaqar/2014/zaqar.2014-08-25-15.10.html
21:02:25 <flaper87> kgriffs to land redis patch
21:02:29 <flaper87> I believe that's done
21:02:31 <flaper87> right ?
21:02:41 <kgriffs> pretty much
21:02:48 <vkmc> the ascii thumbs up said so
21:02:49 <flaper87> #info Base redis patch has been approved
21:03:08 <kgriffs> I am in the middle of working on expiring claims and messages
21:03:10 <flaper87> kgriffs: anything critical left before we can mark that work as done?
21:03:18 <flaper87> kgriffs: roger
21:03:22 <kgriffs> ran into a snag with trying to keep the stats counters up to date
21:03:25 <kgriffs> so, I have to fix that
21:03:32 <flaper87> kk
21:03:39 <flaper87> kgriffs to publish rough benchmark numbers, more later with redis numbers
21:03:46 <kgriffs> and then also add a script that can be called from cron periodically to trigger the driver's GC method
21:04:02 <flaper87> #info Bench numbers were sent to the mailinig list. No feedback for now
21:04:11 <kgriffs> otherwise, there are a few lower-priority work items on the blueprint we could slip if needed
21:04:31 <flaper87> kgriffs: lets split them
21:04:41 <kgriffs> flaper87: actually, did get some feedback from Mr. Pipes on that
21:04:54 <flaper87> kgriffs: yeah but he asked to test with keep-alive
21:04:58 <kgriffs> he was wanting to see the result of turning off keepalive
21:05:00 <kgriffs> ywah
21:05:02 <kgriffs> anyway
21:05:02 <flaper87> he didn't mention anything about the numbers
21:05:04 <flaper87> right ?
21:05:10 <kgriffs> not really iirc
21:05:32 <flaper87> I should've said: No *useful* feedback :P
21:05:51 <flaper87> anyway, I think we should keep sending those emails
21:05:56 <flaper87> lets move on
21:06:12 <kgriffs> k. I'd like to do a "Round 2" sometime this week once the redis driver is squared away
21:06:12 <flaper87> The agenda is pretty small this week too
21:06:22 <flaper87> kgriffs: +1
21:06:35 <flaper87> #action kgriffs to re-run benchmarks using the redis driver
21:07:09 <flaper87> #topic What checks should go to the API/Storage layer?
21:07:34 <flaper87> so, there are 2 patches pending for review that introduce some checks in the storage layer
21:07:46 <flaper87> 1 is from wpf and the other one is mine
21:08:20 <flaper87> regardless on whether those patches are correct, I think we should have some *blendable* rules w.r.t where API - I mean, Zaqar's  API - checks should go
21:08:23 <flaper87> for example:
21:08:38 <flaper87> #link https://review.openstack.org/#/c/117706/
21:08:46 <vkmc> flaper87, yours has been merged IIRC
21:09:05 <flaper87> #link https://review.openstack.org/#/c/117706/3/zaqar/queues/storage/mongodb/pools.py,cm
21:09:09 <flaper87> vkmc: w0000t
21:09:12 <flaper87> :P
21:09:24 <vkmc> flaper87, it's not in the review queue... so :o
21:09:49 <flaper87> In order to enforce this, wpf got an instance of `flavors` collection and is doing queries right from the storage driver
21:10:05 <flaper87> there's a way to do this from the wsgi transport
21:10:17 <flaper87> there are several questions we should ask ourselves
21:10:32 <flaper87> but the one I want us to answer now is where does that check belong
21:10:51 <flaper87> Regardless on whether it's more performant to do it in the storage layer or not
21:11:10 <flaper87> The reason I'm putting performance aside now is because I'd like the code base to be consistent
21:11:27 <flaper87> and we should strive to do that. There will be cases where that won't be possible
21:11:49 <flaper87> Thoughts so far?
21:12:12 <flaper87> The other thing to think about is that storage drivers are multi-version
21:12:20 <kgriffs> by "that check" do you yours or wpf's?
21:12:26 <flaper87> that is, there's no 1:1 mapping between the storage driver and the transport
21:12:37 <flaper87> I meant wpf's
21:13:02 <flaper87> kgriffs: https://review.openstack.org/#/c/117706/3/zaqar/queues/storage/mongodb/pools.py,cm L104
21:14:38 <flaper87> knock knock?
21:15:03 <kgriffs> looking
21:15:57 <flaper87> I think one sane thing to do is to keep API specific checks within the API
21:16:18 <flaper87> TBH, I'm really not sure what the right thing to do there is
21:16:26 <kgriffs> hmmm
21:16:28 <flaper87> so, we should probably take more time and put more thoughts on it
21:17:06 <kgriffs> I've been thinking about this more generally lately. Like, we don't do a lot of validation in our storage layer at the moment, but maybe we should
21:17:31 <vkmc> hmm, if IIRC in most reviews we always tried to delegate control to transport
21:18:01 <vkmc> letting storage to worry about storage only
21:18:12 <kgriffs> we do perform queue existence checks in the storage drivers
21:18:25 <flaper87> one thing that has bitten us is mixing controllers
21:18:38 <kgriffs> I think the storage driver ought to check anything that could cause it's data model to break
21:18:56 <vkmc> I agree with that ^
21:18:56 <flaper87> so, we should probably decided if we're going to give more value to performance or consistency here
21:19:07 <flaper87> kgriffs: ++
21:19:26 <vkmc> in our case performance is crucial
21:19:32 <vkmc> how much consistency would be affected?
21:19:51 <flaper87> vkmc: AFAICS, lots of it (with regard to API checks and stuff)
21:20:02 <flwang> o/
21:20:04 <flaper87> I mean, if we have the right rules in place, we'll still be consistent
21:20:12 <flwang> please blame the bus :)
21:20:16 <flaper87> for example: storage layer checks its data model is not broken
21:20:33 <flaper87> that's a good way to put it and a good way to choose where things should go
21:20:35 <flaper87> flwang: >.>
21:20:42 <flaper87> stupid bus
21:20:51 <vkmc> yeah I think it's that is the best flaper87
21:21:44 <flaper87> #agreed Checks should stay in the data plane they belong too. Storage drivers must enforce their data model stays consistent
21:21:58 <flaper87> Does that sound right?
21:22:04 <vkmc> it does to me
21:22:09 <flaper87> kgriffs: flwang ?
21:22:40 <kgriffs> sounds right 2me
21:22:47 <flaper87> ok
21:22:53 <flwang> +1, storage driver should focus on the interaction with db
21:22:56 <flaper87> Also, I think this should go into our dev docs
21:22:59 <flaper87> vkmc: ?
21:23:01 <flaper87> :D
21:23:03 <flwang> instead of involving too much logic
21:23:32 <flaper87> #action vkmc to add checks enforcement rule to our development docs
21:23:34 <flaper87> :D
21:23:57 <vkmc> :) sure thing
21:24:05 <flaper87> ok, lets move on
21:24:08 <flaper87> #topic Summit Sessions Proposals
21:24:23 <flaper87> You probably already saw this on the mailing list
21:24:26 <flaper87> I've created https://etherpad.openstack.org/p/kilo-zaqar-summit-topics
21:24:29 <flaper87> #link https://etherpad.openstack.org/p/kilo-zaqar-summit-topics
21:24:49 <flaper87> lets start adding proposals there so we can start getting feedback from the team
21:25:12 <flaper87> Lets add things that we're definitely going to get done
21:25:31 <flaper87> WE should use the summit to discuss things that require a f2f discussion
21:25:40 <flaper87> and are essential for Zaqar
21:25:49 <kgriffs> kk
21:25:51 <vkmc> get messages by id removal is one, for sure
21:26:02 <kgriffs> lol, yeah
21:26:08 <flaper87> vkmc: that could fall into one of our API sessions
21:26:16 <vkmc> kewl
21:26:21 <flaper87> which leads me to the next topic, if there's nothing else to add here
21:26:41 <flaper87> #topic Should we start discussiong API v2?
21:26:43 <flwang> I"m wondering is there an operation session for this summit
21:26:53 <flaper87> #undo
21:26:54 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x30bb810>
21:27:11 <flaper87> flwang: we could have one if there's something relevant to discuss
21:27:16 <flaper87> there's an OPs session
21:27:24 <flaper87> actually, I'm not sure if that talk got accepted
21:27:28 <flaper87> kgriffs: do you know if Oz
21:27:34 <flaper87> kgriffs: do you know if Oz's talk got accepted ?
21:28:01 <kgriffs> i hadn't heard. I can find out.
21:28:06 <flaper87> kk
21:28:08 <flwang> kgriffs: thanks
21:28:28 <kgriffs> wrt v2
21:28:30 <flaper87> We could probably have an informal devops discussion at our pod
21:28:33 <flwang> Catalyst IT will enable Zaqar asap
21:28:33 <flaper87> #topic Should we start discussiong API v2?
21:28:39 <flaper87> flwang: AWESOMEEEEEEEEEEEEEEEEEE
21:28:43 <flwang> so we really need to get some ops experience
21:28:53 <kgriffs> I don't want to talk about it unless we feel like we have the bandwidth to get it done during kilo
21:29:06 <flaper87> kgriffs: +1
21:29:06 <kgriffs> I think we could have a goal to have a "community preview" of v2 for the kilo summit
21:29:31 <flaper87> If we want to remove message-by-id, we'll have to discuss v2
21:29:35 <flwang> may I know what's the killer feature to distinguish the v1.1 and v2? :)
21:29:43 <kgriffs> and then take the community feedback and finalize v2 in the next cycle
21:30:04 <flaper87> kgriffs: totally agreed
21:30:17 <flaper87> I'd like to give 1 full cycle without API changes to gather enough feedback
21:31:03 <flaper87> vkmc: flwang ?
21:31:17 <vkmc> +1 to that
21:31:31 <flwang> +1, stable is always good for prod env :)
21:31:47 <flaper87> ok
21:32:11 <flaper87> #agreed lets not start working on new APIs. Lets give the community at least 1 full cycle to digest v1.1 before we start talking about v2
21:32:26 <flaper87> anything else on this topic?
21:32:57 <flaper87> I'll take that as a no
21:33:04 <flaper87> #topic Graduation status
21:33:07 <flaper87> #link https://launchpad.net/zaqar/+milestone/juno-3
21:33:17 <flaper87> so, the base patch for readis just landed
21:33:35 <flaper87> kgriffs: you said there are a couple of other patches that are still critical for this blueprint to be considered implemented
21:33:45 <kgriffs> yeah
21:33:46 <flaper87> Do you think we can get them done this week?
21:33:58 <flaper87> Before FF
21:33:58 <kgriffs> yes, I will have them by tomorrow or wed
21:34:02 <flaper87> awesome
21:34:09 <flaper87> otherwise we'll have to ask for a FFE
21:34:09 <kgriffs> just to recap
21:34:12 <kgriffs> the patches are
21:34:17 * flaper87 STFU
21:34:28 <kgriffs> 1. Garbage collection / expiration of claims, messages
21:34:48 <kgriffs> 2. Remove stats counters and just calculate them dynamically
21:35:04 <kgriffs> that second one has to be done before GC...long story
21:35:23 <kgriffs> then there are a few other work items on the bp that are "bonus" if we get to them
21:35:24 * flaper87 was going to ask if #2 is essential. It looks like it is
21:35:50 <flaper87> ok
21:36:22 <flaper87> #info Essential things missing in the redis patch are: 1. Garbage collection / expiration of claims, messages, 2. Remove stats counters and just calculate them dynamically
21:37:10 <flaper87> vkmc: updates on this one:
21:37:13 <flaper87> #link https://blueprints.launchpad.net/zaqar/+spec/api-v1.1-user-guide
21:37:24 <flaper87> I know there's a py33 issue on the configs one
21:37:41 * kgriffs has to leave in a minute
21:38:03 <flaper87> kgriffs: ok, thanks for the hard work on the redis patch
21:38:14 <flaper87> great work there (both of you)
21:38:16 <kgriffs> my pleasure
21:38:17 <vkmc> thanks kgriffs :)
21:38:49 <flaper87> kgriffs: also, remember the TC meeting tomorrow
21:38:56 <flaper87> kgriffs: 20 UTC
21:38:59 <kgriffs> kk
21:39:03 <flaper87> vkmc: so, updates ?
21:39:04 <vkmc> flaper87, that bp is targeted for K and will be started after we get some feedback from the community
21:39:22 <flaper87> targetted for k ?
21:39:30 <vkmc> flaper87, which is being done right now is https://blueprints.launchpad.net/zaqar/+spec/document-config-options
21:39:41 <flaper87> vkmc: https://blueprints.launchpad.net/zaqar/+spec/api-v1.1-user-guide is on Juno
21:39:46 <flaper87> Should I move it ?
21:40:45 <flaper87> vkmc: ^
21:40:45 <vkmc> for what I discussed with kgriffs|afk... it should be moved it
21:40:52 <vkmc> s/it/
21:41:35 <flaper87> oh ok, sorry. I must have missed that discussion
21:41:43 <vkmc> no problem
21:42:01 <flaper87> I moved it to k-1
21:42:14 <vkmc> the user guide for API v1 is in good shape
21:42:36 <flaper87> we're in a better shape now
21:42:38 <flaper87> awesome
21:43:01 <vkmc> Catherine did a great job and we updated it to fit our current goals :)
21:43:17 <flaper87> awesome, I'm very glad we did this back then
21:43:20 <flaper87> sweet
21:43:25 <flaper87> vkmc: thanks for leading the docs effort!
21:43:31 <vkmc> flaper87, no problem
21:43:42 <flaper87> anything else I/we should know w.r.t the Juno/Graduation status?
21:44:28 <flaper87> #topic Graduation Meeting
21:44:39 * flwang has to leave for a minute
21:44:43 * vkmc goes through graduation etherpad
21:45:06 <flaper87> Tomorrow at 20 UTC Zaqar will be reviewed for graduation
21:45:11 <flaper87> that's the first of 2 meetings
21:45:26 <flaper87> During the first meeting the graduation requirements are going to be revisited
21:45:35 <flaper87> It'd be nice if we all attend the meeting
21:46:15 <vkmc> count with my presence :)
21:46:30 <flaper87> awesome!
21:46:37 <flaper87> I'll be there too
21:46:42 <flaper87> In case some questions arise
21:47:06 <flaper87> I think we're not in bad shape. Some things could be better but I'm possitive about our status
21:47:06 <vkmc> thanks
21:47:27 <flaper87> Now, if there's nothing else to add here, I'll move on to open discussions
21:47:41 <flaper87> #topic Open Discussions
21:47:58 * flaper87 likes gummy bears
21:48:05 <vkmc> haha :)
21:48:06 * flaper87 is wearing new glasses
21:48:18 <vkmc> reading glasses?
21:48:32 <flaper87> yup
21:48:43 <flaper87> well, they used to be just for reading but things got worse
21:48:46 <flaper87> :/
21:48:50 <vkmc> boo, that's a bummer
21:49:29 <flaper87> yeah
21:49:31 <flaper87> :/
21:49:41 <flaper87> ok, I don't have any other personal and embarrasing thing to share
21:49:43 <flaper87> anyone ?
21:49:57 <vkmc> I'm just thinking if there is something missing for graduation
21:49:58 <flaper87> Who's wearing a superman underware today?
21:50:10 <vkmc> what is the status with Heat?
21:50:40 <flaper87> the status with Heat - and every other integrated project - is that they want us but they won't use us until we graduate
21:51:10 <vkmc> ok, but they want us... which is good
21:51:33 <flaper87> yeah, I believe zaneb updated Heat usescases with some of his ideas
21:52:15 <vkmc> that's cool
21:52:51 <vkmc> well, I think there is nothing else to bring up about our status
21:53:13 <flaper87> ok, lets talk about serious stuff
21:53:21 <flaper87> you should all watch True Detective
21:53:23 <flaper87> it's coool
21:53:29 <vkmc> I saw it
21:53:32 <flaper87> not as great as Breaking Bad but it's nice
21:53:38 <flaper87> vkmc: do you like it ?
21:53:41 <vkmc> and now I don't know what to watch :(
21:53:44 <vkmc> oh I loved it
21:53:53 <flaper87> DON'T SPOILE IT
21:54:00 <vkmc> I won't haha
21:54:04 <flaper87> I still have some episodes to watch
21:54:10 <vkmc> oh do you? DO YOU?
21:54:12 * flaper87 knows how to play the intro theme
21:54:28 <flaper87> ... in guitar
21:54:31 <vkmc> which episode is next?
21:54:46 <flaper87> I think 7th
21:55:04 <vkmc> oh in that one...!
21:55:06 <vkmc> :p
21:55:10 <flaper87> youuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuu
21:55:14 <flaper87> don't youuu dare
21:55:25 <vkmc> hahaha nah I won't
21:55:31 <vkmc> I think I'll start watching The Wire
21:55:31 <flaper87> 2 more great but different TV series
21:55:36 <vkmc> I heard great comments about it
21:55:37 <flaper87> Undatable: SOOOOOOOOOOOOOO FUN
21:55:51 <flaper87> Mom: Not as fun as undatable but it's nice
21:56:03 * flaper87 writes The Wire down
21:56:21 <vkmc> 9.4 in IMDB ;)
21:56:29 <flaper87> that must be good
21:56:36 <flaper87> or IMDB just sucks
21:56:36 * vkmc looks for Undatable and Mom
21:56:38 <flaper87> :P
21:56:50 <vkmc> true detective has 9.3
21:56:53 <vkmc> you tell me
21:56:54 <vkmc> hahaha
21:56:55 <flaper87> http://www.imdb.com/title/tt2788780/
21:57:20 <vkmc> sounds like fun
21:57:40 <flaper87> vkmc: https://www.youtube.com/watch?v=SuAGmC5g2_o
21:57:49 <vkmc> is it as How I met your mother?
21:57:57 <vkmc> (please say no)
21:58:09 <flaper87> nope
21:58:23 * vkmc sighs
21:58:27 <flaper87> at least I don't think it is
21:58:29 <flaper87> :P
21:58:34 <vkmc> do you like How I met your mother?
21:58:40 <flaper87> not really
21:58:55 * vkmc has found a friend in flaper87
21:59:23 <vkmc> (sorry to all HIMYM fans)
21:59:34 <flaper87> :D :D :D :D
21:59:37 <flaper87> screw them
21:59:39 * flaper87 hides
21:59:42 <vkmc> lol
21:59:42 <flaper87> ok, time's up
21:59:45 <vkmc> meeting is over!
21:59:47 <flaper87> best open discussion EVER!
21:59:51 <flaper87> Thanks everyone
21:59:53 <vkmc> lol yeah
21:59:54 <flaper87> #endmeeting