15:00:04 <flaper87> #startmeeting Zaqar
15:00:05 <openstack> Meeting started Mon Sep  8 15:00:04 2014 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <openstack> The meeting name has been set to 'zaqar'
15:00:11 <flaper87> #topic Roll Call
15:00:14 <kgriffs> o/
15:00:20 <flaper87> vkmc: malini flwang ?
15:00:25 <vkmc> o/
15:00:48 <flaper87> I think malini is not around
15:01:01 <flaper87> #topic Review Items from last week
15:01:07 <flaper87> #link https://wiki.openstack.org/wiki/Meetings/Zaqar#Agenda
15:01:12 <flaper87> that's the agenda for today
15:01:18 <flaper87> #link http://eavesdrop.openstack.org/meetings/zaqar/2014/zaqar.2014-09-01-21.00.html
15:01:35 <flaper87> kgriffs to re-run benchmarks using the redis driver
15:02:03 <kgriffs> I started working on that last week. goal is to finish today - publish something at least, in advance of the next TC mtg
15:02:16 <flaper87> kgriffs: great news, thanks!
15:02:39 <flaper87> #info kgriffs is working on re-running benchmarks on redis. Hopefully ready before the TC meeting tomorrow
15:02:42 <flaper87> vkmc to add checks enforcement rule to our development docs
15:03:33 <flaper87> vkmc: ?
15:03:57 <vkmc> flaper87, what do you mean by checks enforcement rule?
15:04:03 <vkmc> sorry I'm lost
15:04:15 <flaper87> dunno, that's an action item from last week
15:04:17 <flaper87> :D
15:04:24 * flaper87 tries to figure out what that is
15:04:30 <vkmc> let me check the logs
15:04:35 <flaper87> ahhh
15:04:48 <flaper87> so, we have to document when an API check has to go to the storage layer or the API layer
15:05:07 <flaper87> vkmc: ^
15:05:27 <flaper87> I can take that
15:05:46 <flaper87> #action To document where API checks should go (API or Storage layer)
15:05:46 <vkmc> flaper87, oh it makes sense
15:05:53 <vkmc> I can do that
15:05:57 <flaper87> #undo
15:05:58 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x326e3d0>
15:06:01 <flaper87> #action vkmc To document where API checks should go (API or Storage layer)
15:06:10 <flaper87> ok, moving on
15:06:18 <flaper87> #topic Early adoption of dox (flaper87)
15:06:31 <flaper87> not sure if you guys read the email thread about dox
15:06:40 <flaper87> I started hacking on it and it seems like a neat idea
15:06:45 <flaper87> #link https://github.com/stackforge/dox
15:06:52 <flaper87> #link https://review.openstack.org/#/c/119740/
15:07:06 <flaper87> so, I've proposed a review that suggest becoming early adopters/users of this tool
15:07:13 <flaper87> dox is basically tox on top of docker
15:07:37 <flaper87> ideally, developers shouldn't need to install redis and whatnot to test Zaqar, instead they'd just need docker and dox
15:07:38 <kgriffs> good stuff
15:07:53 <flaper87> with that, no one will have an excuse not to run all tests locally
15:07:55 <flaper87> :D
15:08:11 <vkmc> neat!
15:08:12 <kgriffs> flaper87: how do you see this in relation to devstack?
15:08:23 <flaper87> I hacked on dox over the weekend and I worte the dox.yml file for zaqar
15:08:41 <flaper87> kgriffs: I think we'll endup having a docker image with devstack in it
15:08:54 <flaper87> the ultimate goal is to have images like `infra/zaqar/trusty`
15:09:01 <kgriffs> I like the idea of deploying a "production cluster of dockers" instead of a big gnarly shell script
15:09:03 <flaper87> so that developers don't even need the `prep` section
15:09:16 <flaper87> kgriffs: right
15:09:23 <kgriffs> let's us realize the isolation benefits wrt dependencies that a SOA is *supposed* to provide
15:09:31 <flaper87> +1
15:09:33 <kgriffs> </two-cents>
15:09:39 <flaper87> We'll see how it evolves
15:09:44 <kgriffs> kk
15:09:59 <flaper87> So, If you think it makes sense to adopt it, +2 otherwise, I'll STFU and ktanksbai
15:10:17 <flaper87> any other question on dox?
15:10:40 <flaper87> i'll take that as a no
15:10:41 <vkmc> not from me
15:10:45 <flaper87> #topic Goals for the next couple of weeks (flaper87)
15:10:56 <flaper87> Soooo, j-3 was cut last week. w0000000000000000t
15:11:07 <flaper87> we've rc1 ahead but with reaaaaallly few things in it
15:11:18 <flaper87> I'd like us to focus on getting the client back in shape
15:11:27 <kgriffs> +1
15:11:39 <flaper87> it's quite behind Zaqar and it'd be nice if we can get to the release with the client fulling supporting v1.1
15:11:44 <kgriffs> that should help us also smoke test j-3 and catch bugs
15:11:50 <flaper87> +1
15:12:04 <flaper87> ok, I'll start by adding the v1.1 spec to the client
15:12:14 <flaper87> and we can work on the missing features on top of that
15:12:17 <kgriffs> I am finishing up the last Redis patch I wanted to land
15:12:19 <vkmc> we still have to finish the support for v1.0 in the client
15:12:24 <kgriffs> important performance patch
15:12:31 <flaper87> #action flaper87 to start adding v1.1 to the client
15:12:33 <flaper87> vkmc: wiat, what?
15:12:36 <flaper87> what's missing?
15:12:44 <flaper87> I thought we had full support for it
15:12:44 <vkmc> shouldn't it make sense to get feedback from the community about v1.1 and then add the support for v1.1?
15:12:56 <kgriffs> flaper87: I think vkmc is referring to CLI commands
15:12:57 <flaper87> let me rephrase, what's missing that was not added in Juno?
15:13:02 <flaper87> aaaaaaah ok ok
15:13:04 <vkmc> oh sorry
15:13:04 <vkmc> yes
15:13:09 <flaper87> well, that makes sense
15:13:11 <flaper87> yeah
15:13:18 <kgriffs> and a full series of screencasts.
15:13:23 <kgriffs> ;)
15:13:25 <flaper87> vkmc: I know you started working on that a couple of weeks ago
15:13:43 <flaper87> what about you keep taking care of the CLI and I worked on the v1.1 support for the *library* ?
15:13:47 <vkmc> flaper87, I did yeah, I was waiting for some feedback to keep working on it
15:13:51 <flaper87> Does that sound good to you?
15:14:01 <vkmc> of course it does
15:14:06 <flaper87> awesome
15:14:15 <kgriffs> yeah, we also decided docs was higher priority at the time
15:14:25 <flaper87> indeed!
15:14:26 <kgriffs> vkmc has been working miracles w/ docs
15:14:30 <vkmc> sorry I mixed terms
15:14:32 <flaper87> I'm happy with the current state, really!
15:14:43 <flaper87> vkmc++
15:15:20 <flaper87> ok, any other comment/thought ?
15:15:39 <vkmc> ok so, start adding v1.1 to the *client* and finish the *cli* for v1.0
15:15:39 <flaper87> #topic Final graduation meeting tomorrow (flaper87)
15:15:44 <flaper87> #undo
15:15:45 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x3264810>
15:15:49 <flaper87> vkmc: yeah
15:16:00 <flaper87> the work on the CLI for v1.0 should be good for v1.1 too
15:16:01 <vkmc> +1
15:16:02 <flaper87> I think
15:16:29 <flaper87> The better the library is, the easier it'll be for others to start using zaqar
15:16:30 * kgriffs notest #undo command for future reference
15:16:36 <flaper87> #topic Final graduation meeting tomorrow (flaper87)
15:16:38 <flaper87> kgriffs: ;)
15:16:43 <flaper87> ok ok ok ok
15:16:47 <flaper87> I bet you didn't know this
15:16:51 <flaper87> tomorrow is the final review
15:16:52 <flaper87> :D
15:17:02 <flaper87> A summary of what happened last week
15:17:37 <flaper87> I think the TC meeting went well. There were some concerns raised about NoSQL being added as a requirement, whether we should add an optional project as integrated etc
15:17:48 * flaper87 wishes he had the link to the email thread handy
15:18:18 <flaper87> Those concerns were sent to the mailing list to start a discussion before our meeting tomorrow
15:18:47 <vkmc> https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg33997.html
15:18:48 <flaper87> We haven't gotten as much feedback as I'd have liked
15:18:53 <flaper87> vkmc: thanks :D
15:18:55 <vkmc> :)
15:18:58 <flaper87> #link https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg33997.html
15:19:11 <flaper87> anyway, tomorrow is the big day
15:19:29 <vkmc> is there anything we could do to be 'more' prepared?
15:19:34 <flaper87> Whether we're graduating or not, I think Zaqar is a gread product and ready to be consumed by big players
15:19:46 <flaper87> vkmc: that's actually one of the things I wanted to ask :D
15:19:50 <flaper87> you stole my thunder
15:19:57 <vkmc> sorryyyy
15:19:59 <flaper87> Do you think there's something missing for tomorrow?
15:20:05 <flaper87> vkmc: kidding
15:20:18 <vkmc> today I'm being a pain in the neck
15:20:20 <flaper87> Do you reckon we should prepare more material before our meeting tomorrow?
15:20:33 <flaper87> If any, will that actually help?
15:20:45 <kgriffs> flaper87: how is that etherpad coming w/ use cases?
15:20:53 <flaper87> I've prepared - with the help of many gentle folks from other teams - this etherpad with use cases: https://etherpad.openstack.org/p/zaqar-integrated-projects-use-cases
15:20:59 <flaper87> LOL
15:21:03 <kgriffs> I think it may be helpful to highlight why those use cases couldn't just be done on top of RabbitMQ
15:21:16 <vkmc> yeah... that etherpad is key
15:21:20 * flaper87 kicks kgriffs out of his brain
15:21:29 <kgriffs> because, that is what some folks are hinting at
15:21:32 <flaper87> I need to get some Trove folks to look at it
15:21:36 <flaper87> I'll do that today
15:21:47 <kgriffs> user agent is a big one
15:21:56 <kgriffs> can you get some guys from that project to comment?
15:22:01 <flaper87> I think there're some really neat/key use-cases in the etherpad already
15:22:05 <flaper87> but we need moar
15:22:09 <flaper87> yup
15:22:19 <flaper87> I'll chase them down to hell if needed
15:22:36 <kgriffs> I say that because it would be silly to try to expose a Rabbit endpoint to the guest
15:22:43 * kgriffs in my opinion
15:22:56 <flaper87> They were in the session at the Juno summit and I talked with them afterwards
15:22:59 <kgriffs> firewall, and also security issues, and stuff
15:23:09 <flaper87> They mentioned several times the will of adoption Zaqar once it graduates
15:23:15 <kgriffs> cool
15:23:15 <flaper87> the use case is precisely the user-agent thing
15:23:42 <flaper87> s/adoption/adopting/
15:23:50 <flaper87> anyway, me and my silly typos
15:23:53 <kgriffs> Rackspace has also talked about using Zaqar to communicate with the backup agents used in Cloud Backup, although that product is not OpenStack, it does highlight an "app/saas use case"
15:24:16 <flaper87> kgriffs: would it be worth it to mention it in the use-cases list?
15:24:22 <kgriffs> flaper87: I think so
15:24:30 <vkmc> I think so too
15:24:30 <flaper87> awesome, lets add it
15:24:35 <kgriffs> flaper87: try to track down ametts and see if they are still thinking about it
15:25:07 <flaper87> kgriffs: kk, I'll see if he's around otherwise I'll just call his wife and ask where he is
15:25:13 <kgriffs> sweet
15:25:24 * flaper87 will chase everybody down!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
15:25:29 <flaper87> no mercy
15:25:45 <flaper87> (isn't that the name of some boy-band ?
15:25:47 <flaper87> )
15:26:05 <flaper87> anyway. Other than that, is there anything you think we should totally do?
15:26:29 <kgriffs> flaper87: I'll send an email to Mr. Metts
15:26:53 <flaper87> kgriffs: awesome, that'd be great
15:27:13 <flaper87> nothing else comes to my mind, really
15:27:22 <flaper87> I believe everything that had to be said has been said
15:27:39 <kgriffs> pretty please everone review my redis patchset in 30 mins
15:27:47 <kgriffs> (will upload soon)
15:27:50 <flaper87> I'll take a look at the logs of last week meeting and see if I spot something else
15:28:00 <flaper87> kgriffs: +1
15:28:06 <kgriffs> has anyone heard from prashanth lately?
15:28:17 <flaper87> kgriffs: yeah, he showed up then dissapeared
15:28:19 <flaper87> vkmc: ?
15:28:19 <vkmc> hmm... and the NoSQL concern? is there something else to say there?
15:28:47 <flaper87> vkmc: girl, you almost made me say something I was going to regret :D
15:28:48 <vkmc> kgriffs, I saw him last week, when we chatted about the gc script
15:28:55 <kgriffs> it's a little frustrating - they say SQL is an anti-pattern, so we use NoSQL and they say "ain't nobody gonna deploy that"
15:28:58 <flaper87> vkmc: I don't think so, I mean. We can't do much there
15:29:17 <vkmc> flaper87, :x should I STFU for the rest of the day? lol
15:29:25 <flaper87> WE depend on it and if that is a real issue, which I don't think it is, then I dunno what to do
15:29:36 <flaper87> vkmc: hahaha, nooo. "It's not you, it's me"
15:29:38 <flaper87> (ROFL)
15:29:51 <vkmc> oh c'mon I don't believe you hahaha
15:30:22 <vkmc> well, yeah... there is not much to do there
15:30:32 <flaper87> yeah :/
15:30:51 <vkmc> I don't buy that of 'nobody gonna deploy that'
15:31:07 <flaper87> well, that's what people said about openstack when it first came out
15:31:09 <flaper87> ;)
15:31:12 <kgriffs> someone needs to call them on this catch-22
15:31:16 <vkmc> if they are deploying OpenStack then NoSQL shouldn't be a problem
15:31:52 <flaper87> seriously, I do see the problem about "adding a new technology to the stack" but I don't think that's the real concern
15:31:57 <flaper87> that just happened to be there
15:32:21 <flaper87> the real concern is the "should we add a project that is optional to the integrated team, which also adds a NoSQL dependency to the stack"
15:32:32 <flaper87> or something along that
15:32:51 <vkmc> it's not Zaqar only
15:32:56 <flaper87> vkmc: I know
15:32:58 <vkmc> other projects use NoSQL as well
15:32:59 <cpallares> flaper87: I think their concern was about training people to use it, no?
15:33:24 <flaper87> cpallares: that was also there, yeah.
15:33:35 <flaper87> but still, it's part of the growth and evolution
15:33:39 <kgriffs> I'm surrounded by sys admins at work. They have no trouble deploying, say, Elasticsearch if the tool they want to use requires it.
15:33:54 <kgriffs> I think admins are smarter than many give them credit.
15:33:57 <vkmc> +1 kgriffs
15:33:58 <cpallares> kgriffs: That's a good argument.
15:33:59 <flaper87> kgriffs: exactly, they'll just figure it out
15:34:21 <flaper87> anyway, we all agree on that
15:34:29 <vkmc> also... with that thinking we wouldn't be able to achieve greater things
15:34:29 <flaper87> lets bring all this comments to the meeting tomorrow
15:34:40 <flaper87> we'll see what happens
15:35:09 <flaper87> I mentioned several times that I'd be happy if Zaqar gets moved to an 'optional-projects' group once that group exists
15:35:27 <kgriffs> flaper87: yeah
15:35:28 <vkmc> '640k ought to be enough for everybody' thinking
15:35:47 <vkmc> me too
15:35:55 <flaper87> great
15:36:01 <flaper87> so, I've nothing else to add there
15:36:17 <kgriffs> but it is silly to hold up graduation based on pie-in-the-sky-maybe-someday thinking around the future of the integrated release. In the meantime, we could be delivering a lot of value to other projects and app developers.
15:36:45 <flaper87> indeed, that's the point I hope we'll be able to make tomorrow when this'll come up
15:37:00 <kgriffs> kk
15:37:22 <flaper87> One way or another, Zaqar will be blessed one day so why should we delay it if technically speaking it's up for the game
15:37:24 <flaper87> ?
15:37:36 <flaper87> cool, that's all I've got.
15:37:36 <vkmc> +1 flaper87
15:37:58 <flaper87> #topic Open Discussion
15:38:24 <flaper87> So, I finally watched all episodes of True Detective seasson 1
15:38:28 <vkmc> LOL
15:38:28 <flaper87> ZOMFG
15:38:43 <vkmc> I was going to mention that I saw Undateable
15:38:44 <flaper87> the seasson two will come out in summer 2014
15:38:48 <flaper87> what's wrong with people ?
15:38:59 <flaper87> vkmc: isn't it fun?
15:39:03 <vkmc> s/saw/watched
15:39:13 <flaper87> vkmc: you should also watch `Mom`
15:39:17 <vkmc> yup
15:39:18 <flaper87> it's really fun too
15:39:25 <vkmc> will do :)
15:39:31 <vkmc> I also gave a shot to The Wire
15:39:50 <flaper87> That one didn't catch me, I should probably try again
15:39:59 <vkmc> I couldn't finish the first episode
15:40:07 <flaper87> lol
15:40:26 <vkmc> but probably it's me
15:40:31 <vkmc> hahaha
15:40:40 <flaper87> it's not you, it's them
15:40:41 <flaper87> :P
15:40:54 <flaper87> anyway, something else folks want to talk about?
15:41:00 <flaper87> otherwise, I'll call it!
15:41:28 <flaper87> ok, thanks guys. Hope to see you all tomorrow at the TC meeting
15:41:32 <vkmc> nobody else wants to discuss about tv shows
15:41:34 * vkmc sad panda
15:41:35 <flaper87> remember, it's at 20:00 UTC
15:41:37 <cpallares> lol
15:41:40 * flaper87 sad panda
15:41:50 <cpallares> I've heard good things about true detective
15:41:57 <vkmc> must watch cpallares
15:42:02 <flaper87> cpallares: it's A.M.A.Z.I.N.G
15:42:09 * cpallares will watch
15:42:23 <flaper87> Watch tru detective you must
15:42:23 <vkmc> be careful with flaper87, he is a spoiler
15:42:26 <flaper87> true*
15:42:29 <cpallares> :O
15:42:30 <flaper87> vkmc: WHA?
15:42:35 <flaper87> that's not trueeeeeeeeeeeee
15:42:41 <vkmc> lol
15:42:54 <flaper87> I had to quit IRC and delete all logs because vkmc was spoiling true detective
15:43:00 <flaper87> my eyes were bleeding
15:43:13 <cpallares> vkmc: :O et tu?
15:43:28 <cpallares> tsk, tsk
15:43:30 <flaper87> cpallares: so now you don't believe me, ah?
15:43:32 <flaper87> >.>
15:43:32 <vkmc> cpallares, I didn't do that
15:43:48 <flaper87> in any case, it's kgriffs' fault!
15:43:55 <flaper87> byeeeeeeeeeeeeeeeeeeeeeeeeeeee
15:43:57 <cpallares> It's always kgriffs fault
15:43:58 <flaper87> #endmeeting