21:01:59 <flaper87> #startmeeting Zaqar
21:02:00 <openstack> Meeting started Mon Aug 31 21:01:59 2015 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:03 <openstack> The meeting name has been set to 'zaqar'
21:02:09 <flaper87> vkmc flwang1 therve ryansb exploreshaifali courtesy ping
21:02:10 <vkmc> o/
21:02:12 <ryansb> hi
21:02:15 <flaper87> #topic Roll Call
21:02:16 <flaper87> o/
21:02:27 <flaper87> flwang1: ?
21:02:41 * flaper87 drives flwang1 to the office
21:02:55 <flaper87> oh well, I guess it's just us for now
21:02:58 <flaper87> #topic Agenda
21:02:59 <vkmc> flaper87, you have to wake him up
21:03:01 <flaper87> #link https://wiki.openstack.org/wiki/Meetings/Zaqar#Agenda
21:03:08 <flaper87> That's our agenda for today
21:03:13 <flaper87> feel free to add topics in there
21:03:19 <flaper87> #topic Review Prev Meeting Actions
21:03:25 <flaper87> vkmc to sync with folks from horizon about a possible joint session for zaqar+horizon
21:03:28 <flaper87> vkmc: ?
21:03:51 <vkmc> last weekly meeting for Horizon I catch up with them
21:04:12 <vkmc> they seemed quite interested of having a working session with us, shared with Ceilometer folks
21:04:34 <flaper87> #info Horizon interested in a shared session w/ folks from Ceilo
21:04:55 <flaper87> vkmc: sounds great, I'll keep that in mind and I'll make sure it's written down for the next PTL
21:05:06 <vkmc> they certainly had to discuss things before setting something formal, so I proposed them to ping us when they have some plans for M
21:05:21 <flwang1> o/
21:05:23 <vkmc> or when we have to define the working sessions :)
21:05:38 <flaper87> vkmc: sounds like a plan to me!
21:05:44 <vkmc> which... I'm not very sure when that happens
21:05:44 <flaper87> please, do follow up with them
21:05:47 <flaper87> flwang1: welcome
21:05:51 <vkmc> sure
21:05:55 <flaper87> Don't worry, it's happening
21:05:56 <flwang1> blame the traffic
21:05:57 <flaper87> :)
21:06:04 * flaper87 blames the traffic
21:06:06 <flaper87> flwang1 to sync with folks from swift about a possible joint session for zaqar+swift (swift notification middleware)
21:06:10 <flaper87> flwang1: ^ ?
21:06:19 <flaper87> Should I blame the traffic for that too?
21:06:21 <flaper87> :P
21:06:23 * flaper87 ducks
21:06:37 <flwang1> flaper87: yep, i haven't got a chance to talk with them
21:06:46 * flaper87 blames the traffic
21:06:49 <flwang1> sorry, will do today and update in zaqar channel
21:06:50 <flaper87> #action flwang1 to sync with folks from swift about a possible joint session for zaqar+swift (swift notification middleware)
21:07:03 <flaper87> flaper87 to sync with folks from Sahara about their guest-agent use-case
21:07:17 <flaper87> so, I talked to Sahara's PTL and then shortly participated in their last meeting
21:07:31 <flaper87> The agreement is very similar to the one vkmc found for horizon
21:07:44 <flaper87> we'll meet before the summit and then have a more detailed plan for the summit
21:07:53 <flaper87> hopefully, we'll manage to pull off a hacking session
21:08:04 <flaper87> The difference is that we already know what we want from each other
21:08:11 <flaper87> and the required features are already implemented
21:08:19 <flaper87> we need to expand the client but that's doable
21:08:41 <flaper87> that's it
21:08:43 <flaper87> #topic Pending important reviews
21:08:53 <flaper87> #link https://review.openstack.org/#/c/209910/ flwang policy
21:08:56 <flaper87> #link https://review.openstack.org/#/c/202374/ flwang email notification
21:08:58 <flaper87> #link https://review.openstack.org/#/c/218430/ vkmc move websockets to v2
21:09:00 <flaper87> #link https://review.openstack.org/#/c/215134/ therve signed urls over websocket
21:09:02 <flaper87> #link https://review.openstack.org/#/c/206080/ notifications over websocket
21:09:03 <flaper87> Please, whatever you do, focus on that ^
21:09:09 <flaper87> #info Feature Freeze Week
21:09:26 <flaper87> I know we said, because of our very big team, that we'll be flexible on the FF
21:09:41 <flaper87> However, I believe those are the reviews pending that will close our features implementations
21:09:51 <flaper87> I believe it's totally doable to get them in this week
21:10:01 <flaper87> flwang1: would you mind if I take the policy one over?
21:10:10 <flaper87> I can help you figuring out what's wrong with the tests
21:10:21 <flaper87> vkmc: thanks a lot for the efforts on moving ws to v2
21:10:28 <flaper87> That'll be of great value for Zaqar
21:10:30 <flwang1> flaper87: ok, feel free to take it
21:10:41 <flaper87> I'll just help you to get the gate green
21:10:41 <ryansb> also https://review.openstack.org/165632 as long as Akanksha Srivastava comes back and adds a test
21:10:45 <flwang1> flaper87: i will upload my latest code
21:10:47 <flaper87> then it's all yours
21:10:52 <ryansb> (not very high priority, but would be nice)
21:11:11 <flwang1> flaper87: no problem
21:11:12 <flaper87> ryansb: sure, but that can land even after FF
21:11:20 <ryansb> true
21:11:28 <flaper87> This week, we should just focus on reviews that complete new features
21:11:32 <vkmc> :D
21:11:40 <flaper87> flwang1: danke
21:11:46 <flaper87> So far, great work everyone
21:11:54 * flaper87 is happy and hugs this amazing team
21:12:09 <flaper87> but you better get those reviews in
21:12:13 <flaper87> or I'll take my hug back
21:12:15 <flaper87> >.>
21:12:18 <vkmc> haha
21:12:23 <exploreshaifali> lol
21:12:27 <ryansb> lol
21:12:41 <flaper87> questions? other reviews?
21:13:09 <flaper87> #topic Results from the Test Day
21:13:16 <flaper87> I'd consider the test day successful. Zaqar and zaqarclient were tested and these bugs were found:
21:13:19 <flaper87> #link https://bugs.launchpad.net/bugs/+bugs?field.tag=zaqar-liberty-test-day
21:13:30 <flaper87> most of those bugs already have a pending patch
21:13:56 <flaper87> Those patches can wait until next week but, if you've some spare time and you think they won't cause merge conflicts, then feel free to take a look at them
21:14:00 <vkmc> flaper87, thanks for working on that Fla
21:14:19 <flaper87> As part of the effort, we also wrote this wiky page - far from complete - https://wiki.openstack.org/wiki/Zaqar/TestingDay/Liberty
21:14:20 <vkmc> I was wondering if we could organize a second bug day
21:14:33 <vkmc> considering it was hard to participate in this one because of the feature freeze and our roles in other OpenStack projects
21:14:50 <flaper87> I'm happy because that Wiki page can be used as template for future TestDays
21:15:17 <flaper87> vkmc: yes, that's great feedback. We should've considered the FF week as an important thing on our date picking process
21:15:22 <flwang1> vkmc: we should plan a doc day soon :)
21:15:36 <flaper87> That said, I'd be happy to organize a new test day on the week of rc1
21:15:37 <vkmc> yeah as well
21:15:43 <flaper87> flwang1: that's on the agenda, don't spoile it
21:15:46 <flaper87> >.>
21:15:49 <flaper87> spoil
21:15:55 <vkmc> awesome!
21:16:14 <flaper87> I'll schedule a new test day and I'll make sure the wiki page is complete by then
21:16:20 <vkmc> perhaps for that second test day we could focus on the features that are on the review queue
21:16:32 <flwang1> vkmc: good idea
21:16:32 <vkmc> flaper87, this time I promise to make some time to help
21:16:33 <flaper87> I also worked on a small script that uses zaqarclient, which ended up being very useful to find many of those bugs
21:16:50 <vkmc> flaper87, link link link
21:16:53 <flaper87> The sad thing is that the script looks a lot like a functional test
21:17:01 <flaper87> which means our functional tests SUCK!
21:17:06 <vkmc> lol
21:17:07 <flaper87> and that's why our gate is broken
21:17:10 <ryansb> vkmc: I think "merged in liberty" would be a little better as a test day topic
21:17:10 <vkmc> they could use some love yes
21:17:22 <vkmc> ryansb, sounds good
21:17:23 <flaper87> I'll post the script tomorrow, I've added it in the examples dir
21:17:24 <vkmc> !
21:17:24 <flwang1> flaper87: is  it possible to wrap your lovely script into tempest>
21:17:25 <flaper87> :D
21:17:47 <flaper87> flwang1: I'd like to make it a zaqarclient's functional test
21:17:53 <flaper87> flwang1: but yes, it can be translated to that
21:17:58 <flwang1> either good for me
21:18:16 <flwang1> i just want to have a good repo to keep it
21:18:18 <flaper87> I'll clean it up and prepare it for next week
21:18:31 <flwang1> flaper87: it would be great, thanks, man
21:18:31 <flaper87> and I believe we should fix our gate asap and make it voting again
21:18:37 <flaper87> That's a goal before Liberty ends
21:19:06 <vkmc> I really want to fix Rally's gate
21:19:09 <flaper87> anyway, I'm happy with the results. Sad that not all of us could make it but I'm sure we'll all participate in the next one
21:19:31 <flaper87> vkmc: that sounds good too. I'm wondering if that would be better to be pushed back to Mitaka
21:19:57 <flaper87> just a thought
21:20:03 <flaper87> anything else on the topic?
21:20:08 <flaper87> Concerns? Feedback?
21:20:10 <vkmc> yeah, certainly not a priority for Liberty
21:20:34 <flaper87> ooook, moving on
21:20:36 <vkmc> not from me
21:20:38 <flaper87> #topic Docs sprint (Friday, September 11th)
21:20:45 <flaper87> BAM!
21:20:57 <vkmc> oh wow
21:20:57 <flaper87> So, I'd like to organize a Doc sprint on Friday 11th
21:21:12 <flaper87> I took Friday because it seemed to work for the TEst Day (leaving FF week aside)
21:21:27 <flaper87> This week is FF week so, Friday 4th seemed a bit extreme
21:21:40 <flaper87> In summary, next week, on friday, we'll be sprinting on docs
21:21:47 <vkmc> sounds good... I'll be sharing the office with godlike so he can help too
21:22:11 <godlike> vkmc: I'll bring the fernet
21:22:12 <vkmc> godlike, thank me later
21:22:17 <flaper87> I'll prepare a list of topics missing but please, feel free to add more
21:22:19 <godlike> vkmc: thank ME later
21:22:21 <flaper87> #link https://etherpad.openstack.org/p/zaqar-liberty-doc-sprint
21:22:47 <flaper87> godlike: Unless you've figured out how to send fernet over IRC, you shouldn't be mentioning it here
21:22:54 <flaper87> ah wai, I have fernet at home
21:22:59 <flaper87> yummyyyyy
21:23:02 <flaper87> wait*
21:23:03 <godlike> flaper87: how do you think that fernet got there? ;)
21:23:04 <flaper87> anyway
21:23:09 <flaper87> godlike: LOL
21:23:15 <vkmc> godlike, CoC -> don't say fernet unless you have a way of sharing it
21:23:27 <godlike> lol
21:23:28 <flaper87> Please, add fernet to that etherpad
21:23:32 <flaper87> erm, I mean, topics
21:23:46 <flaper87> or fernet... really, it's fine
21:24:03 <flaper87> Anyway, I'll work on the list of topics, you should add your name next to the topic you want to sprint on
21:24:11 <flaper87> 1 review per topic, etc, etc, etc
21:24:22 <flaper87> I'll write all this on the DocSprint wiki page
21:24:27 <flaper87> #action to work and stop talking
21:24:31 <flaper87> #undo
21:24:31 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa7a26d0>
21:24:35 <flaper87> #action flaper87 to work and stop talking
21:24:55 <flaper87> #action flaper87 seriously, to write down the topics for the doc sprint and the instructions https://etherpad.openstack.org/p/zaqar-liberty-doc-sprint
21:25:08 <flaper87> That's all I have on this topic
21:25:11 <flaper87> questions?
21:25:13 <flaper87> concerns?
21:25:26 <ryansb> makes sense
21:25:39 <flaper87> ryansb: I know you're referring to the working part
21:25:40 <flaper87> >.>
21:25:52 <ryansb> lolol, that and the docs sprint
21:25:55 <ryansb> but whichever
21:25:57 <vkmc> haha
21:25:58 <flaper87> :D
21:26:06 <vkmc> LGTM
21:26:12 <flaper87> #topic Other Updates
21:26:27 <flaper87> In other news, puppet structure for Zaqar landed
21:26:41 <flwang1> flaper87: that's awesome
21:26:41 <ryansb> I think the big thing for a docs sprint would be more verifying existing docs
21:26:52 <flwang1> flaper87: i just want to know what's left
21:26:54 <flaper87> pls, all together, lets say thank you to Emiliem and the puppet team, hug them, dedicate a song to them
21:27:04 <flwang1> how far way to deploy zaqar with puppet
21:27:11 <flaper87> flwang1: I just asked Jason to do that
21:27:13 <ryansb> we could use more docs too, but verifying that they're still valid is important
21:27:23 <flwang1> flaper87: cool
21:27:32 <flaper87> flwang1: Jason will be working on what's left, he'll also give us the missing pisses and an ETA
21:27:50 <flwang1> flaper87: excellent
21:27:57 <flaper87> ryansb: yeah, that sounds good. I'll try to grab all that in the topics list (what we have, what's outdated and what's missing)
21:28:17 <flaper87> Does anyone have other amazing updates to share?
21:28:34 <flaper87> if they are not amazing, please, remember you have to give gummybears before and after sharing the bad news
21:28:39 <ryansb> #ReviewMoreCodee
21:28:41 <ryansb> #ReviewMoreCode
21:28:51 * flaper87 echos ryansb
21:29:19 <flaper87> I know many of you are busy with other projects but please, 1h per day, that's all Zaqar is asking
21:29:31 <vkmc> jasondotstar, ^
21:29:33 <flaper87> Look at its cat eyes (like the ones from Shrek)
21:29:52 <flaper87> and you'll realize how cute Zaqar is and how important reviews are
21:30:20 * flaper87 should stop doing the things he does before the meeting or simply avoid attending the meeting at 21UTC
21:30:26 <flaper87> :P
21:30:39 <ryansb> lol
21:31:03 <exploreshaifali> :D
21:31:08 <flaper87> ok
21:31:16 * ryansb doesn't have news
21:31:18 <flaper87> if there's nothing else on this, very generic, topic
21:31:31 <flaper87> I'd suggest moving on to the next, more specific and consistent, one
21:31:37 <flaper87> #topic Open Discussion
21:31:43 <flaper87> SUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUP ?
21:32:09 <vkmc> lol
21:32:12 <ryansb> the knowledge that our functional tests aren't very good worries me
21:32:25 <ryansb> since that's what I've been developing my swift backend against
21:32:34 <flaper87> ryansb: to be fair, they are not good on the client side
21:32:41 <flaper87> The ones on the server side could use some love
21:32:47 <flaper87> but at least they run in the gate
21:32:53 <ryansb> oh, I see
21:33:01 <flaper87> zaqarclient's gate is failing and non-voting
21:33:04 <flaper87> also
21:33:16 <flaper87> to be fair, we made it non-voting because something else broke it (outside our control)
21:33:20 <flaper87> and then shit happened
21:33:24 <ryansb> I mean, presumably a sufficiently advanced functional test of the server would also test the client, right?
21:33:31 <flaper87> not trying to make up excuses
21:33:36 <flaper87> just trying to provide some history
21:33:56 <flaper87> ryansb: I agree with that
21:33:58 <ryansb> sure, makes sense. Any idea how much work it would be to fix the gate?
21:34:21 <flaper87> After my zaqar/zaqarclient patches land, I think there's not much to do
21:34:32 <flaper87> probably we just need zaqarclient's
21:34:38 <flaper87> I'll take a look at that tomorrow
21:34:43 <ryansb> cool
21:35:06 <flaper87> ryansb: btw, I'd love to see and advanced zaqar functional test consuming current stable zaqarclient
21:35:15 <flaper87> that'd also guarantee backwards compatibility
21:35:33 <flaper87> For M, I'd love to see our test suite (At least functional ones) completely revamped
21:35:36 <ryansb> you mean for server changes, obviously
21:35:39 <ryansb> not client changes
21:35:42 <flaper87> ryansb: yes
21:36:24 <flaper87> IF we keep zaqarclient's functional tests updated, we can simply add a zaqarclient gate to Zaqar
21:36:30 <flaper87> and that should be enough
21:36:39 <flaper87> anyway, there's a lot to do in our test suite
21:37:30 <flaper87> that's all I have
21:37:35 <flaper87> anything else? anyone?
21:37:48 <ryansb> that's it for me
21:37:52 <flaper87> otherwise, I'll call it a meeting and I'll wish a happy Feature Freeze week to everyone
21:37:58 <ryansb> A++
21:38:00 <flaper87> (note the sarcasm on the last part :P)
21:38:05 <flaper87> #endmeeting