15:01:09 <flaper87> #startmeeting Zaqar
15:01:09 <openstack> Meeting started Mon Sep  7 15:01:09 2015 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:11 <flaper87> Courtesy ping: vkmc therve ryansb flwang dynarro jasondotstar
15:01:13 <openstack> The meeting name has been set to 'zaqar'
15:01:13 <flaper87> Courtesy ping: vkmc therve ryansb flwang dynarro jasondotstar
15:01:18 <flaper87> Courtesy ping: vkmc therve ryansb flwang dynarro jasondotstar
15:01:24 <flaper87> #topic roll call
15:01:26 <flaper87> o/
15:01:27 <vkmc> o/
15:01:38 <vkmc> \o
15:01:43 <flaper87> I guess flwang is sleeping
15:01:49 <flaper87> ryansb is on holiday
15:01:53 <flaper87> therve: may be around
15:02:00 <therve> Hola
15:02:00 <flaper87> and dynarro is probably eating supper
15:02:56 <flaper87> actually, dynarro is joining. She just forgot the channel name. :D
15:03:14 <vkmc> haha
15:03:48 * flaper87 waits a few seconds
15:03:54 <flaper87> there she is
15:03:59 <flaper87> #topic Agenda https://wiki.openstack.org/wiki/Meetings/Zaqar#Agenda
15:04:07 <flaper87> #undo
15:04:08 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0xa7a2990>
15:04:09 <dynarro> o/
15:04:10 <flaper87> #topic Agenda
15:04:13 <flaper87> #link https://wiki.openstack.org/wiki/Meetings/Zaqar#Agenda
15:04:20 <flaper87> Pending important reviews
15:04:22 <flaper87> Docs sprint (Friday, September 11th)
15:04:25 <flaper87> Mitaka Summit preparations
15:04:36 <flaper87> Those are our topics for today, besides the recurent ones
15:05:06 <flaper87> #topic Pending important reviews
15:05:15 <flaper87> #link https://review.openstack.org/#/c/209910/ flwang policy
15:05:17 <flaper87> #link https://review.openstack.org/#/c/206080/ notifications over websocket
15:05:38 <flaper87> The policy patch has received several iterations and it seems to be on its final state
15:05:55 <flaper87> vkmc: it'd be cool if you could take a look at it late today since ryansb is on holiday
15:06:07 <vkmc> flaper87, will do
15:06:25 <flaper87> There's also therve's notification over websocket, which depended on vkmc's patch that landed earlier today
15:06:36 <vkmc> that will need a rebase
15:07:12 <therve> I think it's been done already
15:07:29 <diga> o/
15:07:34 <flaper87> Other than that, please, give priorities to bugs assigned to this milestone: https://bugs.launchpad.net/zaqar/+milestone/liberty-rc1
15:07:37 <flaper87> #link https://bugs.launchpad.net/zaqar/+milestone/liberty-rc1
15:07:39 <flaper87> diga: hey there :D
15:08:00 <diga> Hello flaper87
15:08:00 <flaper87> There are three bugs in-progress and 2 triaged
15:08:11 <flaper87> help reviewing/fixing those is very welcomed
15:08:38 <flaper87> anything else? Otherwise we'll move on
15:08:55 <flaper87> #topic Docs sprint (Friday, September 11th)
15:09:04 <flaper87> I've collected some of the topics and questions that I believe it'd be cool to have answered in the docs but I don't think the list is complete. It'd be great to have some help completing this list  so that we're ready for friday.
15:09:07 <flaper87> #link https://etherpad.openstack.org/p/zaqar-liberty-doc-sprint
15:09:09 <flaper87> Ah, btw, remember that we'll have the docs sprint on Friday, September 11th
15:09:10 <flaper87> #info Zaqar's docs sprint on Friday, September 11th.
15:09:16 <vkmc> w00t, thanks flaper87
15:09:42 <therve> Cool
15:09:58 <flaper87> I don't have much else to say here other than please add topics and make some time on Friday to contribute
15:10:11 <flaper87> even 1h can get you to write a good part of the docs
15:10:31 <therve> flaper87, Can we talk about the gate?
15:10:45 <flaper87> therve: yup, one more topic and the floor will be yours
15:10:49 <flaper87> #topic Mitaka Summit preparations
15:11:09 <flaper87> Again, not much to say other than asking for contributions:
15:11:11 <flaper87> #link https://etherpad.openstack.org/p/Mitaka-Zaqar
15:11:29 <flaper87> That's the etherpad for the next summit and it'd be great to start collecting topics there
15:11:38 <flaper87> there's a small template that you can copy/paste
15:11:54 <flaper87> add as many ideas as you want, we'll vote later
15:12:06 <flaper87> and the next PTL will help organizing the schedule
15:12:18 <flaper87> comments? thoughts? concerns?
15:12:38 <flaper87> #topic Zaqar's gate (therve)
15:13:01 <therve> So yeah you patch about logs made me realize the poor state of our gate
15:13:10 <therve> I think we have several jobs basically doing nothing
15:13:16 <therve> 2 on the server and 1 on the client
15:13:32 <therve> There may be not much to discuss than "let's fix this"
15:14:07 <flaper87> absolutely, earlier today I was like: "Wait a minute, where did all the http calls go?"
15:14:18 <flaper87> that question was followed by a: "Oh crap"
15:14:34 <therve> Yeah I think logs are the tip of the iceberg :)
15:14:48 <flaper87> I think I know what's going on, it likely broke when we moved to the plugin
15:14:58 <flaper87> since I did the migration, I'm happy to take this on
15:15:04 <flaper87> last famous words
15:15:12 <flaper87> I'm sure there'll be a shitload of things to fix
15:15:18 <flaper87> (sorry for swearing)
15:15:20 <therve> flaper87, I can try if you want.
15:15:27 <therve> Your time is more precious than mine :)
15:16:08 <flaper87> lol, thanks! :D
15:16:20 <flaper87> So, I think the issue is here: https://github.com/openstack/zaqar/blob/master/devstack/gate/gate_hook.sh or in project-config
15:16:36 <therve> Yeah
15:16:40 <therve> I have at least one idea to try
15:16:41 <flaper87> Somewhere in the execution of the gate_hook something is *not* happening
15:16:50 <flaper87> therve: go for it
15:16:56 <flaper87> happy to help if needed
15:17:09 <therve> Will do
15:17:22 <flaper87> I'll then work on fixing the client's functional gate, which is broken as well
15:17:27 <flaper87> as dynarro knows and suffers
15:17:30 <flaper87> :P
15:17:45 <dynarro> LOL
15:17:51 <dynarro> indeed
15:17:56 <flaper87> therve: thanks for bringing this up
15:18:06 <flaper87> vkmc: you mentioned you wanted to fix Rally's gate
15:18:09 <therve> No problem!
15:18:13 <vkmc> I did yes
15:18:21 <flaper87> vkmc: will you have time for that before Liberty is out?
15:18:31 <vkmc> certainly the lack of logs in the gate are making that harder
15:18:40 <flaper87> Also, the stable gate is pretty broken as well
15:18:42 <vkmc> but yeah, I'll try to have it fixed by then
15:18:59 <flaper87> but that I think I know how to fix
15:19:07 <vkmc> :) cool
15:19:16 <flaper87> vkmc: please, otherwise, I'm tempted to remove the Rally gate and add it back later
15:19:30 <flaper87> HAving a non-voting job for so long makes me sad
15:20:07 <flaper87> ok, anything else on this topic?
15:20:22 <therve> I'm good!
15:20:31 <flaper87> moving on
15:20:36 <flaper87> #topic Open Discussion
15:20:40 <flaper87> I've nothing else
15:20:43 <flaper87> :D
15:21:03 <flaper87> unless there's something ppl want to talk about, I'll call this a short meeting and move on with our tasks
15:21:07 <vkmc> flaper87, nooo, not with the rally gate!
15:21:11 <vkmc> I'll fix it
15:21:36 <flaper87> vkmc: ok ok :)
15:21:42 <flaper87> thanks
15:21:48 <vkmc> :)
15:22:05 <flaper87> ok, thanks folks!
15:22:12 <vkmc> waaaaaaaaaaait
15:22:14 <flaper87> Enjoy your week
15:22:16 * flaper87 waits
15:22:35 <vkmc> so for the OpenStack summit, cpallares and I will be presenting about websocket
15:22:50 <vkmc> and we discussed about doing a demo
15:23:07 <vkmc> every feedback on how that demo should look would be welcome
15:23:16 <vkmc> I already got some feedback from flaper87
15:23:30 <vkmc> but I'm also interested in hearing your thoughts therve, since you worked a lot on the websocket driver
15:24:06 <flaper87> one of the things vkmc and I mentioned offline was to do some sort of Game
15:24:17 <flaper87> it'd be really cool
15:24:20 <dynarro> cool!
15:24:22 <flaper87> (that requires therve's patch)
15:24:26 <vkmc> yeah
15:24:50 <vkmc> we have to think this through... because it will help to show what Zaqar is capable off and therefore gain some adoption :)
15:25:29 <flaper87> #action dynarro flwang therve ryansb vkmc cpallare to think about possible demos for Zaqar at the summit
15:25:32 <vkmc> #link http://sched.co/49vj
15:25:44 <therve> vkmc, I'd be happy to help looking for the presentation and/or some code
15:25:51 <therve> I won't be there unfortunately
15:25:55 <vkmc> therve, thanks!
15:25:57 <vkmc> oh :(
15:26:18 <flaper87> vkmc: btw, thanks for presenting about Zaqar
15:26:22 <flaper87> that's super great
15:26:32 <vkmc> \o/ it will be fun
15:26:52 <vkmc> I'm glad the proposal has been accepted
15:27:28 <flaper87> w000h000
15:27:29 <dynarro> \o/
15:27:29 <vkmc> well, I'll start drafting something and will let you guys know
15:27:30 <flaper87> ok
15:27:36 <flaper87> awesome
15:27:40 <vkmc> thanks flaper87
15:27:41 <flaper87> etherpad should be fine
15:27:45 <vkmc> yeah
15:27:47 <flaper87> anything else? anyone ?
15:28:22 <flaper87> #endmeeting