15:08:38 <vkmc> #startmeeting zaqar
15:08:39 <openstack> Meeting started Mon Jan 18 15:08:38 2016 UTC and is due to finish in 60 minutes.  The chair is vkmc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:43 <openstack> The meeting name has been set to 'zaqar'
15:08:50 <vkmc> #topic roll-call
15:08:54 <vkmc> o/
15:08:57 <vkmc> hi guys :)
15:09:05 <Eva-i> hi
15:09:11 <vkmc> since flwang1 is not around to drive the meeting, I think I can give it a try
15:09:45 <vkmc> so let's check the agenda...
15:09:46 <Eva-i> what we will discuss today?
15:10:19 <vkmc> since we are about to cut Mitaka-2, I'd like to focus on the changes that we consider important to get merged now
15:10:38 <vkmc> #link https://launchpad.net/zaqar/+milestone/mitaka-2
15:10:52 <vkmc> there is no many triaged features/bug fixes there, we need to fix that
15:11:05 <vkmc> #action vkmc triage bugs/features for Mitaka-2
15:11:07 <ryansb> I'd really like to get https://review.openstack.org/#/c/253731/ in for M2
15:11:13 <vkmc> ryansb++
15:11:24 <vkmc> #topic mitaka-2
15:11:29 <therve> ryansb, Client is released independently
15:11:36 <therve> So I don't think it matters much
15:11:38 <ryansb> ah, well that makes it easy
15:12:13 <ryansb> therve: I think I'll take that "bug" we were talking about last week (that Queues need a .subscribe method in the Python lib)
15:12:13 <vkmc> checking the server side, I see many patches Eva-i submitted
15:12:32 <vkmc> those are already there for review
15:12:48 <vkmc> we need to check the bug list to see if we should get something else in
15:13:00 <vkmc> like that one... "queues need a subscribe method"
15:13:15 <therve> vkmc, Client as well
15:13:20 <vkmc> yup
15:13:31 <Eva-i> My websocket binary support patch needs to be released in m-2, but now I think it needs further improvement.
15:13:48 <Eva-i> I opened many bugs recently.
15:14:28 <vkmc> so...
15:14:52 <vkmc> #action check bugs both server-side and client-side for m-2
15:15:15 <therve> vkmc, Again, client doesn't matter for m2 :)
15:15:23 <therve> AFAIK, at least
15:15:55 <Eva-i> https://bugs.launchpad.net/zaqar/+bug/1533668 check out this bug for example
15:15:56 <openstack> Launchpad bug 1533668 in zaqar "Zaqar can't list queues, when enable_virtual_pool = True (affects devstack)" [Undecided,New]
15:15:56 <vkmc> right
15:19:01 <Eva-i> If there was Fei Long, he would probably asked has anyone checked out zaqar-ui https://review.openstack.org/#/c/255213/
15:19:41 <vkmc> yes
15:19:49 <vkmc> I'm looking at previous meetings logs
15:20:18 <vkmc> let's jump to that
15:20:21 <vkmc> #topic zaqar-ui
15:21:43 <vkmc> this one got recently merged
15:21:45 <vkmc> #link https://review.openstack.org/#/c/255213/
15:21:52 <vkmc> and there are also other patch sets waiting for review
15:22:08 <vkmc> this is a wip but maybe flwang1 could use some help testing this
15:22:09 <vkmc> #link https://review.openstack.org/#/c/258474/3
15:22:36 <vkmc> and that's pretty much it on that side... flwang1 probably can update us better next time we chat with him :)
15:22:48 <Eva-i> I will try new zaqar-ui patches today. But it's hard for me to understand how it works.
15:22:58 <Eva-i> vkmc: yes
15:23:03 <vkmc> how to enable the plugin you say?
15:23:06 <vkmc> I need to test that too
15:23:18 <vkmc> I'll ping you if I can make some time to test it and we can do that together
15:23:20 <Eva-i> I know how to enable the plugin, it's in readme.md
15:23:35 <vkmc> oh cool
15:23:40 <vkmc> so what's your concern?
15:24:27 <Eva-i> I just don't know how the code is getting glued together.
15:24:40 <Eva-i> I just need to spend some time understanding it.
15:26:28 <vkmc> ok ok
15:26:35 <vkmc> we can check that later eitherways
15:26:35 <Eva-i> We can move to another topic now
15:26:39 <Eva-i> I want to discuss one thing about websocket transport on today's meeting.
15:27:21 <ryansb> k
15:28:20 <vkmc> yes
15:28:24 <vkmc> let's move to that then
15:28:34 <vkmc> #topic binary support for the websocket transport
15:28:43 <vkmc> Eva-i, floor is yours
15:30:54 <Eva-i> When the client is communicating with Zaqar through http requests, it always sends requests to API version-specific zaqar endpoint ("v2" for example), so Zaqar knows how to process this request depending on the API.
15:33:12 <Eva-i> When the websocket transport is used, there's no way the client can tell Zaqar which version of websocket API it wants to use. Though zaqar has only one websocket API version now.
15:34:28 <therve> Eva-i, It only supports v2. There is no way to choose an API just yet
15:34:41 <ryansb> Yeah, but *one day* we'll need to version it
15:35:23 <Eva-i> But I'd like the client able to specify the version as it can help us in future if we will release the new version of websocket API.
15:35:49 <Eva-i> Is it too early to think about it?
15:35:59 <ryansb> is there a reason they can't be locked to the version with which they initiated the websocket connection?
15:37:47 <therve> ryansb, We'd need to have routing in the websocket side, which we don't
15:38:01 <therve> But that seems like the easiest option yeah
15:38:07 <ryansb> good point.
15:38:44 <vkmc> you specify the version when you instantiate the api
15:38:53 <vkmc> right now v2 is the only one
15:39:11 <vkmc> but for newer versions we can inherit from that and add the required changes, and you are done
15:39:14 <vkmc> or what am I missing?
15:43:25 <vkmc> Eva-i, ^?
15:43:59 <Eva-i> I think I should have prepared more for this conversation
15:44:32 <Eva-i> I'm just worrying about future compatibility
15:44:48 <ryansb> Eva-i: I think for right now, what you're doing is fine
15:45:01 <Eva-i> Maybe I'll bring this topic up when API v2 will be stable
15:45:44 <ryansb> agreeing that websocket connections are going to stick to the version they were initiated with in the HTTP API is probably the way forward
15:48:03 <vkmc> +1
15:48:04 <vkmc> sounds good
15:48:12 <vkmc> let's talk more about this on the design session
15:48:24 <vkmc> since this something that will probably happen on the next cycle
15:48:28 <vkmc> agree?
15:48:50 <Eva-i> There's http handshake during websocket connection initiation, but Zaqar can't control it AFAIK
15:49:30 <vkmc> yeah no, that's implemented on the websocket library
15:50:03 <Eva-i> The client don't have a way to know websocket api version or a way to tell it to Zaqar
15:50:09 <Eva-i> If we don't do some things right before making websocket API v2 stable, the future versioning for websocket transport might be a bit problematic.
15:50:43 <Eva-i> But okay, let's move to another topic
15:50:57 <vkmc> we are almost close to the end of our meeting
15:51:08 <vkmc> so let's move things to open discussion
15:51:11 <vkmc> #topic open discussion
15:51:52 <vkmc> Eva-i, I understand your concerns, let's work on designing how we can handle that
15:55:28 <Eva-i> BTW, I'm bringing back Zaqar installation guide in production environment https://review.openstack.org/#/c/268851/. I'd like your help figuring out which things might are outdated in this guide.
16:01:32 <vkmc> sounds good, thanks Eva-i
16:01:35 <vkmc> we are over time
16:01:38 <vkmc> let's call this a meeting
16:01:41 <vkmc> thanks all
16:01:43 <vkmc> #endmeeting