03:01:17 <hongbin> #startmeeting zun
03:01:18 <openstack> Meeting started Tue Nov 15 03:01:17 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:01:19 <eliqiao> o/
03:01:22 <openstack> The meeting name has been set to 'zun'
03:01:22 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2016-11-08_0300_UTC Today's agenda
03:01:27 <hongbin> #topic Roll Call
03:01:28 <Namrata> Namrata
03:01:31 <mkrai> Madhuri Kumari
03:01:32 <Wenzhi> Wenzhi
03:01:34 <shubhams> Shubham Sharma
03:01:35 <pksingh> pradeep,
03:01:40 <kevinz> kevinz
03:02:04 <hongbin> Thanks for joining hte meeting eliqiao Namrata mkrai Wenzhi shubhams pksingh kevinz
03:02:06 <eliqiao> Eli Qiao
03:02:10 <hongbin> #topic Announcements
03:02:16 <hongbin> 1. Zun is going to have a PTL election
03:02:22 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107010.html
03:02:33 <hongbin> I am going to submit my candidacy soon
03:02:53 <hongbin> After the PTL is elected, I will submit an application to join the big-tent
03:03:06 <eliqiao> +1 for hongbin
03:03:10 <Wenzhi> cool
03:03:14 <shubhams> Thats great
03:03:18 <kevinz> cool
03:03:22 <pksingh> :)
03:03:27 <mkrai> :)
03:03:37 <hongbin> Then, we become officially openstack project :)
03:03:46 <Namrata> great
03:03:48 <Wenzhi> bravo
03:03:50 <hongbin> #topic Review Action Items
03:03:52 <kenji-i> cool
03:03:59 <hongbin> 1. hongbin create a bp for adding support for secure container (DONE)
03:04:06 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-secure-container
03:04:31 <hongbin> mkrai: i assigned it to you, since you looks interesting to work on this
03:04:45 <pksingh> hongbin: will be using hyper or clear containers?
03:04:51 <hongbin> mkrai: do you have time to take it?
03:04:57 <mkrai> Ok thanks I will work on it
03:05:10 <hongbin> pksingh: depend on mkrai :)
03:05:16 <mkrai> pksingh: clear container as of now
03:05:27 <pksingh> hongbin: mkrai: if i can help that would be greate
03:05:41 <mkrai> sure pksingh. Thanks
03:05:50 <pksingh> hongbin: ok
03:05:56 <hongbin> mkrai: pksingh : sure. for big bp, i encourage us to pair up
03:06:13 <hongbin> since the work is big, so two people is better
03:06:31 <hongbin> 2. hongbin create a bp for k8s integration (DONE)
03:06:37 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/k8s-integration
03:06:52 <hongbin> I need a volunteer for this one
03:07:09 <shubhams> I would love to be
03:07:15 <hongbin> i set the bp to highest priority since it is frequently requested by people
03:07:18 <pksingh> pksingh: i can pair up with subham
03:07:19 <mkrai> I can help too
03:07:27 <hongbin> shubhams: ack
03:07:47 <shubhams> thanks pksingh mkrai
03:07:51 <eliqiao> sign up for helping reviewing too.
03:08:07 <mkrai> This one will need lots of discussion
03:08:11 <hongbin> shubhams: pksingh mkrai : i will assign it to shubhams , but he don't need to do all the work
03:08:22 <shubhams> mkrai: I agree
03:08:29 <mkrai> hongbin: cool
03:08:47 <hongbin> yes, it would be great if we have 3 people for that.
03:09:12 <pksingh> hongbin: mkrai shubhams we can pair up :)
03:09:13 <shubhams> hongbin: Sounds good to me
03:09:14 <hongbin> shubhams: i rely on you to coordinate the work with mkrai and pksingh :)
03:09:31 <shubhams> hongbin: You can be assured
03:09:47 <hongbin> shubhams: i am going to add this to the weekly team meeting agenda
03:09:58 <shubhams> hongbin: ack
03:10:15 <hongbin> that means i expect any of you to report the status of this bp to the team every week
03:10:32 <hongbin> is it ok for you guys?
03:10:51 <pksingh> hongbin: ok for me
03:10:52 <mkrai> Yes +1
03:10:56 <shubhams> works for me
03:10:59 <eliqiao> cool
03:11:09 <hongbin> #action hongbin add k8s bp to weekly meeting agenda
03:11:19 <hongbin> ok, let's move on
03:11:22 <hongbin> #topic Support interactive mode (kevinz)
03:11:28 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-interactive-mode The BP
03:11:33 <hongbin> #link https://review.openstack.org/#/c/396841/ The design spec
03:11:41 <hongbin> kevinz: :)
03:12:16 <kevinz> I'm thinking about when zun-compute and client are not in the same node
03:12:42 <kevinz> I've tried and this method works
03:12:42 <pksingh> kevinz: client means, zun-client?
03:12:47 <kevinz> yeah
03:13:09 <hongbin> kevinz: maybe you could briefly explain what you already did so far
03:13:10 <kevinz> I will modified the spec according to hongbin and shubhams' comments
03:13:29 <hongbin> kevinz: then, explain what is missing and what you are going to work on
03:13:45 <kevinz> hongbin: in the spec?
03:14:08 <hongbin> kevinz: yes, briefly explain the approach you proposed in the spec
03:14:25 <kevinz> hongbin: OK
03:14:27 <kevinz> no problem
03:14:48 <hongbin> kevinz: since not everyone have reviewed the bp so far, so it is better to give a briefing first
03:15:30 <kevinz> OK. I plan to refer to the library, dockerpty
03:15:52 <hongbin> #link https://github.com/d11wtq/dockerpty
03:16:07 <kevinz> We can create the stdin stdout stderr to connect to the docker tty
03:16:57 <kevinz> docker tty is easy to create when we pass the parameters tty=True and stdin_open=True ,when creating container
03:18:05 <kevinz> Then in python-zunclient, use stdin stdout stderr to connect the docker tty we will get a pesudo tty
03:19:04 <hongbin> kevinz: get that
03:19:10 <kevinz> But dockerpty doesn't satisfied all our request, so I will refer to this to re-write the code
03:19:25 <sudipto> This is good solution when you have the zunclient residing on the same machine as the one running the docker container...
03:19:44 <pksingh> sudipto: +1,
03:19:57 <hongbin> sudipto: you stated the key problem :)
03:20:09 <pksingh> kevinz: how over rest api? do we need some hijacking of http?
03:20:15 <hongbin> i believe kevinz is working on solving this problem
03:20:23 <sudipto> we may have to devise a way to redirect the output to a console.log or a sttderr.log and then read that file remotely... (thinking the VM analogy)
03:20:48 <kevinz> Yeah ,another method is refering to how Nova deal
03:21:08 <sudipto> hongbin, yeah i stated the obvious :)
03:21:17 <pksingh> i think kubectl client for k8 does the same, we can look there if anyone knows golang
03:22:09 <kevinz> sudipto: pksigh: dockerpty also can work and connect remote docker daemon
03:22:55 <hongbin> i don't think zun allowed python-zunclient to connect to docker daemon directly
03:23:16 <hongbin> if users have to connect to docker deamon, it must go through the zun api
03:23:43 <kevinz> hongbin: Then I think nova console give the good method
03:24:08 <eliqiao> mean another service to do FWDing?
03:24:09 <kevinz> will get a redirection
03:24:17 <kevinz> Yeah
03:24:34 <eliqiao> hmm... I kinds doubt that the interactive mode.
03:25:00 <eliqiao> container's differnet with VM. no need too much login operation on containers.
03:25:15 <pksingh> eliqiao: +1
03:25:34 <hongbin> hmm, let's discuss it.
03:25:37 <eliqiao> just my 2 cents.
03:26:19 <kevinz> we can use a method to auto connect the redirection link?
03:26:30 <hongbin> sudipto: i think you also have doubts on the interactive mode as well?
03:27:26 <kevinz> juse link a project "https://github.com/larsks/novaconsole" does
03:27:31 <sudipto> hongbin, no doubts about interactive mode. It all depends on what you want to achieve with it. I agree with eliqiao that there's not much of an interaction really needed with containers. However I do see the logs being important.
03:27:45 <eliqiao> hongbin: I am not strong disagree with it. just don't want us to waste more time on it if it's hard to implement it.
03:28:00 <hongbin> eliqiao: get that
03:28:04 <hongbin> sudipto: ack
03:28:31 <hongbin> kevinz: i think sudipto & eliqiao  gave an important suggestion
03:29:02 <hongbin> kevinz: then, you can first investigate the feasibility to implement this feature
03:29:09 <sudipto> if you want to allow interactive mode, we may have to look at something like a vncclient
03:29:17 <kevinz> hongbin: OK
03:29:22 <hongbin> kevinz: if it turns out to be hard to implement, let's bring it back to the team to discuss
03:29:53 <hongbin> i think interactive mode might be good from user experience point of vie
03:29:55 <hongbin> view
03:30:17 <kevinz> hongbin: Yeah for user it really important experience
03:30:23 <hongbin> but, it might not be so important, we can consider it as an optional feature
03:30:50 <kevinz> OK I will continue investigating this
03:30:55 <hongbin> kevinz: thanks
03:31:11 <hongbin> any other question regarding to this topic?
03:31:11 <kevinz> my pleasure
03:31:26 <sudipto> The interactive mode sort of falls under the attach and exec discussions as well, no?
03:31:40 <hongbin> sudipto: yes
03:32:03 <sudipto> alrite.
03:32:24 <hongbin> ok, move on
03:32:30 <hongbin> #topic Container image store (mkrai)
03:32:35 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/glance-integration The BP
03:32:39 <hongbin> mkrai: ^^
03:32:59 <mkrai> I have implemented the last patch to store image in glance when we pull from docker
03:33:11 <mkrai> But there is some issue storing the image in glance
03:33:24 <mkrai> I am looking at it and will post the patch by today eod
03:33:46 <hongbin> mkrai: what are the issues?
03:33:49 <mkrai> After this patch, we can mark this bp complete
03:34:21 <mkrai> error reading data from http response object
03:34:29 <hongbin> i see
03:34:34 <mkrai> I tried it outside zun and it worked well
03:34:45 <mkrai> But not sure why isn't it working inside zun
03:35:33 <hongbin> mkrai: just let us know if you need help for that
03:36:14 <hongbin> mkrai: in general, the glance integration is almost finish, which is a good progress
03:36:33 <hongbin> thanks mkrai and shubhams and all others for the hard work
03:37:06 <pksingh> yes mkrai and shubhams did great work :)
03:37:34 <hongbin> ok, next topic
03:37:37 <hongbin> #topic Container network (hongbin)
03:37:43 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/neutron-integration The BP
03:37:48 <hongbin> #link https://review.openstack.org/#/c/365754/ The proposed spec (merged)
03:37:56 <hongbin> #link https://review.openstack.org/#/c/380646/ The patch
03:38:28 <hongbin> The link above is the patch, which implement a complete soluation
03:38:44 <hongbin> however, it looks the patch is too large, so i am going to split the patch into several
03:38:57 <mkrai_> Sorry got dc. I will continue in open discussion
03:39:01 <hongbin> this is the first split-out patch
03:39:03 <hongbin> #link https://review.openstack.org/#/c/396896/
03:39:33 <hongbin> i am going to do this step-by-step
03:39:44 <hongbin> first, implement sandbox without nova
03:40:13 <hongbin> second, i am going to add another driver (called novadocker), which uses nova to implement the sandbox
03:40:29 <hongbin> thrid, duplicated the first docker driver (tbd)
03:40:51 <mkrai_> hongbin: this will implement the nova-integration bp as well. Right?
03:41:07 <hongbin> mkrai_: no, nova integration is a different bp
03:41:24 <hongbin> mkrai_: the nova integration bp is for using nova api to connect to zun
03:41:31 <mkrai_> he novadocker driver will include the work I guess
03:41:37 <hongbin> mkrai_: this bp is for using novadocker as a coe
03:41:38 <reedip> armax : Just got your message(reedip: if you can unblock https://review.openstack.org/#/c/393011/, that would be great) , will do this
03:42:08 <hongbin> mkrai_: ??
03:42:20 <mkrai_> we can use the same driver for creating containers
03:42:49 <hongbin> ok, i need to explain that
03:43:08 <mkrai_> Thanks that will be great
03:43:21 <hongbin> for sandbox proposal, we use nova (with docker virt driver) to provision sandbox
03:44:04 <hongbin> for nova integration, i guess it is for implementing a virt driver that connects to zun
03:44:20 <hongbin> it will be a zun virt driver
03:45:06 <mkrai_> Ok I will look at your patch to understand this
03:45:20 <Namrata> i will also have a look
03:45:29 <hongbin> ok
03:45:33 <mkrai_> It seems bit confusing to me and I will get back to you in case of any concern
03:45:42 <hongbin> ok
03:46:08 <hongbin> then, let's move on
03:46:14 <hongbin> #topic Open Discussion
03:46:40 <mkrai_> I want to discuss about https://review.openstack.org/#/c/395552/
03:46:54 <mkrai_> This bp has 'image search' API
03:47:25 <mkrai_> In docker, the search returns image with matching string
03:47:50 <mkrai_> And thats seems correct. But I think there should also be option to search exact image name
03:47:59 <mkrai_> Also search image with tag also
03:48:09 <mkrai_> which currently docker lacks
03:48:24 <mkrai_> So how do team want zun search to work like?
03:48:52 <hongbin> mkrai_: as i commented in the patch, i think it is a good idea to have an option like --exact
03:49:10 <hongbin> mkrai_: this option will search image by exact name
03:49:32 <pksingh> hongbin: +1
03:49:33 <lakerzhou> Hi there, we (lenovo) are actively looking to work with openstack container project. we might have two engineers planning to join ZUN. Is there particular bugs/blueprint that we can start with.
03:49:36 <mkrai_> Ok sounds good to me. I will update the patch
03:49:47 <shubhams> hongbin: should this option be exposed to users ?
03:49:55 <hongbin> mkrai_: for tag, i am not sure, maybe you could have another option
03:50:00 <mkrai_> shubhams: yes
03:50:09 <hongbin> shubhams: yes :)
03:50:18 <pksingh> mkrai_: one more suggestion, url should be /image/search?name=xyz,exact=true
03:50:23 <mkrai_> hongbin: we can add filters also but currently docker doesn't have this option
03:50:24 <hongbin> lakerzhou: good to hear that
03:50:30 <pksingh> hongbin: what do u think?
03:50:54 <mkrai_> pksingh: our REST APIs have been implemented this way
03:51:21 <hongbin> mkrai_: pksingh not sure right now, need to look into it
03:51:51 <mkrai_> pksingh: I am ok with the current format
03:52:07 <mkrai_> pksingh: Can you tell me the reason for this change?
03:52:14 <pksingh> mkrai_: i think current is /image/name/search?
03:52:26 <mkrai_> pksingh: yes
03:52:57 <hongbin> lakerzhou: i will work with you to figure it out
03:53:03 <pksingh> mkrai_: what i think, search always work this way, am i right?
03:53:27 <pksingh> mkrai_: you search anything in a collection by query?
03:54:24 <pksingh> mkrai_: no hard line from me, just a suggestion
03:54:24 <mkrai_> pksingh: yes agree.
03:54:51 <mkrai_> I don't think it is feasible to change just one API
03:55:11 <mkrai_> Other APIs are designed this way for ex /containers/{ID}/logs etc
03:55:34 <pksingh> mkrai_: you can, just pass key=value to search method
03:56:00 <lakerzhou> Hongbin, I was disconnected, maybe I missed something. Do you have any recommendations for starters?
03:56:04 <pksingh> mkrai_: but for them we know the ID, right and we also know that they exist in collection
03:56:30 <hongbin> lakerzhou: i will work with you offline to figure it out (i don't have a list right now)
03:56:53 <mkrai_> We need to change the routing then
03:56:56 <pksingh> mkrai_: either way is ok, just conveying the way docker and goole search api works
03:57:46 <pksingh> mkrai_: i dont think so my patch for 'zun run' works with query parameter
03:57:53 <lakerzhou> Thanks a lot. Hongbin. I will join zun irc channel more often.
03:58:08 <pksingh> mkrai_: and delete also takes force=true in query?
03:58:22 <mkrai_> pksingh: It will work
03:58:32 <mkrai_> What param do you need to pass to run?
03:58:41 <pksingh> start=True
03:58:47 <hongbin> lakerzhou: thanks for your interests to contribute to zun, looking forward to work with you in the future
03:59:01 <pksingh> mkrai_: we can discuss later, i am ok with both the ways
03:59:05 <mkrai_> pksingh: And the endpoint?
03:59:09 <hongbin> ok, time is up
03:59:10 <mkrai_> pksingh: Ok sure
03:59:14 <hongbin> overflow on zun channel
03:59:22 <hongbin> all, thanks for joining hte meeting
03:59:27 <mkrai_> Thanks all!
03:59:31 <hongbin> #endmeeting