03:00:06 <hongbin> #startmeeting zun
03:00:07 <openstack> Meeting started Tue Dec 13 03:00:06 2016 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:10 <openstack> The meeting name has been set to 'zun'
03:00:12 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2016-12-13_0300_UTC Today's agenda
03:00:17 <hongbin> #topic Roll Call
03:00:21 <Namrata> hi
03:00:21 <pksingh> pradeep
03:00:24 <kevinz> kevinz
03:00:34 <Namrata> Namrata
03:00:38 <eliqiao> hi
03:00:41 <eliqiao> eliqiao
03:00:44 <mkrai_> Madhuri Kumari
03:00:54 <shubhams> shubhams:
03:00:58 <Wenzhi> Wenzhi
03:01:09 <hongbin> thanks for joining the meeting Namrata pksingh kevinz Namrata eliqiao mkrai_ shubhams Wenzhi
03:01:19 <hongbin> #topic Announcements
03:01:24 <hongbin> 1. Welcome Pradeep to the core team
03:01:31 <Wenzhi> welcome!
03:01:39 <mkrai_> Congratulations pksingh!
03:01:43 <shubhams> Congrats Pradeep
03:01:45 <eliqiao> great addition!
03:01:45 <hongbin> pksingh: thanks for your contribution. it is good to have you in the core team
03:01:47 <mkrai_> Welcome
03:01:58 <pksingh> thanks all :)
03:02:06 <hongbin> #topic Review Action Items
03:02:12 <hongbin> 1. hongbin create a etherpad to discuss the zun core api (DONE)
03:02:18 <hongbin> #link https://etherpad.openstack.org/p/zun-core-api
03:02:29 <hongbin> we will revisit this etherpad later in the agenda
03:02:35 <hongbin> 2. hongbin start a ML to discuss the k8s integration bp (DONE)
03:02:42 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/108569.html
03:03:02 <hongbin> shubhams replied to the ML
03:03:11 <hongbin> so, let's continue the discussion here
03:03:28 <hongbin> #topic Kubernetes integration (shubhams)
03:03:36 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/k8s-integration The BP
03:03:41 <hongbin> #link https://etherpad.openstack.org/p/zun-k8s-integration The etherpad
03:04:03 <hongbin> shubhams: want to drive this one?
03:04:14 <shubhams> hongbin:  Had discussion with mkrai_ and pksingh  and we think that having a pod (or similar concept) within zun is better than just acting like a proxy
03:04:47 <hongbin> shubhams: ack
03:04:51 <shubhams> We want to know views of team as it will require considerable efforts and analysis if we do it
03:05:22 <hongbin> thoughts everyone?
03:05:25 <diga> o/
03:05:37 <hongbin> welcome to the meeting diga
03:05:48 <diga> hongbin: thnks :)
03:05:55 <Wenzhi> acting like a proxy is definitely not a good idea
03:06:04 <mkrai_> +1 for it as I think behaving as proxy to any COE wouldn't add much value to zun
03:06:19 <eliqiao> +1 for not using proxy as k8s
03:06:44 <hongbin> i also agree on this: no proxy
03:06:46 <pksingh> and having purpose of comon interface for different coe will be defeated if we act like proxy
03:07:35 <hongbin> i think some team members also challenged the necessary to bring k8s to zun
03:07:35 <shubhams> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/108735.html
03:07:44 <sudipto> o/ sorry for being late.
03:07:45 <mkrai_> +1 pksingh
03:07:50 <hongbin> sudipto: hey
03:07:51 <sudipto> logged in from the car :)
03:08:01 <hongbin> sudipto: :)
03:08:12 <hongbin> sudipto: we just discussed the k8s integration bp
03:08:14 <shubhams> Link I posted has the reasoning for our suggestion. Interested people can see :)
03:08:27 <hongbin> sudipto: do you have any comment about that?
03:09:20 <hongbin> shubhams: i think we can break this bp into two : 1. introduce pod, 2. k8s integration
03:09:32 <shubhams> hongbin: agree
03:09:38 <pksingh> hongbin: +1
03:09:39 <hongbin> shubhams: but we can start them in parallel
03:09:49 <shubhams> hongbin: And I think both should work in parallel
03:09:51 <hongbin> #action hongbin split the k8s bp into two
03:10:20 <Wenzhi> if we introduce pod, do we need to introduce k8s's RC and service as well?
03:10:44 <hongbin> Wenzhi: i don't think we should do it right now
03:10:55 <shubhams> Wenzhi: ATM, I dont think we should focus on having them
03:11:02 <Wenzhi> ok
03:11:20 <hongbin> the last question i have for all of you
03:11:49 <hongbin> do you think if it is valuable to bring k8s to zun (since several poeple challenged this idea in before)
03:12:06 <hongbin> just want to make sure if everyone think this is the right direction
03:12:33 <hongbin> any opposition point of view?
03:12:56 <sudipto_> I have POVs, but i am not hard bound.
03:13:17 <mkrai_> As of now I would say "no". When we have our own pod like concept we can eventually integrate k8s also without affecting the end users.
03:13:25 <hongbin> sudipto_: yes, we would like to hear your point of view
03:13:36 <sudipto_> I feel that k8s integration is as good as asking people to use another abstraction on top of kubernetes and us chasing the kubernetes releases to have feature parity.
03:13:46 <mkrai_> All COEs will act yes the drivers and we can plug them in as per use.
03:14:03 <shubhams> I think having k8s is just optional , and not necessary for zun's success .
03:14:29 <sudipto_> yeah and i think the trade off is, whether we should work on optional features or the relatively important ones.
03:14:51 <sudipto_> but if there's a real need for k8s, i would like to hear that.
03:15:48 <diga> hongbin: mkrai_ : Ultimate target is to use zun to provision/manage containers on top of Container infrastructure like k8s, docker swarm etc
03:16:31 <hongbin> ok
03:16:38 <shubhams> hongbin: IIRC, when you came back from Barcelona Summit, you said that people are interested in k8s with zun. What was their motivation for this(if by any chance you could discuss in details)
03:17:07 <hongbin> shubhams: they just kept asking if zun support k8s
03:17:22 <mkrai_> diga: Initially we planned to integrate with k8s, swarm but now it seems people are not in favor of it
03:17:23 <shubhams> hongbin: ok
03:18:09 <hongbin> shubhams: the one that really asked for k8s is other openstack team (i.e. trove). they wanted a unified api for different coe
03:18:19 <sudipto_> My take is, i am not opposed to supporting k8s but it's good to build on the docker driver to support composition of containers first.
03:18:33 <diga> mkrai_: okay
03:19:00 <mkrai_> +1 sudipto_
03:19:02 <Wenzhi> sudipto_: agreed
03:19:03 <sudipto_> else we could have just stuck to being a gateway for the COEs
03:19:04 <hongbin> ok, sounds like we should adjust the priority of the k8s bp?
03:19:15 <shubhams> hongbin: agree
03:19:20 <kevinz> +1 sudipto_
03:19:33 <hongbin> right now, the bp is essential, let's drop it to medium?
03:19:50 <mkrai_> +1
03:19:56 <diga> +1
03:20:01 <hongbin> done
03:20:21 <hongbin> i will create a pod bp, which will be given a higher priority
03:20:26 <sudipto_> +1
03:20:35 <hongbin> sounds good to everyone?
03:20:40 <Wenzhi> good
03:20:44 <hongbin> any other comment?
03:20:46 <mkrai_> Yes
03:20:56 <Qiming> +3
03:21:01 <diga> fine
03:21:02 <hongbin> Qiming: :)
03:21:03 <shubhams> hongbin: sounds good
03:21:07 <hongbin> very good
03:21:10 <pksingh> +1
03:21:25 <hongbin> next one
03:21:26 <hongbin> #topic Support interactive mode (kevinz)
03:21:32 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-interactive-mode The BP
03:21:38 <hongbin> #link https://review.openstack.org/#/c/396841/ The design spec
03:21:41 <hongbin> kevinz: ^^
03:21:50 <kevinz> Hi
03:23:02 <hongbin> kevinz: do you like to give an update for this one?
03:23:03 <kevinz> This week I'm still working to give protocol,,,so I don't have much more update this week. Hope to submit first draft before next meeting
03:23:17 <hongbin> kevinz: ack. that is fine
03:23:22 <kevinz> Thanks~
03:23:33 <hongbin> next topic
03:23:50 <hongbin> #topic Should we hold a team meeting at 2016-12-27 UTC 0300?
03:24:40 <mkrai_> hongbin: Why we don't want to hold meeting?
03:24:45 <shubhams> I will be available
03:24:55 <hongbin> it is xmas
03:24:55 <pksingh> I am available too
03:25:03 <shubhams> mkrai_: many people will be gone for new year leave (i guess)
03:25:09 <sudipto> i will be off.
03:25:09 <mkrai_> I will be available :)
03:25:19 <kevinz> I Will be off too
03:25:20 <Wenzhi> available
03:25:29 <sudipto> Going to thailand :)
03:25:41 <pksingh> sudipto: :)
03:25:51 <hongbin> ok, sounds like half of hte team members will not be available
03:26:03 <hongbin> let me ask another question
03:26:09 <hongbin> #topic Should we hold a team meeting at 2017-01-03 UTC 0300?
03:26:27 <mkrai_> available
03:26:28 <hongbin> will everyone available at Jan 03?
03:26:28 <sudipto> Available for that one :)
03:26:33 <kevinz> Fine
03:26:35 <shubhams> available
03:26:36 <pksingh> available
03:26:43 <diga> yep
03:26:49 <Namrata> available
03:27:02 <hongbin> ok, then how about dropping the 12-27 one, then hold the 01-03
03:27:18 <mkrai_> Ok
03:27:21 <sudipto> would you be available hongbin
03:27:21 <pksingh> k
03:27:21 <sudipto> ?
03:27:40 <hongbin> sudipto: i am not sure, it is a holiday at Canada :)
03:27:59 <hongbin> sudipto: but Jan 03, i will be available
03:28:20 <sudipto> hopefully not logging in from a motor vehicle like me right now :)
03:28:27 <hongbin> #agreed cancel the team meeting at 12-27
03:28:35 <hongbin> sudipto: :)
03:28:47 <hongbin> ok
03:28:51 <hongbin> #topic Open Discussion
03:29:13 <hongbin> there is an etherpad that needs to be discussed: #link https://etherpad.openstack.org/p/zun-core-api
03:29:15 <hongbin> #link https://etherpad.openstack.org/p/zun-core-api
03:29:38 <diga> hongbin: I would like to take this BP - https://blueprints.launchpad.net/zun/+spec/coe-integration
03:29:40 <hongbin> we can do it right now, or leave it as homework
03:30:00 <hongbin> diga: this bp is of priority "not"
03:30:05 <diga> We need to generic layer may be based on the factory implementation
03:30:16 <Qiming> just posted some comments to the core api
03:30:20 <hongbin> diga: which means it is not in the recent roadmap, it is a long term idea
03:30:30 <diga> hongbin: okay
03:30:56 <hongbin> diga: however, you can work with mkrai_ shubhams pksingh for the k8s bp, it is one of the coe
03:31:07 <diga> hongbin: anything I can start
03:31:10 <diga> hongbin: okay
03:31:34 <hongbin> Qiming: you are of color blue?
03:31:47 <Qiming> I cannot read colors, :)
03:31:54 <Qiming> yes, probably
03:32:53 <Qiming> my suggestion is to merge all container operations into a single URL
03:32:58 <hongbin> Qiming: you were suggestion: /containers/<ID>/actions/<ACTION> ?
03:33:10 <Qiming> yes
03:33:19 <hongbin> Qiming: ack
03:33:26 <Qiming> http://developer.openstack.org/api-ref/compute/#servers-run-an-action-servers-action
03:34:14 <hongbin> others, thoughts?
03:35:04 <hongbin> Qiming: i see. nova is designed the api in this way
03:35:13 <pksingh> hongbin: i think action is part of the body?
03:35:16 <Qiming> also, for these operations, maybe we should return 202 instead of 200
03:35:30 <hongbin> pksingh: yes, <action> is in the body
03:35:57 <hongbin> that means make them async?
03:36:11 <Qiming> yes, they are inherently async operations
03:36:37 <hongbin> i see
03:36:43 <mkrai_> Qiming: the benefit is reduced no of APIs exposed?
03:36:54 <Qiming> yes, mkrai_
03:36:57 <mkrai_> Single API endpoint for all actions
03:37:13 <Qiming> except for basic CRUD calls
03:37:22 <mkrai_> Yes got it
03:37:36 <Qiming> a POST to the collection 'actions' means a creation of an action resource
03:37:38 <pksingh> Qiming: isn't it confusing having same url for different controller actions?
03:38:01 <Qiming> that is a more RESTful way to operate your resources
03:38:23 <Wenzhi> right
03:38:40 <Qiming> it is different from CLI or GUI
03:39:04 <Qiming> from CLI or dashboard, you can still present these operations in whatever way users appreciate
03:39:46 <Qiming> just my 2 cents for team to consider
03:39:51 <csomerville> It might be worth asking the nova team if they're happy with that design decision.
03:40:00 <eliqiao> suggest to fellow API design as https://wiki.openstack.org/wiki/API_Working_Group
03:40:44 <eliqiao> s/fellow/follow/
03:41:07 <pksingh> csomerville: +1
03:41:26 <hongbin> ok, i can create a bp for that first
03:41:30 <Qiming> there was a patch #234994 proposing this idea
03:42:02 <Qiming> however, it was stuck by some trivial things, and blocked by the tendency people loves "-1" a patch
03:42:07 <csomerville> Was just discussing today how multiple actions to single URL in nova makes it more difficult to track feature usage by http access logs
03:42:11 <hongbin> then, everyone can cast feedback to the bp (i.e. what is nova POV)
03:42:41 <Qiming> csomerville, reasonable concern though
03:42:54 <mkrai_> hongbin: Qiming How about raising ML with nova in subject?
03:43:08 <Qiming> sounds tood
03:43:09 <pksingh> mkrai_: +1
03:43:10 <Qiming> good
03:43:15 <hongbin> ok
03:43:31 <hongbin> mkrai_: maybe raise it with API WG is more appropreciate
03:43:38 <mkrai_> Yes
03:44:05 <hongbin> #action hongbin raise a ML with API WG to discuss the consolidate of actions into single URL
03:44:33 <hongbin> at the same time, we can ping the nova channel to get more feedback
03:45:01 <hongbin> anything else to discuss?
03:45:31 <hongbin> sounds no more
03:45:40 <hongbin> all, thanks for joining the meeting
03:45:44 <hongbin> #endmeeting