#openstack-meeting: zun

Meeting started by hongbin at 03:00:14 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Zun#Agenda_for_2016-12-20_0300_UTC Today's agenda (hongbin, 03:00:19)

  1. Roll Call (hongbin, 03:00:24)
  2. Announcements (hongbin, 03:02:02)
  3. Review Action Items (hongbin, 03:02:38)
    1. https://blueprints.launchpad.net/zun/+spec/introduce-pod The Pod BP (hongbin, 03:02:49)
    2. https://blueprints.launchpad.net/zun/+spec/k8s-integration The k8s BP (hongbin, 03:02:54)
    3. http://lists.openstack.org/pipermail/openstack-dev/2016-December/109136.html (hongbin, 03:03:43)
    4. http://lists.openstack.org/pipermail/openstack-dev/2016-December/109208.html (hongbin, 03:07:34)

  4. Introduce pod (hongbin, 03:10:08)
    1. https://blueprints.launchpad.net/zun/+spec/introduce-pod The BP (hongbin, 03:10:14)

  5. Support multi-host deployment (hongbin) (hongbin, 03:12:16)
    1. https://blueprints.launchpad.net/zun/+spec/support-multiple-hosts The BP (hongbin, 03:12:23)

  6. Support interactive mode (kevinz) (hongbin, 03:13:41)
    1. https://blueprints.launchpad.net/zun/+spec/support-interactive-mode The BP (hongbin, 03:13:47)
    2. https://review.openstack.org/#/c/396841/ The design spec (hongbin, 03:13:52)
    3. https://github.com/kevin-zhaoshuai/container-interactive-client (kevinz, 03:14:11)
    4. https://github.com/kevin-zhaoshuai/container-interactive-client (hongbin, 03:15:20)
    5. https://www.irccloud.com/pastebin/Nujli3wo (diga, 03:18:22)
    6. https://docs.docker.com/engine/reference/api/docker_remote_api_v1.21/#/resize-a-container-tty (kevinz, 03:18:41)

  7. Make Zunclient an OpenStackClient plugin (Namrata) (hongbin, 03:23:00)
    1. https://blueprints.launchpad.net/zun/+spec/zun-osc-plugin (hongbin, 03:23:05)
    2. http://docs.openstack.org/developer/python-openstackclient/plugins.html#checklist-for-adding-new-openstack-plugins (hongbin, 03:27:12)
    3. https://github.com/openstack/python-barbicanclient/blob/master/setup.cfg#L45-L48 (stevemar, 03:29:04)
    4. ACTION: hongbin start a ML to osc team to discus the name collision issue (hongbin, 03:30:25)
    5. http://lists.openstack.org/pipermail/openstack-dev/2015-October/076354.html (hongbin, 03:32:41)
    6. https://etherpad.openstack.org/p/zunclient_openstack-client-cli (Namrata, 03:37:04)

  8. Open Discussion (hongbin, 03:38:56)
    1. https://review.openstack.org/#/c/391871/ (hongbin, 03:44:23)
    2. https://bugs.launchpad.net/zun/+bug/1650979 (hongbin, 03:49:32)


Meeting ended at 03:53:24 UTC (full logs).

Action items

  1. hongbin start a ML to osc team to discus the name collision issue


Action items, by person

  1. hongbin
    1. hongbin start a ML to osc team to discus the name collision issue


People present (lines said)

  1. hongbin (124)
  2. mkrai_ (21)
  3. stevemar (19)
  4. pksingh_ (16)
  5. kevinz (13)
  6. Namrata (13)
  7. diga (7)
  8. openstack (5)
  9. pksingh (4)
  10. Qiming (4)
  11. prameswar (3)


Generated by MeetBot 0.1.4.