03:00:18 <hongbin> #startmeeting zun
03:00:19 <openstack> Meeting started Tue Jan 24 03:00:18 2017 UTC and is due to finish in 60 minutes. The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:22 <openstack> The meeting name has been set to 'zun'
03:00:25 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-01-24_0300_UTC Today's agenda
03:00:29 <hongbin> #topic Roll Call
03:00:31 <Namrata> Namrata
03:00:32 <shubhams> shubham
03:00:34 <kevinz> kevinz
03:01:24 <hongbin> thanks for joining the meeting Namrata shubhams kevinz
03:01:43 <lakerzhou> Lakerzhou
03:01:52 <mkrai> Madhuri Kumari
03:01:54 <hongbin> i knew these weeks are lunar new year, so some team members might not be able to join
03:02:02 <diga> o/
03:02:02 <hongbin> hey lakerzhou mkrai
03:02:06 <hongbin> hi diga
03:02:15 <diga> hongbin: Hi
03:02:18 <hongbin> ok, let's start
03:02:18 <lakerzhou> Hi Jong in
03:02:24 <hongbin> #topic Announcements
03:02:29 <hongbin> i have one
03:02:51 <hongbin> for zun cores, please vote on the proposal: http://lists.openstack.org/pipermail/openstack-dev/2017-January/110724.html
03:02:55 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110724.html
03:03:08 <hongbin> that is it from my side
03:03:15 <hongbin> anyone else has any announcement?
03:03:31 <hongbin> #topic Review Action Items
03:03:32 <hongbin> none
03:03:37 <hongbin> #topic Cinder integration (diga)
03:03:41 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/cinder-zun-integration The BP
03:03:46 <hongbin> #link https://review.openstack.org/#/c/417747/ The design spec
03:03:50 <hongbin> diga: ^^
03:04:01 <diga> yes
03:04:19 <diga> hongbin: I started the development yesterday
03:04:32 <hongbin> diga: cool
03:04:44 <diga> hongbin: By end of the week, will submit the first PS
03:05:12 <pksingh> Hello
03:05:16 <hongbin> diga: awesome, looking forward to your patch
03:05:23 <hongbin> pksingh: hey
03:05:29 <diga> hongbin: :)
03:05:53 <pksingh> sorry, i got litle late
03:05:58 <hongbin> one thing i am going to add, the design spec of cinder integration has merged
03:06:07 <hongbin> #link https://review.openstack.org/#/c/417747/ The design spec
03:06:08 <diga> hongbin: yes
03:06:21 <hongbin> however, let diga know if there is something that you have a concern
03:06:25 <hongbin> pksingh: np
03:06:58 <hongbin> any other question for diga ?
03:07:26 <hongbin> ok, advance topic
03:07:26 <diga> hongbin: No, I think I am good to go now on the submitted spec
03:07:32 <hongbin> thanks diga
03:07:38 <hongbin> #topic Support interactive mode (kevinz)
03:07:41 <diga> hongbin: welcome!
03:07:45 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-interactive-mode The BP
03:07:50 <hongbin> #link https://review.openstack.org/#/c/396841/ The design spec
03:07:52 <hongbin> kevinz: ^^
03:08:02 <kevinz> Hi
03:08:42 <kevinz> I have uploaded some wip patches both in server side and client side.
03:09:07 <hongbin> kevinz: you have some links?
03:09:10 <kevinz> https://review.openstack.org/#/c/422525/ https://review.openstack.org/#/c/417681/
03:09:31 <hongbin> #link https://review.openstack.org/#/c/422525/
03:09:36 <hongbin> #link https://review.openstack.org/#/c/417681/
03:11:03 <hongbin> kevinz: perhaps you could briefly talk about what is the current status of this bp and what these patches are about
03:11:15 <kevinz> BTW, both the client and server side need more test cases
03:11:31 <pksingh> will find some time to review these patches today
03:12:14 <kevinz> OK. The client side is working for websocket client, user will do the "attach" command , get a websocket link from API server.
03:13:09 <kevinz> The client side use select poll mechanism and some interpt to deal with user input , output and stderr
03:14:29 <hongbin> kevinz: cool
03:14:36 <kevinz> In server side, there are two API, one is about "attach", mainly to get the Docker daemon version. The other is "resize", to do the resize tty function in the compute node
03:15:06 <kevinz> That's the briefly introduction about these two patch :-)
03:15:28 <hongbin> kevinz: thanks for the introduction
03:15:42 <hongbin> kevinz: is there any road blocker so far for implementing this bp?
03:15:57 <hongbin> kevinz: e.g. the docker-py version, etc.
03:17:16 <kevinz> Hongbin: Just one problem, websocket link need the compute node ip, or hostname
03:17:38 <hongbin> kevinz: use the host_ip in the config file will work?
03:18:33 <kevinz> hongbin: Does API server know all the compute nodes' IP?
03:19:18 <hongbin> kevinz: i am not sure exactly, it seems no
03:19:50 <kevinz> I konw API server can search from DB to get all computes node's hostname, but I'm not sure this "hostname" can work in websocket link, I will check it
03:19:52 <hongbin> kevinz: i think the compute host needs to return the ip address
03:20:36 <kevinz> hongbin: OK, that is a solution, I will add to the attach function.
03:20:42 <kevinz> Thanks
03:20:56 <hongbin> kevinz: alternatively, there is a 'host' field in container, check that as well
03:21:04 <hongbin> kevinz: thanks kevinz
03:21:20 <hongbin> all, any other question for kevinz ?
03:21:24 <kevinz> Yeah ,I will check this.
03:21:57 <hongbin> ok, next topic
03:22:00 <hongbin> #topic How to expose CPU configurations for containers
03:22:30 <hongbin> it looks sudipta is not here, but he discussed with me in before about that
03:22:57 <hongbin> both I and he agree to expose the vcpu as the resource constraint
03:23:06 <hongbin> for simplicity
03:23:43 <hongbin> at the backend, we tranaslate vcpu into docker specific config (e.g. cpu_period, cpu_share, etc.)
03:24:15 <pksingh> seems interesting
03:24:26 <hongbin> later, sudipta will propose a feature to pin to container to specific cpu cores
03:24:46 <hongbin> all, thoughts?
03:25:31 <pksingh> i did not get much time last week, will look more into it
03:25:47 <mkrai> I guess we need a spec for this
03:25:59 <pksingh> mkrai: +1
03:26:04 <hongbin> mkrai: ack
03:26:32 <hongbin> i think we need to create a bp first
03:26:45 <hongbin> #action hongbin create a bp for exposing container cpu resource
03:27:15 <hongbin> ok, it looks that is all the discussion about this topic, anything else to add?
03:27:46 <pksingh> hongbin: you and sudipto discussed on zun channel, right?
03:28:06 <hongbin> pksingh: i don't remember...
03:28:13 <pksingh> hongbin: :)
03:28:20 <lakerzhou> Is it related to CPU pinning?
03:29:09 <hongbin> pksingh: if you cann't find the log in zun channel, perhaps, it is a private chat, sorry, i didn't pay attention at that time
03:29:17 <lakerzhou> Do we support flavor in sun?
03:29:22 <pksingh> hongbin: no problem
03:29:25 <hongbin> lakerzhou: yes, the cpuset feature is about cpu pinning
03:29:49 <lakerzhou> Zun*
03:30:05 <hongbin> lakerzhou: the native docker driver don't have a flavor, the nova driver will have a flavor
03:30:41 <hongbin> lakerzhou: this bp covers some of the details: https://blueprints.launchpad.net/zun/+spec/auto-select-nova-flavor
03:31:17 <lakerzhou> Ok, I guess I should read it first
03:31:25 <lakerzhou> Thank you
03:31:51 <hongbin> ok, if there is no other comment, i am going to advance topic
03:32:06 <hongbin> #topic Discuss BPs that are pending approval
03:32:12 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-port-bindings Support container port mapping
03:32:35 <hongbin> this proposal is about expose the port mapping feature in zun api
03:32:54 <hongbin> folks, any thoughts on this one? good idea? bad idea?
03:33:20 <pksingh> we discussed on this one, that this will expose compute node network?
03:33:34 <hongbin> yes, it seems it will
03:34:27 <pksingh> i think we also decided not to do it as of now, if i remmeber
03:34:41 <hongbin> pksingh: ack
03:34:58 <hongbin> others, thoughts?
03:35:15 <shubhams> I think its a good to have feature but not very much urgent for now
03:35:41 <hongbin> shubhams: i think pksingh means this is not a good idea at all
03:36:25 <shubhams> hongbin: I got that and my view point stands same : We could have it
03:36:43 <hongbin> shubhams: i see
03:37:06 <hongbin> shubhams: could you elaborate? why it is good to have it?
03:37:27 <mkrai> pksingh: Can you tell us the reason of not supporting it?
03:37:36 <hongbin> shubhams: would love to consider your input :)
03:37:38 <mkrai> I just want to know the reason behind it
03:37:59 <shubhams> In some (or infact most) scenarios application would want to run on a specific ports and many apps tends to rely on certain ports
03:38:19 <pksingh> mkrai: this needs to go through compute's node network, because port will be of compute node, and we dont want to give access of compute node to anyone
03:38:54 <hongbin> shubhams: this sounds like a k8s service feature
03:39:01 <shubhams> In such scenarios if users of zun could bind ports then it would be easy for them to deploy. They do not need to change anything in their application
03:39:06 <shubhams> hongbin: yes similar
03:39:43 <hongbin> shubhams: ok, i see. i think your requested feature is valid, however, it could be achieved in an alternative way
03:40:06 <hongbin> shubhams: i.e. support k8s service similar feature in zun
03:40:22 <shubhams> pksingh: Do you mean to say, we do not want user to know which ports are free and which are in use ?
03:40:44 <mkrai> pksingh: got your point. But isn't the same way implemented in docker?
03:40:48 <hongbin> shubhams: however, as pksingh said, the port mapping feature has security risk to expose the management network for attack, this is a critial pitfall i think
03:41:03 <shubhams> hongbin: may be that could solve the purpose but I am not sure as of now about it
03:41:13 <pksingh> shubhams: i dont want that user access computenodeip:port
03:41:23 <pksingh> we can have different mechanism to do it
03:41:30 <hongbin> shubhams: ack
03:41:30 <shubhams> hongbin: pksingh : acked
03:42:09 <hongbin> ok, then let me create a bp to record this use case
03:42:23 <hongbin> however, i will leave the solution open, so we could further think about it
03:42:25 <pksingh> mkrai: in docker user is controlling the his node, directly i thnk
03:42:35 <pksingh> hongbin: +1
03:42:59 <hongbin> #action hongbin create a bp to add support for expose container port
03:43:36 <hongbin> any additional comment about this one?
03:44:05 <hongbin> ok, next one
03:44:11 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-zun-top Support top command
03:44:30 <hongbin> this proposal is about adding support for 'docker top' command in zun
03:44:38 <hongbin> what do you think abou the idea?
03:45:07 <shubhams> hongbin: How this will work in multihost env ?
03:45:20 <mkrai> +1 for this
03:45:30 <mkrai> same question as shubhams
03:45:44 <hongbin> shubhams: i am not sure exactly
03:45:54 <mkrai> #link https://review.openstack.org/#/c/423971/
03:46:00 <mkrai> there is patch already for this I guess
03:46:03 <pksingh> shubhams: multihost means?
03:46:19 <mkrai> Is feng present today?
03:46:28 <hongbin> mkrai: i don't think so
03:46:33 <shubhams> pksingh: multiple hosts for container deployment
03:47:05 <pksingh> shubhams: it is getting top logs of the container, i think, what is the challange
03:47:21 <shubhams> IMO, we should have it but we also need a small spec as well
03:47:48 <pksingh> shubhams: +1
03:48:09 <hongbin> shubhams: could you relay your comment to the review?
03:48:24 <shubhams> hongbin: yes sure
03:48:43 <hongbin> shubhams: thx
03:49:13 <hongbin> ok, it looks that is all for this one
03:49:30 <hongbin> #topic Open Discussion
03:49:50 <hongbin> all, any other topic to bring up?
03:50:20 <hongbin> Namrata: are you working on the Zun resource in Heat?
03:50:31 <Namrata> yes I am working on it
03:50:53 <hongbin> Namrata: great, feel free to share if there is any update from your side :)
03:51:33 <Namrata> yeah sure I will add soem patches this week
03:51:38 <Namrata> *some
03:51:42 <hongbin> cool
03:52:57 <pksingh> hongbin: which cycle we are targeting? :)
03:53:18 <hongbin> pksingh: zun is currently at indepedent release mode
03:53:34 <hongbin> pksingh: that means we are free to decide which cycle to target
03:53:42 <hongbin> pksingh: you have any thought about that?
03:53:53 <pksingh> hongbin: ok, cool
03:54:16 <pksingh> hongbin: i think if we can implement all the necesary BPs, then we can decide
03:54:30 <hongbin> pksingh: agree
03:54:54 <hongbin> ok, it looks there is no more topic
03:55:04 <hongbin> all, thanks for joining the meeting
03:55:08 <hongbin> #endmeeting