03:00:04 <hongbin> #startmeeting zun
03:00:05 <openstack> Meeting started Tue Jan 31 03:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:08 <openstack> The meeting name has been set to 'zun'
03:00:10 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-01-31_0300_UTC Today's agenda
03:00:14 <hongbin> #topic Roll Call
03:00:17 <Namrata> Namrata
03:00:19 <shubhams> Shubham
03:01:18 <hongbin> thanks for joining the meeting Namrata shubhams
03:01:49 <hongbin> these weeks are chinese new year, so a lot of folks are vacation right now
03:02:07 <shubhams> hongbin:  seems we 3 only. Lets wait for a minute or two for others to join .
03:02:13 <lakerzhou> Hongbin, I am here also
03:02:21 <hongbin> hey lakerzhou
03:02:38 <hongbin> yes, let's wait for a minute
03:02:49 <diga> o/
03:02:55 <hongbin> diga: hi
03:03:04 <diga> hongbin: Hi
03:03:07 <hongbin> ok, let's have a short meeting this week
03:03:13 <hongbin> #topic Announcements
03:03:18 <hongbin> 1. Welcome Kevin to the core team
03:03:27 <hongbin> #topic Review Action Items
03:03:31 <mkrai> Hi
03:03:34 <mkrai> Sorry I am late
03:03:36 <hongbin> 1. hongbin create a bp for exposing container cpu resource (N/A, a BP was already created)
03:03:41 <mkrai> Welcome kevin
03:03:51 <hongbin> mkrai: hi mkrai , thanks for joining the meeting
03:03:58 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/cpuset-container Support pinning container to CPU cores
03:04:12 <hongbin> 2. hongbin create a bp to add support for expose container port (DONE)
03:04:18 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/expose-containerized-app
03:04:27 <hongbin> any question about these two action items?
03:05:03 <hongbin> seems not. next topic
03:05:05 <hongbin> #topic Cinder integration (diga)
03:05:10 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/cinder-zun-integration The BP
03:05:15 <hongbin> #link https://review.openstack.org/#/c/417747/ The design spec
03:05:22 <hongbin> diga: ^^
03:05:28 <diga> yes
03:05:41 <hongbin> diga: any update from your side about hte cinder integration?
03:05:51 <diga> hongbin: I am working on it, but last week i was busy product release so couldn't get time
03:06:02 <hongbin> diga: np
03:06:12 <diga> I am starting today on it, as yesterday we shipped the release
03:06:30 <hongbin> diga: thanks diga
03:06:42 <diga> hongbin: one more thing, I got official support from my company to contribute to OpenStack
03:06:55 <hongbin> diga: good to hear
03:06:58 <sudipto_> o/
03:07:05 <diga> hongbin: I think today onward I can spend at least 2 hours
03:07:05 <hongbin> sudipto_: hey
03:07:14 <sudipto_> sorry a little late today.
03:07:22 <hongbin> diga: great
03:07:25 <hongbin> sudipto_: np
03:07:38 <diga> hongbin: just one question on driver
03:07:50 <hongbin> diga: go ahead
03:08:15 <diga> hongbin: as we are writing driver for image, storage, networking etc
03:08:47 <diga> hongbin: can we have center driver folder & under that we can create multiple drivers
03:08:49 <diga> ?
03:09:21 <diga> drivers/images driver/volumes  drivers/networks etc
03:09:33 <diga> to keep the design simple
03:09:49 <mkrai> I think that can be done
03:09:54 <hongbin> i think nova is using this structure
03:10:01 <diga> Yes
03:10:12 <hongbin> images/driver volumes/driver networks/driver
03:10:38 <lakerzhou> I started reading code. It sounds a good idea to me.
03:10:55 <diga> okay
03:11:40 <diga> I think this design structure we should follow going ahead
03:11:41 <hongbin> diga: however, i think container driver is the only important driver for us
03:11:54 <diga> hongbin: okay
03:12:01 <hongbin> diga: we are not writting drivers for network and volume (kuryr does)
03:12:23 <hongbin> diga: but feel free to propose the folder change if you think it is better
03:12:24 <diga> hongbin: okay
03:12:41 <diga> hongbin: Sure
03:12:58 <diga> hongbin: Thanks
03:13:00 <hongbin> diga: any other question from you?
03:13:08 <diga> hongbin: No, I am done!
03:13:17 <hongbin> thanks diga
03:13:24 <hongbin> #topic Kuryr integration (hongbin)
03:13:29 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/kuryr-integration The BP
03:13:40 <hongbin> i give a short update of this one
03:13:59 <hongbin> i have wrote down the spec, and needs a few patch from kuryr side to merge
03:14:33 <hongbin> all, feel free to comment on the spec if you like
03:14:41 <diga> will go through the spec
03:14:47 <hongbin> #link https://review.openstack.org/#/c/425883/
03:14:55 <mkrai> What patches from Kuryr side?
03:15:14 <hongbin> #link https://review.openstack.org/#/c/426595/
03:15:20 <hongbin> above is the kuryr patch
03:15:42 <mkrai> Ok got it
03:15:43 <diga> mkrai: I think idea is same as we have proposed for volume integration, we are not going to call kuryr API
03:16:27 <diga> hongbin: am i correct ?
03:16:36 <hongbin> diga: i think you are
03:16:58 <diga> yep
03:17:04 <hongbin> ok, advance topic
03:17:08 <hongbin> #topic Support interactive mode (kevinz)
03:17:20 <hongbin> it looks kevin is on vacation
03:17:24 <hongbin> skip this one
03:17:29 <hongbin> #topic The image API (prameswar)
03:17:34 <hongbin> #link https://review.openstack.org/#/c/425249/
03:17:36 <prameswar> hi
03:17:41 <prameswar> Currently, we are storing image data in db. instead of db we can use storage driver for that as we discussed before.
03:18:25 <prameswar> we can support multiple image driver
03:18:37 <prameswar> to store image
03:18:51 <prameswar> what you guys think ?
03:18:54 <mkrai> prameswar: By storage driver, you mean?
03:19:28 <prameswar> sorry image driver
03:19:34 <prameswar> like docker store images
03:19:42 <diga> prameswar: you mean you want to store image in object store ??
03:19:58 <prameswar> kind of
03:20:25 <prameswar> i am not sure what exactly but db not seems good
03:20:34 <prameswar> to me
03:20:46 <mkrai> We are just storing the image info in db
03:20:58 <mkrai> We have glance/docker to store images
03:21:27 <prameswar> but i think docker store image info in some json format
03:21:32 <prameswar> if i am not wrong
03:21:41 <prameswar> it don't use database
03:21:43 <diga> this is good thing to store in glance
03:21:59 <mkrai> yes
03:22:41 <hongbin> prameswar: right now, image API has list/show/pull/search
03:22:46 <shubhams> prameswar:  Any pitfalls or disadvantages you see having info stored in db? asking as only basic info is stored in db as of now
03:23:16 <hongbin> prameswar: if we skip the db, than all these operations are got from dockerhub/glance, is that correct?
03:23:47 <prameswar> i think so
03:23:51 <sudipto_> prameswar, yes docker stores them in json blob, but why do we have to change for that?
03:24:37 <diga> I dont see any problem in storing image url info in db
03:24:41 <hongbin> i think the problem right now is that the image api is not able to handle the multi-host senario
03:24:59 <mkrai> hongbin: Yes that is a valid point
03:25:01 <hongbin> e.g. zun image-search : it search image in one host
03:25:03 <shubhams> hongbin:  correct
03:25:36 <hongbin> i guess this is a motivation mentioned in the review
03:25:53 <diga> okay
03:26:11 <hongbin> it seems prameswar 's proposal could solve the problem (although i haven't think about it carefully)
03:26:45 <hongbin> prameswar: i think you can propose a spec if you want to do that
03:26:49 <prameswar> let me spend some time on this . i will collect some more info then will let you know
03:27:04 <prameswar> yes , sure
03:27:20 <mkrai> +1 for spec
03:27:31 <hongbin> yes, then we can discuss on the spec
03:27:56 <diga> I will go through the spec today
03:28:01 <hongbin> any other comment about this topic?
03:28:41 <hongbin> ok, next topic
03:28:49 <hongbin> #topic Discuss BPs that are pending approval
03:28:54 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-blkio Support blkio
03:29:43 <hongbin> i didn't get a chance to study the blkio option yet
03:29:50 <hongbin> anyone else has a comment on this one?
03:30:05 <mkrai> It seems that it will be good to support
03:30:17 <hongbin> mkrai: ack
03:30:19 <sudipto_> Doesn't have much details?
03:30:42 <hongbin> sudipto_: no, it doesn't
03:30:50 <diga> what use case we solve using this BP ?
03:31:03 <hongbin> i am not sure exactly what was proposed....
03:31:18 <diga> okay
03:31:22 <mkrai> limit the IO operation per container
03:31:29 <hongbin> ok, let me ask for clarification in the bp before approving it
03:31:36 <diga> ok
03:31:58 <diga> we should explore more on this
03:32:05 <hongbin> any other comment?
03:32:20 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-zun-stats Support stats
03:32:50 <sudipto_> IMO, this is a good addition.
03:33:04 <hongbin> sudipto_: ack
03:33:13 <mkrai> There is patch already for this
03:33:20 <hongbin> sudipto_: do you know the docker stats command well?
03:33:35 <hongbin> sudipto_: what this command is going to do?
03:33:48 <mkrai> No that is for top. Sorry
03:33:59 <sudipto_> hongbin, yeah sort of. This should you the top command equivalent data of sorts.
03:34:08 <sudipto_> but for each docker container.
03:34:23 <hongbin> sudipto_: is the data streaming from server to client?
03:34:42 <sudipto_> hongbin, yes.
03:34:56 <hongbin> sudipto_: i see
03:35:00 <sudipto_> it does not give you a snapshot, rather a continuous stream.
03:35:12 <sudipto_> i guess that's what you asked.
03:35:19 <hongbin> sudipto_: yes
03:35:32 <hongbin> i am not sure how to implement it then, since it is streaming
03:36:02 <hongbin> also, i am not sure how to handle the multi-host senario
03:36:14 <diga> does docker expose stats API ?
03:36:15 <hongbin> does the data streaming from multiple hosts?
03:36:22 <mkrai> diga: Yes
03:36:30 <diga> ok
03:36:36 <hongbin> sudipto_: ^^
03:36:51 <sudipto_> hongbin, I haven't tried this on multiple hosts.
03:36:59 <hongbin> :)
03:37:04 <lakerzhou> Who will consume the stats data? Apps such as ceilometer?
03:37:21 <hongbin> lakerzhou: i don't know that as well
03:37:31 <sudipto_> lakerzhou, i guess yes. But that way zun command line may not be needed to support it.
03:38:09 <diga> in that case, if docker shows stats for one docker endpoint, so in this case, we can accept docker host & for the first time, we should accept one docker host to display stats
03:38:48 <diga> streaming from multiple hosts we can think more
03:38:48 <mkrai> stats is per container
03:38:56 <hongbin> diga: host should be an admin-only api (at least in nova)
03:39:12 <diga> hongbin: okay
03:39:16 <sudipto_> Maybe this is a better fit in Ceilometer?
03:39:19 <hongbin> mkrai: i think top is per container?
03:39:30 <hongbin> sudipto_: not sure
03:40:03 <mkrai> hongbin: Display a live stream of container(s) resource usage statistics
03:40:18 <hongbin> mkrai: ok
03:40:50 <hongbin> all, should this bp be approved/disapproved, or table it?
03:41:05 <mkrai> Then the multiple host issue is not valid I guess
03:41:17 <hongbin> i see
03:41:22 <diga> hmm
03:41:29 <mkrai> I think we need to look how do we handle the live streaming?
03:41:34 <mkrai> from docker daemon to zun
03:41:43 <diga> yeah
03:42:18 <hongbin> this would not be easy, might be something similar to what kevin was doing (interactive mode)
03:42:32 <mkrai> Yes
03:42:32 <diga> there are other libraries support live streaming we can use those, but it will be dependancy in zun
03:43:03 <mkrai> We can ask the author of bp to see the feasibility of doing this in zun
03:43:12 <hongbin> sure
03:43:16 <diga> +1
03:43:19 <hongbin> then, let's table this bp
03:43:33 <diga> yep
03:43:40 <hongbin> until we get the answer from the author
03:43:52 <hongbin> #topic Open Discussion
03:43:53 <diga> this is good addition to Zun
03:43:53 <shubhams> hongbin: +1
03:44:11 <hongbin> all, any other topic to discuss
03:44:26 <diga> hongbin: are we planning for PTG ?
03:44:39 <sudipto_> I just posted a spec here: https://review.openstack.org/#/c/427007/2/specs/cpuset-container.rst (It's pretty much out of my head atm) - please take a look when you can.
03:44:48 <hongbin> diga: no, zun won't attend the ptg
03:45:03 <diga> hongbin: okay
03:45:23 <hongbin> sudipto_: cool
03:45:27 <Namrata> i have posted a patch to add zun resources https://review.openstack.org/#/c/426210/
03:45:58 <sudipto_> This is an attempt to build host capabilities in zun as well. I will keep refining the spec as we  go. Let me know if there' sa need for a separate BP all together for host capabilities.
03:46:01 <hongbin> Namrata: awesome!
03:46:27 <Namrata> thanks.it is up for review
03:46:46 <hongbin> sudipto_: i think the host capabilities worth a separated spec, it would be a lot of work
03:47:14 <sudipto_> yeah i have wrote down very minimalistic things, I am guessing you'd have to help me out co-authoring some of the stuff hongbin
03:47:27 <hongbin> sudipto_: for sure
03:47:42 <hongbin> #action hongbin create a spec for host capability
03:48:09 <hongbin> i guess a lot of code will be copied from nova :)
03:48:26 <sudipto_> hongbin, yeah maybe, we probably wouldn't need many things as well.
03:48:45 <hongbin> yes
03:48:55 <hongbin> ok, any other topic?
03:49:17 <hongbin> today, many chinese folks are not able to come due to the chinese new year
03:49:31 <mkrai> Happy chinese new year hongbin :)
03:49:35 <hongbin> then, let's end the meeting a bit earlier
03:49:45 <hongbin> mkrai: thank you :)
03:49:46 <sudipto_> Happy new year hongbin :)
03:49:54 <hongbin> thanks
03:50:00 <diga> hongbin: Happy New year!
03:50:09 <hongbin> all, thanks for joining hte meeting
03:50:12 <hongbin> #endmeeting