03:00:07 <hongbin> #startmeeting zun
03:00:08 <openstack> Meeting started Tue Feb  7 03:00:07 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:12 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-02-07_0300_UTC Today's agenda
03:00:12 <openstack> The meeting name has been set to 'zun'
03:00:16 <hongbin> #topic Roll Call
03:00:21 <Namrata> Namrata
03:00:24 <sudipto> o/
03:00:24 <lakerzhou> lakerzhou
03:00:28 <kevinz> kevinz
03:00:29 <mkrai> Madhuri Kumari
03:00:31 <Wenzhi> Wenzhi
03:01:02 <hongbin> thanks for joining the meeting Namrata sudipto lakerzhou kevinz mkrai Wenzhi
03:01:11 <hongbin> let's get started
03:01:13 <hongbin> #topic Announcements
03:01:17 <hongbin> none
03:01:22 <hongbin> #topic Review Action Items
03:01:28 <hongbin> 1. hongbin create a spec for host capability (DONE)
03:01:33 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/expose-host-capabilities
03:01:48 <hongbin> any comment on this bp?
03:02:11 <mkrai> Is there any spec posted for it?
03:02:29 <hongbin> mkrai: sudipto has drafted a spec about cpu policy
03:02:33 <lakerzhou> I haven't got chance to read it, but will do it tomorrow.
03:02:42 <mkrai> I read the bp and the idea is clear
03:02:50 <hongbin> ok
03:03:00 <eliqiao_> hi
03:03:06 <hongbin> hey eliqiao_
03:03:08 <eliqiao_> I am late ,sorry, in a meeting.
03:03:14 <hongbin> np
03:03:28 <hongbin> lakerzhou: thanks for your comment on the spec, it is helpful
03:03:36 <hongbin> ok, moving on
03:03:38 <hongbin> #topic Cinder integration (diga)
03:03:45 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/cinder-zun-integration The BP
03:03:50 <hongbin> #link https://review.openstack.org/#/c/417747/ The design spec
03:04:03 <hongbin> it looks diga is not here
03:04:11 <hongbin> i saw he submitted a patch for that
03:04:26 <hongbin> #link https://review.openstack.org/#/c/429943/
03:04:39 <hongbin> feel free to comment on the patch if you like
03:04:51 <hongbin> any comment on this bp?
03:05:24 <hongbin> ok, next topic
03:05:26 <hongbin> #topic Kuryr integration (hongbin)
03:05:32 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/kuryr-integration The BP
03:05:57 <hongbin> i am working on this one, there is a spec that seems to be closed
03:06:08 <hongbin> #link https://review.openstack.org/#/c/425883/
03:06:30 <hongbin> feel free to comment on it if you interest
03:06:48 <hongbin> any comment?
03:07:22 <hongbin> ok, next one
03:07:23 <hongbin> #topic Support interactive mode (kevinz)
03:07:29 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-interactive-mode The BP
03:07:33 <hongbin> #link https://review.openstack.org/#/c/396841/ The design spec
03:07:36 <hongbin> kevinz: ^^
03:08:05 <kevinz> Hi hongbin, I've submitted a new patch set after address you and Pradeep's comments
03:08:07 <kevinz> https://review.openstack.org/#/c/422525/
03:08:41 <kevinz> If the API and code is Ok, I will add more test cases for this
03:09:15 <hongbin> cool, will find some time tomorrow to go through it again
03:09:37 <kevinz> OK Thanks :D
03:09:57 <hongbin> kevinz: a question for you, which version of docker-py you required for this feature?
03:10:27 <kevinz> hongbin: Now it's fine with currently version.
03:10:33 <hongbin> kevinz: ack
03:11:12 <hongbin> any other comment on this feature?
03:11:32 <sudipto_> I will go through the code today.
03:11:59 <hongbin> thanks kevinz sudipto_
03:12:04 <kevinz> sudipto_: Cool, thanks
03:12:13 <hongbin> ok, next one
03:12:15 <hongbin> #topic Introduce host capabilities and cpusets
03:12:20 <hongbin> #link https://review.openstack.org/#/c/427007/ The spec
03:12:27 <hongbin> sudipto_: you want to drive this one?
03:12:58 <sudipto> Ok, so this is the work for exclusive cpusets that drove us to think about a light weight scheduler to begin with.
03:13:15 <sudipto> lakerzhou, recommended that we do this work keeping in mind the nova's new placement API.
03:13:27 <lakerzhou> "ZUN won't support a compute host to have both dedicated and a shared policy at the same time applicable to it. " sounds to me, this assumption is too strong
03:13:56 <mkrai> Is there any link for nova's new placement API? What is it?
03:14:17 <hongbin> #link http://docs.openstack.org/developer/nova/placement.html
03:14:19 <sudipto> lakerzhou, the reason why this is dicey is because, for a shared case - you wouldn't know which cpusets are being shared - and then if the user requests dedicated - then you may take out the already in use cpusets
03:14:31 <sudipto> the same behaviour is in Nova as well today.
03:14:38 <lakerzhou> can you please explain a little bit why to make such assumption? we can talk offline if you prefer
03:15:35 <sudipto> Nova's new placement APIs are still getting ironed out, so i have made a few 'ease of use' assumptions for us.
03:16:35 <lakerzhou> The assumption is different than existing nova's behavior.
03:17:17 <lakerzhou> do you think it is final design, or temporary solution?
03:17:28 <sudipto> lakerzhou, http://specs.openstack.org/openstack/nova-specs/specs/ocata/approved/nested-resource-providers.html#proposed-change - In the proposed change section - the second last paragraph
03:18:24 <diga> o/
03:18:26 <lakerzhou> ok, I will check again. let 's take it offline. It sounds a big change to me.
03:18:34 <hongbin> diga: hey, thanks for joining
03:18:35 <sudipto> lakerzhou, this behaviour can be changed, given we can isolate NUMA nodes within a given host that would be used for pinning. However, if you have a solution w.r.t how this mixed case can be achieved, then why not.
03:18:36 <diga> sorry got late
03:18:55 <sudipto> lakerzhou, sounds good. Your reviews have been helpful.
03:19:36 <sudipto> Request everyone to take a look and comment as much as possible. Esp on the implementation details.
03:19:53 <sudipto> hongbin, i am done :-)
03:19:58 <diga> sudipto: I hv gone through your spec, we are only considering NUMA nodes for this BP ?
03:20:01 <hongbin> sudipto: thx
03:20:46 <sudipto> diga, you could do a normal pinning as well - on a system that does not come with the NUMA capabilities (older generation) - but i thought supporting hyper threading for such systems is a must.
03:20:59 <diga> sudipto: okay
03:21:09 <sudipto> diga, however, these things can be worked out once we have the first draft of the code out.
03:21:26 <sudipto> I was just taking the most important/simplistic case to begin with.
03:21:47 <diga> sudipto: let me know if you need any help, I am working with nova-placement & have good exp in placement scenarios
03:21:50 <diga> okay
03:22:09 <sudipto> diga, great, first of all, i would need your help in reviewing the spec as brutally as possible :-)
03:22:28 <diga> sudipto: sure, will go through it today
03:23:03 <sudipto> hongbin, we are done i think.
03:23:09 <sudipto> as in on this topic
03:23:15 <hongbin> any further comment on this topic?
03:23:31 <hongbin> seems not
03:23:48 <hongbin> diga: you want to give a brief update about the cinder volume work?
03:23:59 <diga> hongbin: yes
03:24:08 <hongbin> diga: go ahead
03:24:42 <diga> hongbin: cinder  & docker related work in remaining, API/DB level work is done
03:25:19 <diga> hongbin: I am targeting cinder & Docker to complete in 2 days
03:25:29 <hongbin> diga: cool
03:25:47 <diga> hongbin: simultaneosly working on zunclient for volume create/show/list/delete
03:26:31 <diga> hongbin: I think i will try to complete everything by next week core code, test case i will try to complete but not sure
03:26:42 <hongbin> diga: sound great
03:27:03 <hongbin> diga: thanks for your hard work on this one
03:27:11 <sudipto> diga, thank you!
03:27:19 <sudipto> I would ben more than happy to review the code.
03:27:20 <diga> sudipto: hongbin: welcome!
03:27:33 <diga> sudipto: :) sure
03:27:52 <hongbin> ok, then let's enter open discussion
03:27:57 <hongbin> #topic Open Discussion
03:28:19 <hongbin> Namrata: you want to give a brief update about your Heat resource work?
03:28:44 <Namrata> yeah sure.
03:28:59 <diga> hongbin: I think we should plan mid-cycle meeting or remote PTG in this month (one or two days), to plan Pike cycle features
03:29:15 <Namrata> I have added zun resourceshttps://review.openstack.org/#/c/426210/
03:29:22 <hongbin> diga: one second
03:29:44 <Namrata> https://review.openstack.org/#/c/429259/ zun client plugin too
03:29:55 <hongbin> #link https://review.openstack.org/#/c/426210/
03:30:02 <hongbin> #link https://review.openstack.org/#/c/429259/
03:30:08 <Namrata> i will join the heat meeting tommorow and ask for reviewing the patches
03:30:36 <hongbin> Namrata: thanks
03:30:53 <hongbin> Namrata: the patches look good to me so far
03:30:53 <Namrata> further i will be working on container resource
03:31:01 <Namrata> thanks hongbin
03:31:14 <hongbin> yes, it will be a very useful feature
03:31:22 <hongbin> i knew solum team is looking for that
03:31:44 <diga> Namrata: hongbin : this work should go to heat correct ? zun driver in Heat ?
03:32:07 <mkrai> diga: Yes
03:32:10 <Namrata> diga:yes
03:32:15 <diga> okay
03:33:24 <hongbin> ok, does anyone else want to bring a topic for team discussion?
03:33:47 <eliqiao_> yes hongbin
03:33:57 <hongbin> eliqiao_: go ahead
03:34:10 <eliqiao_> would like to talk the disadvantage of some detail
03:34:25 <hongbin> disadvantage of ?
03:34:40 <eliqiao_> I tried zun recently, and found that if I create a sandbox with novadocker driver
03:34:59 <eliqiao_> we will ensure sandbox is ready (a poll with timeout)
03:35:21 <hongbin> yes
03:35:28 <eliqiao_> but if I delete the container before the sandbox is ready, the poll is still going.
03:35:42 <hongbin> i see
03:35:54 <eliqiao_> the correct logic is need to notice it and stop polling...
03:36:07 <hongbin> agree
03:36:31 <hongbin> eliqiao_: i think you filed a bug for that already?
03:36:35 <eliqiao_> seems no good solution to resolve this :(
03:36:38 <diga> better we should fix timeout issue, for every driver we use, this is typical scenarios we should handle
03:36:41 <eliqiao_> not yet
03:36:54 <hongbin> eliqiao_: mind filing one?
03:36:56 <eliqiao_> will do it later.
03:36:58 <eliqiao_> okay
03:37:18 <hongbin> #action eliqiao_ create a bug for polling issue
03:37:43 <eliqiao_> besides, another issue is that python-zunclent doesn't give detail error message
03:37:51 <eliqiao_> but lower prority
03:38:21 <eliqiao_> it's about uer experence, will file bug later..
03:38:34 <hongbin> eliqiao_: great, thanks for that
03:39:01 <eliqiao_> I am done, will try zun more later and hope can give more feedback
03:39:09 <hongbin> eliqiao_: thx
03:39:16 <eliqiao_> thanks for listening :)
03:39:38 <hongbin> any other topic ?
03:40:02 <hongbin> ok, all. thanks for joining the meeting
03:40:06 <hongbin> #endmeeting