03:00:07 <hongbin> #startmeeting zun
03:00:08 <openstack> Meeting started Tue Feb 14 03:00:07 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:12 <openstack> The meeting name has been set to 'zun'
03:00:13 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-02-14_0300_UTC Today's agenda
03:00:17 <hongbin> #topic Roll Call
03:00:22 <pksingh> hello
03:00:25 <shubhams> Shubham
03:00:27 <sudipto> o/
03:00:28 <lakerzhou> lakerzhou
03:00:31 <Namrata> Namrata
03:00:31 <mkrai> Madhuri Kumari
03:00:34 <kevinz> kevinz
03:00:59 <hongbin> thanks for joining the meeting pksingh shubhams sudipto lakerzhou Namrata mkrai kevinz
03:01:06 <hongbin> #topic Announcements
03:01:12 <hongbin> 1. Select a mascot representing Zun
03:01:16 <hongbin> #link https://www.openstack.org/project-mascots/
03:01:39 <hongbin> i was received an email from openstack foundation to ask the zun team to select a logo
03:02:11 <hongbin> basically, we select a animal or an item, someone will make a logo for zun team
03:02:31 <mkrai> What is the meaning of zun ?
03:02:33 <mkrai> I forgot
03:02:41 <hongbin> zun is a container
03:02:44 <mkrai> That is a chinese word, right?
03:02:50 <sudipto> I guess that means a container?
03:03:04 <hongbin> it seems to be an old chinese world
03:03:11 <hongbin> yes
03:03:32 <hongbin> #link https://en.wikipedia.org/wiki/Zun
03:03:32 <mkrai> hongbin By when we have to reply?
03:03:39 <eliqiao> hi
03:03:48 <hongbin> mkrai: i guess one week or two
03:03:52 <hongbin> hi eliqiao
03:04:08 <hongbin> ok, any idea?
03:04:16 <hongbin> or want to discuss it offline?
03:04:28 <shubhams> hongbin: any specific theme for this that we have to follow?
03:04:36 <mkrai> Need to think
03:04:47 * eliqiao lurk
03:04:49 <hongbin> shubhams: i don't think there is any specific theme
03:04:57 <hongbin> ok, let me send an email for that
03:05:16 <hongbin> #action hongbin send a ML to discuss the team mascot
03:05:25 <hongbin> ok, next one
03:05:30 <hongbin> #topic Review Action Items
03:05:34 <hongbin> 1. eliqiao_ create a bug for polling issue (DONE)
03:05:41 <hongbin> #link https://bugs.launchpad.net/zun/+bug/1662415
03:05:41 <openstack> Launchpad bug 1662415 in Zun "Improve sandbox creation polling" [Medium,Triaged]
03:05:51 <hongbin> thanks eliqiao for creating the bug
03:06:00 <Qiming> maybe a barrel, :)
03:06:02 <Qiming> https://en.wikipedia.org/wiki/Barrel
03:06:08 <hongbin> i guess anyone can assign it to himself/herself if he/she want
03:06:15 <hongbin> Qiming: hey
03:06:22 <Qiming> o/
03:06:28 <hongbin> interesting
03:06:46 <kevinz> Cool
03:06:49 <hongbin> #topic Cinder integration (diga)
03:06:55 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/cinder-zun-integration The BP
03:06:59 <hongbin> #link https://review.openstack.org/#/c/417747/ The design spec
03:07:11 <hongbin> diga told me he won't be able to come today
03:07:22 <hongbin> he said he was working on this bp
03:07:32 <hongbin> he will submit the patches by thursday
03:07:43 <hongbin> that is all
03:07:47 <hongbin> any comment ?
03:08:22 <hongbin> ok, next one
03:08:27 <hongbin> #topic Kuryr integration (hongbin)
03:08:32 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/kuryr-integration The BP
03:08:47 <hongbin> the spec is up for review for about one week or two
03:09:02 <hongbin> #link https://review.openstack.org/#/c/425883/
03:09:16 <sudipto> hongbin, i reviewed it yesterday. Had a few concerns...
03:09:19 <hongbin> several people have provided feedback, and hte spec was revisioned a few times
03:09:31 <hongbin> sudipto: ack, will address your comments later
03:09:38 <sudipto> hongbin, sure.
03:10:12 <hongbin> i would ask everyone to review the spec again if you have a chance
03:10:22 <pksingh> will review it today
03:10:23 <hongbin> it seems it is close to merge soon
03:10:30 <mkrai> I will review
03:10:33 <hongbin> thanks
03:10:44 <hongbin> ok, next one
03:10:50 <hongbin> #topic Support interactive mode (kevinz)
03:10:55 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/support-interactive-mode The BP
03:11:00 <hongbin> #link https://review.openstack.org/#/c/396841/ The design spec
03:11:06 <hongbin> kevinz: ^^
03:11:46 <kevinz> Hi hongbin, https://review.openstack.org/#/c/417681/  this patch has been merged
03:12:09 <kevinz> I will add some test cases here and investigate the security problem
03:12:32 <hongbin> kevinz: ack
03:13:15 <hongbin> kevinz: i tried the attach command, it works very well
03:13:49 <hongbin> kevinz: i think the next step is to implement a run command that does attach automatically, like docker run -it
03:14:18 <kevinz> hongbin: Yeah Thanks , I will do it
03:14:31 <hongbin> kevinz: also, it seems the container will die after a attach and deattach
03:14:51 <hongbin> kevinz: it seems there is a way to keep the container alive after a de-attach
03:15:00 <hongbin> kevinz: those are good to support
03:15:16 <kevinz> OK I will find out the reason.
03:15:36 <hongbin> kevinz: yes, those are minor tweaks to follow up
03:15:47 <hongbin> kevinz: however, the work is amazing
03:16:01 <hongbin> kevinz: thanks for the great work, i knew it is not easy
03:16:23 <hongbin> kevinz: but you make it !
03:16:34 <kevinz> hongbin: My pleasure
03:16:46 <hongbin> that is all from me
03:16:50 <kevinz> Thanks for your comments on that patch
03:16:58 <hongbin> all, any comment for kevinz ?
03:17:07 <hongbin> np
03:17:20 <pksingh> really great work !!
03:17:44 <hongbin> kevinz: i guess you can close the bp ?
03:17:50 <kevinz> Thanks for pksingh, your valuable advice for this bp
03:18:17 <pksingh> np
03:18:18 <kevinz> hongbin:OK I will close it after add zun run
03:18:24 <hongbin> kevinz: ack
03:18:57 <hongbin> ok, advance topic
03:19:05 <hongbin> #topic Introduce host capabilities and cpusets
03:19:10 <hongbin> #link https://review.openstack.org/#/c/427007/ The spec
03:19:17 <hongbin> sudipto: lakerzhou ^^
03:19:30 <lakerzhou> I had minor comments about the NUMA support
03:20:04 <sudipto> I seemed to have replied to them.
03:21:01 <lakerzhou> I think it should be addressed in another feature. The current design cover one use case. It can be extended later it is necessary.
03:21:16 <sudipto> Do you any more concerns for now lakerzhou or can we take the comments during the code reviews?
03:21:37 <lakerzhou> no I don't have concerns.
03:21:53 <hongbin> yes, i agree that the current design is well covered for one use case
03:22:12 <sudipto> You're more than welcome to review the patches :)
03:22:13 <hongbin> we can always improve it later
03:22:27 <eliqiao> hongbin: about host capabilities, I think we could support cache allocation later.
03:22:50 <lakerzhou> sudipto, I certainly well, thanks for the great work :)
03:22:53 <sudipto> yeah, thought of that.
03:22:55 <hongbin> eliqiao: could you elaborate?
03:23:36 <hongbin> eliqiao: perhaps sudipto can comment on your question
03:24:59 <sudipto> hongbin, this is something that eliqiao is driving in nova: https://blueprints.launchpad.net/nova/+spec/cat-support (i am guessing this is what it is?)
03:25:07 <eliqiao> sudipto: yes.
03:25:34 <hongbin> i see
03:25:39 <hongbin> it looks like a good to have
03:25:53 <eliqiao> sudipto: That's for VM support in nova, though libvirt.
03:26:20 <sudipto> eliqiao, but i think the l3-cache would apply to containers too...
03:26:22 <eliqiao> hongbin: for container support, we could leverage other software, like intel-cat-cmt ..
03:26:39 <sudipto> is it supported by all the servers of intel?
03:26:58 <eliqiao> sudipto: yes, only on xeon cpu.
03:27:15 <sudipto> in order to support this, we would have to do quite a bit of plumbing in the zun code, since we don't have libvirt to our helm
03:27:34 <sudipto> but yeah we could look at this maybe in the second iteration once we have all the pieces in?
03:27:45 <eliqiao> sudipto: right, I will talk with my colleage for zun support.
03:28:10 <eliqiao> they are working on an agent which will provide cache monitor/allocation.
03:28:18 <eliqiao> later we can integrate it to zun.
03:28:46 <hongbin> eliqiao: ack
03:29:11 <hongbin> eliqiao: feel free to create a bp/spec if you want to lead this work
03:29:21 <eliqiao> I will find my time to review host-capabilities in zun and to see if we can support cat in zun
03:29:27 <eliqiao> hongbin: okay. thx.
03:30:08 <hongbin> ok, any other comment?
03:30:46 <sudipto> hongbin, should we merge the spec, if everyone is on the same page?
03:31:05 <hongbin> sudipto: i am ok with that (already gave +2)
03:31:52 <hongbin> it seems lakerzhou also agreed to merge it
03:31:55 <pksingh> i agree too
03:31:59 <hongbin> i think it is ready to go
03:32:32 <lakerzhou> Hongbin, I agree
03:33:05 <hongbin> ok
03:33:20 <hongbin> sudipto: any other comment you want to make?
03:33:37 <sudipto> hongbin, just would like to thank people who took the time out to review the spec. :)
03:33:57 <hongbin> :)
03:34:22 <hongbin> thanks sudipto for this work
03:34:33 <hongbin> ok, next topic
03:34:36 <hongbin> #topic Update image API to support multi-compute scenario (Wenzhi)
03:34:42 <hongbin> #link https://review.openstack.org/#/c/432857/
03:35:01 <hongbin> it looks wenzhi is not here
03:35:11 <hongbin> however, he proposed an interesting patch
03:35:39 <hongbin> i have reviewed his patch, perhaps, i can explain it a bit
03:35:58 <hongbin> what he proposed is an API to schedule a container
03:36:23 <hongbin> this api basically write down the host to the container object in db
03:36:41 <hongbin> then, the image api can select host based on the 'host' field in the container object
03:37:04 <sudipto> hongbin, i went through the patch, thought i saw jenkins fail on that yesterday.
03:37:47 <hongbin> sudipto: it seems he uploaded another patchset, perhaps, it fixed the jenkins
03:38:01 <sudipto> hongbin, sure.
03:38:31 <hongbin> i wanted to discuss the idea here, but it seems it is better to leave it offline
03:38:47 <hongbin> then, everyone has a chance to review it
03:39:14 <mkrai> Yes I will review it and post my comments on the patch
03:39:22 <hongbin> mkrai: ack
03:39:32 <hongbin> ok, then let's enter open discussion
03:39:34 <hongbin> #topic Open Discussion
03:39:45 <hongbin> anyone has a topic to bring up?
03:40:03 <mkrai> Yes I have one
03:40:09 <hongbin> mkrai: go ahead
03:40:19 <mkrai> #link https://review.openstack.org/#/c/431442/
03:40:34 <mkrai> this is support to add image-search API in zunclient
03:40:59 <mkrai> But seems the response object for image drivers, glance and docker are completely different
03:41:15 <mkrai> So we need to think of some common response object for the same
03:41:38 <hongbin> yes, possibly, we need to define an object for image
03:41:58 <mkrai> docker search returns 'stars', 'official' etc which glance doesn't have
03:42:30 <hongbin> mkrai: one way to handle that is to define a metadata field
03:42:57 <mkrai> hongbin: that includes driver specific fields?
03:43:07 <hongbin> mkrai: possibly
03:43:22 <hongbin> mkrai: another way to handle that is to simply hide those fields
03:43:56 <mkrai> hongbin: Do you think just the name and driver would be enough?
03:44:04 <mkrai> with metadata field
03:44:31 <hongbin> mkrai: personally, i would like to see more fields that are common for both docker and glance
03:44:52 <hongbin> i.e. size, location, etc.
03:45:18 <mkrai> hongbin: docker search don't show size and all
03:45:24 <sudipto> location is important IMHO
03:45:35 <mkrai> only common field is 'name' I guess
03:45:38 <sudipto> IIUC, that should tell you if it's a public registry or a private one.
03:46:07 <mkrai> NAME                  DESCRIPTION                                    STARS OFFICIAL  AUTOMATED
03:46:19 <mkrai> These are the fields for docker
03:46:22 <hongbin> i see
03:46:24 <sudipto> but i thought there was debate around that in glance, whether the location should be admin only.
03:46:41 <hongbin> sudipto: ack
03:47:22 <hongbin> mkrai: then, i am ok to start with name and driver
03:47:33 <mkrai> I will try to create a common response object and post it on review link
03:47:51 <mkrai> You all can post your suggestion on that
03:48:03 <mkrai> hongbin: ack
03:48:16 <hongbin> thanks mkrai
03:48:20 <mkrai> hongbin: sudipto Thanks
03:48:52 <Namrata> hongbin:I am working on container resource.the patch is ready I am testing it.
03:48:52 <mkrai> That's all from my side.
03:49:02 <Namrata> will upload it today
03:49:27 <hongbin> Namrata: awesome
03:50:03 <hongbin> Namrata: did the heat team give you enough comment for this feature?
03:50:55 <Namrata> i havent joined the team meeting
03:51:07 <Namrata> i will do this week and ask for reviewing the patches
03:51:22 <hongbin> Namrata: that is fine, i will help you to ping them
03:51:32 <Namrata> sure .thanks hongbin
03:52:18 <hongbin> thanks Namrata for working on this feature in heat
03:52:34 <Namrata> hongbin:thanks for sugesting the same
03:53:16 <hongbin> ok, it seems there is no more topic to bring up
03:53:37 <hongbin> then, i will end the meeting a bit earlier, all , thanks for joining the meeting
03:53:45 <hongbin> #endmeeting