03:01:09 <hongbin> #startmeeting zun
03:01:10 <openstack> Meeting started Tue Feb 28 03:01:09 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:01:14 <openstack> The meeting name has been set to 'zun'
03:01:15 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-02-28_0300_UTC Today's agenda
03:01:19 <hongbin> #topic Roll Call
03:01:23 <pksingh> Pradeep
03:01:26 <kevinz> kevinz
03:01:28 <Namrata> Namrata
03:01:31 <lakerzhou> lakerzhou
03:01:56 <Wenzhi> Wenzhi
03:02:06 <hongbin> thanks for joining the meeting pksingh kevinz Namrata lakerzhou Wenzhi
03:02:21 <hongbin> #topic Project mascot
03:02:30 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/112516.html
03:02:46 <hongbin> this is a continued discussion from the last meeting
03:03:08 <hongbin> we need to choose a team mascot to repersent zun
03:03:18 <hongbin> so far, the proposed mascot is
03:03:23 <hongbin> Barrel
03:03:29 <hongbin> Storks
03:03:33 <hongbin> Falcon
03:03:39 <hongbin> Dolphins
03:03:43 <hongbin> Tiger
03:03:48 <hongbin> any other proposal?
03:04:30 <hongbin> seems no :)
03:04:58 <hongbin> i was told that barrel falcon are not a good choice
03:05:03 <eliqiao> haha ...
03:05:21 <hongbin> barrel is not animal or natual element, so disqualify
03:05:36 <hongbin> falcon seems to be chosen by other team
03:05:41 <eliqiao> how about mythi
03:05:41 <hongbin> what is left is
03:05:50 <hongbin> mythi?
03:05:52 <lakerzhou> seems fish/ocean animals are popular for container projects
03:06:16 <hongbin> eliqiao: what is mythi? picture?
03:06:26 <hongbin> lakerzhou: yes, it seems it is
03:06:34 <hongbin> lakerzhou: you have a proposal?
03:06:53 <eliqiao> hongbin: wait a min
03:06:55 <lakerzhou> I vote for dolphin
03:07:13 <hongbin> lakerzhou: ack
03:07:37 <eliqiao> https://www.google.com/url?sa=i&rct=j&q=&esrc=s&source=images&cd=&cad=rja&uact=8&ved=0ahUKEwj57ZP257HSAhUN5WMKHSnZD4sQjRwIBw&url=http%3A%2F%2Fwww.30yes.com%2Fcontent%2F99531.html&bvm=bv.148073327,d.cGc&psig=AFQjCNE7qQHCJ5FR6N4PQeJ15GAJkkOIlg&ust=1488337626958245 hongbin
03:08:08 <Wenzhi> ah... Pi Xiu
03:08:49 <pksingh> eliqiao: page in chineese :(, i cant read it
03:08:53 <eliqiao> yep :)
03:09:05 <hongbin> i am from chinese, but i still don't know what is pi xiu :)
03:09:13 <hongbin> first time see t
03:09:15 <hongbin> it
03:09:37 <hongbin> interesting
03:10:00 <eliqiao> http://www.wentaisun.co.uk/culture.php?culture_id=5 hongbin pksingh
03:10:02 <Wenzhi> it's a mythical animal
03:10:08 <eliqiao> Pi Xiu
03:10:15 <eliqiao> Wenzhi: :)
03:10:48 <hongbin> eliqiao: ok, thanks for the proposal
03:10:57 <hongbin> any other proposed mascot?
03:11:00 <pksingh> eliqiao: thanks for english version
03:11:30 <hongbin> ok, if nothing else, let's have a vote
03:11:37 <hongbin> here is the choice
03:11:46 <hongbin> 1. Storks
03:11:55 <hongbin> 2. Dolphins
03:12:01 <hongbin> 3. Tiger
03:12:06 <hongbin> 4. Pi Xiu
03:12:25 <hongbin> all, happy voting
03:13:13 <hongbin> no vote?
03:13:15 <pksingh> 2
03:13:18 <lakerzhou> 2
03:13:29 <eliqiao> 4 :)
03:13:33 <Wenzhi> 2
03:13:51 <hongbin> kevinz: ^^
03:13:55 <hongbin> Namrata: ^^
03:14:09 <Namrata> hi
03:14:19 <Namrata> dolphins
03:14:19 <kevinz> hi  I prefer 2
03:14:28 <Wenzhi> eliqiao: seems Pi Xiu is not a natural element either
03:14:31 <hongbin> ok, all thanks for your vote
03:14:36 <hongbin> Wenzhi: ^^
03:14:53 <hongbin> i am not sure if it is nature as well
03:15:03 <hongbin> but we decided 2
03:15:07 <hongbin> Dolphins
03:15:13 <Wenzhi> Go Dolphins
03:15:21 <eliqiao> K. cool..
03:15:22 <hongbin> #agreed choose dolphins as the zun team mascot
03:15:34 <hongbin> ok, move on
03:15:40 <hongbin> #topic Cinder integration (diga)
03:15:54 <hongbin> it seems diga is not here
03:16:04 <hongbin> anyone else want to discuss this topic?
03:16:38 <hongbin> ok, next one
03:16:40 <hongbin> #topic Kuryr integration (hongbin)
03:16:45 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/kuryr-integration The BP
03:17:10 <hongbin> for this one, i am waiting for the kuryr patches to merge
03:17:40 <hongbin> i will continue to work on it
03:17:55 <hongbin> any question for this bp?
03:17:57 <pksingh> hongbin: i have one question
03:18:02 <hongbin> pksingh: go ahead
03:18:31 <pksingh> hongbin: if user create any network, would you pass that to nova docker driver in nics option?
03:19:44 <hongbin> pksingh: i haven't thought through it carefully
03:20:09 <hongbin> pksingh: i will try to get the native docker driver work at the first iteration
03:20:28 <pksingh> hongbin: actually i was thinking we should, because you are implementing the same in docker driver, but not sure
03:20:28 <hongbin> pksingh: then, i check if it fits into nova-docker in the second iteration
03:20:41 <pksingh> hongbin: cool
03:20:47 <hongbin> pksingh: yes, i am open to that
03:21:07 <pksingh> hongbin: i tried this day before yesterday and it works :)
03:21:55 <hongbin> ok, any other question?
03:22:20 <hongbin> #topic Introduce host capabilities and cpusets (sudipto)
03:22:25 <hongbin> #link https://review.openstack.org/#/c/427007/ The spec
03:22:41 <hongbin> it looks sudipta is not here, i can update on behalf
03:23:07 <hongbin> i worked with sudipta to submit a few patches for this
03:23:19 <hongbin> first, there is a spec
03:23:36 <hongbin> #link https://review.openstack.org/#/c/427007/
03:23:52 <hongbin> he revised the spec to make it simple at the first iteration
03:24:12 <pksingh> hongbin: will look into it today
03:24:13 <hongbin> we tried the resource provider model, but found it is very complicated
03:24:19 <hongbin> pksingh: ack
03:24:41 <hongbin> after dicussion, we decided to switch to a simpler model (compute_node model)
03:25:05 <hongbin> we will switch to the resource_provider model later, possibly after nova split out its scheduler
03:25:07 <hongbin> that is the plan
03:25:20 <eliqiao> hongbin: ACK, we can switch back to resource provider after it get implemented.
03:25:31 <hongbin> eliqiao: yes
03:25:38 <pksingh> agree
03:25:40 <eliqiao> maybe 3/4 release later.
03:25:57 <hongbin> yes, and we pushed up a few patches for that
03:25:59 <hongbin> #link https://review.openstack.org/#/c/436714/
03:26:09 <hongbin> #link https://review.openstack.org/#/c/436572/
03:26:28 <hongbin> the first patch is the datamodel
03:26:44 <hongbin> the second patch is the basic for inventory numa resources
03:26:56 <hongbin> that is all from my side
03:27:02 <hongbin> any question?
03:27:35 <hongbin> ok, next topic
03:27:38 <hongbin> #topic Discussion of the image API
03:27:45 <hongbin> #link https://etherpad.openstack.org/p/zun-image-api the etherpad
03:28:10 <hongbin> it looks there are a lot of discussion of the image api
03:28:21 <hongbin> so i created an etherpad to let everyone work on the design
03:28:43 <hongbin> all, please feel free to cast your input to the etherpad
03:28:55 <hongbin> we can revisit the etherpad in the next meeting
03:29:07 <hongbin> any comment for the image api?
03:29:38 <pksingh> are we discussing on etherpad?
03:29:51 <hongbin> pksingh: yes, we can
03:30:03 <pksingh> that would be better
03:30:31 <hongbin> pksingh: do you have any comment to bring it up here, or prefer to work on the etherpad later?
03:31:11 <pksingh> hongbin: i have the same comment, if we want to have the API, then we can go ahead as suggested in etherpad
03:31:26 <hongbin> pksingh: ok
03:31:45 <hongbin> then, next topic
03:31:51 <hongbin> #topic Use 'uuid' instead of 'id' as object ident in data model (Wenzhi)
03:31:57 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/112585.html
03:32:17 <hongbin> Wenzhi: want to lead this discussion?
03:32:22 <Wenzhi> Ok
03:32:58 <Wenzhi> per the feedback form the maillist, seems everyone agree with this proposal -- replace 'id' with 'uuid'
03:33:47 <Wenzhi> actually I already replaced the 'id' with 'uuid' in etcd API backend for containers/images
03:33:47 <hongbin> Wenzhi: yes, it seems so
03:34:13 <hongbin> cool
03:34:20 <hongbin> then, we need to work on the sql side
03:34:41 <Wenzhi> I plan to leave the sql side as it is by now
03:34:49 <Wenzhi> and start with etcd side
03:35:00 <hongbin> ok
03:35:09 <Wenzhi> if everything goes fine, then we can modify the sql side
03:35:24 <hongbin> sure
03:35:30 <pksingh> Wenzhi: +1
03:36:09 <kevinz> Wenzhi: +1
03:36:09 <hongbin> Wenzhi: mind creating a bp for the sql side when the finished the etcd side?
03:36:19 <Wenzhi> hongbin:sure
03:36:25 <hongbin> Wenzhi: thx
03:36:56 <hongbin> #action Wenzhi created a bp for migrate from 'id' to 'uuid' in the sql backend once the etcd backend is finishing migration
03:37:11 <hongbin> ok
03:37:19 <hongbin> any other comment on this topic?
03:38:00 <hongbin> then, move to the last topic in the agenda
03:38:01 <hongbin> #topic Introduce container composition
03:38:19 <hongbin> Wenzhi: kevinz : any of you want to lead this topic?
03:38:51 <kevinz> Hi hongbin
03:38:53 <hongbin> #link https://review.openstack.org/#/c/437759/
03:39:20 <kevinz> we just finish the WIP specs for this
03:39:43 <Wenzhi> yes, still need to address some comments
03:40:30 <hongbin> Wenzhi: ack
03:40:56 <kevinz> Right, we've introduce the new object "capsule", the same as the compose or pod
03:41:58 <hongbin> yes, there is one thing we need to give it more thoughts
03:42:29 <hongbin> that is how do you like to design the "capsule", i.e. make it as compose, or make it as a pod
03:43:24 <hongbin> or make it between docker compose and k8s pod
03:43:34 <lakerzhou> what is the use case of the capsule? pod is specific to k8s.
03:43:58 <Wenzhi> IMO we can make it a 'pod', and add support for docker compose file
03:44:06 <hongbin> lakerzhou: there is a demand to run multiple container and patch them into the same host
03:45:01 <hongbin> lakerzhou: i think the use case is simple, run a containerized application that are comprosed with multiple containers
03:45:16 <hongbin> Wenzhi: ack
03:45:28 <Wenzhi> yes, the user cases are just like k8s pod
03:46:39 <hongbin> any other comment about the pod vs compose debate?
03:47:27 <pksingh> so it will be like POD correct?
03:47:44 <hongbin> pksingh: that depends on how we designed it
03:48:01 <hongbin> pksingh: we can make it like a k8s pod or a docker compose
03:48:57 <pksingh> in future if we are going to integrate with k8, then i think we may need pod like thing
03:49:52 <hongbin> pksingh: yes, it might
03:50:41 <hongbin> it seems most people prefer to make it like a pod?
03:50:50 <pksingh> +1 for pod
03:51:27 <hongbin> ok, we can continue the discussion in the review
03:51:46 <kevinz> OK
03:52:01 <Wenzhi> ack
03:52:15 <hongbin> my suggestion is to take care the portability
03:52:39 <hongbin> for example, if we make it as a pod, make sure the file format are similar to pod
03:52:55 <hongbin> then, users can easily migrate between pod and capsule
03:53:05 <Wenzhi> got it
03:53:06 <kevinz> ack, thanks hongbin
03:53:12 <pksingh> hongbin: +1
03:53:26 <hongbin> ok, then let's enter open discussion
03:53:32 <hongbin> #topic Open Discussion
03:53:51 <hongbin> Namrata: i knew you were working hard on the heat side, do you want to give some updates?
03:54:12 <Namrata> Hongbin I will update the patches today
03:54:21 <Namrata> no other updates
03:54:30 <hongbin> Namrata: ack
03:55:02 <hongbin> Namrata: i saw those patches, which will look very good after addressing the outstanding comments
03:55:20 <Namrata> yes.I will work on that
03:55:27 <Namrata> thanks for the help hongbin
03:55:33 <hongbin> Namrata: thanks for the work
03:56:10 <hongbin> all, do you have any other topic to bring up?
03:57:05 <hongbin> it seems no
03:57:13 <hongbin> all, thanks for joining the meeting
03:57:18 <pksingh> bye all
03:57:19 <hongbin> #endmeeting