03:00:14 <hongbin> #startmeeting zun
03:00:15 <openstack> Meeting started Tue Apr 11 03:00:14 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:18 <openstack> The meeting name has been set to 'zun'
03:00:22 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-04-11_0300_UTC Today's agenda
03:00:27 <hongbin> #topic Roll Call
03:00:31 <kevinz> kevinz
03:00:32 <Namrata> Namrata
03:00:38 <shubhams> shubham kumar sharma
03:00:46 <Shunli> shunli
03:01:34 <lakerzhou> lakerzhou
03:02:01 <hongbin> thanks for joining the meeting kevinz Namrata shubhams Shunli lakerzhou
03:02:08 <hongbin> let's get started
03:02:14 <hongbin> #topic Announcements
03:02:20 <hongbin> 1. Madhuri and Pradeep are on leave, so might not be able to join the meeting
03:02:34 <hongbin> 2. Zun will hold a feedback session at Boston Forum (Thursday 11:00 - 11:40)
03:02:41 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/attachments/20170410/32dd3c13/attachment.pdf
03:03:05 <hongbin> if you go to boston summit, remember to come to the feedback session :)
03:03:24 <hongbin> this session is for the team to get boarder feedback from the community
03:03:51 <lakerzhou> you just answered my question
03:03:51 <kevinz> Cool
03:03:53 <hongbin> i will chair the session, hopefully, we could get some helpful input
03:04:03 <shubhams> great
03:04:05 <lakerzhou> great
03:04:15 <hongbin> how many of you will go to the boston summit?
03:04:22 <kevinz> But I can't go to Boston..
03:04:24 <lakerzhou> I will.
03:04:37 <hongbin> kevinz: lakerzhou ack
03:04:48 <hongbin> lakerzhou: look forward to seeing you there :)
03:05:08 <hongbin> 3. Propose to have a "Boston Summit" release by the end of April
03:05:10 <shubhams> hongbin:  I wont be coming
03:05:13 <Shunli> I cannot
03:05:13 <lakerzhou> sure, I will have a lighting talk there.
03:05:19 <Namrata> if visa gets approved
03:05:26 <Namrata> then i will
03:05:43 <hongbin> Shunli: shubhams ack, hope to have a chance to see you in elsewhere
03:05:51 <hongbin> Namrata: ack
03:06:13 <hongbin> 3. Propose to have a "Boston Summit" release by the end of April
03:07:03 <hongbin> i propose to make a release before the boston summit, the date would be roughly by the end of april
03:07:24 <hongbin> the goal of this release is to have a version to demo on the summit
03:07:54 <kevinz> That greate
03:08:03 <hongbin> just let me know if anything you want to include in this summit
03:08:27 <hongbin> i will try to get them in and incorproate it in a demo if possible
03:08:38 <Namrata> great
03:08:58 <lakerzhou> cool
03:09:02 <hongbin> any qestion for hte above announment?
03:09:25 <kevinz> do we have a demo in Keynote?
03:09:36 <hongbin> kevinz: i am not sure yet
03:09:59 <kevinz> hongbin: OK
03:10:00 <hongbin> kevinz: will let you know if there is one
03:10:16 <diga> o/
03:10:23 <diga> sorry got late
03:10:27 <hongbin> diga: hi diga, thianks for joining
03:10:38 <hongbin> #topic Cinder integration (diga)
03:10:44 <diga> hongbin: hi
03:11:04 <hongbin> diga: you are arriving at the right time, want to give the team a update?
03:11:05 <diga> hongbin: I have incorporated your comments and have made the changes accordingly
03:11:11 <diga> hongbin: :)
03:11:28 <diga> hongbin: I will push my patch in sometime,
03:11:46 <hongbin> diga: ack
03:11:49 <hongbin> #link https://review.openstack.org/#/c/429943/
03:12:14 <diga> hongbin: will ping you later
03:12:31 <hongbin> diga: i saw the gate was failed, do you need help for trouble-shooting the gate?
03:12:49 <diga> hongbin: also CLI is also implemented & working,
03:12:56 <diga> hongbin: Yeah
03:13:11 <hongbin> diga: ok, i can help you with that
03:13:11 <diga> hongbin: I dont know how to pass the gate without test cases
03:13:20 <diga> hongbin: it will be really helpful
03:13:32 <hongbin> sure, will help you offline
03:13:32 <diga> hongbin: Thank you!
03:13:48 <diga> hongbin: sure
03:13:53 <hongbin> #action hongbin help diga to get the cinder integration patch passed the gate
03:14:24 <diga> hongbin: sorry I wasn't active on irc/zun in last two weeks due product release
03:14:36 <hongbin> diga: that is fine
03:14:46 <hongbin> diga: thanks for your contribution on this feature
03:14:55 <diga> hongbin: welcome!
03:15:12 <hongbin> all, any remark on this bp?
03:15:50 <hongbin> seems no, advance topic
03:15:52 <hongbin> #topic Kuryr integration (hongbin)
03:15:58 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/kuryr-integration The BP
03:16:20 <hongbin> this is hte patch: https://review.openstack.org/#/c/453387/
03:16:22 <hongbin> #link https://review.openstack.org/#/c/453387/
03:16:53 <hongbin> i think this patch is pretty close to remove the aip
03:16:55 <hongbin> wip
03:17:45 <diga> hongbin: will take a look at it today
03:17:48 <hongbin> what it does is to find a neutron network, and use kuryr plugin to create a docker network
03:18:11 <hongbin> diga: ack
03:18:14 <diga> hongbin: looks good approach
03:18:51 <diga> hongbin: 1 question, this is only for docker right, not k8s
03:19:05 <hongbin> diga: yes, only for docker
03:19:12 <diga> hongbin: got it
03:19:38 <kevinz> hongbin: Thanks for this great work. I will find time to review and try it:-)
03:20:03 <hongbin> kevinz: ack, perhaps try it after the wip is removed
03:20:24 <kevinz> Yeah sure
03:20:38 <hongbin> ok, any question about this topic?
03:20:47 <shu-mutou> Hi!
03:20:57 <hongbin> shu-mutou: hi shu, thanks for joining
03:21:13 <shu-mutou> I wrote up the priorities of Zun UI for Pike, please check it. https://etherpad.openstack.org/p/pike-zun-ui
03:21:21 <diga> hongbin: I will post my comments on patch if any
03:21:26 <hongbin> #link https://etherpad.openstack.org/p/pike-zun-ui
03:21:55 <hongbin> #action everyone review the zun ui ehterpad: https://etherpad.openstack.org/p/pike-zun-ui
03:22:28 <hongbin> ok, advance topic
03:22:36 <hongbin> #topic Introduce container composition
03:22:45 <hongbin> #link https://review.openstack.org/#/c/437759/
03:22:58 <hongbin> kevinz: want to drive this one?
03:23:15 <kevinz> kevinz: Yeah
03:23:42 <kevinz> Here is the details. https://etherpad.openstack.org/p/zun-container-composition
03:24:01 <kevinz> Including the yaml file structure and API for "Capsule"
03:25:05 <FengShengqin> the format of yaml file is like docker-compose?
03:25:33 <hongbin> kevinz: i think you are ready to incorporate the sample yaml file into the spec
03:25:33 <kevinz> FengShengqin: The format is more like Kubernetes
03:26:11 <FengShengqin> like pod ?
03:26:13 <kevinz> hongbin: OK, I will add it to spec
03:26:20 <hongbin> kevinz: whenever you think it is ready, you can remove the wip , and we will do another iteration of reviews
03:26:21 <diga> hongbin: can you explain what is the purpose of this use case in short?
03:26:44 <kevinz> <FengShengqin> Yeah like a pod
03:26:50 <hongbin> diga: the use case is supporting multi-container application
03:27:01 <diga> hongbin: okay
03:27:03 <kevinz> hongbin: OK I will. That's cool
03:27:53 <hongbin> kevinz: yes, this feature looks ready to move forward from my side
03:28:02 <diga> hongbin: in this case, we are going to implement app containers scenario
03:28:23 <diga> hongbin: only app endpoint will be shared to the end user
03:28:43 <hongbin> diga: don't get what is "app containers scenario"
03:28:44 <kevinz> hongbin: Thanks, I'll continue
03:29:35 <hongbin> diga: i think it is simply the pod use cases
03:29:52 <hongbin> diga: group multiple containers into a single host
03:30:09 <diga> hongbin: means, lets say I want to deploy wordpress website, wordpresse app needed (wordpress, mysql etc), so in this case, we are going to start two container simultaneously
03:30:16 <diga> hongbin: okay
03:30:38 <hongbin> diga: yes, you can group wordpress and mysql into a capsule
03:30:40 <diga> hongbin: ohh its pod like, got it
03:30:49 <diga> hongbin: yeah
03:31:11 <hongbin> kevinz: thanks kevin for working on this feature
03:31:29 <kevinz> hongbin: My pleasure :-)
03:31:31 <hongbin> before advance topic, any other questions for kevinz ?
03:32:19 <hongbin> #topic Open Discussion
03:32:22 <FengShengqin> why  group multiple containers into a single host   ?
03:33:10 <kevinz> FengShengqin: That will be easy for user to use multiple containers according to their requests
03:33:19 <hongbin> FengShengqin: to support use cases that needs a set of closely-related containers that are pysically collocated
03:34:21 <hongbin> yes, it is basically the pod/compose use cases
03:34:52 <FengShengqin> i see
03:34:58 <Shunli> any flag or policies like nova server group to control?
03:35:16 <Shunli> containers on a host or some host
03:36:45 <hongbin> Shunli: i think contianers in the capsule would have only one policy: scheduled to the same host
03:37:21 <hongbin> Shunli: you have use cases for supporting additional scheduling policies?
03:38:11 <Shunli> I guess containers like vms, there are anti-affinity use cases.
03:38:26 <hongbin> Shunli: ack
03:39:00 <hongbin> Shunli: i think we can record this use case as a bp, then i willl have the team to review it later
03:39:35 <Shunli> OK. Log a bp first
03:39:54 <hongbin> Shunli: mind i assign you an action item to create the bp?
03:39:59 <Shunli> But i'm not sure how this will relate to 'capsule'
03:40:17 <hongbin> it doesn't have to relate to capsule imo
03:40:19 <Shunli> Sure, I will log one.
03:40:47 <hongbin> #action Shunli created a bp for descriping anti-infinity scheduling use cases
03:41:32 <hongbin> Shunli: btw, i sent you and sudipta an email about the host capability
03:42:36 <hongbin> Shunli: do you have any question about what i said about the host capability?
03:42:37 <Shunli> seems it's drawn in the mails. Let me find it out.
03:42:57 <hongbin> ok
03:43:30 <hongbin> Namrata: lakerzhou : if you want, feel free to chime in and give the team an update of the work you did
03:43:53 <Shunli> Seems I didn't get the mail. Did you send to slzhou@fiberhome.com?
03:44:26 <hongbin> Shunli: don't remember the address, will confirm it
03:44:50 <hongbin> Shunli: i will re-send if hte address is wrong
03:44:57 <Shunli> OK. thx.
03:45:04 <hongbin> np
03:45:32 <Namrata> Thanks hongbin
03:46:00 <hongbin> Namrata: yes, please go ahead and talk about your heat work
03:46:21 <Namrata> yeah sure
03:48:50 <hongbin> Namrata: do you have a chance to update the spec: https://review.openstack.org/#/c/426210/
03:49:22 <Namrata> Hongbin : was busy with another work
03:49:24 <hongbin> Namrata: huangtianhua give a few suggestions about several things
03:49:30 <hongbin> Namrata: i see
03:49:34 <Namrata> will complete this week
03:49:40 <Namrata> all the patches related to heat
03:49:48 <Namrata> sorry for the inconvinience
03:49:54 <hongbin> Namrata: sure, np
03:50:01 <hongbin> Namrata: thanks for the work
03:50:05 <Namrata> thanks
03:50:09 <lakerzhou> a quick update of container snapshot. I just tested the following: generate snapshot; verify the snapshot with docker images; created glance image; created new zun container from the glance image; verified the container created properly.
03:50:23 <lakerzhou> I am working on unit testing codes now
03:50:55 <hongbin> lakerzhou: cool, thanks zhou
03:51:10 <lakerzhou> np
03:51:42 <lakerzhou> I will try to complete the BP before BSS release
03:52:05 <hongbin> thx
03:52:15 <hongbin> ok, sounds like we finish the agenda of the meeting
03:52:29 <hongbin> any last minute remark?
03:52:54 <hongbin> seems no, all thanks for joining the meeting, have a good day
03:52:58 <hongbin> #endmeeting