03:00:13 <hongbin> #startmeeting zun
03:00:14 <openstack> Meeting started Tue Jul 11 03:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:17 <openstack> The meeting name has been set to 'zun'
03:00:19 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-07-11_0300_UTC Today's agenda
03:00:21 <hongbin> #topic Roll Call
03:00:24 <kevinz> O/
03:00:27 <shubhams> Shubham
03:00:33 <FengShengqin> fengshegnqin
03:00:34 <spn_> o/
03:00:42 <kiennt> o/
03:00:42 <Namrata> Namrata
03:00:43 <mkrai> o/
03:00:48 <lakerzhou1> O/
03:01:18 <hongbin> thanks for joining the meeting kevinz shubhams FengShengqin spn_ kiennt Namrata mkrai lakerzhou1
03:01:43 <hongbin> ok, let's get started
03:01:45 <hongbin> #topic Announcements
03:01:52 <hongbin> 1. Hongbin, Kevin and Shengqin will be at OpenStack China Day 2017-07-25.
03:01:58 <hongbin> Someone volunteer to hold the team meeting at 2017-07-25? or cancel it?
03:02:21 <Shunli> shunliz
03:02:28 <hongbin> hi Shunli
03:02:34 <mkrai> I can chair it but seems most of the  active members will be on leave so its better to cancel
03:02:40 <mkrai> hongbin: WDYT?
03:03:04 <Shunli> )-:
03:03:06 <hongbin> mkrai: ok, then let's cancel it
03:03:35 <hongbin> i will send out a ML to announcement that
03:03:40 <mkrai> hongbin: Ok
03:03:49 <Shunli> see you next time.
03:03:58 <hongbin> 2. New BPs created
03:04:04 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/internal-dns-resolution Neutron DNS Using Container hostname
03:04:09 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/multi-node-ci Setup CI for multi-node Zun deployment
03:04:15 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/container-actions-api Introduce API to track status of each container actions
03:04:18 <mkrai> Sounds good
03:04:55 <mkrai> All the best for presentation :)
03:05:05 <hongbin> the purpose of these announcement is to let everyone know what BPs we are creating, so that everyone would have a chance to review the new BPs
03:05:10 <Shunli> sorry for later, you are talking that next team meeting will be canceled?
03:05:13 <hongbin> mkrai: thank you
03:05:40 <hongbin> Shunli: the next next one :) since some of us is at China day
03:05:58 <Shunli> ack ,thx hingbin
03:06:31 <hongbin> ok, any other comment for the two announcement today?
03:07:02 <hongbin> ok, move on
03:07:06 <hongbin> #topic Review Action Items
03:07:12 <hongbin> 1. hongbin figure out why project logo is missing in Project Navigator (DONE)
03:07:18 <hongbin> #link https://www.openstack.org/software/project-navigator The logo is there now
03:07:26 <hongbin> 2. hongbin figure out why project logo is missing in LB as well (DONE)
03:07:29 <hongbin> #link https://launchpad.net/zun The logo is there now.
03:07:33 <kevinz> thx hongbin :-)
03:07:46 <hongbin> kevinz: my pleasure :)
03:07:51 <mkrai> hongbin: What was the issue?
03:08:29 <mkrai> Anyway thanks for fixing it :)
03:08:30 <hongbin> mkrai: the first one is the website maintained by OpenStack Foundation is not updated
03:08:57 <hongbin> mkrai: the second one is resolved by configuring the LB
03:09:14 <mkrai> hongbin: I see. Thanks
03:10:01 <hongbin> ok, that is all the action items, move on to the next topic
03:10:03 <hongbin> #topic Introduce container composition (kevinz)
03:10:11 <hongbin> kevinz: ^^
03:11:44 <hongbin> from what i knew, kevinz uploaded a WIP patch for this BP
03:11:46 <hongbin> #link https://review.openstack.org/#/c/480456/
03:12:15 <Shunli> really a huge patch
03:12:19 <kevinz> Hi
03:12:20 <hongbin> :)
03:12:43 <kevinz> A little huge, I will reuse some code to cut off the patch size:-)
03:13:12 <mkrai> Can we break it in multiple patches ?
03:13:13 <Shunli> no problem, as it's a huge feature.
03:13:26 <kevinz> mkrai:Yeah of course
03:13:35 <kevinz> That will make it easy to read
03:13:38 <mkrai> So that easy to review if at all possible. Like split the api  and server code
03:13:43 <mkrai> kevinz: Thanks
03:13:47 <kevinz> yw
03:14:07 <mkrai> kevinz: Is the patch functional?
03:14:08 <kevinz> I will split this week after the Slides for China day is ready
03:14:22 <mkrai> I would like to try creating a capsule
03:14:32 <mkrai> kevinz: Ok
03:14:34 <kevinz> mkrai: Yeah you can try it, now support capsule and list
03:14:44 <kevinz> capsule create and capsule list
03:14:59 <mkrai> kevinz: That's great
03:15:33 <spn_> sorry trying to figure out. is capsule like a pod?
03:16:31 <mkrai> spn_: Yes
03:16:36 <hongbin> spn_: i think yes, you could consider it as a similar concept of pod
03:16:39 <kevinz> spn_: yeah you can treat it like a pod, container composition
03:16:43 <mkrai> capsule consist of multiple containers
03:17:21 <spn_> mkrai: hongbin kevinz : thank u :)
03:17:56 <hongbin> any additional comment for this topic?
03:18:26 <hongbin> kevinz: thanks for your huge contribution on this feature !
03:18:44 <hongbin> #topic NFV use cases
03:19:01 <hongbin> lakerzhou1: hi, you want to drive this topic ?
03:19:01 <kevinz> hongbin: My pleasure:-)
03:19:15 <hongbin> #link https://etherpad.openstack.org/p/zun-nfv-use-cases
03:19:47 <lakerzhou1> I am working on the second design spec, hopefully I can send it for review this week
03:20:24 <hongbin> lakerzhou1: cool, perhaps you could explain to others what is the second design spec is about
03:20:51 <lakerzhou1> a couple of questions that need to have answers: 1. should we work with Kuryr, or kuryr is the only option
03:21:35 <lakerzhou1> the second spec will define how to create SR-IOV network and attach container to the network.
03:22:02 <hongbin> i see
03:23:01 <spn_> second spec is use case 2?
03:23:12 <lakerzhou1> If we follow Nova/neutron SR-IOV implementation, SR-IOV network and ports are create first, then
03:23:25 <lakerzhou1> the port are bound to VMs
03:24:20 <lakerzhou1> spn_. second spec is actually the first use case. In case you did not know, the first spec is to define the PCI-passthrough data model
03:24:42 <Shunli> lakerzhou1: seems kuryr is the only option in zun now. anyway we need a network plugin to create network for container.
03:24:44 <hongbin> #link https://review.openstack.org/#/c/475913/
03:24:44 <lakerzhou1> so scheduler can use the data model to schedule workload on corresponding node
03:26:20 <lakerzhou1> Shunli, if Kuryr is the only option, we need kuryr support on create SR-IOV virtual Function and bind it to container
03:26:59 <Shunli> lakerzhou1: ok, so is there other options?
03:27:01 <lakerzhou1> Mellanox has a driver available and looks simple to me.
03:27:22 <lakerzhou1> https://github.com/Mellanox/docker-passthrough-plugin
03:27:30 <hongbin> #link https://github.com/Mellanox/docker-passthrough-plugin
03:27:47 <lakerzhou1> the driver should work for other vendors NIC too
03:28:13 <lakerzhou1> I am not sure how Kuryr can support the remote driver like this.
03:28:50 <lakerzhou1> if it can be done, it is probably the easiest option for both zun and kuryr
03:29:18 <spn_> lakerzhou1:  for i350 some one mentions here #link http://jason.digitalinertia.net/exposing-docker-containers-with-sr-iov/
03:29:40 <hongbin> i think using kuryr is probably the optimal solution, if the implementation is feasible
03:29:52 <mkrai> hongbin: +1
03:30:08 <lakerzhou1> spn_, it is another remote driver based on pipework
03:30:19 <spn_> lakerzhou1: yup
03:30:24 <Shunli> as i know nova support pci passthrouh. kuryr just forward request to neutron.
03:31:03 <Shunli> so i prefer kuryr can support pci passthrough. this may need some investigation.
03:31:26 <hongbin> lakerzhou1: if using mellanox, it will build another virtual network, that is in parallel with neutron?
03:31:44 <lakerzhou1> the last puzzle to me is how kuryr bind a sriov port to container
03:32:49 <lakerzhou1> the mellanox SR-IOV network is only visible on the docker node
03:33:15 <hongbin> i see
03:33:20 <Shunli> I guess user using zun will not configure two drivers, or switch it between two drivers.
03:34:01 <lakerzhou1> kuryr should have existing implementation to map a neutron network to a docker network
03:34:09 <hongbin> From end-users point of view, they will just see neutron (all docker drivers will be invisible)
03:34:11 <lakerzhou1> and vise versa
03:34:51 <spn_> knowledge of neutron subnets i think
03:35:31 <hongbin> lakerzhou1: i think neutron net and docker net is one-to-many mapping
03:35:45 <lakerzhou1> So there are two options in kuryr, with the new mellanox driver, or without the driver.
03:36:24 <hongbin> lakerzhou1: perhaps you could outline these options in a spec?
03:36:55 <lakerzhou1> hongbin, I am trying to say it is existing kuryr function, to do the mapping.
03:37:09 <lakerzhou1> yes, I will document all the options
03:37:24 <hongbin> ok
03:37:37 <mkrai> lakerzhou1: hongbin We aslo need to see how well Mellanox driver is maintained?
03:37:43 <lakerzhou1> please let me know any ideas
03:38:04 <mkrai> I see there is only one contributor
03:38:22 <hongbin> i see
03:38:54 <lakerzhou1> mkrai, do you know if intel has similar activity? I know intel were working on DPDK container support
03:39:31 <mkrai> lakerzhou1: I am sure there are work going on it but I am not connected to containers team
03:39:42 <mkrai> All are based in US
03:40:07 <mkrai> lakerzhou1: If you want I can try to check it with the containers team
03:40:44 <lakerzhou1> mkrai, please. you can send me a contact if you want.
03:40:55 <mkrai> lakerzhou1: Sure will do that
03:41:27 <hongbin> ok, let's conclude this topic
03:42:05 <hongbin> to proceed, lakerzhou1 will upload a spec to clarify the options about sr-iov binding
03:42:32 <hongbin> after that, everyone could review the spec and weight the pros and cons for each option
03:43:02 <hongbin> then, we could re-discuss it at the next time we meet
03:43:30 <hongbin> comments on it before moving to the next topic?
03:44:12 <Shunli> no
03:44:20 <hongbin> ok
03:44:36 <hongbin> lakerzhou1: thanks for driving this effort
03:44:56 <hongbin> and all the hard work to write the specs
03:45:05 <hongbin> #topic Deprecate NovaDocker driver
03:45:31 <hongbin> first, i can introduce the background
03:45:42 <Shunli> +1 fro deprecate the NovaDocker driver.
03:45:51 <hongbin> right now, there are two drivers: native docker driver and nova docker driver
03:46:37 <lakerzhou1> hongbin, no problem.
03:46:38 <hongbin> the nova docker driver was created in before as experimental driver
03:46:57 <hongbin> the goal is to leverage nova's capability to connect containers to neutron
03:47:30 <hongbin> at that time, the native docker driver hadn't integrate with kuryr yet, so doesn't have neutron connection
03:47:40 <hongbin> however, right now, we have the kuryr integration
03:47:58 <hongbin> then, it looks the nova-docker driver is not needed anymore
03:48:35 <hongbin> therefore, i propose to deprecate it
03:48:35 <mkrai> +1 for deprecating it
03:48:53 <hongbin> mkrai: ack
03:48:57 <Namrata> +1
03:49:12 <hongbin> if everyone agree, i will work on a patch to move the code to /contrib folder
03:49:39 <hongbin> seems there is no objection so far
03:49:48 <diga> Hi, sorry I joined late, was stuck in traffic
03:50:03 <hongbin> diga: hi, thanks for joining
03:50:18 <diga> hongbin: wc!
03:50:18 <hongbin> #agreed deprecate nova docker driver
03:50:48 <hongbin> this finished all the topics in the agenda, le'ts move on to open discussion
03:50:52 <hongbin> #topic Open Discussion
03:51:58 <hongbin> this is the free discussion time, please feel free to bring up any topic if you have one to discuss
03:51:59 <diga> I was on leave last week, I will try to submit patch by passing gate this week on cinder integration
03:52:10 <hongbin> diga: ack
03:52:25 <hongbin> diga: thanks for that
03:52:29 <diga> hongbin: welcone!
03:52:35 <diga> welcome!
03:54:00 <hongbin> kiennt: spn_ i remembered you two are the first time to joiin the team meeting, want to introduce youself to the team?
03:54:31 <spn_> hongbin: sure
03:56:17 <hongbin> spn_: please go ahead :)
03:56:39 <spn_> I work for Dell EMC as Sr.prinicipal engineer. I am based in Dublin. I used to join for magnum meetings before. Then I got send to do some other work inside Dell. Now I am back to work on Openstack. I initially worked on ceilometer in 2012. I used work on Linux kernel specifically qemu/kvm. Now since sometime I am working on Dell openstack reference architecture
03:57:29 <hongbin> spn_: impressive introduction
03:57:39 <mkrai> spn_: Welcome :)
03:57:43 <kiennt> Oh, hi everyone
03:57:52 <spn_> mkrai: thank you
03:58:01 <hongbin> spn_: welcome to the zun team meeting
03:58:07 <diga_> kiennt: spn_ Welcome to Zun !
03:58:13 <kiennt> i'm Kien Nguyen from Fujitsu VietNam, just call me Kien :)
03:58:18 <spn_> diga_: thank you
03:58:28 <kiennt> diga_: Thank you
03:58:36 <mkrai> kiennt: Welcome :)
03:58:55 <Shunli> welcoome
03:58:55 <hongbin> kiennt: welcome,
03:59:27 <hongbin> all, thanks for joining hte meeting
03:59:33 <hongbin> see you next time
03:59:34 <kiennt> mkrai, hongbin: Thank you.
03:59:37 <hongbin> #endmeeting