03:00:21 <hongbin> #startmeeting zun
03:00:22 <openstack> Meeting started Tue Aug 1 03:00:21 2017 UTC and is due to finish in 60 minutes. The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:26 <openstack> The meeting name has been set to 'zun'
03:00:27 <hongbin> #link https://wiki.openstack.org/wiki/Zun#Agenda_for_2017-08-01_0300_UTC Today's agenda
03:00:31 <hongbin> #topic Roll Call
03:00:37 <mkrai> Madhuri o/
03:00:37 <Namrata> Namrata
03:00:39 <shubhams> shubham
03:00:56 <kevinz> kevinz
03:01:01 <spn> o/
03:01:12 <Shunli> shunli
03:01:22 <hongbin> thanks for joining the meeting mkrai Namrata shubhams kevinz spn Shunli
03:01:25 <lakerzhou> lakerzhou
03:01:35 <hongbin> thanks for joining lakerzhou
03:01:42 <hongbin> ok, let's get started
03:01:48 <hongbin> #topic Announcements
03:01:54 <hongbin> 1. python-zunclient 0.4.0 is released for Pike.
03:02:00 <hongbin> #link https://review.openstack.org/#/c/487979/
03:02:21 <hongbin> you should see the stable/pike branch has been cut for python-zunclient
03:02:21 <mkrai> Great :)
03:02:54 <hongbin> that means all patches for python-zunclient are for Q now
03:03:17 <hongbin> if you want to submit for pike, we need to do backporting
03:03:34 <hongbin> 2. The deadline of releasing Zun server is at the week of Aug 21
03:03:39 <hongbin> #link https://releases.openstack.org/pike/schedule.html
03:04:00 <hongbin> i plan to cut the server by Aug 21
03:04:33 <hongbin> if you have patches that needs to go into pike, please submit it before Aug 21
03:04:49 <hongbin> so far, any comment for hte release schedule?
03:04:54 <mkrai> I would like the clear container one to go. Will submit patches soon
03:05:06 <mkrai> Works for me
03:05:26 <hongbin> mkrai: if it can make the pike, that would be great, but remember the zunclient has cut
03:06:01 <mkrai> Ohh I think the server might suffice
03:06:03 <mkrai> But will check
03:06:09 <hongbin> ok
03:06:49 <hongbin> btw, this is the first release of zun that integrates with official openstack release
03:07:20 <hongbin> ok, next one
03:07:22 <hongbin> 3. Etcd job has been moved to experimental queue (type "check experimental" to run this job)
03:07:27 <hongbin> #link https://review.openstack.org/#/c/471840/
03:07:44 <hongbin> i put it in experimental queue because it was failing for a while
03:08:13 <hongbin> putting it as experimental means this job won't be triggered on submiting patch
03:08:30 <hongbin> however, it can be manually trigger by typping "check experimental"
03:08:51 <hongbin> this will save the infra resources, and clear some noice for contributors
03:09:04 <hongbin> any comment for this?
03:09:09 <hongbin> or concern?
03:09:19 <mkrai> After the issue is fixed, we might want to make it voting
03:09:31 <kiennt> Great, what about this patch?
03:09:33 <kiennt> #link https://review.openstack.org/#/c/472538/
03:09:33 <hongbin> mkrai: yes, absolutely
03:09:34 <mkrai> I will be resubmitting the patch for this fix
03:09:56 <hongbin> we can move it back to voting anytime we want
03:09:57 <mkrai> kiennt: Will look this week
03:10:24 <kiennt> mkrai: Hope it will works.
03:10:36 <hongbin> ok, i clear all the annoucements
03:10:43 <hongbin> anyone else has an annoucement?
03:11:07 <mkrai> Vote for Zun presentation for Sydney summit :)
03:11:18 <hongbin> oh, yes
03:11:32 <mkrai> Voting is open till Aug 3
03:11:50 <hongbin> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers/
03:12:18 <hongbin> ok, move on
03:12:20 <hongbin> #topic Review Action Items
03:12:25 <hongbin> 1. mkrai works on a patch to make image validation configurable
03:12:30 <hongbin> mkrai: status?
03:12:41 <mkrai> Sorry didn't get much time to work on this. I will create a bug for this
03:12:51 <mkrai> And will submit the patch this week
03:12:52 <hongbin> ack, np
03:13:12 <hongbin> sure
03:13:31 <hongbin> this issue doesn't look urgent for me, so take your time :)
03:13:41 <hongbin> mkrai: ^^
03:13:48 <mkrai> Ok thanks
03:13:54 <hongbin> ok, next topic
03:13:57 <hongbin> #topic Cinder integration
03:14:25 <hongbin> for this one, i didn't have a chance to get back to it
03:15:22 <hongbin> i will skip it this week, if there is no comment for it
03:15:40 <hongbin> hopefully, i can get a wip patch up at next week
03:16:06 <hongbin> ok, move on
03:16:07 <hongbin> #topic Introduce container composition (kevinz)
03:16:15 <hongbin> kevinz: ^^
03:16:21 <kevinz> Hi hongbin
03:17:06 <hongbin> kevinz: hey
03:17:08 <kevinz> Submit several patches about capsule, and I will push some test cases this week
03:17:22 <kevinz> Also add etcd database operation about capsule
03:18:28 <kevinz> Also add support for create multiple capsule, such as "zun capsule create -f **.yaml --count 3"
03:19:03 <hongbin> like a replication controller?
03:19:39 <kevinz> hongbin: Aha, good point,,,
03:20:30 <kevinz> hongbin: Just support create more capsules with one command, like container create
03:20:45 <hongbin> kevinz: oh, i see, that is different
03:20:58 <kevinz> hongbin: Have not consider it as replication controller,,,
03:21:45 <hongbin> kevinz: keep in mind that implementing RC might need a significant amount of work ...
03:22:12 <kevinz> hongbin: Yeah I see..
03:22:22 <hongbin> kevinz: which might need another spec if you propose to go to that path
03:22:51 <mkrai> hongbin: kevinz Do we want to implement rc like concept in Zun?
03:22:57 <kevinz> hongbin: OK
03:23:17 <hongbin> mkrai: i don't have strong opinion on that
03:23:26 <kevinz> mkrai: Have not decide also
03:23:42 <mkrai> Ok
03:24:30 <hongbin> any other comment on this topic?
03:24:44 <kevinz> that's all from me
03:25:15 <hongbin> ok, thanks kevinz
03:25:23 <hongbin> #topic NFV use cases (lakerzhou)
03:25:26 <hongbin> lakerzhou: there?
03:25:34 <lakerzhou> yes
03:25:44 <hongbin> lakerzhou: want to lead this discussion?
03:26:30 <hongbin> lakerzhou: btw, i saw you have a patch for that
03:26:44 <hongbin> #link https://review.openstack.org/#/c/484496/
03:26:52 <lakerzhou> The spec is ready for final review. I am planning to run test on docker container directly first
03:27:43 <hongbin> ack
03:28:24 <lakerzhou> I don't have more update on that one, team, please review and let me know if you have any questions or concerns
03:28:50 <hongbin> :)
03:29:12 <lakerzhou> I think we are ready for implementation
03:29:22 <hongbin> yes, i think so
03:29:53 <hongbin> most kuryr people have given +1, i guess they will be happy to take the patches
03:30:11 <lakerzhou> great news if they can take it.
03:30:29 <hongbin> yes
03:30:30 <lakerzhou> should we create a BP for kuryr
03:31:22 <hongbin> perhaps you can, but don't need to duplicate another spec to kuryr
03:31:37 <lakerzhou> hongbin, sounds good, I will do it tomorrow.
03:31:44 <hongbin> thanks lakerzhou
03:31:57 <hongbin> all, any comment for this topic? or question for lakerzhou ?
03:32:21 <kevinz> thx lakerzhou
03:32:32 <kevinz> that will add great value to zun
03:32:54 <lakerzhou> np, thanks all the helps and comments in reviewing the spec
03:33:17 <hongbin> ok, next topic
03:33:19 <hongbin> #topic Default API version policy
03:33:25 <hongbin> #link http://lists.openstack.org/pipermail/openstack-dev/2017-July/120207.html
03:33:32 <hongbin> Shunli: there?
03:33:53 <Shunli> yes
03:34:10 <hongbin> Shunli: want to lead the discussion of this topic?
03:34:17 <Shunli> ok
03:34:43 <Shunli> the topic is about when and how to bump the default api version.
03:35:03 <Shunli> now zun client always use the latest api version as the default api version.
03:36:07 <Shunli> I want to know how you guys think about the defautl api version policy.
03:36:32 <Shunli> should we bump the default api version everytime the api version changed?
03:36:51 <Shunli> or we bump the default api version when a major version released?
03:37:10 <mkrai> I am not sure how the microversion works. How does other project handle it?
03:38:09 <Shunli> I only found a ironic client which seem do not bump the default api version when every api version changed.
03:38:42 <hongbin> #link https://specs.openstack.org/openstack/ironic-specs/specs/approved/cli-default-api-version.html
03:39:48 <Namrata> they are taking latest as the default api version
03:40:35 <hongbin> this is how i understand their approach
03:40:56 <hongbin> first, at client side, it defines a list of versions it supports
03:41:18 <hongbin> second, in server side, define the latest api versions
03:41:49 <hongbin> the final chosen api version is negotiated between client and server
03:42:05 <hongbin> basically, it will pick the latest version that both client and server support
03:42:24 <hongbin> for example, client support 1.1 - 1.3, server has up to 1.4
03:42:30 <hongbin> the chosen version will be 1.3
03:42:42 <hongbin> that is how i understand their spec
03:42:50 <mkrai> is this approach already supported in zunclient?
03:43:09 <hongbin> mkrai: no, we hard-code to 'latest' right now
03:44:19 <mkrai> it seems if we have this approach supported in zunclient, its good
03:44:40 <mkrai> And also we should bump the default version to latest.
03:45:34 <Shunli> ok, seems you guys all think we should always use the latest as the default api version.
03:45:58 <mkrai> Shunli: yes it makes no harm I suppose
03:46:21 <Namrata> i also agree using the latest one
03:46:36 <mkrai> hongbin: Can we ask Kenichi Ohmichi from Nova core about this?
03:46:58 <mkrai> He has been doing all the work in api microversioning
03:47:02 <hongbin> mkrai: yes, i can take an AI for that
03:47:25 <mkrai> hongbin: Thanks
03:47:28 <hongbin> #action hongbin ask nova core about how to deal with api microversion
03:47:43 <Shunli> my only concern is that we should alway expose stable cli/api to user.
03:48:00 <mkrai> Shunli: Agree
03:48:07 <hongbin> this is a good point
03:48:24 <hongbin> i think there is a middle ground
03:48:34 <spn> n - 1 approach?
03:48:41 <hongbin> for stable branch, we could hard-code a stable version
03:48:51 <hongbin> for master branch, pick the latest version
03:49:04 <hongbin> spn: go ahead if you have one :)
03:49:29 <spn> hongbin: we have a stable branch right?
03:49:36 <Shunli> +1 for hongbin's proposal
03:49:45 <hongbin> spn: yes, starting for this release, we have
03:49:49 <spn> that should be fine I guess
03:50:38 <hongbin> ok, seems we all agree on this one
03:51:07 <mkrai> +1
03:51:07 <hongbin> any further remark?
03:51:21 <Shunli> i will submit patch use the latest as the default api version for host list&show
03:51:37 <hongbin> Shunli: thx
03:51:55 <hongbin> #topic Open Discussion
03:52:15 <hongbin> anyone has an additional topic to bring up?
03:52:50 <mkrai> none from me
03:52:56 <Shunli> no
03:52:59 <spn> one thing
03:53:08 <hongbin> spn: go ahead
03:53:16 <spn> I was looking for a architecture diagram of zun on the main page of ours
03:53:20 <spn> like how magnum has it
03:53:32 <spn> possible?
03:53:38 <hongbin> sure
03:53:50 <mkrai> spn: +1
03:53:50 <hongbin> i can take an AI for that
03:54:06 <hongbin> #action hongbin pose an architecture diagram at the zun wiki page
03:54:08 <spn> also I am did not find a page
03:54:15 <spn> which has our roadmap listed
03:54:22 <hongbin> #link https://wiki.openstack.org/wiki/Zun
03:54:24 <spn> did I miss a page which has it?
03:55:14 <hongbin> spn: i can try to summarize the roadmap in some way, how other projects present their roadmap?
03:55:42 <spn> I showed the zun page to my exec director and the first question he asked me is what is in the roadmap
03:55:54 <hongbin> i see
03:55:57 <spn> I could not find it on wiki.
03:56:28 <hongbin> yes, i am thinking how to summarize it
03:56:43 <spn> +1 that would be great.
03:56:53 <hongbin> since i don't think other projects summarize their roadmap in wiki as well
03:57:07 <spn> whatever is the best location
03:57:20 <hongbin> ok, i will try that
03:57:26 <kiennt> hongbin,: Just one thing, do you think we should change zun/image/glance/utils to a class like NeutronAPI? Like your new patches
03:58:18 <hongbin> kiennt: i don't have strong opinion on it, if you have a specific patch up for review, i will leave my comment
03:58:47 <kiennt> hongbin: sure, i'll try to do it.
03:59:11 <hongbin> kiennt: btw, thanks for your reviews and patches, they are all helpful :)
03:59:26 <kiennt> hongbin: my pleasure :)
03:59:30 <diga> sorry I got very late
03:59:33 <hongbin> all, time is up
03:59:50 <hongbin> thanks for joining the meeting, hope to see you next time
03:59:53 <hongbin> #endmeeting