03:00:03 <hongbin> #startmeeting zun
03:00:04 <openstack> Meeting started Tue Jul 17 03:00:03 2018 UTC and is due to finish in 60 minutes.  The chair is hongbin. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:07 <openstack> The meeting name has been set to 'zun'
03:00:15 <hongbin> #topic Roll Call
03:00:18 <kevinz> o/
03:00:27 <hongbin> hi kevinz
03:00:47 <kevinz> hey hongbin
03:00:53 <kevinz> CFP submitted
03:01:16 <hongbin> kevinz: cool
03:01:17 <kevinz> Thanks for your "jin yu liang yan"
03:01:28 <hongbin> ...
03:02:03 <hongbin> #topic Blueprints
03:02:11 <hongbin> 1. OpenStack as a virtual Kubernetes node (assignee: kevinz)
03:02:18 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/zun-connector-for-k8s
03:02:23 <hongbin> #link https://github.com/virtual-kubelet/virtual-kubelet/pull/239
03:03:00 <kevinz> I find the dims comments
03:03:13 <kevinz> Will submit a patch today
03:03:26 <kevinz> Still the issue with command.
03:04:11 <hongbin> hope it is not hard to fix
03:04:37 <kevinz> It's OK I think. But first need to build the two cluster.
03:05:12 <kevinz> Beside I will do the capsule align with Kata this week and next week
03:05:32 <hongbin> cool
03:06:07 <hongbin> mkrai: might also interest in the kata work as well
03:06:54 <kevinz> One question, could you help to see the cpu/memory request/limit?
03:07:06 <kevinz> Since we just have limit now, don't have request
03:07:10 <hongbin> sure
03:07:20 <kevinz> Thanks
03:07:22 <hongbin> #action hongbin looks at the cpu/memory request
03:07:45 <hongbin> np
03:08:01 <hongbin> it looks everything is set now
03:08:24 <kevinz> Yes, under process
03:08:42 <hongbin> cool
03:08:45 <hongbin> 2. Introduce quota for containers (assignee: kiennt26)
03:08:52 <hongbin> #link https://blueprints.launchpad.net/zun/+spec/quota-support
03:09:05 <hongbin> kien is not here right now
03:09:26 <hongbin> i am not sure if he updated his patches last week
03:10:10 <hongbin> will look at that this week, and find out how i can help with this feature
03:10:21 <hongbin> 3. OpenStack Zun as Amphora driver (assignee: hongbin)
03:10:27 <hongbin> #link https://storyboard.openstack.org/#!/story/2002117
03:10:50 <hongbin> for this one, i will submit a talk with two octavia team members for the berlin summit
03:10:57 <openstackgerrit> Merged openstack/zun stable/queens: Remove unused auth_url from RequestContext  https://review.openstack.org/581184
03:11:02 <openstackgerrit> Merged openstack/zun stable/queens: Switch keystone session in glanceclient  https://review.openstack.org/581539
03:11:12 <hongbin> hope the talk will be selected
03:11:43 <hongbin> for the code, i will continue to work on it this week
03:12:52 <hongbin> ok, any question so far?
03:13:01 <openstackgerrit> Merged openstack/zun stable/queens: Fall back to the legacy auth_uri option  https://review.openstack.org/581540
03:13:01 <openstackgerrit> Merged openstack/zun master: Synchronize on network attach/detach  https://review.openstack.org/559252
03:14:17 <hongbin> #topic Bugs
03:14:54 <hongbin> i was investigating the reported issue on installing zun with kolla
03:15:15 <hongbin> here is the fix
03:15:17 <hongbin> #link https://review.openstack.org/#/c/582825/
03:15:40 <hongbin> it looks kolla is using 1.24, so zun needs to use this API version as well
03:16:00 <hongbin> however, if we set the docker api version to 1.24, we will run into several issues
03:16:09 <hongbin> and i am trying to fix it
03:16:21 <hongbin> here is one fix
03:16:22 <hongbin> #link https://review.openstack.org/#/c/582824/
03:16:58 <hongbin> any question about that?
03:17:32 <hongbin> #topic Open Discussion
03:19:30 <hongbin> any topic to discuss ?
03:20:41 <hongbin> ok, all thanks for joining, see you next week
03:20:44 <hongbin> #endmeeting