#openstack-meeting-3: api wg

Meeting started by etoews at 16:00:24 UTC (full logs).

Meeting summary

  1. agenda (etoews, 16:02:42)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 16:02:51)

  2. previous meeting action items (etoews, 16:03:41)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-09-24-16.00.html (etoews, 16:03:53)
    2. ACTION: elmiko to make PR against http://docs.openstack.org/infra/manual/developers.html to add info about the openstack-api irc channel (elmiko, 16:06:51)

  3. Magnum (etoews, 16:07:42)
    1. https://swaggerhub.com/api/etoews/OpenStack-Magnum/1.0 (etoews, 16:07:59)
    2. ACTION: miguelgrinberg to begin a guideline for actions (etoews, 16:19:11)
    3. ACTION: etoews to get a api wg liaison from magnum (etoews, 16:20:58)
    4. ACTION: etoews annegentle to figure out how to best collaborate on the magnum api ref (etoews, 16:21:30)

  4. links (etoews, 16:23:26)
    1. ACTION: elmiko create analysis of link references for each service in api-ref (elmiko, 16:35:21)

  5. guidelines dashboard (etoews, 16:35:40)
    1. http://ghostcloud.net/openstack_gerrit_dashboards/dashboard_api-wg.html (etoews, 16:35:50)
    2. https://review.openstack.org/#/c/221163/ too (elmiko, 16:36:36)
    3. ACTION: etoews to freeze https://review.openstack.org/#/c/214817/ and https://review.openstack.org/#/c/221163/ (etoews, 16:38:11)
    4. ACTION: elmiko comment on https://review.openstack.org/#/c/187112 and freeze when ready (elmiko, 16:45:41)

  6. APIImpact (etoews, 16:48:20)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (etoews, 16:48:31)

  7. summit (etoews, 16:54:49)
    1. https://etherpad.openstack.org/p/mitaka-api-wg-session-plans (elmiko, 16:55:00)


Meeting ended at 17:00:02 UTC (full logs).

Action items

  1. elmiko to make PR against http://docs.openstack.org/infra/manual/developers.html to add info about the openstack-api irc channel
  2. miguelgrinberg to begin a guideline for actions
  3. etoews to get a api wg liaison from magnum
  4. etoews annegentle to figure out how to best collaborate on the magnum api ref
  5. elmiko create analysis of link references for each service in api-ref
  6. etoews to freeze https://review.openstack.org/#/c/214817/ and https://review.openstack.org/#/c/221163/
  7. elmiko comment on https://review.openstack.org/#/c/187112 and freeze when ready


Action items, by person

  1. annegentle
    1. etoews annegentle to figure out how to best collaborate on the magnum api ref
  2. elmiko
    1. elmiko to make PR against http://docs.openstack.org/infra/manual/developers.html to add info about the openstack-api irc channel
    2. elmiko create analysis of link references for each service in api-ref
    3. elmiko comment on https://review.openstack.org/#/c/187112 and freeze when ready
  3. etoews
    1. etoews to get a api wg liaison from magnum
    2. etoews annegentle to figure out how to best collaborate on the magnum api ref
    3. etoews to freeze https://review.openstack.org/#/c/214817/ and https://review.openstack.org/#/c/221163/
  4. miguelgrinberg
    1. miguelgrinberg to begin a guideline for actions
  5. openstack
    1. elmiko to make PR against http://docs.openstack.org/infra/manual/developers.html to add info about the openstack-api irc channel
    2. etoews to freeze https://review.openstack.org/#/c/214817/ and https://review.openstack.org/#/c/221163/
    3. elmiko comment on https://review.openstack.org/#/c/187112 and freeze when ready


People present (lines said)

  1. etoews (74)
  2. elmiko (56)
  3. cdent (18)
  4. annegentle (8)
  5. miguelgrinberg (8)
  6. stevelle (7)
  7. openstack (3)
  8. vikram (1)


Generated by MeetBot 0.1.4.