#openstack-meeting: Ceilometer

Meeting started by nijaba at 15:00:02 UTC (full logs).

Meeting summary

    1. http://wiki.openstack.org/Meetings/MeteringAgenda (nijaba, 15:00:03)

  1. actions from previous meeting (nijaba, 15:01:09)
  2. nijaba to schedule v2 review for next meeting (nijaba, 15:01:19)
    1. Done, see meeting agenda (nijaba, 15:01:19)

  3. nijaba to link API v2 proposal to appropriate bp (nijaba, 15:01:30)
    1. done, I added the link to the whiteboard of https://blueprints.launchpad.net/ceilometer/+spec/api-server-pecan-wsme (nijaba, 15:01:30)

  4. jd__ write a wiki page on how to participate to the bug squashing day (nijaba, 15:01:43)
    1. done, see http://wiki.openstack.org/Ceilometer/Contributing and http://wiki.openstack.org/Ceilometer/BugSquashingDay/20130104 (nijaba, 15:01:43)

  5. nijaba to organize new vote next week for meeting on Jan 2nd (nijaba, 15:02:48)
    1. Done, see meeting agenda topic (nijaba, 15:02:48)

  6. nijaba to approve synaps's bp (nijaba, 15:02:58)
    1. done see https://blueprints.launchpad.net/ceilometer/+spec/synaps-integration which is the overarching bp (nijaba, 15:02:58)

  7. nijaba to organixe next thu as bp cleanup day (nijaba, 15:03:23)
    1. lots of cleanup done, but see subsequent topic about remainder (nijaba, 15:03:23)

  8. nijaba to reschedule topic about healthmon for next week when lianhao is around (nijaba, 15:03:35)
    1. Done, see meeting agenda topic (nijaba, 15:03:35)

  9. dhellmann experiment with passing arrays of parameters to wsme for queries (nijaba, 15:03:46)
    1. ACTION: dhellmann experiment with passing arrays of parameters to WSME for queries (dhellmann, 15:05:06)

  10. jd__ announce the bug squashing day on the ml (nijaba, 15:05:56)
    1. done (nijaba, 15:06:46)

  11. jd__ megatweet about the bug squashing day every hour (nijaba, 15:06:58)
    1. Done, please RT :) (nijaba, 15:06:58)
    2. https://lists.launchpad.net/openstack/msg19657.html (dhellmann, 15:07:35)

  12. jd__ rename api to api-v2 and api-v1 to api (nijaba, 15:07:45)
    1. done (nijaba, 15:08:07)
    2. VOTE: Voted on "on january 2nd at 21UTC, I plan to be?" Results are, absent: 5, present: 2 (nijaba, 15:11:31)
    3. AGREED: meeting on jan 2nd will be chaired by jd__ (nijaba, 15:12:36)

  13. Discuss heathmon/ceilometer duplication and differences http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon (nijaba, 15:12:57)
    1. AGREED: healthmon integration: a) implemented missing meters in ceilometer, b) integrate healthmon through multi-publisher (nijaba, 15:18:25)
    2. ACTION: llu-laptop to report agreement result to wiki page http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon (nijaba, 15:19:57)
    3. ACTION: nijaba to get in touch with the healthmon team to see what their reaction is to our plan for integration (nijaba, 15:27:11)
    4. https://blueprints.launchpad.net/ceilometer/+spec/monitoring-physical-devices (llu-laptop, 15:28:17)

  14. API bv2 proposal review http://wiki.openstack.org/Ceilometer/blueprints/APIv2 (nijaba, 15:35:00)
    1. ACTION: API v2 topic to be continued on jan 2nd (nijaba, 15:39:22)
    2. ACTION: nijaba API v2 topic to be continued on jan 2nd (nijaba, 15:39:28)

  15. blueprints cleanup (nijaba, 15:39:53)
    1. So I have spent most of the morning cleanup our bps. You should have received notification if I changed a bp you are registered on. (nijaba, 15:40:01)
    2. The following bp are still needing more definition and an assignee or will otherwise be retargeted for H. (nijaba, 15:41:22)
    3. https://blueprints.launchpad.net/ceilometer/+spec/move-listener-framework-oslo (nijaba, 15:41:22)
    4. https://blueprints.launchpad.net/ceilometer/+spec/meter-post-api (nijaba, 15:41:22)
    5. https://blueprints.launchpad.net/ceilometer/+spec/non-libvirt-hw (nijaba, 15:41:22)
    6. https://blueprints.launchpad.net/ceilometer/+spec/rpc-zeromq (nijaba, 15:41:22)
    7. https://blueprints.launchpad.net/ceilometer/+spec/api-aggregate-average (nijaba, 15:41:23)
    8. https://blueprints.launchpad.net/ceilometer/+spec/remove-disabled-pollsters-option (nijaba, 15:41:24)
    9. ACTION: nijaba to find out if EmilienM wishes to commit on https://blueprints.launchpad.net/ceilometer/+spec/api-aggregate-average (nijaba, 15:47:07)
    10. ACTION: nijaba to send an email to openstack-dev listing the orphan bps (nijaba, 15:49:54)
    11. Here is the list of bp that are going to be in Grizzly 2, only 2 are not yet completed. I hope they will be before the end of next week (nijaba, 15:50:31)
    12. https://launchpad.net/ceilometer/+milestone/grizzly-2 (nijaba, 15:50:31)

  16. Open discussion (nijaba, 15:54:50)
    1. ACTION: nijaba to add bp skeleton to remind ourselves to implement higher level tests for db backends (nijaba, 15:58:36)
    2. https://answers.launchpad.net/ceilometer/+questions?field.sort=recently+updated+first&field.actions.search=Search&field.status=Open&field.search_text= (dhellmann, 15:59:20)


Meeting ended at 16:06:32 UTC (full logs).

Action items

  1. dhellmann experiment with passing arrays of parameters to WSME for queries
  2. llu-laptop to report agreement result to wiki page http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
  3. nijaba to get in touch with the healthmon team to see what their reaction is to our plan for integration
  4. API v2 topic to be continued on jan 2nd
  5. nijaba API v2 topic to be continued on jan 2nd
  6. nijaba to find out if EmilienM wishes to commit on https://blueprints.launchpad.net/ceilometer/+spec/api-aggregate-average
  7. nijaba to send an email to openstack-dev listing the orphan bps
  8. nijaba to add bp skeleton to remind ourselves to implement higher level tests for db backends


Action items, by person

  1. dhellmann
    1. dhellmann experiment with passing arrays of parameters to WSME for queries
  2. llu-laptop
    1. llu-laptop to report agreement result to wiki page http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
  3. nijaba
    1. nijaba to get in touch with the healthmon team to see what their reaction is to our plan for integration
    2. nijaba API v2 topic to be continued on jan 2nd
    3. nijaba to find out if EmilienM wishes to commit on https://blueprints.launchpad.net/ceilometer/+spec/api-aggregate-average
    4. nijaba to send an email to openstack-dev listing the orphan bps
    5. nijaba to add bp skeleton to remind ourselves to implement higher level tests for db backends
  4. openstack
    1. llu-laptop to report agreement result to wiki page http://wiki.openstack.org/Ceilometer/CeilometerAndHealthnmon
    2. nijaba to send an email to openstack-dev listing the orphan bps


People present (lines said)

  1. nijaba (149)
  2. dhellmann (82)
  3. jd__ (30)
  4. llu-laptop (18)
  5. yjiang5 (11)
  6. openstack (9)
  7. zehndton (2)
  8. graflu0 (2)


Generated by MeetBot 0.1.4.