#openstack-meeting: Cinder

Meeting started by thingee at 16:00:03 UTC (full logs).

Meeting summary

  1. announcements (thingee, 16:00:28)
    1. hemna is continuing with the brick switch in nova, please help and review! (thingee, 16:01:14)
    2. https://review.openstack.org/#/c/175569/ (thingee, 16:01:17)
    3. Nova patches in flight for multi-attach support, please help and review! (thingee, 16:01:47)
    4. https://etherpad.openstack.org/p/liberty-volume-multiattach (thingee, 16:01:50)
    5. Propose your topics for the Cinder Midcycle meetup! (thingee, 16:02:17)
    6. https://etherpad.openstack.org/p/cinder-liberty-midcycle-meetup (thingee, 16:02:19)
    7. ACTION: thingee to mention this in the mailing list (thingee, 16:02:46)
    8. apache/nginx support in cinder api will be approved assuming no objections this week (thingee, 16:03:21)
    9. https://review.openstack.org/#/c/192683/6 (thingee, 16:03:23)
    10. clone consistency group spec will be approved this week assuming no objections (thingee, 16:03:43)
    11. https://review.openstack.org/#/c/194834/4 (thingee, 16:03:45)
    12. incremental backup enhancement spec will be approved this week assuming no objections (thingee, 16:04:13)
    13. https://review.openstack.org/#/c/187926/8 (thingee, 16:04:17)
    14. os-brick 0.3.0 will be released this week (thingee, 16:04:42)
    15. cinderclient 1.3.1 is released with version discovery removed (thingee, 16:05:17)

  2. Cinder <-> Nova API fixes Update (thingee, 16:06:27)
    1. https://etherpad.openstack.org/p/CinderNovaAPI (thingee, 16:06:37)
    2. ACTION: scottda is corral all the bugs, design ideas in etherpad https://etherpad.openstack.org/p/CinderNovaAPI (thingee, 16:08:36)
    3. it maybe too late to get changes into Nova at this point, may prep for M (thingee, 16:16:23)
    4. ACTION: jgriffith will write a first draft of defining call/interface (thingee, 16:18:05)

  3. Volume Migration Improvement has made some progress (thingee, 16:19:21)
    1. volume status management is waiting for comments (thingee, 16:19:44)
    2. https://review.openstack.org/#/c/186312/ (thingee, 16:19:47)
    3. migration status management waiting for comments (thingee, 16:20:02)
    4. https://review.openstack.org/#/c/189614/ (thingee, 16:20:04)
    5. tempest tests (thingee, 16:20:29)
    6. https://review.openstack.org/#/c/195443/ (thingee, 16:20:29)
    7. cinder client changes (thingee, 16:20:38)
    8. https://review.openstack.org/#/c/189547/ (thingee, 16:20:38)

  4. Add Fujitsu ETERNUS DX Volume Driver (again) (thingee, 16:24:51)
    1. https://review.openstack.org/#/c/201500/ (thingee, 16:25:07)

  5. Move cinderclient-dsvm-functional job to (non)voting queue (thingee, 16:35:12)
    1. job stats (thingee, 16:36:11)
    2. (thingee, 16:36:13)
    3. http://graphite.openstack.org/render/?width=877&height=548&_salt=1436533755.887&from=00%3A00_20150524&until=23%3A59_20150715&target=stats.zuul.pipeline.experimental.job.check-cinderclient-dsvm-functional.FAILURE&target=stats.zuul.pipeline.experimental.job.check-cinderclient-dsvm-functional.SUCCESS&target=stats.zuul.pipeline.experimental.openstack.python-cind (thingee, 16:36:13)
    4. review request (thingee, 16:36:30)
    5. https://review.openstack.org/#/c/200522/ (thingee, 16:36:32)
    6. AGREED: rebase and merge it! (thingee, 16:37:06)

  6. open discussion (thingee, 16:38:38)
    1. https://goo.gl/eTNPrb (jgriffith, 16:39:56)
    2. replication v2 (thingee, 16:40:20)
    3. https://review.openstack.org/#/c/155644/ (thingee, 16:40:24)
    4. AGREED: auto-failover isn't needed in the initial version (thingee, 16:42:20)
    5. https://review.openstack.org/#/c/201812/ (jgriffith, 16:51:28)


Meeting ended at 16:58:18 UTC (full logs).

Action items

  1. thingee to mention this in the mailing list
  2. scottda is corral all the bugs, design ideas in etherpad https://etherpad.openstack.org/p/CinderNovaAPI
  3. jgriffith will write a first draft of defining call/interface


Action items, by person

  1. jgriffith
    1. jgriffith will write a first draft of defining call/interface
  2. openstack
    1. scottda is corral all the bugs, design ideas in etherpad https://etherpad.openstack.org/p/CinderNovaAPI
  3. scottda
    1. scottda is corral all the bugs, design ideas in etherpad https://etherpad.openstack.org/p/CinderNovaAPI
  4. thingee
    1. thingee to mention this in the mailing list


People present (lines said)

  1. thingee (97)
  2. jgriffith (84)
  3. scottda (28)
  4. hemna (19)
  5. smcginnis (17)
  6. vincent_hou (16)
  7. erlon (14)
  8. jungleboyj (13)
  9. e0ne (11)
  10. dannywilson (8)
  11. Fdaisuke (7)
  12. Swanson (6)
  13. flip214 (5)
  14. patrickeast (5)
  15. DuncanT (4)
  16. openstack (4)
  17. j_king (4)
  18. winston-d_ (3)
  19. tbarron (3)
  20. johnthetubaguy (3)
  21. kmartin (2)
  22. mtanino (2)
  23. geguileo (2)
  24. xyang1 (2)
  25. cebruns (1)
  26. vilobhmm (1)
  27. srikanth_poolla (1)
  28. asselin (1)
  29. eharney (1)
  30. jseiler (1)
  31. ameade (1)
  32. rhe00_ (1)
  33. mtreinish (1)
  34. janonymous_ (1)


Generated by MeetBot 0.1.4.