#openstack-meeting: cinder

Meeting started by thingee at 16:00:05 UTC (full logs).

Meeting summary

  1. announcements (thingee, 16:02:29)
    1. Cinder RC1 should be cut today (thingee, 16:03:16)
    2. https://review.openstack.org/#/c/226850/1 (thingee, 16:03:17)
    3. http://www.openstack.org/blog/2015/09/openstack-community-weekly-newsletter-sept-12-18/ (thingee, 16:08:09)
    4. https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting (thingee, 16:09:57)

  2. Cinder API races bugs (thingee, 16:10:31)
    1. first patch (thingee, 16:10:57)
    2. https://review.openstack.org/#/c/218012 (thingee, 16:10:59)
    3. This follows dependency chain (thingee, 16:11:21)
    4. https://review.openstack.org/#/c/221442 (thingee, 16:11:23)
    5. nothing to discuss (thingee, 16:11:34)
    6. AGREED: in the cinder channel it was agreed this would not be in L (thingee, 16:12:12)

  3. Nova volume bugs (thingee, 16:12:25)
    1. there are lots of nova/cinder bugs (thingee, 16:12:41)
    2. https://bugs.launchpad.net/nova/+bugs?field.tag=volumes (mriedem, 16:12:44)
    3. https://bugs.launchpad.net/nova/+bugs?field.tag=volumes (thingee, 16:12:45)
    4. some might actually already be fixed. Maybe also since os-brick. (thingee, 16:14:14)
    5. mriedem noticed many multi-path bugs. patrickeast has Pure CI testing multi-path with FC and iSCSI (thingee, 16:15:41)
    6. ACTION: scottda to priortize and set some expectation for Mitaka (thingee, 16:19:23)
    7. https://etherpad.openstack.org/p/Mitaka_Priorites_for_Nova_Volume_bugs (scottda, 16:19:36)
    8. markus_z would like to stay in the loop, being the nova bug czar (thingee, 16:19:53)

  4. Design summit topics (thingee, 16:20:25)
    1. https://etherpad.openstack.org/p/cinder-mitaka-summit-topics (thingee, 16:20:33)
    2. ACTION: patrickeast to make etherpad on expermental API research (thingee, 16:24:51)
    3. ACTION: dulk to post an etherpad link under the topic proposal availability zone issues. (thingee, 16:26:45)
    4. ACTION: DuncanT to post his findings and discuss with dulek (thingee, 16:27:02)
    5. ACTION: rhedlind and eharney to collaborate on a driver api doc for cinder dev docs (thingee, 16:28:14)
    6. https://review.openstack.org/#/c/149894/ (hemna, 16:28:44)
    7. spec renewed for VolumeIsBusy with ing states (thingee, 16:29:18)
    8. https://review.openstack.org/#/c/149894/ (thingee, 16:29:21)
    9. ACTION: hemna to put together a nova spec for scottda to present VolumeIsBusy being returned for ing states at next nova meeting (thingee, 16:30:57)
    10. https://etherpad.openstack.org/p/cinder-mitaka-summit-topics (thingee, 16:34:41)
    11. working session proposal: milestone deadlines (thingee, 16:37:00)
    12. AGREED: moving milestone deadlines to sprint (thingee, 16:38:45)
    13. working session proposal cinder-api microversions (thingee, 16:39:26)
    14. https://review.openstack.org/#/c/223803/ #spec (scottda, 16:40:12)
    15. spec for microversions (thingee, 16:40:28)
    16. https://review.openstack.org/#/c/224910/ #code (scottda, 16:40:29)
    17. https://review.openstack.org/#/c/223803/ (thingee, 16:40:37)
    18. code for microversions (thingee, 16:40:48)
    19. https://review.openstack.org/#/c/224910/ (thingee, 16:40:50)
    20. AGREED: Cinder-api microversion working session deep dive seems good! (thingee, 16:42:00)
    21. working session proposal: Remove volume manager locks (thingee, 16:42:39)
    22. ACTION: scottda will talk to hemna on volume manager locks to see if we need a topic in working session (thingee, 16:48:23)
    23. sprint proposal: Future of Cinder and getting back to our roots (thingee, 16:49:51)


Meeting ended at 17:00:43 UTC (full logs).

Action items

  1. scottda to priortize and set some expectation for Mitaka
  2. patrickeast to make etherpad on expermental API research
  3. dulk to post an etherpad link under the topic proposal availability zone issues.
  4. DuncanT to post his findings and discuss with dulek
  5. rhedlind and eharney to collaborate on a driver api doc for cinder dev docs
  6. hemna to put together a nova spec for scottda to present VolumeIsBusy being returned for ing states at next nova meeting
  7. scottda will talk to hemna on volume manager locks to see if we need a topic in working session


Action items, by person

  1. dulek
    1. DuncanT to post his findings and discuss with dulek
  2. eharney
    1. rhedlind and eharney to collaborate on a driver api doc for cinder dev docs
  3. hemna
    1. hemna to put together a nova spec for scottda to present VolumeIsBusy being returned for ing states at next nova meeting
    2. scottda will talk to hemna on volume manager locks to see if we need a topic in working session
  4. patrickeast
    1. patrickeast to make etherpad on expermental API research
  5. scottda
    1. scottda to priortize and set some expectation for Mitaka
    2. hemna to put together a nova spec for scottda to present VolumeIsBusy being returned for ing states at next nova meeting
    3. scottda will talk to hemna on volume manager locks to see if we need a topic in working session


People present (lines said)

  1. thingee (160)
  2. hemna (53)
  3. jgriffith (53)
  4. smcginnis (22)
  5. scottda (22)
  6. mriedem (20)
  7. jungleboyj_ (11)
  8. e0ne (11)
  9. geguileo (9)
  10. dulek (7)
  11. xyang (7)
  12. markus_z (6)
  13. diablo_rojo (5)
  14. patrickeast (5)
  15. eharney (4)
  16. bswartz (4)
  17. openstack (3)
  18. ttx (2)
  19. kmartin (2)
  20. tbarron (2)
  21. jgregor (1)
  22. Swanson (1)
  23. jungleboyj (1)
  24. rajinir (1)
  25. ShamailT (1)


Generated by MeetBot 0.1.4.