#openstack-meeting-4: compass-dev

Meeting started by wshao at 17:04:10 UTC (full logs).

Meeting summary

    1. Let's discuss the feedbacks from TC review on Compass relevance to OpenStack and its 4 opens (wshao, 17:05:29)

  1. TC review of Compass application to OpenStack (wshao, 17:06:53)
    1. Project scope is too general. Not openstack-specific (wshao, 17:13:29)
    2. To address the concern of overlapping, we can watch and join OpenStack chef/puppet/ansible projects (wshao, 17:17:58)
    3. ACTION: Follow up on openstack ansible efforts (wshao, 17:19:51)
    4. http://git.openstack.org/cgit/openstack-infra/ansible-puppet/ (rockyg, 17:21:05)

  2. improvment on open community (wshao, 17:26:24)
    1. ACTION: I will replace syscomass with openstack-compass in current gerrit hooks notifications (wshao, 17:30:08)
    2. ACTION: (Shuo) Follow up on openstack-ansible and figure out a plan for joining the dev and future Compass integration (wshao, 17:32:37)
    3. to summarize on open community, we need to use mailing list for dicussions, use #openstack-compass for technical discussion and community building, use official weekly irc meeting for project planning. and of course, in recruiting more developers (wshao, 17:36:17)
    4. ACTION: (wshao) Figure out the right strategy on user management and relationship to keysone. (wshao, 17:46:48)
    5. comments on static MIB data and older versionof web code still in master branch of compass-web (wshao, 17:47:53)
    6. ACTION: (wshao) contact sdake (wshao, 17:48:07)

  3. static MIB data in compass-core and older versionof web code still in master branch of compass-web (wshao, 17:48:33)
    1. ACTION: (wshao) clean up older version in the repo. Figure out SNMP MIB data issue and eventually move it out of the repo (wshao, 17:49:40)
    2. ACTION: to invite more reviewers (wshao, 17:51:53)
    3. We need to follow the best practices more closely. So -1 on not enough comments, -1 on no test, -1 if style is not good (wshao, 17:52:59)
    4. ACTION: Introducing compas to ML. (wshao, 17:58:49)


Meeting ended at 17:59:54 UTC (full logs).

Action items

  1. Follow up on openstack ansible efforts
  2. I will replace syscomass with openstack-compass in current gerrit hooks notifications
  3. (Shuo) Follow up on openstack-ansible and figure out a plan for joining the dev and future Compass integration
  4. (wshao) Figure out the right strategy on user management and relationship to keysone.
  5. (wshao) contact sdake
  6. (wshao) clean up older version in the repo. Figure out SNMP MIB data issue and eventually move it out of the repo
  7. to invite more reviewers
  8. Introducing compas to ML.


Action items, by person

  1. openstack
    1. Follow up on openstack ansible efforts
    2. I will replace syscomass with openstack-compass in current gerrit hooks notifications
    3. (Shuo) Follow up on openstack-ansible and figure out a plan for joining the dev and future Compass integration
  2. sdake
    1. (wshao) contact sdake
  3. Shuo
    1. (Shuo) Follow up on openstack-ansible and figure out a plan for joining the dev and future Compass integration
  4. wshao
    1. (wshao) Figure out the right strategy on user management and relationship to keysone.
    2. (wshao) contact sdake
    3. (wshao) clean up older version in the repo. Figure out SNMP MIB data issue and eventually move it out of the repo
  5. UNASSIGNED
    1. to invite more reviewers
    2. Introducing compas to ML.


People present (lines said)

  1. rockyg (72)
  2. wshao (63)
  3. dstanek (15)
  4. Shuo (12)
  5. xicheng (5)
  6. openstack (3)
  7. sdake (2)
  8. xiaodongwang (1)


Generated by MeetBot 0.1.4.