#openstack-meeting-4: glance

Meeting started by nikhil at 14:00:07 UTC (full logs).

Meeting summary

  1. roll call (nikhil, 14:00:11)
  2. Updates (nikhil) (nikhil, 14:01:05)
    1. Import Refactor updates (nikhil, 14:01:20)
    2. https://review.openstack.org/#/q/status:open+project:openstack/glance+branch:master+topic:import-refactor-newton (nikhil, 14:01:44)
    3. https://review.openstack.org/#/c/270980/ (nikhil, 14:02:17)
    4. https://review.openstack.org/267209 (nikhil, 14:02:49)
    5. v1 deprecation (nikhil) (nikhil, 14:05:24)
    6. https://review.openstack.org/#/c/328390/ (nikhil, 14:05:32)
    7. ACTION: all: please make it a priority to review v1 deprecation patch https://review.openstack.org/#/c/328390/ (nikhil, 14:06:38)

  3. Important reviews for Newton (nikhil) (nikhil, 14:09:28)
    1. all: please do not encourage trivial fixes or review such at/near to release week (nikhil, 14:11:40)
    2. https://review.openstack.org/270980 (nikhil, 14:12:59)
    3. https://review.openstack.org/328390 (nikhil, 14:13:06)
    4. https://review.openstack.org/272118 (nikhil, 14:13:11)
    5. https://review.openstack.org/324012 (nikhil, 14:13:18)
    6. https://review.openstack.org/313936 (nikhil, 14:13:25)
    7. https://review.openstack.org/352391 (nikhil, 14:13:54)
    8. https://review.openstack.org/360220 (nikhil, 14:15:32)
    9. https://review.openstack.org/229220 (nikhil, 14:16:08)
    10. ACTION: nikhil: verify the date when stable/newton is supposed to be cut (nikhil, 14:18:32)
    11. https://review.openstack.org/357827 (nikhil, 14:19:45)

  4. Release(s) (nikhil) (nikhil, 14:21:09)
    1. https://review.openstack.org/359559 (nikhil, 14:22:10)
    2. https://review.openstack.org/358263 (nikhil, 14:22:17)
    3. https://review.openstack.org/358391 (nikhil, 14:22:23)
    4. https://review.openstack.org/358262 (nikhil, 14:22:28)
    5. https://review.openstack.org/359511 (nikhil, 14:22:59)
    6. https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L135 (nikhil, 14:25:14)
    7. https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L284 (nikhil, 14:25:23)
    8. https://github.com/openstack/requirements/blob/master/global-requirements.txt#L53 (nikhil, 14:25:44)
    9. https://github.com/openstack/requirements/blob/master/global-requirements.txt#L195 (nikhil, 14:25:55)
    10. http://docs.openstack.org/project-team-guide/release-management.html#release-candidate-period-release-3 (nikhil, 14:27:40)
    11. https://review.openstack.org/#/c/357688/ (nikhil, 14:31:38)
    12. https://releases.openstack.org/newton/schedule.html (nikhil, 14:33:42)
    13. So, let's tenatively say (again) Aug 31st is target release date for Newton Glance (EOD ET) (nikhil, 14:35:16)

  5. Barcelona Design Summit space needs (nikhil) (nikhil, 14:44:22)
    1. https://etherpad.openstack.org/p/ocata-glance-summit-planning (nikhil, 14:44:44)
    2. nikhil : will send the final proposal based on votes by 29th to summit planners on Tues 30th (nikhil, 14:47:14)

  6. Open Discussion (nikhil, 14:49:04)
    1. https://review.openstack.org/352564 (nikhil, 14:51:01)
    2. ACTION: Mike Fedosin: update glare plans in the glance documentation and state if any API needs deprecation in glance in newton (nikhil, 14:53:16)
    3. https://review.openstack.org/324012 (nikhil, 14:58:12)


Meeting ended at 14:59:41 UTC (full logs).

Action items

  1. all: please make it a priority to review v1 deprecation patch https://review.openstack.org/#/c/328390/
  2. nikhil: verify the date when stable/newton is supposed to be cut
  3. Mike Fedosin: update glare plans in the glance documentation and state if any API needs deprecation in glance in newton


Action items, by person

  1. nikhil
    1. nikhil: verify the date when stable/newton is supposed to be cut
  2. openstack
    1. all: please make it a priority to review v1 deprecation patch https://review.openstack.org/#/c/328390/


People present (lines said)

  1. nikhil (163)
  2. Jokke_ (41)
  3. rosmaita (17)
  4. tsymanczyk (5)
  5. openstack (3)
  6. abashmak (1)
  7. dharinic (1)
  8. hemanthm (1)
  9. raj_singh (1)


Generated by MeetBot 0.1.4.