#openstack-meeting: Ironic

Meeting started by NobodyCam at 19:01:44 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting (NobodyCam, 19:02:00)

  1. Greetings, roll-call and announcements (NobodyCam, 19:02:12)
    1. nova Driver has landed! (NobodyCam, 19:06:47)

  2. Release cycle progress report (NobodyCam, 19:08:19)
    1. https://launchpad.net/ironic/+milestone/juno-rc1 (lucasagomes, 19:08:53)
    2. https://review.openstack.org/#/c/116561/ (lucasagomes, 19:09:42)
    3. https://review.openstack.org/#/c/118578/ (lucasagomes, 19:09:59)
    4. https://wiki.openstack.org/wiki/Juno_Release_Schedule (devananda, 19:10:42)

  3. SubTeam: integration & testing work (NobodyCam, 19:11:58)
    1. https://review.openstack.org/#/c/119746/ (lucasagomes, 19:14:29)
    2. https://review.openstack.org/#/c/118700/ adds a parallel tempest job that will be experimental until its proven stable (adam_g, 19:14:31)
    3. https://review.openstack.org/#/c/111859/ should hopefully be approved soon (adam_g, 19:15:58)

  4. SubTeam: Ironic Python Agent (NobodyCam, 19:18:44)
  5. SubTeam: integration & testing work (NobodyCam, 19:19:26)
    1. parallel tempest job has been proposed to infra, will be non-voting until proven stable (devananda, 19:19:56)
    2. nova_bm -> ironic grenade job is passing, has one +2, waiting for approvals to merge it (devananda, 19:20:25)
    3. grenade work is also pending some add'l infra patches to set up the env for it correctly (devananda, 19:20:54)
    4. https://review.openstack.org/#/c/112575/ It's a flavor migration tool (romcheg1, 19:21:33)

  6. SubTeam: Ironic Python Agent (NobodyCam, 19:27:21)
    1. https://review.openstack.org/#/c/112693 (NobodyCam, 19:30:02)
    2. devstack, devstack-gate, and infra-config changes are in flight to enable tempest jobs using the agent driver (devananda, 19:31:18)
    3. however, IPA doesn't support ephemeral volumes, and is now failing the rebuild-preserve-ephemeral test (devananda, 19:31:36)
    4. ACTION: Ipa to review docs for end of Juno / start of Kilo cycles (NobodyCam, 19:33:20)
    5. https://etherpad.openstack.org/p/ipa-todos (jroll, 19:35:08)
    6. ACTION: NobodyCam to resume work on DIB element for IPA (devananda, 19:36:57)
    7. ACTION: nobodyca to poke greghaynes (NobodyCam, 19:37:54)

  7. SubTeam: Bug team (NobodyCam, 19:38:56)
    1. any bug in the nova ironic driver should be filed with nova (devananda, 19:41:50)
    2. ACTION: devananda to follow up with mikal to create official bug tag in nova (devananda, 19:43:46)

  8. SubTeam: Oslo (NobodyCam, 19:46:28)
    1. GheRivero on pto no update this meeting (NobodyCam, 19:47:08)

  9. Outstanding items for graduation (NobodyCam, 19:47:49)
    1. https://etherpad.openstack.org/p/IronicGraduationDiscussion (devananda, 19:48:20)

  10. Food for Thought / Open Discussion (NobodyCam, 19:52:34)


Meeting ended at 20:00:54 UTC (full logs).

Action items

  1. Ipa to review docs for end of Juno / start of Kilo cycles
  2. NobodyCam to resume work on DIB element for IPA
  3. nobodyca to poke greghaynes
  4. devananda to follow up with mikal to create official bug tag in nova


Action items, by person

  1. devananda
    1. devananda to follow up with mikal to create official bug tag in nova
  2. greghaynes
    1. nobodyca to poke greghaynes
  3. NobodyCam
    1. NobodyCam to resume work on DIB element for IPA


People present (lines said)

  1. NobodyCam (102)
  2. devananda (82)
  3. jroll (44)
  4. lucasagomes (40)
  5. adam_g (24)
  6. dtantsur (23)
  7. JayF (21)
  8. mrda (11)
  9. wanyen (10)
  10. rloo (7)
  11. Shrews (7)
  12. romcheg1 (5)
  13. openstack (5)
  14. dhellmann (4)
  15. greghaynes (3)
  16. JoshNang (2)
  17. linggao (1)


Generated by MeetBot 0.1.4.