#openstack-meeting: ironic-qa

Meeting started by jlvillal at 17:00:40 UTC (full logs).

Meeting summary

  1. Grenade testing (jlvillal, 17:03:04)
    1. https://review.openstack.org/241018 (jlvillal, 17:03:59)
    2. https://review.openstack.org/241044 (jlvillal, 17:04:11)
    3. https://review.openstack.org/#/c/241393/ (jlvillal, 17:04:51)
    4. https://review.openstack.org/#/c/241426/ (jlvillal, 17:05:00)
    5. https://bugs.launchpad.net/ironic/+bug/1512544 (jlvillal, 17:05:47)

  2. functional testing (jlvillal, 17:07:24)
    1. https://review.openstack.org/#/c/216701/ base patch for tests (aarefiev22, 17:08:20)
    2. https://review.openstack.org/#/c/238577/ (aarefiev22, 17:10:39)
    3. https://review.openstack.org/#/c/239506/ (aarefiev22, 17:10:53)
    4. Patch for functional testing in python-ironicclient is working. (jlvillal, 17:12:02)
    5. https://review.openstack.org/#/c/216701/ (jlvillal, 17:12:05)
    6. Additional functional tests are being proposed for python-ironicclient (jlvillal, 17:13:15)
    7. https://review.openstack.org/#/c/238577/ (jlvillal, 17:13:23)
    8. https://review.openstack.org/#/c/239506/ (jlvillal, 17:13:31)
    9. jlvillal has started a very early patch for ironic functional testing. Comments requested (jlvillal, 17:14:23)
    10. https://review.openstack.org/235612 (jlvillal, 17:14:27)
    11. Basic idea is to be able to start ironic-api, ironic-conductor, and rabbitmq. (jlvillal, 17:14:54)

  3. 3rd party CI (jlvillal, 17:16:28)
    1. https://review.openstack.org/#/c/241294/ (krtaylor, 17:17:06)
    2. krtaylor has a draft for a 3rd party CI spec (jlvillal, 17:17:13)
    3. https://review.openstack.org/#/c/241294/ (jlvillal, 17:17:19)
    4. Agreed at the summit was to have the ability to post comments by end of Mitaka (permissions, accounts, etc), running on all patches by end of N_RELEASE (jlvillal, 17:22:30)
    5. ACTION: jroll or thingee to email expectations for 3rd party CI to list (jlvillal, 17:25:23)
    6. ACTION: sambetts to setup an etherpad and have ironic subteam like status reporting system for the thirdparty CIs. Or find existing etherpad (jlvillal, 17:30:17)
    7. https://etherpad.openstack.org/p/mitaka-ironic-test-qa (krtaylor, 17:31:13)

  4. Opens (jlvillal, 17:32:43)


Meeting ended at 17:35:06 UTC (full logs).

Action items

  1. jroll or thingee to email expectations for 3rd party CI to list
  2. sambetts to setup an etherpad and have ironic subteam like status reporting system for the thirdparty CIs. Or find existing etherpad


Action items, by person

  1. jroll
    1. jroll or thingee to email expectations for 3rd party CI to list
  2. sambetts
    1. sambetts to setup an etherpad and have ironic subteam like status reporting system for the thirdparty CIs. Or find existing etherpad


People present (lines said)

  1. jlvillal (77)
  2. krtaylor (39)
  3. jroll (29)
  4. aarefiev22 (14)
  5. openstack (7)
  6. sambetts (6)
  7. vdrok (1)


Generated by MeetBot 0.1.4.