#openstack-meeting-3: ironic_ui

Meeting started by TheJulia at 18:00:17 UTC (full logs).

Meeting summary

  1. Announcements / Reminders (TheJulia, 18:01:10)
    1. Welcome everyone to the first meeting for the ironic-ui! \o/ (TheJulia, 18:01:23)

  2. Current Status - Items Under Development (TheJulia, 18:03:50)
    1. Support for network_interface (TheJulia, 18:04:34)
    2. https://review.openstack.org/432599 (TheJulia, 18:04:41)
    3. https://wiki.openstack.org/wiki/Meetings/Ironic-ui (TheJulia, 18:05:45)
    4. Support for starting/stopping console (TheJulia, 18:07:35)
    5. https://review.openstack.org/437419 (TheJulia, 18:07:41)
    6. ppiela is Also working on additional power state transitions, soft power-on/off, as well as some refactoring. Expect some code later this week. (TheJulia, 18:10:13)

  3. Current Status - Missing Features (TheJulia, 18:13:22)
    1. Missing features - Portgroup support, setting/getting boot device, RAID configuration, Ability to set resource_class (TheJulia, 18:14:15)
    2. ACTION: TheJulia to clean-up launchpad this week. (TheJulia, 18:14:43)
    3. https://bugs.launchpad.net/ironic-ui (TheJulia, 18:14:51)
    4. https://docs.google.com/spreadsheets/d/1petifqVxOT70H2Krz7igV2m9YqgXaAiCHR8CXgoi9a0/edit?usp=sharing (TheJulia, 18:14:59)

  4. Planning/Priorities (TheJulia, 18:18:28)
    1. ACTION: mgould to look at adding support for node-get-boot-device to the UI (TheJulia, 18:23:25)
    2. ppiela is anticipating to look at adding portgroup support. (TheJulia, 18:27:51)
    3. ACTION: TheJulia to follow-up on testing write-up/guidance that the Horizon team indicated they would attempt to provide this cycle. (TheJulia, 18:32:37)

  5. Open Discussion (TheJulia, 18:33:54)
    1. ACTION: soliosg to take a first pass at reconciling bugs in the ironic-ui launchpad bug tracker. (TheJulia, 18:41:48)
    2. ppiela is seeking operator feedback. (TheJulia, 18:42:17)
    3. ACTION: ppiela to seek feedback from the Operators Mailing list. (TheJulia, 18:48:10)
    4. Presently ironic-ui extracts metadata from descriptions about driver property values to convey defaults, values, dependency relationships. This needs raised visibility and consistency in ironic's drivers, or some other solution to help provide clarity to users. (TheJulia, 18:51:46)


Meeting ended at 18:59:11 UTC (full logs).

Action items

  1. TheJulia to clean-up launchpad this week.
  2. mgould to look at adding support for node-get-boot-device to the UI
  3. TheJulia to follow-up on testing write-up/guidance that the Horizon team indicated they would attempt to provide this cycle.
  4. soliosg to take a first pass at reconciling bugs in the ironic-ui launchpad bug tracker.
  5. ppiela to seek feedback from the Operators Mailing list.


Action items, by person

  1. mgould
    1. mgould to look at adding support for node-get-boot-device to the UI
  2. ppiela
    1. ppiela to seek feedback from the Operators Mailing list.
  3. soliosg
    1. soliosg to take a first pass at reconciling bugs in the ironic-ui launchpad bug tracker.
  4. TheJulia
    1. TheJulia to clean-up launchpad this week.
    2. TheJulia to follow-up on testing write-up/guidance that the Horizon team indicated they would attempt to provide this cycle.


People present (lines said)

  1. TheJulia (81)
  2. ppiela (18)
  3. jroll (11)
  4. soliosg (9)
  5. crushil (7)
  6. mgould (6)
  7. openstack (3)
  8. JayF (2)


Generated by MeetBot 0.1.4.