#openstack-meeting-3: ironic_ui

Meeting started by TheJulia at 18:00:22 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Ironic-ui#Agenda (TheJulia, 18:01:41)

  1. Announcements / Reminders (TheJulia, 18:02:32)
    1. Per a discussion with robcresswell, we should not expect guidance on improving testing from the horizon team until the end of Pike-1 (TheJulia, 18:03:16)

  2. Current Status (TheJulia, 18:04:39)
    1. TheJulia updated launchpad bugs earlier today, so it should be considered the source of truth moving forward. (TheJulia, 18:05:53)
    2. https://bugs.launchpad.net/ironic-ui (TheJulia, 18:05:56)
    3. ppiela sent a note to the Operators mailing list soliciting feedback. No replies as of yet. (TheJulia, 18:06:33)

  3. Planning/Priorities (TheJulia, 18:10:16)
    1. 3 outstanding/new bugs need priority set. (TheJulia, 18:11:23)
    2. https://bugs.launchpad.net/ironic-ui/+bug/1671567 (TheJulia, 18:11:52)
    3. AGREED: bug 1671567 to low priority (TheJulia, 18:16:06)
    4. https://bugs.launchpad.net/ironic-ui/+bug/1663840 (TheJulia, 18:17:02)
    5. AGREED: bug 1663840 to critical priority (TheJulia, 18:18:42)
    6. https://bugs.launchpad.net/ironic-ui/+bug/1672729 (TheJulia, 18:19:22)
    7. AGREED: bug 1672729 to high priority (TheJulia, 18:20:42)

  4. Discussion (TheJulia, 18:22:47)
    1. AGREED: Continue with API client version pinning for the time being, and consider evolving to better support API versioning as time goes on. (TheJulia, 18:30:56)
    2. ACTION: TheJulia to look into the stray port creation case, and if we don't have a bug in ironic, open it as that is the main case for when a full port view would even really be needed. (TheJulia, 18:38:36)
    3. AGREED: We should not use the reservation field to block UI behavior as there are transitory background actions. (TheJulia, 18:46:53)
    4. It seems we need to do a little more research into testing possibilities for full blown integration testing of ironic-ui. A topic for a future meeting. (TheJulia, 18:54:35)

  5. Open Discussion (TheJulia, 18:55:31)


Meeting ended at 18:58:18 UTC (full logs).

Action items

  1. TheJulia to look into the stray port creation case, and if we don't have a bug in ironic, open it as that is the main case for when a full port view would even really be needed.


Action items, by person

  1. TheJulia
    1. TheJulia to look into the stray port creation case, and if we don't have a bug in ironic, open it as that is the main case for when a full port view would even really be needed.


People present (lines said)

  1. TheJulia (91)
  2. dtantsur (38)
  3. jroll (26)
  4. JayF (21)
  5. openstack (12)
  6. robcresswell (5)
  7. ppiela (4)
  8. crushil (4)


Generated by MeetBot 0.1.4.