#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:04:07 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:04:30)
  2. review past meeting work items (d34dh0r53, 15:07:02)
    1. https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-05-30-15.03.html (d34dh0r53, 15:07:18)
    2. https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-05-30-15.03.html (d34dh0r53, 15:07:22)
    3. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:08:26)
    4. ACTION: d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation (d34dh0r53, 15:08:37)
    5. ACTION: dmendiza[m] and d34dh0r53 to look at keystonemiddleware stevedore failures (d34dh0r53, 15:12:30)
    6. ACTION: d34dh0r53 look at https://bugs.launchpad.net/keystone/+bug/2018644 (d34dh0r53, 15:13:03)
    7. https://review.opendev.org/c/openstack/keystonemiddleware/+/878027 is abandoned (xek, 15:15:10)
    8. ACTION: d34dh0r53 figure out why https://review.opendev.org/c/openstack/keystone/+/874844 is failing (d34dh0r53, 15:19:32)

  3. liaison update (d34dh0r53, 15:20:06)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:20:49)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (d34dh0r53, 15:21:16)
    2. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:21:20)
    3. https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:21:24)
    4. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:21:26)

  5. Secure RBAC (dmendiza[m]) (d34dh0r53, 15:23:22)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:23:33)
    2. https://review.opendev.org/c/openstack/keystone/+/863420 (d34dh0r53, 15:23:37)
    3. https://review.opendev.org/c/openstack/keystone/+/822601 (d34dh0r53, 15:23:41)

  6. specification SQLAlchemy 2.0 (stephenfin) (d34dh0r53, 15:26:02)
    1. https://review.opendev.org/q/topic:sqlalchemy-20+is:open+project:openstack/keystone (d34dh0r53, 15:26:18)

  7. open discussion (d34dh0r53, 15:27:19)
    1. https://review.opendev.org/c/openstack/keystonemiddleware/+/877398 (d34dh0r53, 15:28:44)
    2. https://review.opendev.org/c/openstack/keystonemiddleware/+/873921 (dmendiza[m], 15:30:27)
    3. ussuri: https://review.opendev.org/c/openstack/keystone/+/874846 (d34dh0r53, 15:35:45)
    4. victoria: https://review.opendev.org/c/openstack/keystone/+/874847 (d34dh0r53, 15:35:47)
    5. wallaby: https://review.opendev.org/c/openstack/keystone/+/874844 (d34dh0r53, 15:35:49)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/883852 (d34dh0r53, 15:38:46)
    7. ACTION: reviewathon https://review.opendev.org/c/openstack/keystone/+/874346 (d34dh0r53, 15:44:24)

  8. bug review (d34dh0r53, 15:45:18)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:45:25)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:46:06)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:46:40)
    4. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:46:57)
    5. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:48:27)
    6. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:48:48)

  9. conclusion (d34dh0r53, 15:48:56)


Meeting ended at 15:51:51 UTC (full logs).

Action items

  1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
  3. dmendiza[m] and d34dh0r53 to look at keystonemiddleware stevedore failures
  4. d34dh0r53 look at https://bugs.launchpad.net/keystone/+bug/2018644
  5. d34dh0r53 figure out why https://review.opendev.org/c/openstack/keystone/+/874844 is failing
  6. reviewathon https://review.opendev.org/c/openstack/keystone/+/874346


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
    3. dmendiza[m] and d34dh0r53 to look at keystonemiddleware stevedore failures
    4. d34dh0r53 look at https://bugs.launchpad.net/keystone/+bug/2018644
    5. d34dh0r53 figure out why https://review.opendev.org/c/openstack/keystone/+/874844 is failing


People present (lines said)

  1. d34dh0r53 (118)
  2. dmendiza[m] (13)
  3. zaitcev (5)
  4. opendevmeet (3)
  5. xek (2)
  6. drencrom (2)
  7. knikolla (1)


Generated by MeetBot 0.1.4.