#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:01:32 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:01:38)
  2. review past meeting work items (d34dh0r53, 15:03:00)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-02-28-15.02.html (d34dh0r53, 15:03:04)
    2. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:03:40)
    3. ACTION: d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation (d34dh0r53, 15:03:49)

  3. liaison updates (d34dh0r53, 15:04:01)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:04:57)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:05:14)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:05:16)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (d34dh0r53, 15:05:20)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:05:24)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:05:28)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:05:30)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:08:23)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:08:28)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:08:36)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (d34dh0r53, 15:08:38)
    4. https://review.opendev.org/c/openstack/tempest/+/912489 (dmendiza[m], 15:10:05)
    5. https://opendev.org/openstack/keystone/src/branch/master/devstack/lib/scope.sh#L18 (dmendiza[m], 15:12:24)
    6. https://opendev.org/openstack/keystone/src/branch/master/devstack/lib/scope.sh#L24 (dmendiza[m], 15:12:49)
    7. https://opendev.org/openstack/keystone/src/branch/master/devstack/lib/scope.sh#L23 (dmendiza[m], 15:14:00)

  6. specification Improve federated users management (gtema) (d34dh0r53, 15:15:40)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/748748 - waiting for reviews (d34dh0r53, 15:15:47)

  7. open discussion (d34dh0r53, 15:21:01)
    1. https://foss.heptapod.net/python-libs/passlib/-/issues/190 (d34dh0r53, 15:21:09)
    2. https://review.opendev.org/q/topic:%22drop-centos-7%22 (fungi, 15:26:21)

  8. bug review (d34dh0r53, 15:32:13)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:32:24)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:32:47)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:33:04)
    4. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:33:26)
    5. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:33:50)
    6. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:34:10)

  9. conclusion (d34dh0r53, 15:34:26)
    1. https://ptg2024.openinfra.dev (d34dh0r53, 15:35:10)


Meeting ended at 15:37:01 UTC (full logs).

Action items

  1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


People present (lines said)

  1. d34dh0r53 (84)
  2. dmendiza[m] (20)
  3. gtema (13)
  4. fungi (5)
  5. opendevmeet (3)
  6. mharley (2)


Generated by MeetBot 0.1.4.