#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:00:46 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:01:00)
  2. review past meeting work items (d34dh0r53, 15:02:30)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-08-14-15.06.html (d34dh0r53, 15:02:37)
    2. ACTION: dmendiza please review the updates to https://review.opendev.org/c/openstack/keystone/+/924132 (d34dh0r53, 15:04:48)

  3. liaison updates (d34dh0r53, 15:05:53)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:07:49)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:08:15)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:08:48)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:09:02)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:09:15)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:09:21)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:09:29)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:09:46)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:09:54)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:10:21)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (Merged) (d34dh0r53, 15:10:28)
    4. https://review.opendev.org/c/openstack/tempest/+/912489 (Merged) (d34dh0r53, 15:10:34)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:17:27)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/910584 (merged) (d34dh0r53, 15:17:36)
    2. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:17:41)

  7. specification domain manager (mhen) (d34dh0r53, 15:21:11)
    1. https://review.opendev.org/q/topic:%22domain-manager%22 (d34dh0r53, 15:21:32)
    2. https://review.opendev.org/c/openstack/keystone/+/924132/9/releasenotes/notes/domain-manager-persona-7921587ce2fab4fd.yaml (d34dh0r53, 15:21:43)

  8. open discussion (d34dh0r53, 15:25:50)
    1. https://review.opendev.org/q/topic:%22renovate%22+is:open (d34dh0r53, 15:26:05)

  9. bug review (d34dh0r53, 15:32:36)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:32:45)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:34:28)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:35:53)
    4. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:36:18)
    5. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:36:45)
    6. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:37:03)

  10. conclusion (d34dh0r53, 15:39:08)


Meeting ended at 15:40:39 UTC (full logs).

Action items

  1. dmendiza please review the updates to https://review.opendev.org/c/openstack/keystone/+/924132


People present (lines said)

  1. d34dh0r53 (95)
  2. gtema (11)
  3. opendevmeet (6)
  4. dmendiza[m] (6)
  5. mhen (3)
  6. mharley[m] (2)
  7. jph (1)
  8. xek (1)


Generated by MeetBot 0.1.4.