#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:04:29 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:05:32)
  2. review past meeting work items (d34dh0r53, 15:07:12)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-08-21-15.00.html (d34dh0r53, 15:07:44)

  3. liaison updates (d34dh0r53, 15:11:11)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:12:09)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:13:18)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:13:26)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:13:49)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:14:04)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:14:14)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:14:20)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:14:51)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:14:55)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:15:11)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (Merged) (d34dh0r53, 15:15:15)
    4. https://review.opendev.org/c/openstack/tempest/+/912489 (Merged) (d34dh0r53, 15:15:20)
    5. ACTION: dmendiza clean up the SRBAC Specification section of the weekly meeting etherpad (d34dh0r53, 15:30:59)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:31:26)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/910584 (merged) (d34dh0r53, 15:31:30)
    2. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:31:34)

  7. specification domain manager (mhen) (d34dh0r53, 15:36:21)
    1. https://review.opendev.org/q/topic:%22domain-manager%22 (d34dh0r53, 15:36:26)

  8. open discussion (d34dh0r53, 15:40:02)
    1. https://review.opendev.org/q/topic:%22renovate%22+is:open (d34dh0r53, 15:40:15)

  9. bug review (d34dh0r53, 15:52:11)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:52:17)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:53:02)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:53:16)
    4. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:53:38)
    5. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:54:02)
    6. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:54:33)

  10. conclusion (d34dh0r53, 15:54:42)


Meeting ended at 16:00:30 UTC (full logs).

Action items

  1. dmendiza clean up the SRBAC Specification section of the weekly meeting etherpad


People present (lines said)

  1. d34dh0r53 (97)
  2. gtema (23)
  3. dmendiza[m] (6)
  4. opendevmeet (3)
  5. mhen (3)
  6. xek (1)


Generated by MeetBot 0.1.4.