#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:02:12 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:02:43)
  2. review past meeting work items (d34dh0r53, 15:04:23)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-08-28-15.04.html (d34dh0r53, 15:05:02)
    2. ACTION: dmendiza clean up the SRBAC Specification section of the weekly meeting etherpad (d34dh0r53, 15:09:01)

  3. liaison updates (d34dh0r53, 15:09:09)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:11:26)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:11:29)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:11:34)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:11:45)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:11:55)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:12:02)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:12:06)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:12:25)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:12:34)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:12:49)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (Merged) (d34dh0r53, 15:12:55)
    4. https://review.opendev.org/c/openstack/tempest/+/912489 (Merged) (d34dh0r53, 15:13:02)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:16:04)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:16:07)

  7. specification domain manager (mhen) (d34dh0r53, 15:18:31)
    1. https://review.opendev.org/q/topic:%22domain-manager%22 (d34dh0r53, 15:18:35)

  8. open discussion (d34dh0r53, 15:26:34)
    1. https://docs.openstack.org/keystone/2024.1/user/ (d34dh0r53, 15:32:10)
    2. https://review.opendev.org/c/openstack/keystone/+/924132/11/doc/source/admin/service-api-protection.rst (mhen, 15:41:26)

  9. bug review (d34dh0r53, 15:46:13)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:46:23)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:46:36)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:46:50)
    4. https://bugs.launchpad.net/keystoneauth/+bug/2078437 (d34dh0r53, 15:47:16)
    5. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:48:23)
    6. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:48:36)
    7. https://bugs.launchpad.net/ldappool/+bugs?ordterby=-id&start=0 (d34dh0r53, 15:48:56)

  10. conclusion (d34dh0r53, 15:49:31)


Meeting ended at 15:50:10 UTC (full logs).

Action items

  1. dmendiza clean up the SRBAC Specification section of the weekly meeting etherpad


People present (lines said)

  1. d34dh0r53 (84)
  2. mhen (19)
  3. dmendiza[m] (6)
  4. opendevmeet (4)
  5. gtema (2)
  6. xek (1)
  7. mharley[m] (1)


Generated by MeetBot 0.1.4.